Wednesday, 31 October 2018

EIGRP (basic)

EIGRP is a classless, distance vector routing protocol that uses the concept of an autonomous system to describe a set of contiguous routers that run the same routing protocol and share routing information, which also includes subnet mask in its route updates.

EIGRP is sometimes referred to as a hybrid routing protocol or an advanced distance vector protocol because is has characteristics of both distance-vector some link-state protocols. For example, EIGRP doesn't send link-state packets like OSPF does. instead, it traditional distance-vector updates that include information about networks plus the cost o reaching them from the perspective of the advertising router.

EIGRP has link-state characteristics as well it synchronize network topology information between neighbors at startup and then sends specific updates only when topology change occur.

EIGRP has a default hop count of 100, with maximum of 255. In EIGRP speak, hop count refers to how many router an EIGRP update packet can go through before it will be discarded, which limits the size of the autonomous system (AS).

Here's a list of some powerful features:





  • Support for IP and IPv6 
  • Considered classless 
  • Support for VLSM/CIDR
  • Support for summaries and discontinuous networks
  • Efficient neighbor discovery
  • Communication via Reliable Transport Protocol (RTP)
  • Best path selection via diffusing Update Algorithm (DUAL)
  • Reduced bandwidth usage with bounded updates
  • No broadcast  
   
Neighbour Discovery- before EIGRP routers can exchange routes with each other, they must become neighbors, and there are three conditions that must be met before this can happen.

  • Hello and Acknowledge received
  • Autonomous System (AS) numbers match 
  • Identical metrics (K values)
EIGRP routers that belong to different AS don't become neighbor and will not share routing information unless redistribution.

Hello messages are used to identify neighbors and serve a keepalive mechanism between neighbor. EIGRP hello messages are send to multicast address 224.0.0.10 and FF20::A in IPv6. Hello messages send every 5 seconds.

Reported/advertisement distance (AD)  this is the metric of a remote network, as reported by a neighbor. In other words Reported Distance is the neighbor's distance to the destination as reported in an EIGRP packet received from neighbor. It is also the routing table metric of the neighbor router.

In short: AD is the neighbor router distance to the destination.

Feasible distance (FD) this is the best metric among all paths to a remote network, the route with the lowest FD that you'll find in the routing table because its considered the best path. The metric of a feasible distance is calculated using the metric reported by the neighbor that's referred to as the reported or advertised distance plus the metric to the neighbor reporting the route.

In short : FD is the total cost from local router to destination.

Feasible successor (FC): FC is basically an entry in the topology table that represent a path that's inferior to the successor route. FC is define as a path whose advertised distance is less than the feasible distance of the current successor and considered a backup route.

In short: Feasible Successor is the backup route and stored in the topology table.

Neighbor table: Each router keeps state information about adjacent neighbors. when a newly discovered neighbor is found, its address and interface are recorded in the routing table, stored in RAM.

In short: neighbor table contain the list of directly connected router.

Topology table: is populated by the neighbor table and the Diffusing Update Algorithm (DUAL) calculates the best loop-free path to each remote network. it contains all the destinations advertisement by neighboring routers.

In short: topology table contain list all the best route learned from neighbor.


Successor: a successor route is the best route to a remote network. a successor will be copied from the topology table to routing table.


Reliable Transport Protocol (RTP): EIGRP uses RTP and its function is to deliver EIGRP packets between neighbors in a reliable and ordered way. It can use multicast or unicast and to keep things efficient not all packets are sent reliable. Reliable means that when we send a packet we want to get an acknowledgment from the other side to make sure that they received it.

Here's description of the five different types of packets used by EIGRP:

Hello   A hello packets are used to discover EIGRP neighbors and sent via unreliable multicast, meaning  its doesn't require an acknowledgement. 

Update packets have routing information and are sent reliable to whatever router that require this information. Update packets can be sent to a single neighbor using unicast or to a group of neighbors using multicast.

Query packets are used when your EIGRP router hast information about a certain network and doesn't have any backup paths. router will send query packets to its neighbors asking them if they have information about this particular network.   

Reply packets are used in response to the query packets.

ACK packets are used to acknowledge the receipt of update, query and reply packets. ACK packets are sent by using unicast.

EIGRP metric:
 EIGRP uses diffusing update algorithm (DUAL) for selecting and maintain the best path to each remote network. EIGRP uses bandwidth, delay, reliability, load, MTU, and hop count, out of these six component the first four are combined together using well known formula to produce a single number that we call composite metric. by default EIGRP uses bandwidth and delay in the metric calculation 




Formula with default K values (K1=1, K2=0, K3=1, K4=0, K5=0)

Metric=[K1*BW + ((K2*BW) / (256 - LOAD)) + K3 * delay]

EIGRP metric 

BW= (107/lowest bandwidth in kbps)*256
Delay=(sum of total delay/10)*256

By default, EIGRP metric = bandwidth (slowest link) + delay (sum of delays)

Tuesday, 30 October 2018

Virtual Local Area Network (VLAN)

Virtual Local Area Network (VLAN)


 VLAN is a logical grouping of network users and resources connected to administratively defined ports on a switch. VLAN are given the ability to create smaller broadcast domains within a layer 2 switched internetworks by assigning different on the switch to service different subnetworks. A VLAN is treated like its own subnet or broadcast domain, meaning that frames broadcast into the network are only switched between the ports logically grouped within the same VLAN. By default, hosts in a specific VLAN can’t communicate with hosts that are member of another VLAN, so if you want communication, we need a router or Inter-VLAN Routing (IVR).

 Here is some basic information about VLAN:
  • ·         Divides a single broadcast domain into multiple broadcast domains
  • ·         VLAN provide layer 2 security
  • ·         VLAN 1 is the default VLAN
  • ·         We can create VLAN from 2-1001
  • ·         Can be configured on manageable switches only



Configuring basic VLAN on switch:


Topology






GOAL:
  • create four VLANs (10,20,30, and 40).
  • configuring port f 0/1 in to VLAN 10
  • configure multiple ports (2,3, and 4) to VLAN 20


Switch(config)#vlan 10
Switch(config-vlan)#name sales
Switch(config)#vlan 20
Switch(config-vlan)#name marketing
Switch(config)#vlan 30
Switch(config)#vlan 40






 Switch#show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
Gig0/1, Gig0/2
10 sales active
20 marketing active
30 VLAN0030 active
40 VLAN0040 active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0
30 enet 100030 1500 - - - - - 0 0
40 enet 100040 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

Remote SPAN VLANs
------------------------------------------------------------------------------

Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------




To shift the ports 

Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit

Switch(config)#interface range fastEthernet 0/2- 4
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 20
Switch(config-if-range)#exit

Switch#show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
Gig0/1, Gig0/2
10 sales active Fa0/1
20 marketing active Fa0/2, Fa0/3, Fa0/4
30 VLAN0030 active
40 VLAN0040 active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0
30 enet 100030 1500 - - - - - 0 0
40 enet 100040 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

Remote SPAN VLANs
------------------------------------------------------------------------------

Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------







Open Shortest Path First (OSPF) basic.





Open Shortest Path First (OSPF) 

Open shortest path first is an open standard routing protocol that’s been implemented by a wide variety of network venders, include Cisco. And it’s that open standard characteristic that’s the key to OSPF flexibility and popularity. OSPF use the Dijkstra algorithm to initially construct a shortest path tree and follows that by populating the routing table with the resulting best route. Its quick convergence is another reason it’s a favorite. Another two great advantages OSPF offers are that it supports multiple, equal-cost routes to the same destination and it also supports both IPv4 and IPv6 routed protocols.

Here’s a list that summarizes some of OSPF features:

·         Link-state routing protocol.
·         Open standard (IETF)
·         Allow for the creation of areas and autonomous system
·         Minimize the routing update traffic
·         It’s highly flexible, versatile, and scalable
·         Support VLSM/CIDR
·         Offers an unlimited hop count


Terminology

Link a link is a network or router interface assigned to any given network. When an interface is added to the OSPF process, it’s considered to be a link.



Router ID the router ID (RID) is an IP address used to identify the router. Cisco routers choose the router ID by using the highest IP address of all configured loopback interface. To router ID is basically the “name” of each router.

Neighbor neighbor are two or more routers that have an interface on a common network, such as two routers connected on a point-to-point serial link. OSPF neighbors must have a numbers of common configuration options to be able to successfully establishing a neighborship, and all of these options must be configured exactly the same way:
·         Area ID
·         Stub area flag
·         Authentication (if using one)
·         Hello and Dead intervals

Adjacency an adjacency is a relationship between two OSPF routers that permits the direct exchange of routes updates. OSPF directly share routes only with neighbors that have also established adjacencies. Not all the routers neighbors will become adjacent – this depends upon both the type of network and configuration of the routers.

Designated router a designated router(DR) is elected when OSPF routers connected to the same broadcast network to minimize the number of adjacencies formed and to publicize received routing information to and from the remaining routers on the broadcast network or link. Election are won based Upon a router’s priority level, with the one having the highest priority becoming the winner. If there’s a tie, the router ID will be used break it.

Backup designated router a backup designated router is hot standby for the DR on broadcast, or multi-access, links. The BDR receives all routing update from OSPF adjacent routers but does not disperse LSA updates.

Hello protocol the hello protocol provide dynamic neighbor discovery and maintain neighbor relationship. Hello packets are sent to multicast address 224.0.0.5.

Neighbor database the neighbor database is a list of all OSPF routers for which hello packets have been seen.

Topological database the topological database contains information from all of the link state advertisement packets that have been received from an area.

Link state advertisement a link state advertisement (LSA) is an OSPF data packet containing link-state and routing information that’s shared among OSPF routers. LAS packets are used to update and maintain the topological database. There are different types of LSA packets.

OSPF area an ospf area is a grouping of contagious networks and routers.

Broadcast (multi-access) broadcast multi-access networks such as Ethernet allow multiple devices to connect to or access the same network, enabling a broadcast ability in which a single packet is delivered to all nodes on the network.

Nonbroadcast multi-access (NBMA) nonbroadcast multi-access network are networks such as frame relay, X.25, and Asynchronous Transfer Mode (ATM). These kinds of networks allow for multi-access without broadcast ability like Ethernet.

Point-To-Point   Point-To-Point   refers to a type of network topology made up of a direct connection between two routers that provides a single communication path.
Point-to-multipoint Point-to-multipoint refers to type of network topology made up of a series of connections between a single interface on one router and multiple destination routers

 OSPF Metric



OSPF uses a metric referred to as cost. A cost is associated with every outgoing interface include in an SPF tree. Ospf metric is not define in standards, every vendor uses different formula to calculate metric. cisco  uses a simple equation of 108/bandwidth.



Topology 











Goal: verifying reachability between routers LUKE and MARK with basic OSPF  single area,




LUKE#show ip interface brief




Interface              IP-Address             OK? Method         Status             Protocol
Serial3/0              10.1.1.1                  YES manual           up                    up
Loopback0           192.168.100.50      YES manual          up                    up

MARK#show ip interface brief
Interface              IP-Address      OK? Method        Status                Protocol

Serial3/0              10.1.1.2        YES manual              up                    up
Loopback0        192.168.150.75  YES manual           up                    up

LUKE(config)#router ospf 1
LUKE(config-router)#network 10.0.0.0 0.255.255.255 area 0
LUKE(config-router)#network 192.168.100.0 0.0.0.255 area 0

MARK(config)#router ospf 1
MARK(config-router)#network 10.0.0.0 0.255.255.255 area 0
MARK(config-router)#network 192.168.150.0  0.0.0.255 area 0


LUKE#show ip ospf interface brief
Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C
Lo0          1     0               192.168.100.50/24  1     LOOP  0/0
Se3/0        1     0               10.1.1.1/8         64    P2P   1/1

MARK#show ip ospf interface br
Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C
Se3/0        1     0               10.1.1.2/8         64    P2P   1/1

LUKE#ping 192.168.150.75
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.150.75, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/27/68 ms

LUKE#traceroute 192.168.150.75
Type escape sequence to abort.
Tracing the route to 192.168.150.75
VRF info: (vrf in name/id, vrf out name/id)
  1 10.1.1.2 52 msec 88 msec 24 msec


MARK#ping 192.168.100.50
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.50, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/24/36 ms

MARK#traceroute 192.168.150.75
Type escape sequence to abort.
Tracing the route to 192.168.150.75
VRF info: (vrf in name/id, vrf out name/id)
  1 192.168.150.75 8 msec 8 msec 8 msec

















Routing Information Protocol (RIP)



Routing Information Protocol (RIP)

Routing information protocol (RIP) is a true distance-vector routing protocol. RIP sends the complete routing table out of all active interfaces every 30 seconds. It relies on hop count to determine the best route to a remote network, but it has a maximum 15 by default, so a destination of 16 would be considered unreachable. RIP works well in very small networks, but it’s not good at large networks with WAN links or on networks with a large numbers of routers installed and 
completely useless on networks have links with variable bandwidth.

RIP version 1 uses only classful routing, its means all devices in the network must use the same subnet mask, this is because RIP version 1 doesn’t send updates with subnet mask information in tow.
RIP version 2 provides something called prefix routing and does send subnet mask information with its route update. This is called classless routing.

In short

Routing Information Protocol version 1

·         Open standard protocol
·         Classful routing protocol
·         Updates are broadcast via 255.255.255.255
·         Administrative distance is 120
·         Metric: Hop counts, maximum Hop counts: 15  
·         Load balancing of 4 equal paths
·         Used for small organizations
·         Periodic updates and exchange entire routing table for every 30 seconds

Routing Information Protocol version 2

·         Classless routing protocol
·         Support VLSM
·         Supports authentication
Advantage of RIP
·         Easy to configure
·         No design constraints like OSPF protocol
·         No complexity
·         Less overhead
Disadvantage of RIP
·         Bandwidth utilization is very high as broadcast foe every 30 seconds
·         Works only on hop count
·         Not scalable as hop count is only 15
·         Slow convergence


Configuring RIPv2


Topology 

GOAL:

  • design the topology and assign ip addresses as per our diagram
  • make sure that the interface should be in UP  state.
  • configuring dynamic RIPv2. 
  • verify routing table and reachability LAN between LUKE, MARK, and JOHN. by doing ping and traceroute.   
LUKE#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol

Serial3/0              10.1.1.1           YES manual up                    up
Loopback0      192.168.100.50   YES manual up                    up

MARK#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol

Serial3/0              10.1.1.2        YES manual up                    up
Serial3/1              11.1.1.2        YES manual up                    up
Loopback0              192.168.150.75  YES manual up                    up

JOHN#show ip interface brief
Interface              IP-Address           OK? Method Status                Protocol
Serial3/1              11.1.1.1                    YES manual up                     up
Loopback0              192.168.200.100    YES manual up                    up


LUKE(config)#router rip
LUKE(config-router)#version 2
LUKE(config-router)#network 10.0.0.0
LUKE(config-router)#network 192.168.100.0

MARK(config)#router rip
MARK(config-router)#version 2
MARK(config-router)#network 10.0.0.0
MARK(config-router)#network 192.168.150.0
MARK(config-router)#network 11.0.0.0

JOHN(config)#router rip
JOHN(config-router)#version 2
JOHN(config-router)#network 192.168.200.0
JOHN(config-router)#network 11.0.0.0


LUKE#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/8 is directly connected, Serial3/0
L        10.1.1.1/32 is directly connected, Serial3/0
R     11.0.0.0/8 [120/1] via 10.1.1.2, 00:00:09, Serial3/0
      192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.100.0/24 is directly connected, Loopback0
L        192.168.100.50/32 is directly connected, Loopback0
R     192.168.150.0/24 [120/1] via 10.1.1.2, 00:00:09, Serial3/0
R     192.168.200.0/24 [120/2] via 10.1.1.2, 00:00:09, Serial3/0

MARK#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/8 is directly connected, Serial3/0
L        10.1.1.2/32 is directly connected, Serial3/0
      11.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        11.0.0.0/8 is directly connected, Serial3/1
L        11.1.1.2/32 is directly connected, Serial3/1
R     192.168.100.0/24 [120/1] via 10.1.1.1, 00:00:19, Serial3/0
      192.168.150.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.150.0/24 is directly connected, Loopback0
L        192.168.150.75/32 is directly connected, Loopback0
R     192.168.200.0/24 [120/1] via 11.1.1.1, 00:00:25, Serial3/1


JOHN#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

R     10.0.0.0/8 [120/1] via 11.1.1.2, 00:00:05, Serial3/1
      11.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        11.0.0.0/8 is directly connected, Serial3/1
L        11.1.1.1/32 is directly connected, Serial3/1
R     192.168.100.0/24 [120/2] via 11.1.1.2, 00:00:05, Serial3/1
R     192.168.150.0/24 [120/1] via 11.1.1.2, 00:00:05, Serial3/1
      192.168.200.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.200.0/24 is directly connected, Loopback0
L        192.168.200.100/32 is directly connected, Loopback0



LUKE#ping 192.168.200.100
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.200.100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/42/48 ms

LUKE#ping 192.168.150.75
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.150.75, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/18/20 ms

LUKE#ping 11.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/42/44 ms


MARK#ping 192.168.100.50
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.50, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/16/24 ms

MARK#ping 192.168.200.100
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.200.100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/14/20 ms



JOHN#ping 192.168.100.50
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.50, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/44/48 ms

JOHN#ping 192.168.150.75
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.150.75, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/22/28 ms

JOHN#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/30/40 ms



LUKE#traceroute 192.168.200.100
Type escape sequence to abort.
Tracing the route to 192.168.200.100
VRF info: (vrf in name/id, vrf out name/id)
  1 10.1.1.2 28 msec 24 msec 32 msec
  2 11.1.1.1 36 msec 64 msec 48 msec

LUKE#traceroute 192.168.150.75
Type escape sequence to abort.
Tracing the route to 192.168.150.75
VRF info: (vrf in name/id, vrf out name/id)
  1 10.1.1.2 16 msec 20 msec 28 msec
LUKE#traceroute 11.1.1.1

Type escape sequence to abort.
Tracing the route to 11.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 10.1.1.2 20 msec 16 msec 8 msec
  2 11.1.1.1 32 msec 36 msec 32 msec

MARK#traceroute 192.168.100.50
Type escape sequence to abort.
Tracing the route to 192.168.100.50
VRF info: (vrf in name/id, vrf out name/id)
  1 10.1.1.1 24 msec 12 msec 28 msec

MARK#traceroute 192.168.200.100
Type escape sequence to abort.
Tracing the route to 192.168.200.100
VRF info: (vrf in name/id, vrf out name/id)
  1 11.1.1.1 24 msec 44 msec 20 msec


JOHN#traceroute 192.168.100.50
Type escape sequence to abort.
Tracing the route to 192.168.100.50
VRF info: (vrf in name/id, vrf out name/id)
  1 11.1.1.2 12 msec 12 msec 12 msec
  2 10.1.1.1 48 msec 32 msec 40 msec

JOHN#traceroute 192.168.150.75
Type escape sequence to abort.
Tracing the route to 192.168.150.75
VRF info: (vrf in name/id, vrf out name/id)
  1 11.1.1.2 16 msec 20 msec 8 msec

JOHN#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 11.1.1.2 20 msec 20 msec 20 msec
  2 10.1.1.1 28 msec 32 msec 28 msec






 






























PIM Sparse Mode

PIM Sparse Mode  ( PIM-SM )  PIM  Sparse Mode explicitly builds unidirectional shared trees rooted at a ( RP ) rendezvous point per...