Showing posts with label multicast. Show all posts
Showing posts with label multicast. Show all posts

Monday 18 March 2024

What Bootstrap Router (BSR) ? How to configure Multicast PIM Bootstrap Router (BSR)?


What is Rendezvous's point?

The rendezvous point is a meeting point in the Multicast PIM sparse mode for all the multicast traffic. We have two ways to configure the Rendezvous point manually and automatically. Manual RP is for small networks and Auto RP is for large networks.

 

We have two discovery protocols for finding the Rendezvous point on the multicast network

 

1.     Auto Rendezvous point (Auto-RP)

2.     PIMv2 bootstrap router (BSR)

Multicast Bootstrap Router (BSR) 

Multicast PIM Bootstrap, also known as Protocol Independent Multicast (PIM) Bootstrap, is a protocol used in multicast routing to efficiently manage multicast traffic distribution in a network. PIM BSR router function is similar to Auto-RP but BSR is a standard-based protocol PIMv2 standard and also BSR supports IPv6 multicast. 

 




How does Multicast Bootstrap Router (BSR) work? 

 

  • Candidate BSR: Bootstrap Router collects information from the available Rendezvous points in the multicast network and advertises it on PIM-enabled interfaces throughout the multicast network. 
  • Candidate Rendezvous Point: Uses unicast PIM to advertise itself to BSR. 
  • BSR messages are sent hop-by-hop using multicast address 224.0.0.13 with a TTL of 1. These messages are routed only within the local segment.
  • When a multicast router receives a BSR message, it re-sends it to all other PIM-enabled interfaces.
  • BSR messages contain information about the BSR itself and RP-to-group mappings.

BSR vs. Auto-RP:

  • BSR is a standard protocol included in PIMv2, whereas Auto-RP is a Cisco proprietary protocol.
  • BSR uses unicast packets for RP announcements, while Auto-RP uses multicast.
  • BSR does not select the RP; it advertises all RPs with their associated multicast groups, allowing multicast routers to choose the RP they prefer.

 

 

Let's see the topology as per the diagram?

 

 

Topology:-https://youtu.be/vWHXTLczQUs?si=bduAb8ruzpumR8O1

 



 

Goal:

 

1.     configure the topology as per the diagram 

2.     configure IP addresses as per the topology

3.     configure IGP OSPF and advertise directly connected interfaces

4.     enable Multicasting on all the router

5.     configure PIM-SM on all interfaces 

6.     configure IGMP-group  224.50.50.50 on router 5 fa0/0

7.     configure Router 5 to advertise themselves as Rendezvous Point for all the groups

 

 

 

R1(config)#interface serial 4/0
R1(config-if)#ip address 1.1.1.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 10.1.1.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#no keepalive
R1(config-if)#exit
 
R2(config)#interface serial 4/0
R2(config-if)#ip address 1.1.1.2 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface serial 4/1
R2(config-if)#ip address 2.2.2.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit


R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 20.1.1.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#no keepalive
R2(config-if)#exit
 
R3(config)#interface serial 4/1
R3(config-if)#ip address 2.2.2.2 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#exit


R3(config)#interface serial 4/2
R3(config-if)#ip address 3.3.3.1 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#exit


R3(config)#interface fastethernet 0/0
R3(config-if)#ip address 30.1.1.1 255.0.0.0
R3(config-if)#no keepalive
R3(config-if)#no shutdown
R3(config-if)#exit
 
R4(config)#interface serial 4/2
R4(config-if)#ip address 3.3.3.2 255.0.0.0
R4(config-if)#no shutdown
R4(config-if)#exit

R4(config)#interface serial 4/4
R4(config-if)#ip address 5.5.5.2 255.0.0.0
R4(config-if)#no shutdown
R4(config-if)#exit


R4(config)#interface fastethernet 0/0
R4(config-if)#ip address 40.1.1.1 255.0.0.0
R4(config-if)#no shutdown
R4(config-if)#no keepalive
R4(config-if)#exit
 
R5(config)#interface serial 4/4
R5(config-if)#ip address 5.5.5.1 255.0.0.0
R5(config-if)#no shutdown
R5(config-if)#exit

R1(config)#router ospf 100
R1(config-router)#network 1.0.0.0 0.255.255.255 area 0
R1(config-router)#network 10.0.0.0 0.255.255.255 area 0
R1(config-router)#exit
 
*Mar 16 12:21:51.463: %OSPF-5-ADJCHG: Process 100, Nbr 20.1.1.1 on Serial4/0 from LOADING to FULL, Loading Done
 
R2(config)#router ospf 100
R2(config-router)#network 20.0.0.0 0.255.255.255 area 0
R2(config-router)#network 1.0.0.0 0.255.255.255 area 0
R2(config-router)#network 2.0.0.0 0.255.255.255 area 0
R2(config-router)#exit
 
*Mar 16 12:22:02.455: %OSPF-4-DUP_RTRID_NBR: OSPF detected duplicate router-id 20.1.1.1 from 2.2.2.2 on interface Serial4/1
*Mar 16 12:21:51.299: %OSPF-5-ADJCHG: Process 100, Nbr 10.1.1.1 on Serial4/0 from LOADING to FULL, Loading Done

 
R3(config)#router ospf 100
R3(config-router)#network 30.0.0.0 0.255.255.255 area 0
R3(config-router)#network 2.0.0.0 0.255.255.255 area 0
R3(config-router)#network 3.0.0.0 0.255.255.255 area 0
R3(config-router)#exit
 
R4(config)#router ospf 100
R4(config-router)#network 40.0.0.0 0.255.255.255 area 0
R4(config-router)#network 3.0.0.0 0.255.255.255 area 0
R4(config-router)#network 5.0.0.0 0.255.255.255 area 0
R4(config-router)#exit
*Mar 16 12:34:31.987: %OSPF-5-ADJCHG: Process 100, Nbr 50.1.1.1 on Serial4/4 from LOADING to FULL, Loading Done
*Mar 16 12:32:10.451: %OSPF-5-ADJCHG: Process 100, Nbr 30.1.1.1 on Serial4/2 from LOADING to FULL, Loading Done

 
R5(config)# router ospf 100
R5(config-router)#network 50.0.0.0 0.255.255.255 area 0
R5(config-router)#network 5.0.0.0 0.255.255.255 area 0
R5(config-router)#exit
*Mar 16 12:34:31.687: %OSPF-5-ADJCHG: Process 100, Nbr 40.1.1.1 on Serial4/4 from LOADING to FULL, Loading Done
 
 
R1(config)#ip multicast-routing
R1(config)#interface serial 4/0
R1(config-if)#ip pim sparse-mode
R1(config-if)#exit
 
R1(config)#interface fastethernet 0/0
R1(config-if)#ip pim sparse-mode
R1(config-if)#exit
 
R2(config)#ip multicast-routing
R2(config)#interface serial 4/0
R2(config-if)#ip pim sparse-mode
R2(config-if)#exit
 
R2(config)#interface serial 4/1
R2(config-if)#ip pim sparse-mode
R2(config-if)#exit
R2(config)#exit
 
*Mar 16 12:46:14.519: %PIM-5-NBRCHG: neighbor 1.1.1.1 UP on interface Serial4/0
*Mar 16 12:46:58.943: %PIM-5-NBRCHG: neighbor 2.2.2.2 UP on interface Serial4/1

R3(config)#ip multicast-routing
R3(config)#interface serial 4/1
R3(config-if)#ip pim sparse-mode
R3(config-if)#exit
 
R3(config)#interface serial 4/2
R3(config-if)#ip pim sparse-mode
R3(config-if)#exit
 
R3(config)#interface fastethernet 0/0
R3(config-if)#ip pim sparse-mode
R3(config-if)#exit
*Mar 16 12:46:58.947: %PIM-5-NBRCHG: neighbor 2.2.2.1 UP on interface Serial4/1
*Mar 16 12:47:59.979: %PIM-5-NBRCHG: neighbor 3.3.3.2 UP on interface Serial4/2

 
 
R4(config)#ip multicast-routing
R4(config)#interface serial 4/2
R4(config-if)#ip pim sparse-mode
R4(config-if)#exit
R4(config)#interface serial 4/3
R4(config-if)#ip pim sparse-mode
R4(config-if)#exit
 
*Mar 16 12:47:59.783: %PIM-5-NBRCHG: neighbor 3.3.3.1 UP on interface Serial4/2
*Mar 16 13:09:18.855: %PIM-5-NBRCHG: neighbor 5.5.5.1 UP on interface Serial4/4

 
R5(config)#interface loopback 0
R5(config-if)#ip address 15.1.1.1 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#exit
R5(config)#router ospf 100
R5(config-router)#network 15.1.1.0 255.0.0.0 area 0
R5(config-router)#exit
 
R5(config)#ip multicast-routing
R5(config)#interface serial 4/4
R5(config-if)#ip pim sparse-mode
R5(config-if)#exit
 
R5(config)#interface loopback 0
R5(config-if)#ip pim sparse-mode
R5(config-if)#exit
 
R5(config)#interface fastEthernet 0/0
R5(config-if)#ip igmp join-group 224.50.50.50
R5(config-if)#exit
 
R5(config)#interface f0/0
R5(config-if)#ip pim sparse-mode
R5(config-if)#exit
 
*Mar 16 13:42:16.819: %PIM-5-DRCHG: DR change from neighbor 0.0.0.0 to 50.1.1.1 on interface FastEthernet0/0
 
R5(config)#ip pim rp-candidate loopback 0
R5(config)#ip pim bsr-candidate loopback 0
 
R5(config)#do show ip pim rp mapping
PIM Group-to-RP Mappings
This system is a candidate RP (v2)
This system is the Bootstrap Router (v2
)
 
Group(s) 224.0.0.0/4
  RP 15.1.1.1 (?), v2
    Info source: 15.1.1.1 (?), via bootstrap, priority 0, holdtime 150
         Uptime: 00:00:58, expires: 00:01:29
 
R1#show ip pim rp mapping
PIM Group-to-RP Mappings
 
Group(s) 224.0.0.0/4
  RP 15.1.1.1 (?), v2
    Info source: 15.1.1.1 (?), via bootstrap, priority 0, holdtime 150
         Uptime: 00:07:26, expires: 00:02:01

 
 
R1#ping 224.50.50.50
 
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.50.50.50, timeout is 2 seconds:
 
Reply to request 0 from 5.5.5.1, 116 ms
Reply to request 0 from 5.5.5.1, 144 ms

 
 
R2#show ip pim rp mapping
PIM Group-to-RP Mappings
 
Group(s) 224.0.0.0/4
  RP 15.1.1.1 (?), v2
    Info source: 15.1.1.1 (?), via bootstrap, priority 0, holdtime 150
         Uptime: 00:41:52, expires: 00:01:4
7
R2#ping 224.50.50.50
 
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.50.50.50, timeout is 2 seconds:
 
Reply to request 0 from 5.5.5.1, 108 ms
Reply to request 0 from 5.5.5.1, 128 ms

 
R3#show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      S - State Refresh Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
2.2.2.1           Serial4/1                01:06:01/00:01:35 v2    1 / S P
3.3.3.2           Serial4/2                01:05:00/00:01:24 v2    1 / S P
R3#
R3#show ip pim rp mapping
PIM Group-to-RP Mappings
 
Group(s) 224.0.0.0/4
  RP 15.1.1.1 (?), v2
    Info source: 15.1.1.1 (?), via bootstrap, priority 0, holdtime 150
         Uptime: 00:42:53, expires: 00:01:44
 
R4#show ip pim interface
 
Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
3.3.3.2          Serial4/2                v2/S   1      30     1      0.0.0.0
4.4.4.1          Serial4/3                v2/S   0      30     1      0.0.0.0
5.5.5.2          Serial4/4                v2/S   1      30     1      0.0.0.0
R4#show ip pim rp mapping
PIM Group-to-RP Mappings
 
Group(s) 224.0.0.0/4
  RP 15.1.1.1 (?), v2
    Info source: 15.1.1.1 (?), via bootstrap, priority 0, holdtime 150
         Uptime: 00:43:22, expires: 00:02:18


R4#ping 224.50.50.50
 
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.50.50.50, timeout is 2 seconds:
 
Reply to request 0 from 5.5.5.1, 24 ms
Reply to request 0 from 5.5.5.1, 64 ms

 

 
R2#show ip pim bsr-router
PIMv2 Bootstrap information
  BSR address: 15.1.1.1 (?)
  Uptime:      00:44:28, BSR Priority: 0, Hash mask length: 0
  Expires:     00:01:54
x

 

Friday 15 March 2024

What is Auto-RP? How to configure Auto-RP?

What is Rendezvous's point?

The rendezvous point is a meeting point in the Multicast PIM sparse mode for all the multicast traffic. We have two ways to configure the Rendezvous point manually and automatically. Manual RP is for small networks and Auto RP is for large networks.

We have two discovery protocols for finding the Rendezvous point on the multicast network.

  1. Auto Rendezvous point (Auto-RP)
  2. PIMv2 bootstrap router (BSR)

What is Auto Rendezvous Point (Auto-RP)?

Auto Rendezvous Point (Auto-RP) Auto Rendezvous Point, also called Auto-RP, is a protocol used in Cisco networking devices to dynamically distribute multicast group information. Auto-RP is a legacy Cisco proprietary method of learning RP information on the PIM multicast network. Auto-RP used for router automatically learns RP address.

 

How Does Auto Rendezvous Point Work?

Auto-RP operates by designating a specific router as the rendezvous point (RP) for a multicast group. This RP is responsible for maintaining information about the multicast group members and facilitating multicast traffic distribution within the network. Through the Auto-RP protocol, routers can automatically discover the RP and establish communication paths for multicast traffic.

1.       Candidate Rendezvous Point generates advertisements using (S. 224.0.1.39) and groups with group information

2.       Mapping agent listens for (*,224.0.1.39) to learn about Rendezvous Point mappings.

3.       Mapping agent generates advertisement using (S,224.0.1.40) to distribute RP mapping information.

Benefits of Auto Rendezvous Point

Implementing Auto-RP in a network offers several advantages, including:

  • Simplified Configuration: Auto-RP automates determining the rendezvous point, eliminating the need for manual configuration and reducing the risk of human error.
  • Scalability: By efficiently managing multicast group information, Auto-RP ensures that multicast traffic is routed optimally, even in large networks with multiple multicast groups.
  • Improved Network Performance: With Auto-RP, routers can quickly adapt to changes in the network topology and ensure that multicast traffic is delivered efficiently and without delays.

 

 Topology:-


Goal:

  • configure the topology as per the diagram 
  • assign the IP addresses as per the topology 
  • enable Multicast routing on all the routers 
  • configure OSPF on all the routers
  • configure PIM sparse mode
  • configure manually IGMP multicast group membership on router 2 for testing.

  • configure the RP address on all the routers. 
  • configure Router 3 Loopback 0 to be RP and mapping agent for all multicast groups
  • advertise Loopback 0 13.0.0.1 in OSPF
  • Configure Auto-RP on all the routers
  • make sure all the routers can listen to Announcements

 


R1(config)#interface serial 4/0
R1(config-if)#ip address 1.1.1.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 10.1.1.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#no keepalive
R1(config-if)#exit
 
R2(config)#interface serial 4/0
R2(config-if)#ip address 1.1.1.2 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface serial 4/1
R2(config-if)#ip address 2.2.2.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 20.1.1.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#no keepalive
R2(config-if)#exit
 
R3(config)#interface serial 4/1
R3(config-if)#ip address 2.2.2.2 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface serial 4/2
R3(config-if)#ip address 3.3.3.1 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface fastethernet 0/0
R3(config-if)#ip address 30.1.1.1 255.0.0.0
R3(config-if)#no keepalive
R3(config-if)#no shutdown
R3(config-if)#exit
 
R4(config)#interface serial 4/2
R4(config-if)#ip address 3.3.3.2 255.0.0.0
R4(config-if)#no shutdown
R4(config-if)#exit

R4(config)#interface serial 4/4
R4(config-if)#ip address 5.5.5.2 255.0.0.0
R4(config-if)#no shutdown
R4(config-if)#exit

R4(config)#interface fastethernet 0/0
R4(config-if)#ip address 40.1.1.1 255.0.0.0
R4(config-if)#no shutdown
R4(config-if)#no keepalive
R4(config-if)#exit
 
R5(config)#interface serial 4/4
R5(config-if)#ip address 5.5.5.1 255.0.0.0
R5(config-if)#no shutdown
R5(config-if)#exit
R5(config)#interface fastethernet 0/0
R5(config-if)#ip address 50.1.1.1 255.0.0.0
R5(config-if)#no keepalive
R5(config-if)#no shutdown
R5(config-if)#exit
 

R1(config)#router ospf 1
R1(config-router)#network 10.0.0.0 0.255.255.255 area 0
R1(config-router)#network 1.0.0.0 0.255.255.255 area 0
R1(config-router)#exit

*Mar  9 13:26:44.063: %OSPF-5-ADJCHG: Process 1, Nbr 20.1.1.1 on Serial4/0 from LOADING to FULL, Loading Done
*Mar  9 13:27:43.187: %OSPF-5-ADJCHG: Process 1, Nbr 40.1.1.1 on Serial4/3 from LOADING to FULL, Loading Done
 
R2(config)#router ospf 1
R2(config-router)#network 20.0.0.0 0.255.255.255 area 0
R2(config-router)#network 2.0.0.0 0.255.255.255 area 0
R2(config-router)#network 1.0.0.0 0.255.255.255 area 0
R2(config-router)#exit

*Mar  9 13:26:44.079: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.1.1 on Serial4/0 from LOADING to FULL, Loading Done
*Mar  9 13:27:09.215: %OSPF-5-ADJCHG: Process 1, Nbr 30.1.1.1 on Serial4/1 from LOADING to FULL, Loading Done
 
R3(config)#router ospf 1
R3(config-router)#network 2.0.0.0 0.255.255.255 area 0
R3(config-router)#network 2.0.0.0 0.255.255.255 area 0
R3(config-router)#network 3.0.0.0 0.255.255.255 area 0
R3(config-router)#network 30.0.0.0 0.255.255.255 area 0
R3(config-router)#exit

*Mar  9 13:27:55.571: %OSPF-5-ADJCHG: Process 1, Nbr 40.1.1.1 on Serial4/2 from LOADING to FULL, Loading Done
*Mar  9 13:27:09.299: %OSPF-5-ADJCHG: Process 1, Nbr 20.1.1.1 on Serial4/1 from LOADING to FULL, Loading Done
 
 
R4(config)#router ospf 1
R4(config-router)#network 40.0.0.0 0.255.255.255 area 0
R4(config-router)#network 3.0.0.0 0.255.255.255 area 0
R4(config-router)#network 5.0.0.0 0.255.255.255 area 0
R4(config-router)#exit

*Mar  9 13:27:55.763: %OSPF-5-ADJCHG: Process 1, Nbr 30.1.1.1 on Serial4/2 from LOADING to FULL, Loading Done
*Mar  9 13:28:44.047: %OSPF-5-ADJCHG: Process 1, Nbr 50.1.1.1 on Serial4/4 from LOADING to FULL, Loading Done
 
R5(config)#router ospf 1
R5(config-router)#network 5.0.0.0 0.255.255.255 area 0
R5(config-router)#network 50.0.0.0 0.255.255.255 area 0
R5(config-router)#exit
*Mar  9 13:28:43.951: %OSPF-5-ADJCHG: Process 1, Nbr 40.1.1.1 on Serial4/4 from LOADING to FULL, Loading Done


R1(config)#ip multicast-routing

R1(config)#interface serial 4/0
R1(config-if)#ip pim sparse-mode
R1(config-if)#exit


R1(config)#interface fastEthernet 0/0
R1(config-if)#ip pim sparse-mode
R1(config-if)#exit

*Mar  9 13:32:17.003: %PIM-5-DRCHG: DR change from neighbor 0.0.0.0 to 10.1.1.1 on interface FastEthernet0/0
*Mar  9 13:32:57.099: %PIM-5-NBRCHG: neighbor 1.1.1.2 UP on interface Serial4/0
R2(config)#ip multicast-routing

R2(config)#interface serial 4/0
R2(config-if)#ip pim sparse-mode
R2(config-if)#exit

R2(config)#interface serial 4/1
R2(config-if)#ip pim sparse-mode
R2(config-if)#exit

R2(config)#interface fastethernet 0/0
R2(config-if)#ip pim sparse-mode
R2(config-if)#exit

*Mar  9 13:32:57.135: %PIM-5-NBRCHG: neighbor 1.1.1.1 UP on interface Serial4/0
*Mar  9 13:33:39.063: %PIM-5-DRCHG: DR change from neighbor 0.0.0.0 to 20.1.1.1 on interface FastEthernet0/0
*Mar  9 13:34:17.039: %PIM-5-NBRCHG: neighbor 2.2.2.2 UP on interface Serial4/1

R3(config)#ip multicast-routing

R3(config)#interface serial 4/1
R3(config-if)#ip pim sparse-mode
R3(config-if)#exit

R3(config)#interface serial 4/2
R3(config-if)#ip pim sparse-mode
R3(config-if)#exit

R3(config)#interface fastethernet 0/0
R3(config-if)#ip pim sparse-mode
R3(config-if)#exit

*Mar  9 13:34:53.087: %PIM-5-DRCHG: DR change from neighbor 0.0.0.0 to 30.1.1.1 on interface FastEthernet0/0
*Mar  9 13:34:17.139: %PIM-5-NBRCHG: neighbor 2.2.2.1 UP on interface Serial4/1
*Mar  9 13:35:33.479: %PIM-5-NBRCHG: neighbor 3.3.3.2 UP on interface Serial4/2

R4(config)#ip multicast-routing

R4(config)#interface serial 4/2
R4(config-if)#ip pim sparse-mode
R4(config-if)#exit


R4(config)#interface fastethernet 0/0
R4(config-if)#ip pim sparse-mode
R4(config-if)#exit

R4(config)#interface serial 4/4
R4(config-if)#ip pim sparse-mode
R4(config-if)#exit

*Mar  9 13:37:22.723: %PIM-5-NBRCHG: neighbor 5.5.5.1 UP on interface Serial4/4
*Mar  9 13:35:33.647: %PIM-5-NBRCHG: neighbor 3.3.3.1 UP on interface Serial4/2
*Mar  9 13:36:12.595: %PIM-5-DRCHG: DR change from neighbor 0.0.0.0 to 40.1.1.1 on interface FastEthernet0/0


R5(config)#ip multicast-routing
R5(config)#interface serial 4/4
R5(config-if)#ip pim sparse-mode
R5(config-if)#exit
 
R5(config)#interface fastethernet 0/0
R5(config-if)#ip pim sparse-mode
R5(config-if)#exit

*Mar  9 13:37:46.543: %PIM-5-DRCHG: DR change from neighbor 0.0.0.0 to 50.1.1.1 on interface FastEthernet0/0
*Mar  9 13:37:22.611: %PIM-5-NBRCHG: neighbor 5.5.5.2 UP on interface Serial4/4


R1#show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
1.1.1.1          Serial4/0                v2/S   1      30     1      0.0.0.0
10.1.1.1         FastEthernet0/0          v2/S   0      30     1      10.1.1.1

R1#show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      S - State Refresh Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
1.1.1.2           Serial4/0                00:07:37/00:01:27 v2    1 / S P

R2#show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
1.1.1.2          Serial4/0                v2/S   1      30     1      0.0.0.0
2.2.2.1          Serial4/1                v2/S   1      30     1      0.0.0.0
20.1.1.1         FastEthernet0/0          v2/S   0      30     1      20.1.1.1

R2#show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      S - State Refresh Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
1.1.1.1           Serial4/0                00:08:03/00:01:32 v2    1 / S P
2.2.2.2           Serial4/1                00:06:43/00:01:24 v2    1 / S P



R4#show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
3.3.3.2          Serial4/2                v2/S   1      30     1      0.0.0.0
40.1.1.1         FastEthernet0/0          v2/S   0      30     1      40.1.1.1
5.5.5.2          Serial4/4                v2/S   1      30     1      0.0.0.0

R4#show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      S - State Refresh Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
3.3.3.1           Serial4/2                00:06:02/00:01:35 v2    1 / S P
5.5.5.1           Serial4/4                00:04:13/00:01:26 v2    1 / S P


R3(config)#interface loopback 0
R3(config-if)#ip address 13.0.0.1 255.255.255.0
R3(config-if)#exit

R3(config)#interface loopback 0
R3(config-if)#ip pim sparse-mode

R3(config-if)#ip pim send-rp-announce loopback 0 scope 10
R3(config)#ip pim send-rp-discovery loopback 0 scope 10
R3(config)#end

R3(config)#interface fastEthernet 0/0
R3(config-if)#ip igmp join-group 224.5.5.5
R3(config-if)#exit

R3(config)#router ospf 1
R3(config-router)#network 13.0.0.0 255.0.0.0 area 0
R3(config-router)#exit

R1(config)#ip pim autorp listener
R1(config)#end
R2(config)#ip pim autorp listener
R2(config)#end
R3(config)#ip pim autorp listener
R3(config)#end
R4(config)#ip pim autorp listener
R4(config)#end
R5(config)#ip pim autorp listener
R5(config)#end

R1#show ip pim rp mapping
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
  RP 13.0.0.1 (?), v2v1
    Info source: 13.0.0.1 (?), elected via Auto-RP
         Uptime: 00:40:34, expires: 00:02:58

R1#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.39), 00:40:38/stopped, RP 0.0.0.0, flags: D
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial4/0, Forward/Sparse, 00:40:38/00:00:00

(13.0.0.1, 224.0.1.39), 00:00:48/00:02:11, flags: PT
  Incoming interface: Serial4/0, RPF nbr 1.1.1.2
  Outgoing interface list: Null

(*, 224.0.1.40), 00:44:37/stopped, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial4/0, Forward/Sparse, 00:44:37/00:00:00

(13.0.0.1, 224.0.1.40), 00:40:40/00:02:51, flags: PLTX
  Incoming interface: Serial4/0, RPF nbr 1.1.1.2
  Outgoing interface list: Null


R5#show ip pim rp mapping
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
  RP 13.0.0.1 (?), v2v1
    Info source: 13.0.0.1 (?), elected via Auto-RP
         Uptime: 00:41:26, expires: 00:02:01

R5#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.39), 00:41:29/stopped, RP 0.0.0.0, flags: D
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial4/4, Forward/Sparse, 00:41:29/00:00:00

(13.0.0.1, 224.0.1.39), 00:01:39/00:01:20, flags: PT
  Incoming interface: Serial4/4, RPF nbr 5.5.5.2
  Outgoing interface list: Null

(*, 224.0.1.40), 00:44:31/stopped, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial4/4, Forward/Sparse, 00:44:31/00:00:00

(13.0.0.1, 224.0.1.40), 00:41:30/00:02:01, flags: PLTX
  Incoming interface: Serial4/4, RPF nbr 5.5.5.2
  Outgoing interface list: Null

R1#ping 224.5.5.5 repeat 100

Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 224.5.5.5, timeout is 2 seconds:

Reply to request 0 from 2.2.2.2, 56 ms
Reply to request 0 from 2.2.2.2, 56 ms
Reply to request 1 from 2.2.2.2, 72 ms
Reply to request 1 from 2.2.2.2, 96 ms
Reply to request 1 from 2.2.2.2, 96 ms
Reply to request 1 from 2.2.2.2, 72 ms
Reply to request 2 from 2.2.2.2, 88 ms
Reply to request 2 from 2.2.2.2, 108 ms
Reply to request 3 from 2.2.2.2, 68 ms
Reply to 

R1#show ip pim autorp
AutoRP Information:
  AutoRP is enabled.
  AutoRP groups over sparse mode interface is enabled

PIM AutoRP Statistics: Sent/Received
  RP Announce: 0/0, RP Discovery: 0/51


Saturday 5 December 2020

What is PIM Spare-Dense Mode ? How to configure Multicasting PIM Spare-Dense Mode?

 

 PIM Spare-Dense Mode 

PIM (Protocol Independent Multicast) is a family of multicast routing protocols. The word independent comes from the fact that PIM does not build a topology of its own, it uses the information from IGP routing protocols to achieve this. 

There are a number of different PIM flavors:

·                      PIM Sparse-Mode 

·                      PIM Dense-Mode

·                      Bidirectional PIM 

·                      Source-Specific PIM.

 

PIM (Protocol Independent Multicast) Modes

 


PIM modes tell how the multicast tree is built from sender to receiver. PIM mode will decide how the tree is built, and who will receive traffic.

 

PIM supports three different modes:

 

 

1.             PIM Dense Mode

2.             PIM Sparse mode

3.             PIM Sparse-Dense mode

 

 

 

PIM Dense mode:- Dense mode forward multicast traffic on all interfaces until a downstream router requests us to stop forwarding.

 

Pim dense mode Uses implicit join get traffic even if not asked Also called as flood and prune.

PIM Dense Mode Suitable for small multicast implementation.  Default hello= 30 sec & dead= 90 sec Discover PIM neighbor (uses 224.0.0.13). Flood all the multicast traffic on all PIM enables interfaces Prune unwanted traffic to Maintain multicast table

 

 

PIM Sparse mode:-   (PIM-SM PIM Sparse Mode explicitly builds unidirectional shared trees rooted at an (RP) rendezvous point per group, and optionally creates shortest-path trees per source. (PIM-SM) PIM Sparse Mode generally scales fairly well for wide-area usage.


Sparse-mode protocol does not forward the group traffic to any other router unless it receives a message from that router requesting copies of a packet sent to a particular group.

 

The PIM spares mode operation begins with the packet being forwarded to a special router called the rendezvous point (RP).



PIM Sparse Mode uses explicit join means (not receive unless you ask for). PIM Sparse Mode uses both shared tree & source tree, more scalable

 


 PIM Sparse-Dense mode:- .

Let's talk about PIM Spare-Dense mode you can use spare mode or dense mode for each multicasting group. But here is the question comes why do we want to use this?

When we use PIM sparse mode, in our multicast routers we need to know where the RP (Rendezvous Point) is in the network and most important which groups they serve. But again we have a solution.

 There are two methods:

Static: configure the IP address of the RP on all multicast routers.

Dynamic: use Auto RP or BSR.

When we use PIM Sparse mode and Auto RP, the group-to-RP mapping is sent to the multicast 224.0.1.40 address wait a minute….. How do we receive traffic from 224.0.1.40 when we don’t know where the RP (Rendezvous Point) is? There are two methods to solve this:

Use the IP PIM auto RP listener command.

Use the PIM sparse-dense mode.

The IP PIM auto RP listener command floods auto RP 224.0.1.39 and 224.0.1.40 multicast groups on sparse mode interfaces, allowing all routers to receive the group-to-RP mapping information.

PIM sparse-dense mode also allows us to flood the auto RP 224.0.1.39 and 224.0.1.40 multicast groups but also, it also floods all multicast traffic that we don’t have an RP for.

 

 Let's see the configuration 

Topology:- 



`Goal :

1. configure the topology as per the diagram 

2. configure the IP addresses as per the topology 

3. configure OSPF 1 advertise the interfaces  

4. configure manually IGMP multicast  (224.5.5.5) group membership on router 5 for testing.

5. configure router 3 loopback (192.168.30.1) a static rendezvous point (RP) advertise in OSPF 1 with the mask /24. 

6. Make sure route 3 should be RP only for group 224.5.5.5

6. configure RP address on all the routers.

7. configure router 5 to join group 224.15.15.15 and ensure that router 1 should be able to ping the multicast group 224.50.50.50 without RP.


R1#show ip interface brief

Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        10.1.1.1        YES manual up                    up

Serial4/0                    1.1.1.1         YES manual up                    up

Serial4/3                    4.4.4.2         YES manual up                    up

Loopback0              192.168.10.1    YES manual up                    up

Loopback1              192.168.11.1    YES manual up                    up

Loopback2              192.168.12.1    YES manual up                    up

Loopback3              192.168.13.1    YES manual up                    up

R1(config-if)#exit


R2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        20.1.1.1        YES manual up                    up

Serial4/0              1.1.1.2         YES manual up                    up
Serial4/1              2.2.2.1         YES manual up                    up

Loopback0              192.168.20.1    YES manual up                    up
Loopback1              192.168.21.1    YES manual up                    up
Loopback2              192.168.22.1    YES manual up                    up
Loopback3              192.168.23.1    YES manual up                    up


R3#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        30.1.1.1        YES manual up                    up

Serial4/1              2.2.2.2         YES manual up                    up
Serial4/2              3.3.3.1         YES manual up                    up

Loopback0              192.168.30.1    YES manual up                    up
Loopback1              192.168.31.1    YES manual up                    up
Loopback2              192.168.32.1    YES manual up                    up
Loopback3              192.168.33.1    YES manual up                    up

R4#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        40.1.1.1        YES manual up                    up

Serial4/2              3.3.3.2         YES manual up                    up
Serial4/3              4.4.4.1         YES manual up                    up
Serial5/0              5.5.5.2         YES manual up                    up

Loopback1              192.168.41.1    YES manual up                    up
Loopback2              192.168.42.1    YES manual up                    up
Loopback3              192.168.43.1    YES manual up                    up


R5#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        50.1.1.1        YES manual up                    up
Serial5/0                    5.5.5.1         YES manual up                    up
Loopback0              15.0.0.1        YES manual up                    up
Loopback1              15.0.1.1        YES manual up                    up
Loopback2              15.0.2.1        YES manual up                    up
Loopback3              15.0.3.1        YES manual up                    up



R1(config)#router ospf 1
R1(config-router)#network 10.0.0.0 0.255.255.255  area 0
R1(config-router)#network 1.0.0.0 0.255.255.255 area 0
R1(config-router)#network 4.0.0.0 0.255.255.255  area 0
R1(config-router)#network 192.168.10.0 255.0.0.0 area 0
R1(config-router)#network 192.168.11.0 255.0.0.0 area 0
R1(config-router)#network 192.168.12.0 255.0.0.0 area 0
R1(config-router)#network 192.168.13.0 255.0.0.0 area 0
R1(config-router)#exit

*Dec  5 12:20:37.259: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.23.1 on Serial4/0 from LOADING to FULL, Loading Done


R2(config)#router ospf 1
R2(config-router)#network 1.0.0.0 0.255.255.255 area 0
R2(config-router)#network 20.0.0.0 0.255.255.255 area 0
R2(config-router)#network 2.0.0.0 0.255.255.255  area 0
R2(config-router)#network 192.168.20.0 255.0.0.0 area 0
R2(config-router)#network 192.168.21.0 255.0.0.0 area 0
R2(config-router)#network 192.168.22.0 255.0.0.0 area 0
R2(config-router)#network 192.168.23.0 255.0.0.0 area 0
R2(config-router)#exit


*Dec  5 12:19:47.011: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.13.1 on Serial4/0 from LOADING to FULL, Loading Done

*Dec  5 12:21:04.115: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.33.1 on Serial4/1 from LOADING to FULL, Loading  Done


R3(config)#router ospf 1
R3(config-router)#network 2.0.0.0 0.255.255.255 area 0
R3(config-router)#network 30.0.0.0 0.255.255.255 area 0
R3(config-router)#network 3.0.0.0 0.255.255.255  area 0
R3(config-router)#network 192.168.30.0 255.0.0.0 area 0
R3(config-router)#network 192.168.31.0 255.0.0.0 area 0
R3(config-router)#network 192.168.32.0 255.0.0.0 area 0
R3(config-router)#network 192.168.33.0 255.0.0.0 area 0
R3(config-router)#exit

*Dec  5 12:20:24.231: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.23.1 on Serial4/1 from LOADING to FULL, Loading Done

*Dec  5 12:24:51.491: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.43.1 on Serial4/2 from LOADING to FULL, Loading Done


R4(config)#router ospf 1
R4(config-router)#network 5.0.0.0 0.255.255.255 area 0
R4(config-router)#network 3.0.0.0 0.255.255.255 area 0
R4(config-router)#network 4.0.0.0 0.255.255.255  area 0
R4(config-router)#network 40.0.0.0 0.255.255.255 area 0
R4(config-router)#network 192.168.40.0 255.0.0.0 area 0
R4(config-router)#network 192.168.41.0 255.0.0.0 area 0
R4(config-router)#network 192.168.42.0 255.0.0.0 area 0
R4(config-router)#network 192.168.43.0 255.0.0.0 area 0
R4(config-router)#exit

*Dec  5 12:27:51.511: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.33.1 on Serial4/2 from LOADING to FULL, Loading  Done

*Dec  5 12:27:51.511: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.13.1 on Serial4/3 from LOADING to FULL, Loading  Done

*Dec  5 12:32:40.055: %OSPF-5-ADJCHG: Process 1, Nbr 15.0.3.1 on Serial5/0 from LOADING to FULL, Loading Done

R5(config)#router ospf 1
R5(config-router)#network 5.0.0.0 0.255.255.255 area 0
R5(config-router)#network 50.0.0.0 0.255.255.255 area 0
R5(config-router)#network 15.0.0.0  255.0.0.0 area 0
R5(config-router)#network  15.0.1.0  255.0.0.0 area 0
R5(config-router)#network 15.0.2.0  255.0.0.0 area 0
R5(config-router)#network 15.0.3.0  255.0.0.0 area 0
R5(config-router)#end

*Dec  5 12:33:10.787: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.43.1 on Serial5/0 from LOADING to FULL, Loading Done


R1#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

O     2.0.0.0/8 [110/128] via 1.1.1.2, 01:31:38, Serial4/0
O     3.0.0.0/8 [110/128] via 4.4.4.1, 01:25:54, Serial4/3
O     5.0.0.0/8 [110/128] via 4.4.4.1, 01:25:54, Serial4/3
      15.0.0.0/32 is subnetted, 4 subnets
O        15.0.0.1 [110/129] via 4.4.4.1, 01:21:05, Serial4/3
O        15.0.1.1 [110/129] via 4.4.4.1, 01:21:05, Serial4/3
O        15.0.2.1 [110/129] via 4.4.4.1, 01:21:05, Serial4/3
O        15.0.3.1 [110/129] via 4.4.4.1, 01:21:05, Serial4/3
O     20.0.0.0/8 [110/65] via 1.1.1.2, 01:31:38, Serial4/0
O     30.0.0.0/8 [110/129] via 4.4.4.1, 01:19:55, Serial4/3
                 [110/129] via 1.1.1.2, 01:19:55, Serial4/0
O     40.0.0.0/8 [110/65] via 4.4.4.1, 01:19:33, Serial4/3
O     50.0.0.0/8 [110/129] via 4.4.4.1, 01:21:05, Serial4/3
      192.168.20.0/32 is subnetted, 1 subnets
O        192.168.20.1 [110/65] via 1.1.1.2, 01:31:38, Serial4/0
      192.168.21.0/32 is subnetted, 1 subnets
O        192.168.21.1 [110/65] via 1.1.1.2, 01:31:38, Serial4/0
      192.168.22.0/32 is subnetted, 1 subnets
O        192.168.22.1 [110/65] via 1.1.1.2, 01:31:38, Serial4/0
      192.168.23.0/32 is subnetted, 1 subnets
O        192.168.23.1 [110/65] via 1.1.1.2, 01:31:38, Serial4/0
O     192.168.30.0/24 [110/129] via 4.4.4.1, 01:11:06, Serial4/3
                      [110/129] via 1.1.1.2, 01:11:06, Serial4/0
      192.168.31.0/32 is subnetted, 1 subnets
O        192.168.31.1 [110/129] via 4.4.4.1, 01:25:54, Serial4/3
                      [110/129] via 1.1.1.2, 01:30:21, Serial4/0
      192.168.32.0/32 is subnetted, 1 subnets
O        192.168.32.1 [110/129] via 4.4.4.1, 01:25:54, Serial4/3
                      [110/129] via 1.1.1.2, 01:30:21, Serial4/0
      192.168.33.0/32 is subnetted, 1 subnets
O        192.168.33.1 [110/129] via 4.4.4.1, 01:25:54, Serial4/3
                      [110/129] via 1.1.1.2, 01:30:21, Serial4/0
      192.168.41.0/32 is subnetted, 1 subnets
O        192.168.41.1 [110/65] via 4.4.4.1, 01:25:54, Serial4/3
      192.168.42.0/32 is subnetted, 1 subnets
O        192.168.42.1 [110/65] via 4.4.4.1, 01:25:54, Serial4/3
      192.168.43.0/32 is subnetted, 1 subnets
O        192.168.43.1 [110/65] via 4.4.4.1, 01:25:54, Serial4/3


R2#show ip route ospf 1
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

O     3.0.0.0/8 [110/128] via 2.2.2.2, 01:31:09, Serial4/1
O     4.0.0.0/8 [110/128] via 1.1.1.1, 01:32:27, Serial4/0
O     5.0.0.0/8 [110/192] via 2.2.2.2, 01:26:42, Serial4/1
                [110/192] via 1.1.1.1, 01:26:42, Serial4/0
O     10.0.0.0/8 [110/65] via 1.1.1.1, 01:21:27, Serial4/0
      15.0.0.0/32 is subnetted, 4 subnets
O        15.0.0.1 [110/193] via 2.2.2.2, 01:21:53, Serial4/1
                  [110/193] via 1.1.1.1, 01:21:53, Serial4/0
O        15.0.1.1 [110/193] via 2.2.2.2, 01:21:53, Serial4/1
                  [110/193] via 1.1.1.1, 01:21:53, Serial4/0
O        15.0.2.1 [110/193] via 2.2.2.2, 01:21:53, Serial4/1
                  [110/193] via 1.1.1.1, 01:21:53, Serial4/0
O        15.0.3.1 [110/193] via 2.2.2.2, 01:21:53, Serial4/1
                  [110/193] via 1.1.1.1, 01:21:53, Serial4/0
O     30.0.0.0/8 [110/65] via 2.2.2.2, 01:20:44, Serial4/1
O     40.0.0.0/8 [110/129] via 2.2.2.2, 01:20:21, Serial4/1
                 [110/129] via 1.1.1.1, 01:20:21, Serial4/0
O     50.0.0.0/8 [110/193] via 2.2.2.2, 01:21:53, Serial4/1
                 [110/193] via 1.1.1.1, 01:21:53, Serial4/0
      192.168.10.0/32 is subnetted, 1 subnets
O        192.168.10.1 [110/65] via 1.1.1.1, 01:32:27, Serial4/0
      192.168.11.0/32 is subnetted, 1 subnets
O        192.168.11.1 [110/65] via 1.1.1.1, 01:32:27, Serial4/0
      192.168.12.0/32 is subnetted, 1 subnets
O        192.168.12.1 [110/65] via 1.1.1.1, 01:32:27, Serial4/0
      192.168.13.0/32 is subnetted, 1 subnets
O        192.168.13.1 [110/65] via 1.1.1.1, 01:32:27, Serial4/0
O     192.168.30.0/24 [110/65] via 2.2.2.2, 01:11:55, Serial4/1
      192.168.31.0/32 is subnetted, 1 subnets
O        192.168.31.1 [110/65] via 2.2.2.2, 01:31:09, Serial4/1
      192.168.32.0/32 is subnetted, 1 subnets
O        192.168.32.1 [110/65] via 2.2.2.2, 01:31:09, Serial4/1
      192.168.33.0/32 is subnetted, 1 subnets
O        192.168.33.1 [110/65] via 2.2.2.2, 01:31:09, Serial4/1
      192.168.41.0/32 is subnetted, 1 subnets
O        192.168.41.1 [110/129] via 2.2.2.2, 01:26:42, Serial4/1
                      [110/129] via 1.1.1.1, 01:26:42, Serial4/0
      192.168.42.0/32 is subnetted, 1 subnets
O        192.168.42.1 [110/129] via 2.2.2.2, 01:26:42, Serial4/1
                      [110/129] via 1.1.1.1, 01:26:42, Serial4/0
      192.168.43.0/32 is subnetted, 1 subnets
O        192.168.43.1 [110/129] via 2.2.2.2, 01:26:42, Serial4/1
                      [110/129] via 1.1.1.1, 01:26:42, Serial4/0


R3(config)#interface loopback 0
R3(config-if)#ip ospf network point-to-point
R3(config-if)#exit


R3#show ip route ospf 1
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

O     1.0.0.0/8 [110/128] via 2.2.2.1, 01:31:57, Serial4/1
O     4.0.0.0/8 [110/128] via 3.3.3.2, 01:27:29, Serial4/2
O     5.0.0.0/8 [110/128] via 3.3.3.2, 01:27:29, Serial4/2
O     10.0.0.0/8 [110/129] via 3.3.3.2, 01:22:15, Serial4/2
                 [110/129] via 2.2.2.1, 01:22:15, Serial4/1
      15.0.0.0/32 is subnetted, 4 subnets
O        15.0.0.1 [110/129] via 3.3.3.2, 01:22:41, Serial4/2
O        15.0.1.1 [110/129] via 3.3.3.2, 01:22:41, Serial4/2
O        15.0.2.1 [110/129] via 3.3.3.2, 01:22:41, Serial4/2
O        15.0.3.1 [110/129] via 3.3.3.2, 01:22:41, Serial4/2
O     20.0.0.0/8 [110/65] via 2.2.2.1, 01:31:57, Serial4/1
O     40.0.0.0/8 [110/65] via 3.3.3.2, 01:21:08, Serial4/2
O     50.0.0.0/8 [110/129] via 3.3.3.2, 01:22:41, Serial4/2
      192.168.10.0/32 is subnetted, 1 subnets
O        192.168.10.1 [110/129] via 3.3.3.2, 01:27:29, Serial4/2
                      [110/129] via 2.2.2.1, 01:31:57, Serial4/1
      192.168.11.0/32 is subnetted, 1 subnets
O        192.168.11.1 [110/129] via 3.3.3.2, 01:27:29, Serial4/2
                      [110/129] via 2.2.2.1, 01:31:57, Serial4/1
      192.168.12.0/32 is subnetted, 1 subnets
O        192.168.12.1 [110/129] via 3.3.3.2, 01:27:29, Serial4/2
                      [110/129] via 2.2.2.1, 01:31:57, Serial4/1
      192.168.13.0/32 is subnetted, 1 subnets
O        192.168.13.1 [110/129] via 3.3.3.2, 01:27:29, Serial4/2
                      [110/129] via 2.2.2.1, 01:31:57, Serial4/1
      192.168.20.0/32 is subnetted, 1 subnets
O        192.168.20.1 [110/65] via 2.2.2.1, 01:31:57, Serial4/1
      192.168.21.0/32 is subnetted, 1 subnets
O        192.168.21.1 [110/65] via 2.2.2.1, 01:31:57, Serial4/1
      192.168.22.0/32 is subnetted, 1 subnets
O        192.168.22.1 [110/65] via 2.2.2.1, 01:31:57, Serial4/1
      192.168.23.0/32 is subnetted, 1 subnets
O        192.168.23.1 [110/65] via 2.2.2.1, 01:31:57, Serial4/1
      192.168.41.0/32 is subnetted, 1 subnets
O        192.168.41.1 [110/65] via 3.3.3.2, 01:27:29, Serial4/2
      192.168.42.0/32 is subnetted, 1 subnets
O        192.168.42.1 [110/65] via 3.3.3.2, 01:27:29, Serial4/2
      192.168.43.0/32 is subnetted, 1 subnets
O        192.168.43.1 [110/65] via 3.3.3.2, 01:27:29, Serial4/2



R4#show ip route ospf 1
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

O     1.0.0.0/8 [110/128] via 4.4.4.2, 01:27:58, Serial4/3
O     2.0.0.0/8 [110/128] via 3.3.3.1, 01:27:58, Serial4/2
O     10.0.0.0/8 [110/65] via 4.4.4.2, 01:22:43, Serial4/3
      15.0.0.0/32 is subnetted, 4 subnets
O        15.0.0.1 [110/65] via 5.5.5.1, 01:23:09, Serial5/0
O        15.0.1.1 [110/65] via 5.5.5.1, 01:23:09, Serial5/0
O        15.0.2.1 [110/65] via 5.5.5.1, 01:23:09, Serial5/0
O        15.0.3.1 [110/65] via 5.5.5.1, 01:23:09, Serial5/0
O     20.0.0.0/8 [110/129] via 4.4.4.2, 01:27:58, Serial4/3
                 [110/129] via 3.3.3.1, 01:27:58, Serial4/2
O     30.0.0.0/8 [110/65] via 3.3.3.1, 01:22:00, Serial4/2
O     50.0.0.0/8 [110/65] via 5.5.5.1, 01:23:09, Serial5/0
      192.168.10.0/32 is subnetted, 1 subnets
O        192.168.10.1 [110/65] via 4.4.4.2, 01:27:58, Serial4/3
      192.168.11.0/32 is subnetted, 1 subnets
O        192.168.11.1 [110/65] via 4.4.4.2, 01:27:58, Serial4/3
      192.168.12.0/32 is subnetted, 1 subnets
O        192.168.12.1 [110/65] via 4.4.4.2, 01:27:58, Serial4/3
      192.168.13.0/32 is subnetted, 1 subnets
O        192.168.13.1 [110/65] via 4.4.4.2, 01:27:58, Serial4/3
      192.168.20.0/32 is subnetted, 1 subnets
O        192.168.20.1 [110/129] via 4.4.4.2, 01:27:58, Serial4/3
                      [110/129] via 3.3.3.1, 01:27:58, Serial4/2
      192.168.21.0/32 is subnetted, 1 subnets
O        192.168.21.1 [110/129] via 4.4.4.2, 01:27:58, Serial4/3
                      [110/129] via 3.3.3.1, 01:27:58, Serial4/2
      192.168.22.0/32 is subnetted, 1 subnets
O        192.168.22.1 [110/129] via 4.4.4.2, 01:27:58, Serial4/3
                      [110/129] via 3.3.3.1, 01:27:58, Serial4/2
      192.168.23.0/32 is subnetted, 1 subnets
O        192.168.23.1 [110/129] via 4.4.4.2, 01:27:58, Serial4/3
                      [110/129] via 3.3.3.1, 01:27:58, Serial4/2
O     192.168.30.0/24 [110/65] via 3.3.3.1, 01:13:11, Serial4/2
      192.168.31.0/32 is subnetted, 1 subnets
O        192.168.31.1 [110/65] via 3.3.3.1, 01:27:58, Serial4/2
      192.168.32.0/32 is subnetted, 1 subnets
O        192.168.32.1 [110/65] via 3.3.3.1, 01:27:58, Serial4/2
      192.168.33.0/32 is subnetted, 1 subnets
O        192.168.33.1 [110/65] via 3.3.3.1, 01:27:58, Serial4/2



R5#show ip route ospf 1
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

O     1.0.0.0/8 [110/192] via 5.5.5.2, 01:23:43, Serial5/0
O     2.0.0.0/8 [110/192] via 5.5.5.2, 01:23:43, Serial5/0
O     3.0.0.0/8 [110/128] via 5.5.5.2, 01:23:43, Serial5/0
O     4.0.0.0/8 [110/128] via 5.5.5.2, 01:23:43, Serial5/0
O     10.0.0.0/8 [110/129] via 5.5.5.2, 01:23:16, Serial5/0
O     20.0.0.0/8 [110/193] via 5.5.5.2, 01:23:43, Serial5/0
O     30.0.0.0/8 [110/129] via 5.5.5.2, 01:22:33, Serial5/0
O     40.0.0.0/8 [110/65] via 5.5.5.2, 01:22:10, Serial5/0
      192.168.10.0/32 is subnetted, 1 subnets
O        192.168.10.1 [110/129] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.11.0/32 is subnetted, 1 subnets
O        192.168.11.1 [110/129] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.12.0/32 is subnetted, 1 subnets
O        192.168.12.1 [110/129] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.13.0/32 is subnetted, 1 subnets
O        192.168.13.1 [110/129] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.20.0/32 is subnetted, 1 subnets
O        192.168.20.1 [110/193] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.21.0/32 is subnetted, 1 subnets
O        192.168.21.1 [110/193] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.22.0/32 is subnetted, 1 subnets
O        192.168.22.1 [110/193] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.23.0/32 is subnetted, 1 subnets
O        192.168.23.1 [110/193] via 5.5.5.2, 01:23:43, Serial5/0
O     192.168.30.0/24 [110/129] via 5.5.5.2, 01:13:43, Serial5/0
      192.168.31.0/32 is subnetted, 1 subnets
O        192.168.31.1 [110/129] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.32.0/32 is subnetted, 1 subnets
O        192.168.32.1 [110/129] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.33.0/32 is subnetted, 1 subnets
O        192.168.33.1 [110/129] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.41.0/32 is subnetted, 1 subnets
O        192.168.41.1 [110/65] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.42.0/32 is subnetted, 1 subnets
O        192.168.42.1 [110/65] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.43.0/32 is subnetted, 1 subnets
O        192.168.43.1 [110/65] via 5.5.5.2, 01:23:43, Serial5/0

R1(config)#ip multicast-routing
R1(config)#access-list 5 permit host 224.5.5.5
R1(config)#ip pim rp-address 192.168.30.1 5
R1(config)#exit


*Dec  5 12:46:07.499: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up

R1(config)#interface serial 4/3
R1(config-if)#ip pim sparse-dense-mode
R1(config-if)#exit

*Dec  5 12:48:17.707: %PIM-5-NBRCHG: neighbor 1.1.1.2 UP on interface Serial4/0

*Dec  5 12:49:29.379: %PIM-5-NBRCHG: neighbor 4.4.4.1 UP on interface Serial4/3

R2(config)#ip multicast-routing
R2(config)#access-list 5 permit host 224.5.5.5
R2(config)#ip pim rp-address 192.168.30.1 5
R2(config)#exit


R2(config)#interface serial 4/0
R2(config-if)#ip pim sparse-dense-mode
R2(config-if)#exit


R2(config)#interface serial 4/1
R2(config-if)#ip pim sparse-dense-mode
R2(config-if)#exit

*Dec  5 12:47:27.207: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up
*Dec  5 12:47:27.323: %PIM-5-NBRCHG: neighbor 1.1.1.1 UP on interface Serial4/0



R3(config)#interface loopback 0
R3(config-if)#ip ospf network point-to-point
R3(config-if)#exit

R3(config)#ip multicast-routing
R3(config)#access-list 5 permit host 224.5.5.5
R3(config)#ip pim rp-address 192.168.30.1 5
R3(config)#exit

*Dec  5 12:43:03.315: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down

*Dec  5 12:43:03.395: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel1, changed state to up

R3(config)#interface serial 4/2
R3(config-if)#ip pim sparse-dense-mode
R3(config-if)#exit

R3(config)#interface serial 4/1
R3(config-if)#ip pim sparse-dense-mode
R3(config-if)#exit

*Dec  5 12:47:14.287: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up
*Dec  5 12:47:14.763: %PIM-5-NBRCHG: neighbor 2.2.2.1 UP on interface Serial4/1

*Dec  5 12:47:58.711: %PIM-5-NBRCHG: neighbor 3.3.3.2 UP on interface Serial4/2

R4(config)#ip multicast-routing
R4(config)#access-list 5 permit host 224.5.5.5
R4(config)#ip pim rp-address 192.168.30.1 5
R4(config)#exit

R4(config)#interface serial 4/3
R4(config-if)#ip pim sparse-dense-mode
R4(config-if)#exit


*Dec  5 12:46:07.611: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down


R4(config)#interface serial 4/2
R4(config-if)#ip pim sparse-dense-mode
R4(config-if)#exit

*Dec  5 12:50:58.511: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to upal 4/3


R4(config)#interface serial 5/0
R4(config-if)#ip pim sparse-dense-mode
R4(config-if)#exit

*Dec  5 12:50:58.627: %PIM-5-NBRCHG: neighbor 3.3.3.1 UP on interface Serial4/2
*Dec  5 12:50:59.063: %PIM-5-NBRCHG: neighbor 4.4.4.2 UP on interface Serial4/3
*Dec  5 12:51:18.067: %PIM-5-NBRCHG: neighbor 5.5.5.1 UP on interface Serial5/0

R5(config)#ip multicast-routing
R5(config)#interface fastethernet 0/0
R5(config-if)#ip igmp join-group 224.5.5.5
R5(config-if)#exit

R5(config)#access-list 5 permit host 224.5.5.5
R5(config)#ip pim rp-address 192.168.30.1 5
R5(config)#exit

*Dec  5 12:46:42.247: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down

R5(config)#interface serial 5/0
R5(config-if)#ip pim sparse-dense-mode
R5(config-if)#exit

*Dec  5 12:51:48.647: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up
*Dec  5 12:51:48.755: %PIM-5-NBRCHG: neighbor 5.5.5.2 UP on interface Serial5/0

R5(config)#interface fastEthernet 0/0
R5(config-if)#ip igmp join-group 224.15.15.15
R5(config-if)#exit

R1#show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
1.1.1.1          Serial4/0                v2/SD  1      30     1      0.0.0.0
4.4.4.2          Serial4/3                v2/SD  1      30     1      0.0.0.0


R1#show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
1.1.1.2           Serial4/0                01:31:36/00:01:37 v2    1 / S P G
4.4.4.1           Serial4/3                01:30:25/00:01:24 v2    1 / S P G

R2#show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
1.1.1.2          Serial4/0                v2/SD  1      30     1      0.0.0.0
2.2.2.1          Serial4/1                v2/SD  1      30     1      0.0.0.0

R2#  show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
1.1.1.1           Serial4/0                01:32:21/00:01:20 v2    1 / S P G
2.2.2.2           Serial4/1                01:31:54/00:01:25 v2    1 / S P G



R3#show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
3.3.3.1          Serial4/2                v2/SD  1      30     1      0.0.0.0
2.2.2.2          Serial4/1                v2/SD  1      30     1      0.0.0.0

R3#  show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
3.3.3.2           Serial4/2                01:31:13/00:01:31 v2    1 / S P G
2.2.2.1           Serial4/1                01:31:57/00:01:21 v2    1 / S P G


R4#show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
3.3.3.2          Serial4/2                v2/SD  1      30     1      0.0.0.0
4.4.4.1          Serial4/3                v2/SD  1      30     1      0.0.0.0
5.5.5.2          Serial5/0                v2/SD  1      30     1      0.0.0.0

R4#  show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
3.3.3.1           Serial4/2                01:31:15/00:01:30 v2    1 / S P G
4.4.4.2           Serial4/3                01:31:14/00:01:35 v2    1 / S P G
5.5.5.1           Serial5/0                01:30:55/00:01:24 v2    1 / S P G


R5#show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
5.5.5.1          Serial5/0                v2/SD  1      30     1      0.0.0.0

R5#  show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
5.5.5.2           Serial5/0                01:30:57/00:01:24 v2    1 / S P G


R5(config)#interface fastEthernet 0/0
R5(config-if)#ip igmp join-group 224.15.15.15
R5(config-if)#exit

R1#ping 224.15.15.15 repeat 999
Type escape sequence to abort.
Sending 999, 100-byte ICMP Echos to 224.15.15.15, timeout is 2 seconds:

Reply to request 0 from 50.1.1.1, 260 ms
Reply to request 1 from 50.1.1.1, 64 ms
Reply to request 2 from 50.1.1.1, 28 ms
Reply to request 3 from 50.1.1.1, 44 ms
Reply to request 4 from 50.1.1.1, 44 ms
Reply to request 5 from 50.1.1.1, 40 ms
Reply to request 6 from 50.1.1.1, 36 ms
Reply to request 7 from 50.1.1.1, 24 ms
Reply to request 8 from 50.1.1.1, 24 ms
Reply to request 9 from 50.1.1.1, 36 ms
Reply to request 10 from 50.1.1.1, 40 ms
Reply to request 11 from 50.1.1.1, 16 ms
Reply to request 12 from 50.1.1.1, 36 ms
Reply to request 13 from 50.1.1.1, 20 ms
Reply to request 14 from 50.1.1.1, 32 ms
Reply to request 15 from 50.1.1.1, 52 ms
Reply to request 16 from 50.1.1.1, 36 ms
Reply to request 17 from 50.1.1.1, 16 ms
Reply to request 18 from 50.1.1.1, 12 ms
Reply to request 19 from 50.1.1.1, 40 ms
Reply to request 20 from 50.1.1.1, 24 ms
Reply to request 21 from 50.1.1.1, 40 ms
Reply to request 22 from 50.1.1.1, 36 ms
Reply to request 23 from 50.1.1.1, 20 ms
Reply to request 24 from 50.1.1.1, 24 ms
Reply to request 25 from 50.1.1.1, 20 ms
Reply to request 26 from 50.1.1.1, 36 ms
Reply to request 27 from 50.1.1.1, 20 ms
Reply to request 28 from 50.1.1.1, 16 ms
Reply to request 29 from 50.1.1.1, 36 ms
Reply to request 30 from 50.1.1.1, 36 ms
Reply to request 31 from 50.1.1.1, 32 ms

R1#ping 224.5.5.5
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.5.5.5, timeout is 2 seconds:

Reply to request 0 from 50.1.1.1, 172 ms
Reply to request 0 from 50.1.1.1, 232 ms

R1#ping 224.15.15.15
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.15.15.15, timeout is 2 seconds:

Reply to request 0 from 50.1.1.1, 172 ms



R2#ping 224.5.5.5
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.5.5.5, timeout is 2 seconds:

Reply to request 0 from 50.1.1.1, 116 ms
Reply to request 0 from 50.1.1.1, 180 ms

R2#ping 224.15.15.15
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.15.15.15, timeout is 2 seconds:

Reply to request 0 from 50.1.1.1, 112 ms
Reply to request 0 from 50.1.1.1, 136 ms


R3#ping 224.5.5.5
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.5.5.5, timeout is 2 seconds:

Reply to request 0 from 50.1.1.1, 172 ms
Reply to request 0 from 50.1.1.1, 184 ms
Reply to request 0 from 50.1.1.1, 172 ms

R3#ping 224.15.15.15
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.15.15.15, timeout is 2 seconds:

Reply to request 0 from 50.1.1.1, 108 ms

R4#ping 224.5.5.5
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.5.5.5, timeout is 2 seconds:

Reply to request 0 from 50.1.1.1, 56 ms
Reply to request 0 from 50.1.1.1, 232 ms
Reply to request 0 from 50.1.1.1, 212 ms

R4#ping 224.15.15.15
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.15.15.15, timeout is 2 seconds:

Reply to request 0 from 50.1.1.1, 60 ms

R1#show ip mroute 224.5.5.5
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.5.5.5), 00:25:37/stopped, RP 192.168.30.1, flags: SPF
  Incoming interface: Serial4/3, RPF nbr 4.4.4.1
  Outgoing interface list: Null

(4.4.4.1, 224.5.5.5), 00:02:14/00:00:45, flags: PFT
  Incoming interface: Serial4/3, RPF nbr 4.4.4.1, Registering
  Outgoing interface list: Null

R1#show ip mroute 224.15.15.15
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.15.15.15), 00:06:28/stopped, RP 0.0.0.0, flags: D
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial4/3, Forward/Sparse-Dense, 00:06:28/stopped
    Serial4/0, Forward/Sparse-Dense, 00:06:28/stopped

(3.3.3.2, 224.15.15.15), 00:02:22/00:00:37, flags: PT
  Incoming interface: Serial4/3, RPF nbr 4.4.4.1
  Outgoing interface list:
    Serial4/0, Prune/Sparse-Dense, 00:02:22/00:00:37, A

(4.4.4.1, 224.15.15.15), 00:02:22/00:00:37, flags: PT
  Incoming interface: Serial4/3, RPF nbr 4.4.4.1
  Outgoing interface list:
    Serial4/0, Prune/Sparse-Dense, 00:02:22/00:00:37




 

 

 

 

 


 


Instagram

Facebook


Twitter



LINKEDIN








How to configure the DHCP server on a Cisco ASA device?

How to configure the DHCP server on a Cisco ASA device?    DHCP (Dynamic Host Configuration Protocol) servers provide all the basic informat...