Wednesday 31 October 2018

EIGRP (basic)

EIGRP is a classless, distance vector routing protocol that uses the concept of an autonomous system to describe a set of contiguous routers that run the same routing protocol and share routing information, which also includes subnet mask in its route updates.

EIGRP is sometimes referred to as a hybrid routing protocol or an advanced distance vector protocol because is has characteristics of both distance-vector some link-state protocols. For example, EIGRP doesn't send link-state packets like OSPF does. instead, it traditional distance-vector updates that include information about networks plus the cost o reaching them from the perspective of the advertising router.

EIGRP has link-state characteristics as well it synchronize network topology information between neighbors at startup and then sends specific updates only when topology change occur.

EIGRP has a default hop count of 100, with maximum of 255. In EIGRP speak, hop count refers to how many router an EIGRP update packet can go through before it will be discarded, which limits the size of the autonomous system (AS).

Here's a list of some powerful features:





  • Support for IP and IPv6 
  • Considered classless 
  • Support for VLSM/CIDR
  • Support for summaries and discontinuous networks
  • Efficient neighbor discovery
  • Communication via Reliable Transport Protocol (RTP)
  • Best path selection via diffusing Update Algorithm (DUAL)
  • Reduced bandwidth usage with bounded updates
  • No broadcast  
   
Neighbour Discovery- before EIGRP routers can exchange routes with each other, they must become neighbors, and there are three conditions that must be met before this can happen.

  • Hello and Acknowledge received
  • Autonomous System (AS) numbers match 
  • Identical metrics (K values)
EIGRP routers that belong to different AS don't become neighbor and will not share routing information unless redistribution.

Hello messages are used to identify neighbors and serve a keepalive mechanism between neighbor. EIGRP hello messages are send to multicast address 224.0.0.10 and FF20::A in IPv6. Hello messages send every 5 seconds.

Reported/advertisement distance (AD)  this is the metric of a remote network, as reported by a neighbor. In other words Reported Distance is the neighbor's distance to the destination as reported in an EIGRP packet received from neighbor. It is also the routing table metric of the neighbor router.

In short: AD is the neighbor router distance to the destination.

Feasible distance (FD) this is the best metric among all paths to a remote network, the route with the lowest FD that you'll find in the routing table because its considered the best path. The metric of a feasible distance is calculated using the metric reported by the neighbor that's referred to as the reported or advertised distance plus the metric to the neighbor reporting the route.

In short : FD is the total cost from local router to destination.

Feasible successor (FC): FC is basically an entry in the topology table that represent a path that's inferior to the successor route. FC is define as a path whose advertised distance is less than the feasible distance of the current successor and considered a backup route.

In short: Feasible Successor is the backup route and stored in the topology table.

Neighbor table: Each router keeps state information about adjacent neighbors. when a newly discovered neighbor is found, its address and interface are recorded in the routing table, stored in RAM.

In short: neighbor table contain the list of directly connected router.

Topology table: is populated by the neighbor table and the Diffusing Update Algorithm (DUAL) calculates the best loop-free path to each remote network. it contains all the destinations advertisement by neighboring routers.

In short: topology table contain list all the best route learned from neighbor.


Successor: a successor route is the best route to a remote network. a successor will be copied from the topology table to routing table.


Reliable Transport Protocol (RTP): EIGRP uses RTP and its function is to deliver EIGRP packets between neighbors in a reliable and ordered way. It can use multicast or unicast and to keep things efficient not all packets are sent reliable. Reliable means that when we send a packet we want to get an acknowledgment from the other side to make sure that they received it.

Here's description of the five different types of packets used by EIGRP:

Hello   A hello packets are used to discover EIGRP neighbors and sent via unreliable multicast, meaning  its doesn't require an acknowledgement. 

Update packets have routing information and are sent reliable to whatever router that require this information. Update packets can be sent to a single neighbor using unicast or to a group of neighbors using multicast.

Query packets are used when your EIGRP router hast information about a certain network and doesn't have any backup paths. router will send query packets to its neighbors asking them if they have information about this particular network.   

Reply packets are used in response to the query packets.

ACK packets are used to acknowledge the receipt of update, query and reply packets. ACK packets are sent by using unicast.

EIGRP metric:
 EIGRP uses diffusing update algorithm (DUAL) for selecting and maintain the best path to each remote network. EIGRP uses bandwidth, delay, reliability, load, MTU, and hop count, out of these six component the first four are combined together using well known formula to produce a single number that we call composite metric. by default EIGRP uses bandwidth and delay in the metric calculation 




Formula with default K values (K1=1, K2=0, K3=1, K4=0, K5=0)

Metric=[K1*BW + ((K2*BW) / (256 - LOAD)) + K3 * delay]

EIGRP metric 

BW= (107/lowest bandwidth in kbps)*256
Delay=(sum of total delay/10)*256

By default, EIGRP metric = bandwidth (slowest link) + delay (sum of delays)


Before we start  EIGRP configuration check out some important  of EIGRP CCIE exam topics.

Here is the lists of all EIGRP labs and theories CCNA to CCIE

1.Enhanced Interior Gateway Routing Protocol (EIGRP)

2.Stuck In Active (EIGRP)

3.EIGRP Equal-Cost and Unequal-Cost load balancing

4.Route filtering passive interface

5.Route summarization

6.EIGRP STUB and Configuration

7.Routing Protocol Authentication (EIGRP ) and configuration


Configuration



Topology 






GOAL:


  • Configure topology as per the diagram
  • ensure that all the interface are working.
  • configure EIGRP 100 on both routers and advertise directly connected interface as per the topology
  • ensure the communication between both the routers.



R1(config)#interface serial 3/0
R1(config-if)#ip address 10.1.1.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface loopback 0
R1(config-if)#ip address 192.168.100.1 255.255.255.0


R2(config)#interface serial 3/0
R2(config-if)#ip address 10.1.1.2 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface loopback 0
R2(config-if)#ip address 192.168.200.1 255.255.255.0


R1#show ip interface brief
Interface              IP-Address      OK? Method   Status                Protocol
Serial3/0              10.1.1.1        YES manual        up                    up
Loopback0           192.168.100.1   YES manual   up                    up

R2#show ip interface brief
Interface              IP-Address      OK? Method   Status                Protocol
Serial3/0              10.1.1.2             YES manual     up                    up
Loopback0          192.168.200.1    YES manual    up                    up

R1(config)#router eigrp 100
R1(config-router)#network 10.0.0.0
R1(config-router)#network 192.168.100.0

*Oct 31 17:41:48.563: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 10.1.1.2 (Serial3/0) is up: new adjacency


R2(config)#router eigrp 100
R2(config-router)#network 10.0.0.0
R2(config-router)#network 192.168.200.0

*Oct 31 17:41:48.619: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 10.1.1.1 (Serial3/0) is up: new adjacency

 R1#show ip eigrp 100 topology
EIGRP-IPv4 Topology Table for AS(100)/ID(192.168.100.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 192.168.200.0/24, 1 successors, FD is 2297856

        via 10.1.1.2 (2297856/128256), Serial3/0
P 192.168.100.0/24, 1 successors, FD is 128256
        via Connected, Loopback0
P 10.0.0.0/8, 1 successors, FD is 2169856
        via Connected, Serial 3/0

R2#show ip eigrp 100 topology
EIGRP-IPv4 Topology Table for AS(100)/ID(192.168.200.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 192.168.200.0/24, 1 successors, FD is 128256
        via Connected, Loopback0
P 192.168.100.0/24, 1 successors, FD is 2297856
        via 10.1.1.1 (2297856/128256), Serial3/0
P 10.0.0.0/8, 1 successors, FD is 2169856
        via Connected, Serial3/0

R1#show ip eigrp 100 neighbors
EIGRP-IPv4 Neighbors for AS(100)
H   Address                 Interface              Hold        Uptime   SRTT   RTO  Q  Seq
                                     (sec)                   (ms)                Cnt Num
0   10.1.1.2                Se3/0                    10 00:03:54   42   252  0  4

In the output, the "H" column on the left lists the order in which a peering session was established with the specified neighbor. The order uses sequential numbering, starting with 0. The "H" stand for "handle", which is an internal number used by the EIGRP implementation to reer to a particular neighbor.


R1#show ip route eigrp 100
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

D     192.168.200.0/24 [90/2297856] via 10.1.1.2, 00:09:01, Serial3/0


R1#ping 192.168.200.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.200.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/20/24 ms

R2#ping 192.168.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/20/24 ms








 


 


Instagram

Facebook


Twitter



LINKEDIN








4 comments:

cynthiawilliams said...

This is a very interesting post and I learned so much from your blog. Do posting more.
ccna Training institute in Chennai
ccna institute in Chennai
gst classes in Chennai
ReactJS Training in Chennai
Salesforce Training in Chennai
Tally course in Chennai
Web Designing Course in Chennai
ux design course in Chennai
Web Designing Course in anna nagar

sudhan said...

It is really a very informative post for all those budding entreprenuers planning to take advantage of post for business expansions. You always share such a wonderful articlewhich helps us to gain knowledge .Thanks for sharing such a wonderful article, It will be deinitely helpful and fruitful article.
Cyber Security Training Course in Chennai | Certification | Cyber Security Online Training Course | Ethical Hacking Training Course in Chennai | Certification | Ethical Hacking Online Training Course | CCNA Training Course in Chennai | Certification | CCNA Online Training Course | RPA Robotic Process Automation Training Course in Chennai | Certification | RPA Training Course Chennai | SEO Training in Chennai | Certification | SEO Online Training Course

The Blogger Worlds said...

Rekordbox DJ Crack is the greatest tool for DJ overall performance. That device is developed by the leader DJ who else is very popular. RekordBox Dj License Key Generator

Cyberz Pc said...

Golden Software Surfer Efficient software for 3D modeling and mapping of data. ... Read the Readme.txt file in the Crack folder. Golden Software Surfer 23.1.162 Crack

What is Virtual Router Redundancy Protocol (VRRP)? How to configure Virtual Router Redundancy Protocol (VRRP)?

 Virtual Router Redundancy Protocol (VRRP) is a gateway redundancy networking protocol used to create a virtual gateway similar to HSRP . VR...