Wednesday, 28 November 2018

BGP Attributes




BGP Attributes

 BGP support a wide variety of path attribute, BGP chooses a route to a network based on the attributes of its path.


Four categories of attributes exist are as follows:-

  • Well-know mandatory
  • Well-known discretionary
  • Optional transitive
  • Optional non-transitive

Well-known mandatory attribute must be recognized by all BGP routers, present in all BGP updates, and passed on to other BGP routers. AS path, origin, and next hop.

Well-known discretionary must be recognized by all BGP routers and passed on to other BGP routers but need not be present in an update. Local preference

Optional transitive might or might not be recognized by a BGP router but is passed on to other BGP routers.
If not recognized, it is marked as partial. Aggregation, community.

Optional non-transitive If the BGP process does not recognize the attribute then it can ignore the update and not advertise the path to its peer. Multi-exit discriminator (MED), originator ID

 AS_Path attribute- this particular path attribute lists the autonomous system numbers in the end-to-end path.BGP uses AS_Path as its primary loop-prevention tool.



 AS_Path attribute is a well-known mandatory attribute. its list of AS through which updates are coming. The shortest AS_PATH list is more desirable.


Next_hop is a well-known, mandatory attribute next hop means IP address to reach next autonomous system because BGP is AS by AS routing protocol. 


Origin attribute 

origin informs all AS in internetwork how network got introduced into BGP.

 (i)  represent IGP
 (e) represent EBGP
 (?) represent incomplete        

Weight Attribute is a cisco's attribute. its tell how to exit the AS, path with the highest weight is more desirable. weight is partial attribute, by default weight 0 learn route 32,769 for locally injected routes. its local to the router not advertise to any BGP peers.

Local Preference Attribute

Local preference define how to data traffic should exit from an Autonomous system. path with highest preference value is more desirable by default is 100, and the range 0 through 232  local preference is well known, discretionary attribute it is advertise only to iBGP neighbor within an Autonomous system.

R3#show ip bgp



BGP table version is 5, local router ID is 13.0.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric       LocPrf     Weight     Path
 r>i 10.0.0.0         11.0.0.1                 0                100            0            i
 r>i 20.0.0.0         12.0.0.1                 0                100            0            i
 *>  30.0.0.0         0.0.0.0                  0                                32768       i
 r>i 40.0.0.0         14.0.0.1                 0                 100           0             i










Tuesday, 27 November 2018

BGP Peer Group and config


 By default,  BGP updates are sent on a neighbor to neighbor basis and the  result  more CPU resources being used, also by implementing  non-default settings  for example performing filtering using prefix lists, route map, or filter list to those neighbors, even more CPU resources are consume.

 When, many neighbors are having similar configuration parameters. Cisco IOS allows us to create logical group those similar neighbors into a BGP peer group then you apply your non-default BGP configuration to those parameters to each neighbor individually. Actually a single router can have multiple peer groups, each representing a separate set of parameters. The result less CPU resources required. Remember router still sends out individual BGP updates to each of its neighbors. It does require based on BGP characteristics of establishing a TCP session with each neighbor.


Inshort: BGP peer group means applying same policies to multiple neighbors.It's useful when many neighbors have the same configuration parameter. updates are generated once per peer group.






lets see the configurations.
Topology:

Goal:



  • configure the topology as per the diagram and its interfaces.
  • configure eigrp 100 all the routers to ensure the reachability between the loopbacks. 
  • configure loopback 0 to establishing peering, configure peer group name cisco.
  • configure authentication and make sure all the peer should use same password.(in our topology we use internetworks)
  • configure BGP version 4 and advertise LAN interfaces only.


R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        10.1.1.1        YES manual up                    up
Serial3/0                     1.1.1.1         YES manual up                    up
Serial3/3                     4.1.1.2         YES manual up                    up
Loopback0              11.0.0.1        YES manual up                    up
Loopback1              11.0.1.1        YES manual up                    up
Loopback2              11.0.2.1        YES manual up                    up
Loopback3              11.0.3.1        YES manual up                    up


R2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        20.1.1.1        YES manual up                    up
Serial3/0                     1.1.1.2         YES manual up                    up
Serial3/1                     2.1.1.1         YES manual up                    up
Loopback0              12.0.0.1        YES manual up                    up
Loopback1              12.0.1.1        YES manual up                    up
Loopback2              12.0.2.1        YES manual up                    up

Loopback3              12.0.3.1        YES manual up                    up



R3#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        30.1.1.1        YES manual up                    up
Serial3/1                   2.1.1.2         YES manual up                    up
Serial3/2                   3.1.1.1         YES manual up                    up
Loopback0              13.0.0.1        YES manual up                    up
Loopback1              13.0.1.1        YES manual up                    up
Loopback2              13.0.2.1        YES manual up                    up

Loopback3              13.0.3.1        YES manual up                    up



R4#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        40.1.1.1        YES manual up                    up
Serial3/2                     3.1.1.2         YES manual up                    up
Serial3/3                     4.1.1.1         YES manual up                    up
Loopback0              14.0.0.1        YES manual up                    up
Loopback1              14.0.1.1        YES manual up                    up
Loopback2              14.0.2.1        YES manual up                    up

Loopback3              14.0.3.1        YES manual up                    up

R1(config)#router eigrp 100
R1(config-router)#network 10.0.0.0
R1(config-router)#network 1.0.0.0
R1(config-router)#network 4.0.0.0
R1(config-router)#network 11.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#end


R2(config)#router eigrp 100
R2(config-router)#network 20.0.0.0
R2(config-router)#network 2.0.0.0
R2(config-router)#network 1.0.0.0
R2(config-router)#network 12.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#end


R3(config)#router eigrp 100
R3(config-router)#network 13.0.0.0
R3(config-router)#network 2.0.0.0
R3(config-router)#network 3.0.0.0
R3(config-router)#network 30.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#end


R4(config)#router eigrp 100
R4(config-router)#network 4.0.0.0
R4(config-router)#network 4.0.0.0
R4(config-router)#network 40.0.0.0
R4(config-router)#network 14.0.0.0
R4(config-router)#network 3.0.0.0
R4(config-router)#end



R1(config)#router bgp 501
R1(config-router)#neighbor cisco peer-group
R1(config-router)#neighbor cisco remote-as 501
R1(config-router)#neighbor cisco update-source loopback 0
R1(config-router)#neighbor cisco version 4
R1(config-router)#neighbor cisco password internetworks
R1(config-router)#neighbor 12.0.0.1 peer-group cisco
R1(config-router)#neighbor 13.0.0.1 peer-group cisco
R1(config-router)#neighbor 14.0.0.1 peer-group cisco
R1(config-router)#network 10.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#no synchronization
R1(config-router)#end


R2(config)#router bgp 501
R2(config-router)#neighbor cisco peer-group
R2(config-router)#neighbor cisco remote-as 501
R2(config-router)#neighbor cisco update-source loopback 0
R2(config-router)#neighbor cisco version 4
R2(config-router)#neighbor cisco password internetworks
R2(config-router)#neighbor 11.0.0.1 peer-group cisco
R2(config-router)#neighbor 13.0.0.1 peer-group cisco
R2(config-router)#neighbor 14.0.0.1 peer-group cisco
R2(config-router)#network 20.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#no synchronization
R2(config-router)#end


R3(config)#router bgp 501
R3(config-router)#neighbor cisco peer-group
R3(config-router)#neighbor cisco remote-as 501
R3(config-router)#neighbor cisco update-source loopback 0
R3(config-router)#neighbor cisco version 4
R3(config-router)#neighbor cisco password internetworks
R3(config-router)#neighbor 12.0.0.1 peer-group cisco
R3(config-router)#neighbor 11.0.0.1 peer-group cisco
R3(config-router)#neighbor 14.0.0.1 peer-group cisco
R3(config-router)#network 30.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#no synchronization
R3(config-router)#end


R4(config)#router bgp 501
R4(config-router)#neighbor cisco peer-group 
R4(config-router)#neighbor cisco remote-as 501
R4(config-router)#neighbor cisco update-source loopback 0
R4(config-router)#neighbor cisco version 4
R4(config-router)#neighbor cisco  password internetworks
R4(config-router)#neighbor 12.0.0.1 peer-group cisco
R4(config-router)#neighbor 13.0.0.1 peer-group cisco
R4(config-router)#neighbor 11.0.0.1 peer-group cisco
R4(config-router)#network 40.0.0.0
R4(config-router)#no auto-summary
R4(config-router)#no synchronization
R4(config-router)#end


R1#show ip bgp summary
BGP router identifier 11.0.3.1, local AS number 501
BGP table version is 7, main routing table version 7
4 network entries using 576 bytes of memory
4 path entries using 320 bytes of memory
2/2 BGP path/bestpath attribute entries using 272 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1168 total bytes of memory
BGP activity 5/1 prefixes, 5/1 paths, scan interval 60 secs


Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
12.0.0.1        4          501       7       7        7    0    0 00:00:44        1
13.0.0.1        4          501      17      20        7    0    0 00:10:02        1

14.0.0.1        4          501       9       9        7    0    0 00:02:37        1


R2#show ip bgp summary
BGP router identifier 12.0.3.1, local AS number 501
BGP table version is 9, main routing table version 9
4 network entries using 576 bytes of memory
4 path entries using 320 bytes of memory
2/2 BGP path/bestpath attribute entries using 272 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1168 total bytes of memory
BGP activity 4/0 prefixes, 6/2 paths, scan interval 60 secs


Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
11.0.0.1        4          501       8       8        9    0    0 00:01:23        1
13.0.0.1        4          501       8       8        9    0    0 00:01:26        1
14.0.0.1        4          501       8       6        9    0    0 00:01:32        1


R3#show ip bgp summary
BGP router identifier 13.0.3.1, local AS number 501
BGP table version is 7, main routing table version 7
4 network entries using 576 bytes of memory
4 path entries using 320 bytes of memory
2/2 BGP path/bestpath attribute entries using 272 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1168 total bytes of memory
BGP activity 5/1 prefixes, 5/1 paths, scan interval 60 secs


Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
11.0.0.1        4          501      21      19        7    0    0 00:11:15        1
12.0.0.1        4          501       9       9        7    0    0 00:02:00        1
14.0.0.1        4          501       9      11        7    0    0 00:03:56        1


R4#show ip bgp summary
BGP router identifier 14.0.3.1, local AS number 501
BGP table version is 5, main routing table version 5
4 network entries using 576 bytes of memory
4 path entries using 320 bytes of memory
2/2 BGP path/bestpath attribute entries using 272 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1168 total bytes of memory
BGP activity 4/0 prefixes, 4/0 paths, scan interval 60 secs


Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
11.0.0.1        4          501      11      12        5    0    0 00:04:24        1
12.0.0.1        4          501       7       9        5    0    0 00:02:40        1
13.0.0.1        4          501      11       9        5    0    0 00:04:29        1


R1#show ip bgp
BGP table version is 7, local router ID is 11.0.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found


     Network          Next Hop            Metric LocPrf Weight Path
 *>  10.0.0.0         0.0.0.0                  0         32768 i
 r>i 20.0.0.0         12.0.0.1                 0    100      0 i
 r>i 30.0.0.0         13.0.0.1                 0    100      0 i
 r>i 40.0.0.0         14.0.0.1                 0    100      0 i


R3#show ip bgp
BGP table version is 7, local router ID is 13.0.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 r>i 10.0.0.0         11.0.0.1                 0    100      0 i
 r>i 20.0.0.0         12.0.0.1                 0    100      0 i
 *>  30.0.0.0         0.0.0.0                  0         32768 i
 r>i 40.0.0.0         14.0.0.1                 0    100      0 i

Monday, 26 November 2018

BGP Neighbors




BGP Neighbors

BGP neighbors are routers forming TCP connection for exchanging BGP updates it’s also called as BGP peers or BGP speakers.


There are two types of BGP neighbor relationship

IBGP (internal BGP)
EBGP (external BGP)

BGP first forms a neighbor relationship with BGP speakers (peer). Than its learns information from its peer, BGP place that information in its BGP table and analyze the table to choose the best working route for each subnet in the BGP table, placing those routes into the IP routing table.

There are several requirements for forming BGP neighbors:-

  • A local router’s autonomous system number must match the neighboring router’s ASN.
  • The BGP router ID of the two routers must not be the same.
  • Each router must be part of a TCP connection.
  • Authentication must be passing if it’s configured



BGP message types

  • Open- it’s used to established a neighbor relationship and exchange its parameter, its include ASN and authentication values.
  • Keepalive it’s used to maintain the neighbor relationship and it’s sent periodically
  • Update- its used to exchange path attribute.
  • Notification- it’s used error signals. It does occur in neighbor relationship reset.  




BGP neighbor states

  • Idle – it’s a down state by administratively down or waiting for the next retry attempt.

R1# show ip bgp summary



Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.2         4          501      11       9        8    0    0 00:04:28        4
4.1.1.1         4          501       0       0        1    0    0 never    Idle




  • Connect- this state means its waiting for the TCP connection to be completed.
  • Active- this state means the TCP connection has been completed but there is no BGP messages sent yet to its peer.
  • Opensent- this state means the TCP connection has been established and BGP open message is sent to its BGP speakers but the matching Open message is not received yet from the peer router.
  • Openconfirm- this state means open message has been sent and received from BGP speaker router. But it’s waiting for keepalive message.
  • Established- this state means the entire neighbor parameters match and the neighbor relationship has been established. Now BGP speakers (peers) can exchange update messages.







 Configuration:-



Topology:-


 GOAL:





  • configure the topology as per the diagram
  • configure IBGP peering AS 501 as per our topology using directly connected interfaces.
  • ensure the connectivity and make sure all bgp routers should be able exchange the routes through BGP.




R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        10.1.1.1        YES manual up                    up
Serial3/0                    1.1.1.1         YES manual up                    up
Serial3/3                    4.1.1.2         YES manual up                    up
Loopback0              11.0.0.1        YES manual up                    up
Loopback1              11.0.1.1        YES manual up                    up
Loopback2              11.0.2.1        YES manual up                    up
Loopback3              11.0.3.1        YES manual up                    up


R2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        20.1.1.1        YES manual up                    up
Serial3/0                   1.1.1.2         YES manual up                    up
Serial3/1                   2.1.1.1         YES manual up                    up
Loopback0              12.0.0.1        YES manual up                    up
Loopback1              12.0.1.1        YES manual up                    up
Loopback2              12.0.2.1        YES manual up                    up
Loopback3              12.0.3.1        YES manual up                    up


R3(config-if)#do sh ip int br
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        30.1.1.1        YES manual up                    up
Serial3/1                    2.1.1.2         YES manual up                    up
Serial3/2                    3.1.1.1         YES manual up                    up
Loopback0              13.0.0.1        YES manual up                    up
Loopback1              13.0.1.1        YES manual up                    up
Loopback2              13.0.2.1        YES manual up                    up
Loopback3              13.0.3.1        YES manual up                    up

R4#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        40.1.1.1        YES manual up                    up
Serial3/2                    3.1.1.2         YES manual up                    up
Serial3/3                    4.1.1.1         YES manual up                    up
Loopback0              14.0.0.1        YES manual up                    up
Loopback1              14.0.1.1        YES manual up                    up
Loopback2              14.0.2.1        YES manual up                    up
Loopback3              14.0.3.1        YES manual up                    up


R1(config)#router bgp 501
R1(config-router)#neighbor 1.1.1.2 remote-as 501
R1(config-router)#neighbor 4.1.1.1 remote-as 501
R1(config-router)#network 11.0.0.0 mask 255.255.255.0
R1(config-router)#network 10.0.0.0
R1(config-router)#network 1.0.0.0
R1(config-router)#network 4.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#no synchronization
R1(config-router)#end


R2(config)#router bgp 501
R2(config-router)#neighbor 1.1.1.1 remote-as 501
R2(config-router)#neighbor 2.1.1.2 remote-as 501
R2(config-router)#network 12.0.0.0 mask 255.255.255.0
R2(config-router)#network 20.0.0.0
R2(config-router)#network 2.0.0.0
R2(config-router)#network 1.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#no synchronization
R2(config-router)#end


R3(config)#router bgp 501
R3(config-router)#neighbor 2.1.1.1 remote-as 501
R3(config-router)#neighbor 3.1.1.2 remote-as 501
R3(config-router)#network 13.0.0.0 mask 255.255.255.0
R3(config-router)#network 30.0.0.0
R3(config-router)#network 3.0.0.0
R3(config-router)#network 2.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#no synchronization
R3(config-router)#end


R4(config)#router bgp 501
R4(config-router)#neighbor 4.1.1.2 remote-as 501
R4(config-router)#neighbor 3.1.1.1 remote-as 501
R4(config-router)#network 14.0.0.0 mask 255.255.255.0
R4(config-router)#network 3.0.0.0
R4(config-router)#network 4.0.0.0
R4(config-router)#no auto-summary
R4(config-router)#no synchronization
R4(config-router)#end


R1#show ip bgp summary
BGP router identifier 11.0.3.1, local AS number 501
BGP table version is 10, main routing table version 10
9 network entries using 1296 bytes of memory
11 path entries using 880 bytes of memory
2/2 BGP path/bestpath attribute entries using 272 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2448 total bytes of memory
BGP activity 9/0 prefixes, 12/1 paths, scan interval 60 secs


Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.2         4          501      25      22       10    0    0 00:15:30        4
4.1.1.1         4          501      12      12       10    0    0 00:05:01        3




R3#show ip bgp summary
BGP router identifier 13.0.3.1, local AS number 501
BGP table version is 13, main routing table version 13
9 network entries using 1296 bytes of memory
11 path entries using 880 bytes of memory
2/2 BGP path/bestpath attribute entries using 272 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2448 total bytes of memory
BGP activity 10/1 prefixes, 12/1 paths, scan interval 60 secs


Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.1.1.1         4          501      21      17       13    0    0 00:09:25        4
3.1.1.2         4          501      14      12       13    0    0 00:05:25        3

R1#show ip route bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

B     2.0.0.0/8 [200/0] via 1.1.1.2, 00:05:09
B     3.0.0.0/8 [200/0] via 4.1.1.1, 00:05:09
      12.0.0.0/24 is subnetted, 1 subnets
B        12.0.0.0 [200/0] via 1.1.1.2, 00:05:09
      14.0.0.0/24 is subnetted, 1 subnets
B        14.0.0.0 [200/0] via 4.1.1.1, 00:05:09
B     20.0.0.0/8 [200/0] via 1.1.1.2, 00:05:09
(because of the split horizon rules router 2 not get 30.0.0.0/8 and 13.0.0.0/24 networks)




R3#show ip route bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override


Gateway of last resort is not set

B     1.0.0.0/8 [200/0] via 2.1.1.1, 00:06:43
B     4.0.0.0/8 [200/0] via 3.1.1.2, 00:10:41
      12.0.0.0/24 is subnetted, 1 subnets
B        12.0.0.0 [200/0] via 2.1.1.1, 00:15:08
      14.0.0.0/24 is subnetted, 1 subnets
B        14.0.0.0 [200/0] via 3.1.1.2, 00:10:53
B     20.0.0.0/8 [200/0] via 2.1.1.1, 00:15:08

(here also router 3 is not getting 10.0.0.0/8 and 11.0.0.0/24 networks because of split horizon rules. the solution is full mesh neighbor-ship or we can use route reflector)








Sunday, 25 November 2018

Introduction of BGP





Introduction of BGP

Border Gateway Protocol (BGP) advertises, learn, and choose the best paths inside the wide internet. When two ISPs connected, they typically use BGP to exchange routing information. The ISPs of the world wide exchange routing information with one or more than one ISPs.

Autonomous system


An autonomous system is a collection of networks under a single technical administration domain. IGPs like OSPF EIGRP operate within an Autonomous system. We use BGP between the autonomous systems to exchange of loop-free routing information.

Internal and External BGP


BGP defines in two classes for neighbors.
  1. Internal BGP ( iBGP ) operates within the same autonomous system.
  2. External BGP ( E BGP) operates in between the multiple autonomous system  
          

BGP  features 




  • BGP is a open standard protocol
  • exterior gateway protocol designed for inter-AS domain routing to scale huge neter-network like internet 
  • its support classless , VLSM, CIDR, auto and manual summary 
  • updates are incremental and trigger BGP send updates to manually defined neighbor as unicast.
  • BGP is application layer protocol uses TCP for reliability, TCP  port 179
  • Metric is attributes
  • Administrative distance  is 20 for external updates ( EBGP) and 200 for internal updates (i BGP)

Types of ISP connections 

  • Single Homed
  • Dual-Homed sites
  • Multi-Homing
  • Dual Multi-Homing




Single homed 


Single homed a site with a single ISP connection is single-homed. Single homed is good for a site that does not depend heavily on internet or WAN connectivity. you can advertise the site route or static routes and receives a default route from the internet service provider.




Dual-homed




 A Dual-homed site has two connections to the same ISP either from one router or two routers. one link might br primary and the other is backup, or the site might be load balancing over both the connections. we can use static or dynamic routing.

Multi-homed

 Multi-homing means having connecting links one or more ISP at the same time. it is done for redundancy and backup if one ISP fails and for better performance if one ISP provides a better path to frequently used networks. multi-homed also gives yo an ISP independent solution. BGP is typically used with multihomed connections.


Dual multi-homed

Dual multi-homed means having two connections with multiple ISPs. Dual multihomed  gives you the most redundancy. BGP  is used with ISPs and can be implemented internally also.














PIM Sparse Mode

PIM Sparse Mode  ( PIM-SM )  PIM  Sparse Mode explicitly builds unidirectional shared trees rooted at a ( RP ) rendezvous point per...