Showing posts with label Default Routing. Show all posts
Showing posts with label Default Routing. Show all posts

Friday, 18 January 2019

How to configure Default route EIGRP, RIP, and OSPF?

Default route
we already discuss advertising the default route in IP ROUTING . in this section we see the configuration of the default route in EIGRP, RIP, and OSPF.




lets the configuration:-

Topology:

GOAL:


  • Configure the topology as per our diagram. 
  • assign IP address as per the topology.
  • we have two methods of advertising default route 
  1. default-network ****
  2. redistribution static
  • in this scenario we use redistribution method 
  • configure static route on router 1 toward router 



R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        10.1.1.1        YES manual up                    up
Serial3/0                   1.1.1.1         YES manual up                    up
Loopback0              11.0.0.1        YES manual up                    up
Loopback1              11.0.1.1        YES manual up                    up
Loopback2              11.0.2.1        YES manual up                    up
Loopback3              11.0.3.1        YES manual up                    up
Loopback4              11.0.4.1        YES manual up                    up

R2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        20.1.1.1        YES manual up                    up
Serial3/0                    1.1.1.2         YES manual up                    up
Serial3/1                    2.2.2.1         YES manual up                    up
Serial3/2                    3.3.3.1         YES manual up                    up



R3#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        30.1.1.1        YES manual up                    up
Serial3/1                    2.2.2.2         YES manual up                    up


R4#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        40.1.1.1        YES manual up                    up
Serial3/2                     3.3.3.2         YES manual up                    up


R1(config)#ip route 2.0.0.0 255.0.0.0 1.1.1.2
R1(config)#ip route 3.0.0.0 255.0.0.0 1.1.1.2
R1(config)#ip route 20.0.0.0 255.0.0.0 1.1.1.2
R1(config)#ip route 30.0.0.0 255.0.0.0 1.1.1.2
R1(config)#ip route 40.0.0.0 255.0.0.0 1.1.1.2

R2(config)#router eigrp 111
R2(config-router)#network 2.0.0.0

*Jan 18 14:26:59.043: %DUAL-5-NBRCHANGE: EIGRP-IPv4 111: Neighbor 2.2.2.2 (Serial3/1) is up: new adjacency
R2(config-router)#network 3.0.0.0

*Jan 18 14:27:03.347: %DUAL-5-NBRCHANGE: EIGRP-IPv4 111: Neighbor 3.3.3.2 (Serial3/2) is up: new adjacency

R2(config-router)#network 20.0.0.0
R2(config-router)#redistribute static
R2(config-router)#exit

R2(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.1


R3(config)#router eigrp 111
R3(config-router)#network 2.0.0.0
R3(config-router)#network 30.0.0.0
R3(config-router)#exit

*Jan 18 14:06:12.027: %DUAL-5-NBRCHANGE: EIGRP-IPv4 111: Neighbor 2.2.2.1 (Serial3/1) is up: new adjacency

R4(config)#router eigrp 111
R4(config-router)#network 3.0.0.0
R4(config-router)#network 40.0.0.0

*Jan 18 14:06:46.355: %DUAL-5-NBRCHANGE: EIGRP-IPv4 111: Neighbor 3.3.3.1 (Serial3/2) is up: new adjacency

R4#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 3.3.3.1 to network 0.0.0.0

D*EX  0.0.0.0/0 [170/2681856] via 3.3.3.1, 00:01:47, Serial3/2
D     2.0.0.0/8 [90/2681856] via 3.3.3.1, 00:02:46, Serial3/2
D     20.0.0.0/8 [90/2172416] via 3.3.3.1, 00:02:42, Serial3/2
D     30.0.0.0/8 [90/2684416] via 3.3.3.1, 00:02:46, Serial3/2

R4#ping 11.0.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.0.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/60/76 ms
R4#ping 11.0.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.0.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/56/116 ms
R4#ping 11.0.3.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.0.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/64/76 ms
R4#ping 11.0.4.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.0.4.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/56/80 ms

R3#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 2.2.2.1 to network 0.0.0.0

D*EX  0.0.0.0/0 [170/2681856] via 2.2.2.1, 00:02:47, Serial3/1
D     3.0.0.0/8 [90/2681856] via 2.2.2.1, 00:03:46, Serial3/1
D     20.0.0.0/8 [90/2172416] via 2.2.2.1, 00:03:42, Serial3/1
D     40.0.0.0/8 [90/2684416] via 2.2.2.1, 00:03:46, Serial3/1

R3#ping 11.0.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.0.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/49/76 ms
R3#ping 11.0.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.0.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/35/40 ms
R3#ping 11.0.3.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.0.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/45/60 ms
R3#ping 11.0.4.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.0.4.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/40/52 ms

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 1.1.1.1 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 1.1.1.1
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/8 is directly connected, Serial3/0
L        1.1.1.2/32 is directly connected, Serial3/0
      2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        2.0.0.0/8 is directly connected, Serial3/1
L        2.2.2.1/32 is directly connected, Serial3/1
      3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        3.0.0.0/8 is directly connected, Serial3/2
L        3.3.3.1/32 is directly connected, Serial3/2
      20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        20.0.0.0/8 is directly connected, FastEthernet0/0
L        20.1.1.1/32 is directly connected, FastEthernet0/0
D     30.0.0.0/8 [90/2172416] via 2.2.2.2, 00:05:00, Serial3/1
D     40.0.0.0/8 [90/2172416] via 3.3.3.2, 00:04:56, Serial3/2

R2#ping 11.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/43/72 ms
R2#ping 11.0.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.0.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/36/52 ms
R2#ping 11.0.3.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.0.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/24/32 ms

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/8 is directly connected, Serial3/0
L        1.1.1.1/32 is directly connected, Serial3/0
S     2.0.0.0/8 [1/0] via 1.1.1.2
S     3.0.0.0/8 [1/0] via 1.1.1.2
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/8 is directly connected, FastEthernet0/0
L        10.1.1.1/32 is directly connected, FastEthernet0/0
      11.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
C        11.0.0.0/24 is directly connected, Loopback0
L        11.0.0.1/32 is directly connected, Loopback0
C        11.0.1.0/24 is directly connected, Loopback1
L        11.0.1.1/32 is directly connected, Loopback1
C        11.0.2.0/24 is directly connected, Loopback2
L        11.0.2.1/32 is directly connected, Loopback2
C        11.0.3.0/24 is directly connected, Loopback3
L        11.0.3.1/32 is directly connected, Loopback3
C        11.0.4.0/24 is directly connected, Loopback4
L        11.0.4.1/32 is directly connected, Loopback4
S     20.0.0.0/8 [1/0] via 1.1.1.2
S     30.0.0.0/8 [1/0] via 1.1.1.2
S     40.0.0.0/8 [1/0] via 1.1.1.2

R1#ping 20.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/34/40 ms
R1#ping 30.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 30.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/51/80 ms
R1#ping 40.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 40.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/63/76 ms

lets see the configuration of  default route in RIPv2 but in this section we will see different method by using command.





Topology:





























GOAL:
  • delete the previous topology by using no ip routing command.
  • advertise default route by using command not by redistribution just like previous scenario.
R1(config)#no ip routing
R1(config)#ip routing

R2(config)#no ip routing
R2(config)#ip routing

R3(config)#no ip routing
R3(config)#ip routing

R4(config)#no ip routing
R4(config)#ip routing



R1(config)#ip route 2.0.0.0 255.0.0.0 1.1.1.2
R1(config)#ip route 3.0.0.0 255.0.0.0 1.1.1.2
R1(config)#ip route 20.0.0.0 255.0.0.0 1.1.1.2
R1(config)#ip route 30.0.0.0 255.0.0.0 1.1.1.2
R1(config)#ip route 40.0.0.0 255.0.0.0 1.1.1.2

R2(config)#router rip
R2(config-router)#ver 2
R2(config-router)#network 2.0.0.0
R2(config-router)#network 3.0.0.0
R2(config-router)#network 20.0.0.0
R2(config-router)#exit

R3(config)#router rip
R3(config-router)#ver 2
R3(config-router)#network 2.0.0.0
R3(config-router)#network 30.0.0.0
R3(config-router)#exit

R4(config)#router rip
R4(config-router)#ver 2
R4(config-router)#network 3.0.0.0
R4(config-router)#network 40.0.0.0
R4(config-router)#exit

R2(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.1

R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#default-information originate
R2(config-router)#end

R4#sh ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 3.3.3.1 to network 0.0.0.0

R*    0.0.0.0/0 [120/1] via 3.3.3.1, 00:00:10, Serial3/2
R     2.0.0.0/8 [120/1] via 3.3.3.1, 00:00:10, Serial3/2
R     20.0.0.0/8 [120/1] via 3.3.3.1, 00:00:10, Serial3/2
R     30.0.0.0/8 [120/2] via 3.3.3.1, 00:00:10, Serial3/2
R4#ping 11.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/66/96 ms
R4#ping 11.0.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.0.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/45/52 ms
R4#ping 11.0.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.0.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/56/68 ms

R3#show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 2.2.2.1 to network 0.0.0.0

R*    0.0.0.0/0 [120/1] via 2.2.2.1, 00:00:17, Serial3/1
R     3.0.0.0/8 [120/1] via 2.2.2.1, 00:00:17, Serial3/1
R     20.0.0.0/8 [120/1] via 2.2.2.1, 00:00:17, Serial3/1
R     40.0.0.0/8 [120/2] via 2.2.2.1, 00:00:17, Serial3/1
R3#ping 11.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/50/80 ms
R3#ping 11.0.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.0.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/68/76 ms
R3#ping 11.0.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.0.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/43/60 ms

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 1.1.1.1 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 1.1.1.1
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/8 is directly connected, Serial3/0
L        1.1.1.2/32 is directly connected, Serial3/0
      2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        2.0.0.0/8 is directly connected, Serial3/1
L        2.2.2.1/32 is directly connected, Serial3/1
      3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        3.0.0.0/8 is directly connected, Serial3/2
L        3.3.3.1/32 is directly connected, Serial3/2
      20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        20.0.0.0/8 is directly connected, FastEthernet0/0
L        20.1.1.1/32 is directly connected, FastEthernet0/0
R     30.0.0.0/8 [120/1] via 2.2.2.2, 00:00:22, Serial3/1
R     40.0.0.0/8 [120/1] via 3.3.3.2, 00:00:14, Serial3/2

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 1.1.1.1 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 1.1.1.1
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/8 is directly connected, Serial3/0
L        1.1.1.2/32 is directly connected, Serial3/0
      2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        2.0.0.0/8 is directly connected, Serial3/1
L        2.2.2.1/32 is directly connected, Serial3/1
      3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        3.0.0.0/8 is directly connected, Serial3/2
L        3.3.3.1/32 is directly connected, Serial3/2
      20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        20.0.0.0/8 is directly connected, FastEthernet0/0
L        20.1.1.1/32 is directly connected, FastEthernet0/0
R     30.0.0.0/8 [120/1] via 2.2.2.2, 00:00:22, Serial3/1
R     40.0.0.0/8 [120/1] via 3.3.3.2, 00:00:14, Serial3/2
R2#
R2#ping 30.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 30.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/28/40 ms
R2#ping 40.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 40.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/20/36 ms
R2#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/44/56 ms
R2#ping 11.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/22/44 ms

R1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/8 is directly connected, Serial3/0
L        1.1.1.1/32 is directly connected, Serial3/0
S     2.0.0.0/8 [1/0] via 1.1.1.2
S     3.0.0.0/8 [1/0] via 1.1.1.2
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/8 is directly connected, FastEthernet0/0
L        10.1.1.1/32 is directly connected, FastEthernet0/0
      11.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
C        11.0.0.0/24 is directly connected, Loopback0
L        11.0.0.1/32 is directly connected, Loopback0
C        11.0.1.0/24 is directly connected, Loopback1
L        11.0.1.1/32 is directly connected, Loopback1
C        11.0.2.0/24 is directly connected, Loopback2
L        11.0.2.1/32 is directly connected, Loopback2
C        11.0.3.0/24 is directly connected, Loopback3
L        11.0.3.1/32 is directly connected, Loopback3
C        11.0.4.0/24 is directly connected, Loopback4
L        11.0.4.1/32 is directly connected, Loopback4
S     20.0.0.0/8 [1/0] via 1.1.1.2
S     30.0.0.0/8 [1/0] via 1.1.1.2
S     40.0.0.0/8 [1/0] via 1.1.1.2
R1#ping 20.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/28/52 ms
R1#ping 30.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 30.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/88/136 ms
R1#ping 40.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 40.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/44/72 ms


Sunday, 4 November 2018

Default Routing and configuration


Default Routing - Default Routing is something called gateway of last resort, when a specific route to a particular network does not exist, a router will drop all the packets destined to that specific network. Router forward packets using a default route when there is no specific routes that match a packet’s destination IP address in the routing table. The default route can be identified by all zeros in both the network and subnet mask (0.0.0.0 0.0.0.0). It is the least specific route possible. Default route are also use to connect ISP site or head site.

Routing protocols like RIPv2, EIGRP, and OSPF can advertise default routes, each router chooses the best default route to list as that router’s gateway of last resort.

In short:

 Default route is used by IP to forward any packet with destination not found in the routing table.”

Methods of  advertising default routes in RIP:
·         
      














 Learning default route in RIPv2- Configuration of default route in RIPv2-

Topology:





·         Configure the interface as per the diagram
·         Configure static routing route from ISP to R2
·         Configure a default route on R2 (Head Office) to provide connectivity to internet routs(15.0.0.1-15.0.2.1)

R1#show ip interface brief
Interface                    IP-Address          OK? Method     Status                Protocol
FastEthernet0/0        192.168.1.10    YES manual            up                    up
Serial3/0                         10.0.0.1        YES manual              up                    up

R2#show ip interface brief
Interface                      IP-Address      OK? Method           Status                Protocol
FastEthernet0/0        192.168.1.20    YES manual              up                    up
Serial3/0                         10.1.1.2        YES manual               up                    up
Serial3/1                         12.1.1.1        YES manual               up                    up
Serial3/2                         11.1.1.1        YES manual               up                    up

R3#show ip interface brief
Interface                      IP-Address           OK? Method Status                Protocol
FastEthernet0/0        192.168.1.30      YES manual up                           up
Serial3/1                     12.1.1.2               YES manual up                           up


R4#show ip interface brief
Interface              IP-Address      OK? Method           Status                Protocol
FastEthernet0/0        192.168.1.40    YES manual        up                    up
Serial3/2                         11.1.1.2        YES manual          up                    up
Loopback0                    15.0.0.1        YES manual            up                    up
Loopback1                   15.0.1.1        YES manual            up                    up
Loopback 2                   15.0.2.1        YES manual           up                    up

[Configure RIPv2]

R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.0.0.0
R1(config-router)#network 192.168.1.0
R1(config-router)#no auto-summary

R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 10.0.0.0
R2(config-router)#network 192.168.1.0
R2(config-router)#network 12.0.0.0
R1(config-router)#no auto-summary

R2(config)#ip route 0.0.0.0 0.0.0.0 11.1.1.2

R4(config)#ip route 10.0.0.0 255.0.0.0 11.1.1.1
R4(config)#ip route 12.0.0.0 255.0.0.0 11.1.1.1
R4(config)#ip route 192.168.1.0 255.255.255.0 11.1.1.1

(Advertise default route in RIPv2)

R2(config)#router rip
R2(config-router)#default-information originate

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 10.1.1.2 to network 0.0.0.0

R*    0.0.0.0/0 [120/1] via 10.1.1.2, 00:00:15, Serial3/0
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/8 is directly connected, Serial3/0
L        10.0.0.1/32 is directly connected, Serial3/0
R     12.0.0.0/8 [120/1] via 10.1.1.2, 00:00:15, Serial3/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, FastEthernet0/0
L        192.168.1.10/32 is directly connected, FastEthernet0/0

R3#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 12.1.1.1 to network 0.0.0.0

R*    0.0.0.0/0 [120/1] via 12.1.1.1, 00:00:08, Serial3/1
R     10.0.0.0/8 [120/1] via 12.1.1.1, 00:00:08, Serial3/1
      12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        12.0.0.0/8 is directly connected, Serial3/1
L        12.1.1.2/32 is directly connected, Serial3/1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, FastEthernet0/0
L        192.168.1.30/32 is directly connected, FastEthernet0/0

R1#ping 15.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 15.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/58/68 ms

R1#ping 15.0.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 15.0.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/84/136 ms

R3#traceroute 15.0.0.1
Type escape sequence to abort.
Tracing the route to 15.0.0.1
VRF info: (vrf in name/id, vrf out name/id)
  1 12.1.1.1 72 msec 80 msec 64 msec
  2 11.1.1.2 128 msec 140 msec 136 msec

(Configuring another method of redistribution to advertise default route in RIPv2)

R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#no default-information originate
R2(config-router)#redistribute static
R3#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 12.1.1.1 to network 0.0.0.0

R*    0.0.0.0/0 [120/1] via 12.1.1.1, 00:00:29, Serial3/1
R     10.0.0.0/8 [120/1] via 12.1.1.1, 00:00:29, Serial3/1
      12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        12.0.0.0/8 is directly connected, Serial3/1
L        12.1.1.2/32 is directly connected, Serial3/1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, FastEthernet0/0
L        192.168.1.30/32 is directly connected, FastEthernet0/0

R3#ping 15.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 15.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/56/136 ms

R1#ping 15.0.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 15.0.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/67/112 ms


[In the next section we will configure default EIGRP methods and OSPF methods]



 


 


Instagram

Facebook


Twitter



LINKEDIN








What is layer 3 etherchannel? How to configure layer 3 etherchannel?

EtherChannel technology allows us to bundle multiple physical links into one logical link. It is used to increase the bandwidth and provide ...