Showing posts with label BGP Route Reflector. Show all posts
Showing posts with label BGP Route Reflector. Show all posts

Wednesday, 23 January 2019

BGP route reflector (RR) configuration of two RR servers?


We have already learned what route reflector is and why we use route reflector (RR), if you do not know then Click. In this section, we will see the configuration of two RR servers and will learn about deep RR behavior.











A route reflector is a BGP router that is allowed to ignore the IBGP loop avoidance rule, such as is allowed to advertise updates received from an IBGP peer to another IBGP peer under specific conditions. 
  • If a router receives an IBGP route with the originate-id attribute set to its own router-ID, the route is discarded.
  • If a route reflector (RR) receives a route with a cluster-list attribute containing its cluster-ID, the route is discarded.

In our case we have two RR servers and it will establish a neighbor with other servers and clients.
Let see the configuration:-


Topology:

CCIE

GOAL:
  • Configure the topology as er the diagram and assign the IP address.
  • Configure EIGRP to provide the reachability between BGP speakers (peer)
  • configure router 2 - 4 RR server and router 1 - 3 client.  


R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        40.1.1.1        YES manual up                    up
Serial3/0                     1.1.1.1         YES manual up                    up
Serial3/3                     4.1.1.2         YES manual up                    up
Loopback0               11.0.0.1        YES manual up                    up


R2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        20.1.1.1        YES manual up                    up
Serial3/0                    1.1.1.2         YES manual up                    up
Serial3/1                    2.1.1.1         YES manual up                    up
Loopback0              12.0.0.1        YES manual up                    up


R3#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        30.1.1.1        YES manual up                    up
Serial3/1                    2.1.1.2         YES manual up                    up
Serial3/2                   3.1.1.1         YES manual up                    up
Loopback0              13.0.0.1        YES manual up                    up



R4#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        40.1.1.1        YES manual up                    up
Serial3/2                    3.1.1.2         YES manual up                    up
Serial3/3                   4.1.1.1         YES manual up                    up
Loopback0              14.0.0.1        YES manual up                    up


R1(config)#router eigrp 10
R1(config-router)#network 1.0.0.0
R1(config-router)#network 10.0.0.0
R1(config-router)#network 4.0.0.0
R1(config-router)#network 11.0.0.0
R1(config-router)#auto-summary
R1(config-router)#exit

R2(config)#router eigrp 10
R2(config-router)#network 1.0.0.0
R2(config-router)#network 2.0.0.0
R2(config-router)#network 12.0.0.0
R2(config-router)#network 20.0.0.0
R2(config-router)#auto-summary
R2(config-router)#exit


R3(config)#router eigrp 10
R3(config-router)#network 2.0.0.0
R3(config-router)#network 3.0.0.0
R3(config-router)#network 30.0.0.0
R3(config-router)#network 13.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#exit

R4(config)#router eigrp 10
R4(config-router)#network 3.0.0.0
R4(config-router)#network 4.0.0.0
R4(config-router)#network 40.0.0.0
R4(config-router)#network 14.0.0.0
R4(config-router)#no auto-summary
R4(config-router)#exit

R1#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(10)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   4.1.1.1                 Se3/3                    14 00:27:43   54   324  0  12
0   1.1.1.2                 Se3/0                    14 00:30:36   48   288  0  24

R2#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(10)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   2.1.1.2                 Se3/1                    14 00:29:24   60   360  0  18
0   1.1.1.1                 Se3/0                    12 00:31:07   56   336  0  19



R3#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(10)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   3.1.1.2                 Se3/2                    13 00:28:44   64   384  0  11
0   2.1.1.1                 Se3/1                    10 00:29:46   58   348  0  25
R3#

R4#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(10)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   4.1.1.2                 Se3/3                    11 00:28:53   53   318  0  20
0   3.1.1.1                 Se3/2                    10 00:29:01   45   270  0  19

R1(config)#router  bgp 100
R1(config-router)#neighbor 12.0.0.1 remote-as 100
R1(config-router)#neighbor 12.0.0.1 update-source loopback 0

R1(config-router)# neighbor 14.0.0.1 remote-as 100
R1(config-router)# neighbor 14.0.0.1 update-source loopback 0

R1(config-router)#network 10.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#no synchronization
R1(config-router)#exit

R2(config)#router bgp 100

R2(config-router)#neighbor 11.0.0.1 remote-as 100
R2(config-router)#neighbor 11.0.0.1 update-source loopback 0
R2(config-router)#neighbor 11.0.0.1 route-reflector-client

*Jan 23 13:47:51.839: %BGP-5-ADJCHANGE: neighbor 11.0.0.1 Down RR client config change
*Jan 23 13:47:51.843: %BGP_SESSION-5-ADJCHANGE: neighbor 11.0.0.1 IPv4 Unicast topology base removed from session  RR client config change

*Jan 23 13:47:52.999: %BGP-5-ADJCHANGE: neighbor 11.0.0.1 Up

R2(config-router)#neighbor 13.0.0.1 remote-as 100
R2(config-router)#neighbor 13.0.0.1 update-source loopback 0
R2(config-router)#neighbor 11.0.0.1 route-reflector-client

R2(config-router)#neighbor 14.0.0.1 remote-as 100
R2(config-router)#neighbor 14.0.0.1 update-source loopback 0
R2(config-router)#neighbor 14.0.0.1 route-reflector-client

R2(config-router)#network 20.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#no synchronization
R2(config-router)#end


R3(config)#router bgp 100
R3(config-router)#neighbor 12.0.0.1 remote-as 100
R3(config-router)#neighbor 12.0.0.1 update-source loopback 0

*Jan 23 13:50:42.831: %BGP-5-ADJCHANGE: neighbor 12.0.0.1 Up

R3(config-router)#neighbor 14.0.0.1 remote-as 100
R3(config-router)#neighbor 14.0.0.1 update-source loopback 0

R3(config-router)#network 30.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#no synchronization
R3(config-router)#end


R4(config)#router bgp 100

R4(config-router)#neighbor 11.0.0.1 remote-as 100
R4(config-router)#neighbor 11.0.0.1 update-source loopback 0
R4(config-router)#neighbor 11.0.0.1 route-reflector-client

R4(config-router)#neighbor 12.0.0.1 remote-as 100
R4(config-router)#neighbor 12.0.0.1 update-source loopback 0
R4(config-router)#neighbor 12.0.0.1 route-reflector-client

R4(config-router)#neighbor 13.0.0.1 remote-as 100
R4(config-router)#neighbor 13.0.0.1 update-source loopback 0
R4(config-router)#neighbor 13.0.0.1 route-reflector-client

R4(config-router)#network 40.0.0.0
R4(config-router)#no synchronization
R4(config-router)#no auto-summary
R4(config-router)#end


R2#show ip bgp summary | begin net
3 network entries using 432 bytes of memory
4 path entries using 320 bytes of memory
2/2 BGP path/bestpath attribute entries using 272 bytes of memory
1 BGP rrinfo entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1048 total bytes of memory
BGP activity 3/0 prefixes, 5/1 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
11.0.0.1        4          100      25      26        4    0    0 00:19:31        0
13.0.0.1        4          100      22      23        4    0    0 00:16:41        1
14.0.0.1        4          100      15      12        4    0    0 00:04:00        2


R4#show ip bgp summary | begin network
3 network entries using 432 bytes of memory
4 path entries using 320 bytes of memory
2/2 BGP path/bestpath attribute entries using 272 bytes of memory
1 BGP rrinfo entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1048 total bytes of memory
BGP activity 3/0 prefixes, 7/3 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
11.0.0.1        4          100      13      19       11    0    0 00:07:48        0
12.0.0.1        4          100      15      18       11    0    0 00:06:46        2
13.0.0.1        4          100      13      16       11    0    0 00:06:16        1

R2#show ip bgp 30.1.1.1
BGP routing table entry for 30.0.0.0/8, version 3
Paths: (2 available, best #2, table default, RIB-failure(17))
  Advertised to update-groups:
     2
  Refresh Epoch 2
  Local, (Received from a RR-client)
    13.0.0.1 (metric 2297856) from 14.0.0.1 (14.0.0.1)
      Origin IGP, metric 0, localpref 100, valid, internal
      Originator: 13.0.0.1, Cluster list: 14.0.0.1
      rx pathid: 0, tx pathid: 0
  Refresh Epoch 1
  Local
    13.0.0.1 (metric 2297856) from 13.0.0.1 (13.0.0.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      rx pathid: 0, tx pathid: 0x0


R4#show ip bgp 20.1.1.1
BGP routing table entry for 20.0.0.0/8, version 7
Paths: (1 available, best #1, table default, RIB-failure(17))
  Advertised to update-groups:
     2
  Refresh Epoch 2
  Local, (Received from a RR-client)
    12.0.0.1 (metric 2809856) from 12.0.0.1 (12.0.0.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      rx pathid: 0, tx pathid: 0x0

(from the above output reveal the fact that prefixe 20.1.1.1/8 were recieved from a route reflector client)

R1#show ip bgp 30.1.1.1
BGP routing table entry for 30.0.0.0/8, version 3
Paths: (2 available, best #2, table default, RIB-failure(17))
  Not advertised to any peer
  Refresh Epoch 1
  Local
    13.0.0.1 (metric 2809856) from 14.0.0.1 (14.0.0.1)
      Origin IGP, metric 0, localpref 100, valid, internal
      Originator: 13.0.0.1, Cluster list: 14.0.0.1
      rx pathid: 0, tx pathid: 0
  Refresh Epoch 1
  Local
    13.0.0.1 (metric 2809856) from 12.0.0.1 (12.0.0.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      Originator: 13.0.0.1, Cluster list: 12.0.0.1
      rx pathid: 0, tx pathid: 0x0

(from the above output reveals the originator-ID  and the cluster- list  of prefix 30.1.1.1/8 )

 


 


Instagram

Facebook


Twitter



LINKEDIN








Friday, 7 December 2018

What is BGP Route Reflectors (RR)? How to configure?




Route reflectors (RR) are one method to eliminate the full mesh of IBGP peers in your network. The route reflector allows all IBGP speakers within your autonomous system to learn about the available routes without creating loops.

There are three types of peering in route reflectors:


  1. EBGP neighbor
  2. IBGP client neighbor
  3. IBGP non-client neighbor

When configuring a route reflector (RR), we must tell the router whether the other IBGP router is a client or non-client. An IBGP client is an IBGP router that the route reflector will “reflect” routes to, the non-client is just a regular IBGP neighbor.


When a route reflector forwards a route update, there are a few rules that must be followed:

  • A route learned from an EBGP neighbor can be forwarded to another EBGP neighbor, a client, and a non-client.
  • A route learned from a client can be forwarded to another EBGP neighbor, client or non-client.
  • A route learned from a non-client can be forwarded to another EBGP neighbor and client, but not to a non-client.




In other words: Route Reflector-RR to advertise route received from an iBGP peers to other iBGP peers. All the valid clients update server Route Reflector-RR and server update to all the valid clients.
Each client only establishes a neighbor relationship with servers, clients are not allowed to establish neighbors with other clients. Route Reflector (servers) establish neighbor relationships with other servers (if you have more the one server) and clients.


I hope now you have an idea of what is route reflector, so let's see the configuration:







Route-Reflector Configuration:-

Topology:

Goal:
  • configure the topology as per our diagram.
  • configure EIGRP 65100 to provide connectivity between peers 
  • advertise all the directly connected interfaces, and configure BGP AS 65100 as per our diagram using loopbacks.
  • configure router 5 as a Route-Reflector server and the rest of the routers will play the client role.




R1#show ip interface brief

Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        10.1.1.1        YES manual up                    up
Serial3/0                    1.1.1.1         YES manual up                    up
Serial3/3                    4.1.1.2         YES manual up                    up
Serial3/6                 15.1.1.1        YES manual up                    up
Loopback0              11.0.0.1        YES manual up                    up
Loopback1              11.0.1.1        YES manual up                    up
Loopback2              11.0.2.1        YES manual up                    up
Loopback3              11.0.3.1        YES manual up                    up
R2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        20.1.1.1        YES manual up                    up
Serial3/0                     1.1.1.2         YES manual up                    up
Serial3/1                     2.1.1.1         YES manual up                    up
Serial3/4                  25.1.1.1        YES manual up                    up
Loopback0              12.0.0.1        YES manual up                    up
Loopback1              12.0.1.1        YES manual up                    up
Loopback2              12.0.2.1        YES manual up                    up
Loopback3              12.0.3.1        YES manual up                    up



R3#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        30.1.1.1        YES manual up                    up
Serial3/1                    2.1.1.2         YES manual up                    up
Serial3/2                    3.1.1.1         YES manual up                    up
Serial3/5                  35.1.1.1        YES manual up                    up
Loopback0              13.0.0.1        YES manual up                    up
Loopback1              13.0.1.1        YES manual up                    up
Loopback2              13.0.2.1        YES manual up                    up
Loopback3              13.0.3.1        YES manual up                    up



R4#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        40.1.1.1        YES manual up                    up
Serial3/2                    3.1.1.2         YES manual up                    up
Serial3/3                    4.1.1.1         YES manual up                    up
Serial3/7                  45.1.1.1        YES manual up                    up
Loopback0              14.0.0.1        YES manual up                    up
Loopback1              14.0.1.1        YES manual up                    up
Loopback2              14.0.2.1        YES manual up                    up
Loopback3              14.0.3.1        YES manual up                    up



R5#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        50.1.1.1        YES manual up                    up
Serial3/4                   25.1.1.2        YES manual up                    up
Serial3/5                   35.1.1.2        YES manual up                    up
Serial3/6                   15.1.1.2        YES manual up                    up
Serial3/7                   45.1.1.2        YES manual up                    up
Loopback0              150.0.0.1       YES manual up                    up
Loopback1              150.0.1.1       YES manual up                    up
Loopback2              150.0.2.1       YES manual up                    up
Loopback3              150.0.3.1       YES manual up                    up


R1(config)#router eigrp 65100
R1(config-router)#network 1.0.0.0
R1(config-router)#network 4.0.0.0
R1(config-router)#network 15.0.0.0
R1(config-router)#network 11.0.0.0
R1(config-router)#network 10.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#exit


R2(config)#router eigrp 65100
R2(config-router)#network 1.0.0.0
R2(config-router)#network 2.0.0.0
R2(config-router)#network 20.0.0.0
R2(config-router)#network 12.0.0.0
R2(config-router)#network 25.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#exit


R3(config)#router eigrp 65100
R3(config-router)#network 2.0.0.0
R3(config-router)#network 3.0.0.0
R3(config-router)#network 13.0.0.0
R3(config-router)#network 30.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#exit


R4(config)#router eigrp 65100
R4(config-router)#network 3.0.0.0
R4(config-router)#network 4.0.0.0
R4(config-router)#network 14.0.0.0
R4(config-router)#network 40.0.0.0
R4(config-router)#network 45.0.0.0
R4(config-router)#no auto-summary
R4(config-router)#exit


R5(config)#router eigrp 65100
R5(config-router)#network 150.0.0.0
R5(config-router)#network 50.0.0.0
R5(config-router)#network 15.0.0.0
R5(config-router)#network 25.0.0.0
R5(config-router)#network 35.0.0.0
R5(config-router)#network 45.0.0.0
R5(config-router)#no auto-summary
R5(config-router)#exit


R1(config)#router bgp 65100

R1(config-router)#neighbor 12.0.0.1 remote-as 65100
R1(config-router)#neighbor 12.0.0.1 update-source loopback 0

R1(config-router)#neighbor 14.0.0.1 remote-as 65100
R1(config-router)#neighbor 14.0.0.1 update-source loopback 0


R1(config-router)#neighbor 150.0.0.1 remote-as 65100
R1(config-router)#neighbor 150.0.0.1 update-source loopback 0


R1(config-router)#network 10.0.0.0
R1(config-router)#no synchronization
R1(config-router)#no auto-summary
R1(config-router)#exit

R2(config)#router bgp 65100
R2(config-router)#neighbor 11.0.0.1 remote-as 65100
R2(config-router)#neighbor 11.0.0.1 update-source loopback 0

R2(config-router)#neighbor 13.0.0.1 remote-as 65100
R2(config-router)#neighbor 13.0.0.1 update-source loopback 0

R2(config-router)#  neighbor 150.0.0.1 remote-as 65100
R2(config-router)#  neighbor 150.0.0.1 update-source loopback 0

R2(config-router)#network 20.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#no synchronization
R2(config-router)#exit





R3(config)#router bgp 65100
R3(config-router)#neighbor 12.0.0.1 remote-as 65100
R3(config-router)#neighbor 12.0.0.1 update-source loopback 0


R3(config-router)#neighbor 14.0.0.1 remote-as 65100
R3(config-router)#neighbor 14.0.0.1 update-source loopback 0

R3(config-router)#neighbor 150.0.0.1 remote-as 65100
R3(config-router)#neighbor 150.0.0.1 update-source loopback 0

R3(config-router)#network 30.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#no synchronization
R3(config-router)#exit


R4(config)#router  bgp 65100
R4(config-router)#neighbor 13.0.0.1 remote-as 65100
R4(config-router)#neighbor 13.0.0.1 update-source loopback 0

R4(config-router)#neighbor 11.0.0.1 remote-as 65100
R4(config-router)#neighbor 11.0.0.1 update-source loopback 0


R4(config-router)#  neighbor 150.0.0.1 remote-as 65100
R4(config-router)#  neighbor 150.0.0.1 update-source loopback 0



R4(config-router)#network 40.0.0.0
R4(config-router)#no auto-summary
R4(config-router)#no synchronization
R4(config-router)#exit


R5(config)#router bgp 65100
R5(config-router)#neighbor 11.0.0.1 remote-as 65100
R5(config-router)#neighbor 11.0.0.1 update-source loopback 0

R5(config-router)#neighbor 12.0.0.1 remote-as 65100
R5(config-router)#neighbor 12.0.0.1 update-source loopback 0


R5(config-router)#neighbor 13.0.0.1 remote-as 65100
R5(config-router)#neighbor 13.0.0.1 update-source loopback 0

R5(config-router)#neighbor 14.0.0.1 remote-as 65100
R5(config-router)#neighbor 14.0.0.1 update-source loopback 0

R5(config)#router bgp 65100
R5(config-router)#neighbor 11.0.0.1 route-reflector-client

*Dec  7 14:07:56.415: %BGP-5-ADJCHANGE: neighbor 11.0.0.1 Down RR client config change
*Dec  7 14:07:56.419: %BGP_SESSION-5-ADJCHANGE: neighbor 11.0.0.1 IPv4 Unicast topology base removed from session  RR client config change
*Dec  7 14:07:57.291: %BGP-5-ADJCHANGE: neighbor 11.0.0.1 Up


R5(config-router)#neighbor 12.0.0.1 route-reflector-client

*Dec  7 14:08:04.183: %BGP-5-ADJCHANGE: neighbor 12.0.0.1 Down RR client config change
*Dec  7 14:08:04.187: %BGP_SESSION-5-ADJCHANGE: neighbor 12.0.0.1 IPv4 Unicast topology base removed from session  RR client config change
*Dec  7 14:08:04.407: %BGP-5-ADJCHANGE: neighbor 12.0.0.1 Up

R5(config-router)#neighbor 13.0.0.1 route-reflector-client


*Dec  7 14:08:15.187: %BGP-5-ADJCHANGE: neighbor 13.0.0.1 Down RR client config change
*Dec  7 14:08:15.187: %BGP_SESSION-5-ADJCHANGE: neighbor 13.0.0.1 IPv4 Unicast topology base removed from session  RR client config change
*Dec  7 14:08:15.683: %BGP-5-ADJCHANGE: neighbor 13.0.0.1 Up

R5(config-router)#neighbor 14.0.0.1 route-reflector-client

*Dec  7 14:08:33.659: %BGP-5-ADJCHANGE: neighbor 14.0.0.1 Down RR client config change
*Dec  7 14:08:33.663: %BGP_SESSION-5-ADJCHANGE: neighbor 14.0.0.1 IPv4 Unicast topology base removed from session  RR client config change
*Dec  7 14:08:33.983: %BGP-5-ADJCHANGE: neighbor 14.0.0.1 Up

R5(config-router)#end


R5#show ip bgp 10.1.1.1
BGP routing table entry for 10.0.0.0/8, version 7
Paths: (1 available, best #1, table default, RIB-failure(17))
  Advertised to update-groups:
     2
  Refresh Epoch 2
  Local, (Received from a RR-client)
    11.0.0.1 (metric 2297856) from 11.0.0.1 (11.0.3.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      rx pathid: 0, tx pathid: 0x0
R5#show ip bgp 20.1.1.1
BGP routing table entry for 20.0.0.0/8, version 9
Paths: (1 available, best #1, table default, RIB-failure(17))
  Advertised to update-groups:
     2
  Refresh Epoch 2
  Local, (Received from a RR-client)
    12.0.0.1 (metric 2297856) from 12.0.0.1 (12.0.3.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      rx pathid: 0, tx pathid: 0x0
R5#show ip bgp 30.1.1.1
BGP routing table entry for 30.0.0.0/8, version 11
Paths: (1 available, best #1, table default, RIB-failure(17))
  Advertised to update-groups:
     2
  Refresh Epoch 2
  Local, (Received from a RR-client)
    13.0.0.1 (metric 2809856) from 13.0.0.1 (13.0.3.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      rx pathid: 0, tx pathid: 0x0


R5#show ip bgp 40.1.1.1
BGP routing table entry for 40.0.0.0/8, version 13
Paths: (1 available, best #1, table default, RIB-failure(17))
  Advertised to update-groups:
     2
  Refresh Epoch 2
  Local, (Received from a RR-client)
    14.0.0.1 (metric 2297856) from 14.0.0.1 (14.0.3.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      rx pathid: 0, tx pathid: 0x0


R1#show ip bgp 20.1.1.1
BGP routing table entry for 20.0.0.0/8, version 3
Paths: (2 available, best #2, table default, RIB-failure(17))
  Not advertised to any peer
  Refresh Epoch 1
  Local
    12.0.0.1 (metric 2297856) from 150.0.0.1 (150.0.3.1)
      Origin IGP, metric 0, localpref 100, valid, internal
      Originator: 12.0.3.1, Cluster list: 150.0.3.1
      rx pathid: 0, tx pathid: 0
  Refresh Epoch 1
  Local
    12.0.0.1 (metric 2297856) from 12.0.0.1 (12.0.3.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      rx pathid: 0, tx pathid: 0x0



 


 


Instagram

Facebook


Twitter



LINKEDIN








What is BGP Allowas-in Feature? How to configure BGP Allowas-in? GNS3

  BGP Allowas-in is a configuration option in Border Gateway Protocol (BGP) routing that allows a router to accept routes with its own AS (A...