Showing posts with label Ether_channel. Show all posts
Showing posts with label Ether_channel. Show all posts

Saturday 7 September 2024

What is layer 3 etherchannel? How to configure layer 3 etherchannel?

EtherChannel technology allows us to bundle multiple physical links into one logical link. It is used to increase the bandwidth and provide redundancy between multiple layer 2 / layer 3 interfaces. Layer 2 EtherChannel operates on the data link layer, but layer 3 EtherChannel operates at the network layer, allowing it to route traffic.  Ether-channel load balances traffic over all the links in the bundle. We can use a maximum 8 physical interfaces to configure the bundle into a single logical link.

Note:- when we configure the port channel (layer 3) we must configure No switchport command before using the command port-channel. if we do not configure no switchport command. the port channel will be the default layer 2 channel and we can not change it. To avoid this, configure no switchport command. 


let's see the configuration of layer 3 EtherChannel:-

Topology:-




Goal: configure layer 3 port-channel verify with show commands and configure routing verify with ping.

  • configure the topology as per the diagram
  • configure the IP addresses as per the topology
  • configure portchannel
  • verify port-channel
  • configure routing EIGRP 
  • configure IP on VLAN 1
  • verify with show commands. 
  • ping 



IOU1(config)#interface range ethernet 0/0-3
IOU1(config-if-range)#no switchport

IOU1(config-if-range)#channel-group 10 mode on
Creating a port-channel interface Port-channel 10
IOU1(config-if-range)#exit

IOU1(config)#interface port-channel 10
IOU1(config-if)#ip address 192.168.10.1 255.255.255.0
IOU1(config-if)#no shutdown
IOU1(config-if)#exit

 %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel10, changed state to up


IOU2(config)#interface range ethernet 0/0-3
IOU2(config-if-range)#no switchport
IOU2(config-if-range)#channel-group 10 mode on
Creating a port-channel interface Port-channel 10
IOU2(config-if-range)#exit

IOU2(config)#interface port-channel 10
IOU2(config-if)#ip address 192.168.10.2 255.255.255.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit

%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel10, changed state to up




IOU1#show etherchannel port-channel
                Channel-group listing:
                ----------------------
 
Group: 10
----------
                Port-channels in the group:
                ---------------------------
 
Port-channel: Po10
------------
 
Age of the Port-channel   = 0d:00h:29m:12s
Logical slot/port   = 16/0          Number of ports = 4
GC                  = 0x00000000      HotStandBy port = null
Passive port list   = Et0/0 Et0/1 Et0/2 Et0/3
Port state          = Port-channel L3-Ag Ag-Inuse
Protocol            =    -
Port security       = Disabled
 
Ports in the Port-channel:
 
Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     00     Et0/0    On                 0
  0     00     Et0/1    On                 0
  0     00     Et0/2    On                 0
  0     00     Et0/3    On                 0

 
Time since last port bundled:    0d:00h:29m:12s    Et0/3


IOU2#show etherchannel
                Channel-group listing:
                ----------------------
 
Group: 10
----------
Group state = L3
Ports: 4   Maxports = 4
Port-channels: 1 Max Port-channels = 1
Protocol:    -
Minimum Links: 0

IOU1(config)#ip routing

IOU1(config)#router eigrp 100
IOU1(config-router)#network 10.0.0.0
IOU1(config-router)#network 192.168.10.0
IOU1(config-router)#no auto-summary
IOU1(config-router)#exit


IOU2(config)#ip routing

IOU2(config)#router eigrp 100
IOU2(config-router)#network 20.0.0.0
IOU2(config-router)#network 192.168.10.0
IOU2(config-router)#no auto-summary
IOU2(config-router)#exit

%DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 192.168.10.1 (Port-channel10) is up: new adjacency

%DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 192.168.10.2 (Port-channel10) is up: new adjacency

IOU1(config)#interface ethernet 1/0
IOU1(config-if)#switchport
IOU1(config-if)#switchport mode access
IOU1(config-if)#switchport access vlan 1
IOU1(config-if)#exit

IOU1(config)#interface vlan 1
IOU1(config-if)#ip address 10.1.1.1 255.0.0.0
IOU1(config-if)#no shutdown
IOU1(config-if)#exit

%LINK-3-UPDOWN: Interface Vlan1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up


IOU2(config)#interface ethernet 1/0
IOU2(config-if)#switchport
IOU2(config-if)#switchport mode access
IOU2(config-if)#switchport access vlan 1
IOU2(config-if)#exit

IOU2(config)#interface vlan 1
IOU2(config-if)#ip address 20.1.1.1 255.0.0.0
IOU2(config-if)#no shutdown
IOU2(config-if)#exit

%LINK-3-UPDOWN: Interface Vlan1, changed state to up
\%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up


IOU2#ping 10.1.1.1 source 20.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 20.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/6 ms



IOU2#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 192.168.10.1 1 msec 5 msec 0 msec


Thursday 27 December 2018

Etherchannel and configuration


Ether-channel or (link aggregation). Ether-channel is a technology that allows us to bundle multiple physical links into a single logical link. Ether-channel is used to aggregate bandwidth between multiple layer 2 / layer 3 interfaces.

Ether-channel increases bandwidth and provides redundancy by aggregating individual links between switches. Ether-channel load balances traffic over all the links in the bundle. We can use a maximum 8 physical interfaces to configure the bundle into a single logical link.


when we configure an EtherChannel there are two protocols we can choose from:

  • PAgP (Cisco proprietary)
  • LACP (IEEE standard)




EtherChannel mode


 EtherChannel can be dynamically configured between switches using two protocols

  • PAgP (Port Aggregation Protocol)
  • LACP (Link Aggregation Control Protocol)





PAgP there are a number of options which we can choose from, the interface can be configured as:


On (interface becomes a member of the EtherChannel but it will not negotiate).
Desirable (the interface will actively ask the other side to be an EtherChannel).
Auto (the interface will wait passively for the other side to ask to be an EtherChannel).
Off (no EtherChannel configured on the interface).


Link Aggregation Control Protocol (LACP) is similar to PAgP. We also have different options to choose from when we are going to configure the interface:



On (interfaces become a member of the EtherChannel but it does not negotiate).
Active (the interface will actively ask the other side to be an EtherChannel).
Passive (the interface will wait passively for the other side to ask to be an EtherChannel).
Off (no EtherChannel configured on the interface).

Successful combination of EtherChannel: -

On – On
Desirable –Desirable
Desirable – Auto
Active –Active
Active – passive 




let's see the configuration: -


Topology: -
Link Aggregation
Goal:-
  • configure the topology as per the diagram.
  • configure the four physical links range fa 0/1-4 from switch 1 
  • configure the four physical links range fa0/11-14 from switch 2 
  • configure pagp which is cisco proprietary protocol.



SW-1(config)#interface range fastEthernet 0/1-4


SW-1(config-if-range)#channel-protocol ?
lacp Prepare interface for LACP protocol

pagp Prepare interface for PAgP protocol

SW-1(config-if-range)#channel-protocol pagp

SW-1(config-if-range)#channel-group 11 mode ?

active Enable LACP unconditionally
auto Enable PAgP only if a PAgP device is detected
desirable Enable PAgP unconditionally
on Enable Etherchannel only
passive Enable LACP only if a LACP device is detected


SW-1(config-if-range)#channel-group 11 mode desirable
SW-1(config-if-range)#end

SW-1(config)#interface port-channel 11
SW-1(config-if)#switchport trunk encapsulation dot1q
SW-1(config-if)#switchport mode trunk
SW-1(config-if)#end


SW-2(config)#interface range fastEthernet 0/11-14
SW-2(config-if-range)#channel-protocol pagp
SW-2(config-if-range)#channel-group 11 mode desirable
SW-2(config-if-range)#end


SW-2(config)#interface port-channel 11
SW-2(config-if)#switchport trunk encapsulation dot1q
SW-2(config-if)#switchport mode trunk

SW-2(config-if)#end

SW-1#show etherchannel port-channel
Channel-group listing:
----------------------

Group: 11
----------
Port-channels in the group:
---------------------------

Port-channel: Po11
------------

Age of the Port-channel = 00d:00h:12m:38s
Logical slot/port = 2/11 Number of ports = 4
GC = 0x00000000 HotStandBy port = null
Port state = Port-channel
Protocol = PAGP
Port Security = Disabled

Ports in the Port-channel:


Index Load Port EC state No of bits
------+------+------+------------------+-----------
0 00 Fa0/2 Desirable-Sl 0
0 00 Fa0/3 Desirable-Sl 0
0 00 Fa0/1 Desirable-Sl 0
0 00 Fa0/4 Desirable-Sl 0


Time since last port bundled: 00d:00h:09m:48s Fa0/4


SW-1#show etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port


Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
------+-------------+-----------+----------------------------------------------



11 Po11(SU) PAgP Fa0/1(P) Fa0/2(P) Fa0/3(P) Fa0/4(P)

SW-1#show etherchannel
Channel-group listing:
----------------------

Group: 11
----------
Group state = L2
Ports: 4 Maxports = 8
Port-channels: 1 Max Portchannels = 1
Protocol: PAGP

SW-2#show etherchannel port-channel
Channel-group listing:
----------------------

Group: 11
----------
Port-channels in the group:
---------------------------


Port-channel: Po11
------------

Age of the Port-channel = 00d:00h:16m:06s
Logical slot/port = 2/11 Number of ports = 4
GC = 0x00000000 HotStandBy port = null
Port state = Port-channel
Protocol = PAGP
Port Security = Disabled

Ports in the Port-channel:


Index Load Port EC state No of bits
------+------+------+------------------+-----------
0 00 Fa0/11 Desirable-Sl 0
0 00 Fa0/12 Desirable-Sl 0
0 00 Fa0/13 Desirable-Sl 0
0 00 Fa0/14 Desirable-Sl 0
Time since last port bundled: 00d:00h:07m:03s Fa0/14

SW-2#show etherchannel
Channel-group listing:
----------------------

Group: 11
----------
Group state = L2
Ports: 4 Maxports = 8
Port-channels: 1 Max Portchannels = 1
Protocol: PAGP

SW-1#show ip interface brief
Interface IP-Address OK? Method Status Protocol
Port-channel11 unassigned YES unset up up
FastEthernet0/1 unassigned YES NVRAM up up
FastEthernet0/2 unassigned YES NVRAM up up
FastEthernet0/3 unassigned YES NVRAM up up
FastEthernet0/4 unassigned YES NVRAM up up

FastEthernet0/5 unassigned YES NVRAM up up



SW-1#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
Address 0090.0CA7.0E42
Cost 7
Port 27(Port-channel11)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 00D0.D363.00A3
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20

Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------

Po11 Root FWD 7 128.27 Shr


SW-1#show interfaces trunk
Port      Mode       Encapsulation     Status    Native vlan
Po11       on             802.1q            trunking        1

Port Vlans allowed on trunk
Po11 1-1005

Port Vlans allowed and active in management domain
Po11 1

Port Vlans in spanning tree forwarding state and not pruned


Po11 1

SW-2#show interfaces trunk
Port         Mode     Encapsulation    Status     Native vlan
Po11          on           802.1q           trunking         1

Port Vlans allowed on trunk
Po11 1-1005

Port Vlans allowed and active in management domain
Po11 1

Port Vlans in spanning tree forwarding state and not pruned
Po11 1


What is layer 3 etherchannel? How to configure layer 3 etherchannel?

EtherChannel technology allows us to bundle multiple physical links into one logical link. It is used to increase the bandwidth and provide ...