Monday 5 November 2018

Route summarization


Route summarization

Route Summarization is the process of combining the contagious networks into one sub large network. Route summarization also called route aggregation, route summarization help to minimizing the routing table in an IP networks, summarization use less resources like memory, processor, and bandwidth.

Types of summarization:

1.       1.Auto summary
             Auto summarization is done to a default classful boundary
§  Class A       /8
§  Class B       /16
§  Class C       /24
             Routing protocol like RIPv2, EIGRP, and BGP v4 support               auto summarization and can be disable by the command                    R1(config-router)#no auto-summary
       
        2.Manual summary
        Administrator manually configure summarization to specific             boundary
         
       Manual summarization is supported by all classless routing               protocols like EIGRP, OSPF, RIPv2, and BGP.
 

 Steps for calculating manual summarization:      


Calculate the summary address formula you can use: 256 – number of networks = subnet mask for summary address.

Example: we want to create the most optimal summary for the following 4 networks:
192.168.0.0 / 24 subnet mask 255.255.255.0
192.168.1.0 / 24 subnet mask 255.255.255.0
192.168.2.0 / 24 subnet mask 255.255.255.0
192.168.3.0 / 24 subnet mask 255.255.255.0

 Convert these network addresses to binary:
192.168.0.0
11000000
10101000
00000000
00000000
192.168.1.0
11000000
10101000
00000001
00000000
192.168.2.0
11000000
10101000
00000010
00000000
192.168.3.0
11000000
10101000
00000011
00000000

Now we can see how many bits these network addresses have in common. The first and second octets are having the same, so that’s 16 bits.
Take a look in the third octet:
00000000
00000001
00000010
00000011

You see the first 6 bits of the third octet are the same. Now create our summary address. Calculate 8 + 8 + 6 = 22 bits

Our summary address will be 192.168.0.0 /22 (subnet mask 255.255.252.0).

Now we have seen how to do this in binary, now we do it in decimal. It is a simple trick you can use to calculate this summary.
As you see we have 4 networks, or it’s a block of 4.
 Here is a formula you can use:
256 - Number of networks = subnet mask for summary address.

For our example: 256 - 4 networks = 252
So the subnet mask will be 255.255.252.0
Another way to see at it is by using the CIDR notation. We know a /24 is a block of 256 addresses.  Using a /23 means we have 2 x 256, and a /22 means we have 4 x 256.

lets configure summarization in EIGRP



Topology 


goal:

configure EIGRP 100 on R1, R2, R3, and R4. Advertise the interface as per the diagram
configure manual summarization of above networks as per the calculation.


R1(config)#router eigrp 100
R1(config-router)#network 10.0.0.0
R1(config-router)#network 11.0.0.0
R1(config-router)#no auto-summary

R2(config)#router eigrp 100
R2(config-router)#network 20.0.0.0
R2(config-router)#network 10.0.0.0
R2(config-router)#network 10.0.0.0
.R2(config-router)#network 30.0.0.0
R2(config-router)#no auto-summary

R3(config)#router eigrp 100
R3(config-router)#network 13.0.0.0
R3(config-router)#network 30.0.0.0
R3(config-router)#no auto-summary

R4(config)#router eigrp 100
R4(config-router)#network 20.0.0.0
R4(config-router)#network 14.0.0.0
R4(config-router)#no auto-summary

R1#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      12.0.0.0/24 is subnetted, 4 subnets
D        12.0.0.0 [90/2297856] via 10.1.1.2, 00:00:09, Serial3/0
D        12.0.1.0 [90/2297856] via 10.1.1.2, 00:00:09, Serial3/0
D        12.0.2.0 [90/2297856] via 10.1.1.2, 00:00:09, Serial3/0
D        12.0.3.0 [90/2297856] via 10.1.1.2, 00:00:09, Serial3/0
      13.0.0.0/24 is subnetted, 4 subnets
D        13.0.0.0 [90/2809856] via 10.1.1.2, 00:10:47, Serial3/0
D        13.0.1.0 [90/2809856] via 10.1.1.2, 00:10:47, Serial3/0
D        13.0.2.0 [90/2809856] via 10.1.1.2, 00:10:47, Serial3/0
D        13.0.3.0 [90/2809856] via 10.1.1.2, 00:10:47, Serial3/0
      14.0.0.0/24 is subnetted, 4 subnets
D        14.0.0.0 [90/2809856] via 10.1.1.2, 00:09:50, Serial3/0
D        14.0.1.0 [90/2809856] via 10.1.1.2, 00:09:50, Serial3/0
D        14.0.2.0 [90/2809856] via 10.1.1.2, 00:09:50, Serial3/0
D        14.0.3.0 [90/2809856] via 10.1.1.2, 00:09:50, Serial3/0
D     20.0.0.0/8 [90/2681856] via 10.1.1.2, 00:11:31, Serial3/0
D     30.0.0.0/8 [90/2681856] via 10.1.1.2, 00:11:24, Serial3/0
  

R2#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      11.0.0.0/24 is subnetted, 4 subnets
D        11.0.0.0 [90/2297856] via 10.0.0.1, 00:12:32, Serial3/0
D        11.0.1.0 [90/2297856] via 10.0.0.1, 00:12:32, Serial3/0
D        11.0.2.0 [90/2297856] via 10.0.0.1, 00:12:32, Serial3/0
D        11.0.3.0 [90/2297856] via 10.0.0.1, 00:12:32, Serial3/0
      13.0.0.0/24 is subnetted, 4 subnets
D        13.0.0.0 [90/2297856] via 30.1.1.2, 00:11:48, Serial3/1
D        13.0.1.0 [90/2297856] via 30.1.1.2, 00:11:48, Serial3/1
D        13.0.2.0 [90/2297856] via 30.1.1.2, 00:11:48, Serial3/1
D        13.0.3.0 [90/2297856] via 30.1.1.2, 00:11:48, Serial3/1
      14.0.0.0/24 is subnetted, 4 subnets
D        14.0.0.0 [90/2297856] via 20.1.1.2, 00:10:51, Serial3/2
D        14.0.1.0 [90/2297856] via 20.1.1.2, 00:10:51, Serial3/2
D        14.0.2.0 [90/2297856] via 20.1.1.2, 00:10:51, Serial3/2
D        14.0.3.0 [90/2297856] via 20.1.1.2, 00:10:51, Serial3/2


R3#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

D     10.0.0.0/8 [90/2681856] via 30.1.1.1, 00:12:21, Serial3/1
      11.0.0.0/24 is subnetted, 4 subnets
D        11.0.0.0 [90/2809856] via 30.1.1.1, 00:12:21, Serial3/1
D        11.0.1.0 [90/2809856] via 30.1.1.1, 00:12:21, Serial3/1
D        11.0.2.0 [90/2809856] via 30.1.1.1, 00:12:21, Serial3/1
D        11.0.3.0 [90/2809856] via 30.1.1.1, 00:12:21, Serial3/1
      12.0.0.0/24 is subnetted, 4 subnets
D        12.0.0.0 [90/2297856] via 30.1.1.1, 00:01:42, Serial3/1
D        12.0.1.0 [90/2297856] via 30.1.1.1, 00:01:42, Serial3/1
D        12.0.2.0 [90/2297856] via 30.1.1.1, 00:01:42, Serial3/1
D        12.0.3.0 [90/2297856] via 30.1.1.1, 00:01:42, Serial3/1
      14.0.0.0/24 is subnetted, 4 subnets
D        14.0.0.0 [90/2809856] via 30.1.1.1, 00:11:23, Serial3/1
D        14.0.1.0 [90/2809856] via 30.1.1.1, 00:11:23, Serial3/1
D        14.0.2.0 [90/2809856] via 30.1.1.1, 00:11:23, Serial3/1
D        14.0.3.0 [90/2809856] via 30.1.1.1, 00:11:23, Serial3/1
D     20.0.0.0/8 [90/2681856] via 30.1.1.1, 00:12:21, Serial3/1


R4#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

D     10.0.0.0/8 [90/2681856] via 20.1.1.1, 00:12:03, Serial3/2
      11.0.0.0/24 is subnetted, 4 subnets
D        11.0.0.0 [90/2809856] via 20.1.1.1, 00:12:03, Serial3/2
D        11.0.1.0 [90/2809856] via 20.1.1.1, 00:12:03, Serial3/2
D        11.0.2.0 [90/2809856] via 20.1.1.1, 00:12:03, Serial3/2
D        11.0.3.0 [90/2809856] via 20.1.1.1, 00:12:03, Serial3/2
      12.0.0.0/24 is subnetted, 4 subnets
D        12.0.0.0 [90/2297856] via 20.1.1.1, 00:02:15, Serial3/2
D        12.0.1.0 [90/2297856] via 20.1.1.1, 00:02:15, Serial3/2
D        12.0.2.0 [90/2297856] via 20.1.1.1, 00:02:15, Serial3/2
D        12.0.3.0 [90/2297856] via 20.1.1.1, 00:02:15, Serial3/2
      13.0.0.0/24 is subnetted, 4 subnets
D        13.0.0.0 [90/2809856] via 20.1.1.1, 00:12:03, Serial3/2
D        13.0.1.0 [90/2809856] via 20.1.1.1, 00:12:03, Serial3/2
D        13.0.2.0 [90/2809856] via 20.1.1.1, 00:12:03, Serial3/2
D        13.0.3.0 [90/2809856] via 20.1.1.1, 00:12:03, Serial3/2
D     30.0.0.0/8 [90/2681856] via 20.1.1.1, 00:12:03, Serial3/2


R1(config)#interface serial 3/0
R1(config-if)#ip summary-address eigrp 100 11.0.0.0 255.255.252.0

R2(config)#interface serial 3/0
R2(config-if)#ip summary-address eigrp 100 12.0.0.0 255.255.252.0
R2(config-if)#interface serial 3/1
R2(config-if)#ip summary-address eigrp 100 12.0.0.0 255.255.252.0
R2(config-if)#interface serial 3/2
R2(config-if)#ip summary-address eigrp 100 12.0.0.0 255.255.252.0


R3(config)#interface serial 3/1
R3(config-if)#ip summary-address eigrp 100 13.0.0.0 255.255.252.0

R4(config)#interface serial 3/2
R4(config-if)#ip summary-address eigrp 100 14.0.0.0 255.255.252.0


R1#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      11.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
D        11.0.0.0/22 is a summary, 00:03:20, Null0
      12.0.0.0/22 is subnetted, 1 subnets
D        12.0.0.0 [90/2297856] via 10.1.1.2, 00:02:43, Serial3/0
      13.0.0.0/22 is subnetted, 1 subnets
D        13.0.0.0 [90/2809856] via 10.1.1.2, 00:01:41, Serial3/0
      14.0.0.0/22 is subnetted, 1 subnets
D        14.0.0.0 [90/2809856] via 10.1.1.2, 00:01:14, Serial3/0
D     20.0.0.0/8 [90/2681856] via 10.1.1.2, 00:19:14, Serial3/0
D     30.0.0.0/8 [90/2681856] via 10.1.1.2, 00:19:07, Serial3/0


R2#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      11.0.0.0/22 is subnetted, 1 subnets
D        11.0.0.0 [90/2297856] via 10.0.0.1, 00:03:32, Serial3/0
      12.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
D        12.0.0.0/22 is a summary, 00:02:55, Null0
      13.0.0.0/22 is subnetted, 1 subnets
D        13.0.0.0 [90/2297856] via 30.1.1.2, 00:01:53, Serial3/1
      14.0.0.0/22 is subnetted, 1 subnets
D        14.0.0.0 [90/2297856] via 20.1.1.2, 00:01:26, Serial3/2

R3#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

D     10.0.0.0/8 [90/2681856] via 30.1.1.1, 00:18:56, Serial3/1
      11.0.0.0/22 is subnetted, 1 subnets
D        11.0.0.0 [90/2809856] via 30.1.1.1, 00:03:45, Serial3/1
      12.0.0.0/22 is subnetted, 1 subnets
D        12.0.0.0 [90/2297856] via 30.1.1.1, 00:02:38, Serial3/1
      13.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
D        13.0.0.0/22 is a summary, 00:02:07, Null0
      14.0.0.0/22 is subnetted, 1 subnets
D        14.0.0.0 [90/2809856] via 30.1.1.1, 00:01:39, Serial3/1
D     20.0.0.0/8 [90/2681856] via 30.1.1.1, 00:18:56, Serial3/1

R4#show  ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

D     10.0.0.0/8 [90/2681856] via 20.1.1.1, 00:18:15, Serial3/2
      11.0.0.0/22 is subnetted, 1 subnets
D        11.0.0.0 [90/2809856] via 20.1.1.1, 00:03:55, Serial3/2
      12.0.0.0/22 is subnetted, 1 subnets
D        12.0.0.0 [90/2297856] via 20.1.1.1, 00:02:55, Serial3/2
      13.0.0.0/22 is subnetted, 1 subnets
D        13.0.0.0 [90/2809856] via 20.1.1.1, 00:02:16, Serial3/2
      14.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
D        14.0.0.0/22 is a summary, 00:01:49, Null0
D     30.0.0.0/8 [90/2681856] via 20.1.1.1, 00:18:15, Serial3/2


 R1#ping 14.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 14.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/40/56 ms
R1#ping 13.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 13.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/60/76 ms
R1#ping 12.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/36/40 ms

 R4#traceroute 13.0.0.1
Type escape sequence to abort.
Tracing the route to 13.0.0.1
VRF info: (vrf in name/id, vrf out name/id)
  1 20.1.1.1 40 msec 68 msec 60 msec
  2 30.1.1.2 144 msec 144 msec 64 msec


 


 


Instagram

Facebook


Twitter



LINKEDIN








Sunday 4 November 2018

Default Routing and configuration


Default Routing - Default Routing is something called gateway of last resort, when a specific route to a particular network does not exist, a router will drop all the packets destined to that specific network. Router forward packets using a default route when there is no specific routes that match a packet’s destination IP address in the routing table. The default route can be identified by all zeros in both the network and subnet mask (0.0.0.0 0.0.0.0). It is the least specific route possible. Default route are also use to connect ISP site or head site.

Routing protocols like RIPv2, EIGRP, and OSPF can advertise default routes, each router chooses the best default route to list as that router’s gateway of last resort.

In short:

 Default route is used by IP to forward any packet with destination not found in the routing table.”

Methods of  advertising default routes in RIP:
·         
      














 Learning default route in RIPv2- Configuration of default route in RIPv2-

Topology:





·         Configure the interface as per the diagram
·         Configure static routing route from ISP to R2
·         Configure a default route on R2 (Head Office) to provide connectivity to internet routs(15.0.0.1-15.0.2.1)

R1#show ip interface brief
Interface                    IP-Address          OK? Method     Status                Protocol
FastEthernet0/0        192.168.1.10    YES manual            up                    up
Serial3/0                         10.0.0.1        YES manual              up                    up

R2#show ip interface brief
Interface                      IP-Address      OK? Method           Status                Protocol
FastEthernet0/0        192.168.1.20    YES manual              up                    up
Serial3/0                         10.1.1.2        YES manual               up                    up
Serial3/1                         12.1.1.1        YES manual               up                    up
Serial3/2                         11.1.1.1        YES manual               up                    up

R3#show ip interface brief
Interface                      IP-Address           OK? Method Status                Protocol
FastEthernet0/0        192.168.1.30      YES manual up                           up
Serial3/1                     12.1.1.2               YES manual up                           up


R4#show ip interface brief
Interface              IP-Address      OK? Method           Status                Protocol
FastEthernet0/0        192.168.1.40    YES manual        up                    up
Serial3/2                         11.1.1.2        YES manual          up                    up
Loopback0                    15.0.0.1        YES manual            up                    up
Loopback1                   15.0.1.1        YES manual            up                    up
Loopback 2                   15.0.2.1        YES manual           up                    up

[Configure RIPv2]

R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.0.0.0
R1(config-router)#network 192.168.1.0
R1(config-router)#no auto-summary

R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 10.0.0.0
R2(config-router)#network 192.168.1.0
R2(config-router)#network 12.0.0.0
R1(config-router)#no auto-summary

R2(config)#ip route 0.0.0.0 0.0.0.0 11.1.1.2

R4(config)#ip route 10.0.0.0 255.0.0.0 11.1.1.1
R4(config)#ip route 12.0.0.0 255.0.0.0 11.1.1.1
R4(config)#ip route 192.168.1.0 255.255.255.0 11.1.1.1

(Advertise default route in RIPv2)

R2(config)#router rip
R2(config-router)#default-information originate

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 10.1.1.2 to network 0.0.0.0

R*    0.0.0.0/0 [120/1] via 10.1.1.2, 00:00:15, Serial3/0
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/8 is directly connected, Serial3/0
L        10.0.0.1/32 is directly connected, Serial3/0
R     12.0.0.0/8 [120/1] via 10.1.1.2, 00:00:15, Serial3/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, FastEthernet0/0
L        192.168.1.10/32 is directly connected, FastEthernet0/0

R3#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 12.1.1.1 to network 0.0.0.0

R*    0.0.0.0/0 [120/1] via 12.1.1.1, 00:00:08, Serial3/1
R     10.0.0.0/8 [120/1] via 12.1.1.1, 00:00:08, Serial3/1
      12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        12.0.0.0/8 is directly connected, Serial3/1
L        12.1.1.2/32 is directly connected, Serial3/1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, FastEthernet0/0
L        192.168.1.30/32 is directly connected, FastEthernet0/0

R1#ping 15.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 15.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/58/68 ms

R1#ping 15.0.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 15.0.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/84/136 ms

R3#traceroute 15.0.0.1
Type escape sequence to abort.
Tracing the route to 15.0.0.1
VRF info: (vrf in name/id, vrf out name/id)
  1 12.1.1.1 72 msec 80 msec 64 msec
  2 11.1.1.2 128 msec 140 msec 136 msec

(Configuring another method of redistribution to advertise default route in RIPv2)

R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#no default-information originate
R2(config-router)#redistribute static
R3#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 12.1.1.1 to network 0.0.0.0

R*    0.0.0.0/0 [120/1] via 12.1.1.1, 00:00:29, Serial3/1
R     10.0.0.0/8 [120/1] via 12.1.1.1, 00:00:29, Serial3/1
      12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        12.0.0.0/8 is directly connected, Serial3/1
L        12.1.1.2/32 is directly connected, Serial3/1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, FastEthernet0/0
L        192.168.1.30/32 is directly connected, FastEthernet0/0

R3#ping 15.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 15.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/56/136 ms

R1#ping 15.0.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 15.0.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/67/112 ms


[In the next section we will configure default EIGRP methods and OSPF methods]



 


 


Instagram

Facebook


Twitter



LINKEDIN








Saturday 3 November 2018

Access Lists


Access Lists 

An access lists is essentially a list of conditions that categorize packets, and they really come in handy when you need to exercise control over network traffic. 
Access-lists are one of the most common and an easiest-to-understand use of access list is to filter unwanted packets when implementing security policies. You can set them up to make very specific decisions about regulating traffic patterns so that they’ll allow only certain host to access web resources on the internet while restricting others. With the right combination of access list, network managers arm themselves with the power to enforce nearly any security policy they can invent.

Access lists statements

If a given condition is met, then a given action is taken. If the specific condition is not met, nothing happens and the next statement is evaluated. Access lists statement are basically packets filters that packets are compared against, categorized by, and acted upon accordingly. Once the lists are built, they can be applied to either inbound or out bound traffic on any interface. Applying an ACL cause the router to analyze every packet crossing that interface in the specified direction and take the appropriate action.

There are three important rules that a packet follow when it’s being compared with an access list:

·         The packet is always compared with each line of the ACL in sequential order it will always started with the first statement of the ACL, moves on to 2 statement, then 3rd statement, and so on.
·         
       The packet is compared with statement of the access list until a match is made. Once it matches the condition on a statement of the access list, the packet is acted upon and no further comparisons take place.
·          
      There is an implicit “deny” at the end of each access list, this means that if a packet doesn’t match any condition on any of the statements in the access list, the packet will be discarded.

Type of access list (ACL)

1.       Standard access lists    these access list use only source IP address in an IP packet as the condition test. All decisions are made based on the source IP address. This means that standard ACLs basically permit or deny an entire suite of protocols. They do not distinguished between any of the many type of IP traffic such as web, telnet, UDP and so on.
2.       
      Extended access lists extended ACLs can evaluate many of the other fields in the layer 3 and layer 4 headers of an IP packet. They can evaluate source and destination IP addresses, the protocol field in the network layer header, and the port number at the transport layer header. This gives extended ACLs the ability to make much more granular decisions when controlling traffic.
3.     
         Named access lists name access list are either standard or extended and not actually a district type. To use ACLs as a packet filter, you need to apply it to an interface on the router which you wanted the traffic filtered. And you’ve got to specify which direction of traffic you want the ACLs applied to. You must you different ACLs for inbound and outbound traffic on a single interface :

·         Inbound ACLs: when an access lists is applied to inbound packet on an interface, those packets are processed through the access list before being routed to the outbound interface. Any packets that are denied won’t be routed.

·         Outbound ACLs when an access list is applied to outbound packets on an interface, packets are routed to the outbound interface and then processed through the access list before being queued.


Friday 2 November 2018

What is Gateway Load-Balancing protocol (GLBP) and how to implement the configuration?




Gateway Load-Balancing protocol (GLBP)

Let’s take a look of HSRP and VRRP both provide gateway resiliency with per-subnet load balancing, the upstream bandwidth of the standby members
Gateway Load-balancing Protocol GLBP is Cisco proprietary protocol, GLBP allow dynamic selection and simultaneous use of multiple available routers gateways, and also permit automatic failover between those gateways. Multiple routers share the load of frames that, from a client perspective, are sent to a single default gate way address, with GLBP you can fully utilize resources.

(In short)

GLBP Gateway load-balancing protocol is providing redundancy gateway and true load balancing. GLBP allow a mechanism of four routers in each forwarding group. By default, the active router directs the traffic from host to each successive router in the group using Round-Robin algorithm.

GLBP Functions

·       

      Active Virtual Gateway (AVG): Member of a group elects one gateway to be the AVG for the group, and the other group member provide backup for the AVG in the event of AVG failure. AVG assign a different virtual MAC addresses to each member of the GLBP group.






·          
      Active Virtual Forwarder Each gateway assume to the responsibility for forwarding packets that are sent to the virtual MAC address assigned to that gateway AVG. these gateways are called AVF for their virtual MAC address.
·         
      GLBP communication GLBP members communicate between each other through hello messages sent every 3 seconds to the multicast address 224.0.0.102, User Datagram Protocol (UDP) port 3222.

GLBP provides upstream load-sharing by utilizing the redundant uplinks simultaneously. It uses link capacity efficiently, thus providing solid peak-load traffic coverage. By making use of multiple available paths upstream from router or layer 3 switch running GLBP, you can reduce output queues.

GLBP Features
·         Load-sharing we can configure GLBP so that traffic from LAN client is shared by multiple routers. Load sharing distributes the traffic load among available routers.
·         Multiple virtual routers GLBP supports up to 1.024 virtual routers as GLBP groups on each routers physical interface and up to four virtual forwarders per group.
·         Preemption GLBP allow us to preempt an AVG router with a higher-priority backup virtual gateway that has become available. Forwarder preemption works in a similar way, except weighting instead of priority and is enabled by default.
·         Efficient resource utilization: GLBP makes it possible for any router in a group to serve as a backup, which eliminates the need for a dedicated backup router because all available routers can support network traffic.

GLBP Balancing host traffic

GLBP balances the traffic using the round –robin algorithm:
  • ·         When a host send an ARP message for the gateway IP address, the AVG return the virtual MAC address of one of the AVFS.
  • ·         When a second host sends an ARP message, the AVG return the next virtual MAC address from list.



Remember that each GLBP router will be the designated AVF for the specific virtual MAC address that’s been assigned to it.

Thursday 1 November 2018

What is HSRP-(Hot Standby Routing Protocol)?

Hot Standby Routing Protocol (HSRP)  is a cisco proprietary  redundancy protocol that provides  back up to a router in the event of failure.

 HSRP allow you to configure two or more routers into a standby group to present the appearance of single Virtual router on the LAN. The router share the same IP address and MAC address. therefore in the event of failure of one router the host on the LAN are able to continue forwarding packets to a consistent IP and MAC address. HSRP is not provide load-balancing.






Each standby group that you define include the following routers:

  • Active router
  • Standby router
  • Virtual router
  • Any other routers that maybe attached to the subnet
Active router one router is active and other two or more routers just sit there in standby mode and won't be active unless a failure occur. 

Standby router the standby group will always have at least two routers that participating in it. The primary players in the group are the active router and one standby router that communicate to each other using multicast hello messages, hello timer in HSRP 3 seconds and hold timer is 10 seconds.

Virtual router in an HSRP group has a virtual IP address and  virtual MAC address. virtual router is not a physical router entity. the physical router that communicates as the virtual router is the current active router.

Other routers just monitor the hello messages sent by the active and standby routers to ensure that an active and standby router exists for the HSRP  group that they belong to.

Interface tracking 

HSRP enable routers can track the interface status of the outside interface. if the outside link of the active router goes down, the standby router will take over and become the active router. There is a default priority of 100 if you raise the priority  its means your router has higher priority to become active router.

What is Layer 2 Switching?



Switching uses the hardware address of devices on a LAN to segment the network. Switching breaks up large collision domains into smaller domains and a collision domain is a network segment with two or more devices sharing the same bandwidth. each port on a switch is its collision domain. Layer 2 switching increases the bandwidth because each port of the switch is its self-collision domain.




Switch services bridges use software to create and manage a Content Addressable Memory (CAM) table. new switches use Application-Specific Integrated Circuits (ASICs) to build and maintain their MAC filter table. 

Advantages of using Layer 2 switchings:
  • Hardware-based bridging 
  • Wire-speed
  • Low latency
  • Low cost 
Layer 2 switching increases the bandwidth because each switch port is its own self-collision domain.

 Layer 2 Switch Functions:


Address learning layer 2 switches remember the source hardware address of each frame received on an on-interface and enter this information into a MAC database called a forward/filter table.

Forward/filter decisions when a frame is received on an interface, the switch looks at the destination hardware address, and then chooses the appropriate exit interface for it in the MAC database. This way, the frame is only forwarded out of the correct destination port.

Loop avoidance if multiple connections between switches are created for redundancy purposes, network loops can occur, and spanning tree protocol (STP) is used to prevent network.



 


 


Instagram

Facebook


Twitter



LINKEDIN








What is Virtual Router Redundancy Protocol (VRRP)? How to configure Virtual Router Redundancy Protocol (VRRP)?

 Virtual Router Redundancy Protocol (VRRP) is a gateway redundancy networking protocol used to create a virtual gateway similar to HSRP . VR...