Sunday, 11 November 2018

Routing Protocol Authentication (RIP, and OSPF)




Routing Protocol Authentication (OSPF, and RIPv2)

A router authenticates the source of each routing update packet that it receives. Many routings' protocols support authentication like OSPF, EIGRP, ISIS, BGP, and RIPv2.

Cisco routers support different approaches to authentication route advertisements received from a neighboring router:

Plain text authentication

Hashing authentication (using MD5)


Simple password authentication:

The router sends packets and keys (if a routing protocol doesn’t support multiple keys, the key number associated with a routing update is 0). The neighboring router checks whether the key matches its key. The outing update is rejected if the keys do not match. The only routing protocols that plan text authentication are RIPv2, OSPF, and ISIS.

MD5 authentication

Configure a key (password) and key ID, router generates a message digest or hash of the key, key ID, and message. The message digest is sent with the packet key is not sent. The neighboring router receives the update and runs a hashing algorithm on the routing update with the local key, the results in a hash digest. If the hash digit matches, the router accepts the packet, if it does not the update is rejected. This process is more secure than plain text authentication. IS-IS, OSPF, RIPv2 and EIGRP use MD5.

Let’s see the configuration:


Topology:



Goal:

  • configure the topology and interface as per the diagram
  • configure RIPv2 on both the routers and advertise the interface as per the topology
  • make sure both the routers exchange the routes only after successful authentication.



R1#show ip interface brief

Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        10.1.1.1        YES manual up                    up

Serial3/0                    1.1.1.1         YES manual up                    up


R2#show ip interface brief

Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        20.1.1.1        YES manual up                    up

Serial3/0                    1.1.1.2         YES manual up                    up





 R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 1.0.0.0
R1(config-router)#network 10.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#end

R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 1.0.0.0
R2(config-router)#network 20.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#end




 R1#show ip route rip

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set


R     20.0.0.0/8 [120/1] via 1.1.1.2, 00:00:07, Serial3/0

R2#show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

R     10.0.0.0/8 [120/1] via 1.1.1.1, 00:00:21, Serial3/0



  
configuring authentication:

R1(config)#key chain anyname1

R1(config)#key chain anyname1
R1(config-keychain)#key 1
R1(config-keychain-key)#key-string internetworks
R1(config)#interface serial 3/0
R1(config-if)#ip rip authentication md
R1(config-if)#ip rip authentication key-chain anyname1

R2(config)#key chain anyname2
R2(config-keychain)#key 1
R2(config-keychain-key)#key-string internetworks
R2(config-keychain-key)#end
R2(config)#interface serial 3/0
R2(config-if)#ip rip authentication mode md5
R2(config-if)#ip rip authentication key-chain anyname2



R1#show ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/8 is directly connected, Serial3/0
L        1.1.1.1/32 is directly connected, Serial3/0
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/8 is directly connected, FastEthernet0/0
L        10.1.1.1/32 is directly connected, FastEthernet0/0
R     20.0.0.0/8 [120/1] via 1.1.1.2, 00:00:26, Serial3/0



R2#clear ip route *

R2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/8 is directly connected, Serial3/0
L        1.1.1.2/32 is directly connected, Serial3/0
R     10.0.0.0/8 [120/1] via 1.1.1.1, 00:00:09, Serial3/0
      20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        20.0.0.0/8 is directly connected, FastEthernet0/0
L        20.1.1.1/32 is directly connected, FastEthernet0/0



R1#show key chain

Key-chain anyname1:
    key 1 -- text "internetworks"
        accept lifetime (always valid) - (always valid) [valid now]
        send lifetime (always valid) - (always valid) [valid now]

R2#show key chain
Key-chain anyname2:
    key 1 -- text "internetworks"
        accept lifetime (always valid) - (always valid) [valid now]
        send lifetime (always valid) - (always valid) [valid now]

OSPF Authentication

there are two types of  authentication in OSPf

1.Simple
2.Cryptographic (MD5/ SHA)



All OSPF packet will be authenticated when you enable any formation of authentication in OSPF.

Before we start  BGP configuration check out some important  of BGP CCIE exam topics.


Here are the lists of all OSPF labs and theories CCNA to CCIE.









let see the configuration:-


Topology:-


GOAL:

  • Configure the topology as per our diagram
  • configure OSPF in area 0 and advertise all the interfaces
  • configure router 1 and router 2 to exchange routes after establishing successful authentication by using clear text  



R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        10.1.1.1        YES manual up                    up
Serial3/0                   1.1.1.1         YES manual up                    down
Loopback0              11.0.0.1        YES manual up                    up
Loopback1              11.0.1.1        YES manual up                    up
Loopback2              11.0.2.1        YES manual up                    up
Loopback3              11.0.3.1        YES manual up                    up

R2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        20.1.1.1        YES manual up                    up
Serial3/0                   1.1.1.2         YES manual up                    up
Loopback0              12.0.0.1        YES manual up                    up
Loopback1              12.0.1.1        YES manual up                    up
Loopback2              12.0.2.1        YES manual up                    up
Loopback3              12.0.3.1        YES manual up                    up


R1(config)#router ospf 10
R1(config-router)#router-id 11.11.11.11
R1(config-router)#network 1.0.0.0 0.255.255.255 area 0
R1(config-router)#network 10.0.0.0 0.255.255.255 area 0
R1(config-router)#network 11.0.0.0 0.0.0.255 area 0

R2(config)#router ospf 10
R2(config-router)#router-id 12.12.12.12
R2(config-router)#network 12.0.0.0 0.0.0.255 area 0
R2(config-router)#network 20.0.0.0 0.255.255.255 area 0

R2(config-router)#network 1.0.0.0 0.255.255.255 area 0


R1(config)#interface serial 3/0
R1(config-if)#ip ospf authentication
R1(config-if)#ip ospf authentication-key internet


*Dec  5 12:09:31.047: %OSPF-5-ADJCHG: Process 10, Nbr 12.12.12.12 on Serial3/0 from FULL to DOWN, Neighbor Down: Dead timer expired

R2(config)#interface serial 3/0
R2(config-if)#ip ospf authentication
R2(config-if)#ip ospf authentication-key internet

(ip ospf authentication command you can enable plaintext authentication on the
interface level.)


*Dec  5 12:16:37.095: %OSPF-5-ADJCHG: Process 10, Nbr 11.11.11.11 on Serial3/0 from LOADING to FULL, Loading Done

R1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface

12.12.12.12       0   FULL/  -        00:00:39    1.1.1.2         Serial3/0

R2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
11.11.11.11       0   FULL/  -        00:00:39    1.1.1.1         Serial3/0

(When we have lots of interfaces do not want to enable OSPF authentication for
each and every interface. we can also enable area-wide authentication by using the area
authentication command). 


let's see: -

R1(config)#router ospf 10
R1(config-router)#area 0 authentication
R1(config-router)#end

*Dec  5 12:27:32.931: OSPF-10 EVENT: Area config: 'area 0 authentication '

R2(config)#router ospf 10
R2(config-router)#area 0 authentication

R1#show ip ospf interface serial 3/0
Serial3/0 is up, line protocol is up
  Internet Address 1.1.1.1/8, Area 0, Attached via Network Statement
  Process ID 10, Router ID 11.11.11.11, Network Type POINT_TO_POINT, Cost: 64
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           64        no          no            Base
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:00
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 12.12.12.12
  Suppress hello for 0 neighbor(s)
  Simple password authentication enabled



R2#show ip ospf interface serial 3/0
Serial3/0 is up, line protocol is up
  Internet Address 1.1.1.2/8, Area 0, Attached via Network Statement
  Process ID 10, Router ID 12.12.12.12, Network Type POINT_TO_POINT, Cost: 64
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           64        no          no            Base
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:04
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 11.11.11.11
  Suppress hello for 0 neighbor(s)
  Simple password authentication enabled

Saturday, 10 November 2018

What is OSPF STUB, totally stubby, NSSA, Totally NSSA and (configuration)?




OSPF STUBS

OSPF stubs allow the OSPF routers in an area to use default routes for forwarding packets to Area Border Routers (ABRs), rather than more specific routes. OSPF stubs reduce memory consumption and CPU processing time on the routers inside the area because the routers in that area can have fewer LSAs in their LSDBs.

If you configure a stub area it will block all type 5 external LSAs (E1 and E2 routes).  All the prefixes you redistributed into OSPF from another routing protocol are not welcome in the stub area. Default routes are advertised into stub areas by the ABR. All OSPF routers in the stub area must be configured as stubs.

In short: the OSPF stub allows the routers in an area to use the default route for forwarding packets to ABR rather than more specific routes.

OSPF has special area types called stub areas:

  • Stub
  • Totally Stubby
  • Not-So-Stubby Area (NSSA)
  • Totally Not So Stubby Area (Totally NSSA)


Stub Area Rules:
  1. In the OSPF Stub area, there should not be an ASBR.
  2. The OSPF Stub area should not be Area 0.
  3. No virtual link must be passing through that area.
  4. All routers in that area must be configured as stub routers.

A stub area is an isolated area that does not receive External LSA. Routers in Stub areas do not receive type 4 and type 5 LSAs it is replaced by a default route to an external autonomous system advertised by the area border router (ABR) Stub areas can have type 1, 2, and 3 OSPF LSAs.
  
 Totally stubby area External LSAs are stopped (E1 and E2) and summary LSAs are stopped (OIA routes). Replaced by a default route to other areas advertised by the ABR. Totally stubs is reducing the routing table to a minimum. This is a Cisco proprietary feature.


NSSA breaks stub area rules. NSSA area creates a special type of link-state advertisement (LSA) known as type 7, type 7 LSAs is only exist in the NSSA area. An NSSA autonomous system boundary router (ASBR) generates this LSA and an NSSA area border router (ABR) translates it into a type 5 LSA, ABR sends default routes into NSSA instead of external routes from other ASBR.

Totally NSSAs are similar to totally stubby areas, with the exception that the routers that are internal to the totally NSSAs need to have no knowledge of subnets outside of the area (with the exception of the routes injected by the NSSA ASBR)
Stub configuration:


Topology:


GOAL:
  • configure the topology and advertise the interfaces as per diagram.
  • configure ospf as per the diagram and redistribute RIP routes in to OSPF on R4.
  • configure area 10 to stop LSA 5 and LSA 4.
  • make sure that the area 10 routers still able to reach the external routes.


R1#show ip interface brief

Interface              IP-Address      OK? Method Status              Protocol
FastEthernet0/0      10.1.1.1        YES manual up                     up
Serial3/0                   1.1.1.1         YES manual up                    up
Loopback0              11.0.0.1        YES manual up                    up
Loopback1              11.0.1.1        YES manual up                    up
Loopback2              11.0.2.1        YES manual up                    up
Loopback3              11.0.3.1        YES manual up                    up




R2#show ip interface brief

Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0     20.1.1.1        YES manual up                    up
Serial3/0                  1.1.1.2         YES manual up                    up
Serial3/1                  2.1.1.1         YES manual up                    up
Loopback0             12.0.0.1        YES manual up                    up
Loopback1             12.0.1.1        YES manual up                    up
Loopback2             12.0.2.1        YES manual up                    up
Loopback3             12.0.3.1        YES manual up                    up




R3#show ip interface brief

Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0       30.1.1.1        YES manual up                    up
Serial3/1                   2.1.1.2         YES manual up                    up
Serial3/2                   3.1.1.1         YES manual up                    up
Loopback0              13.0.0.1        YES manual up                    up
Loopback1              13.0.1.1        YES manual up                    up
Loopback2              13.0.2.1        YES manual up                    up
Loopback3              13.0.3.1        YES manual up                    up




R4#show ip interface brief

Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        40.1.1.1        YES manual up                    up
Serial3/2                    3.1.1.2         YES manual up                    up
Loopback0              14.0.0.1        YES manual up                    up
Loopback1              14.0.1.1        YES manual up                    up
Loopback2              14.0.2.1        YES manual up                    up
Loopback3              14.0.3.1        YES manual up                    up


R1(config)#router ospf 1
R1(config-router)# network 11.0.0.0 0.255.255.255 area 10
R1(config-router)#network 1.0.0.0 0.255.255.255 area 10
R1(config-router)#network 10.0.0.0 0.255.255.255 area 10


R2(config)#router ospf 1
R2(config-router)#network 1.0.0.0 0.255.255.255 area 10
R2(config-router)#network 2.0.0.0 0.255.255.255 area 0
R2(config-router)#network 20.0.0.0 0.255.255.255 area 0
R2(config-router)#network 12.0.0.0 0.255.255.255 area 0
R2(config-router)#end


R3(config)#router ospf 1
R3(config-router)#network 30.0.0.0 0.255.255.255 area 0
R3(config-router)#network 13.0.0.0 0.255.255.255 area 0
R3(config-router)#network 2.0.0.0 0.255.255.255 area 0
R3(config-router)#network 3.0.0.0 0.255.255.255 area 20

R4(config)#router rip
R4(config-router)#version 2
R4(config-router)#network 14.0.0.0
R4(config-router)#no auto-summary
R4(config-router)#end

R4(config)#router ospf 1
R4(config-router)#network 3.0.0.0 0.255.255.255 area 20
R4(config-router)#network 40.0.0.0 0.255.255.255 area 20
R4(config-router)#redistribute rip subnets
R4(config-router)#end

R1#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

O IA  2.0.0.0/8 [110/128] via 1.1.1.2, 00:06:24, Serial3/0
O IA  3.0.0.0/8 [110/192] via 1.1.1.2, 00:06:24, Serial3/0
      12.0.0.0/32 is subnetted, 4 subnets
O IA     12.0.0.1 [110/65] via 1.1.1.2, 00:02:08, Serial3/0
O IA     12.0.1.1 [110/65] via 1.1.1.2, 00:02:08, Serial3/0
O IA     12.0.2.1 [110/65] via 1.1.1.2, 00:02:08, Serial3/0
O IA     12.0.3.1 [110/65] via 1.1.1.2, 00:02:08, Serial3/0
      13.0.0.0/32 is subnetted, 4 subnets
O IA     13.0.0.1 [110/129] via 1.1.1.2, 00:00:28, Serial3/0
O IA     13.0.1.1 [110/129] via 1.1.1.2, 00:00:28, Serial3/0
O IA     13.0.2.1 [110/129] via 1.1.1.2, 00:00:28, Serial3/0
O IA     13.0.3.1 [110/129] via 1.1.1.2, 00:00:28, Serial3/0
      14.0.0.0/24 is subnetted, 4 subnets
O E2     14.0.0.0 [110/20] via 1.1.1.2, 00:04:59, Serial3/0
O E2     14.0.1.0 [110/20] via 1.1.1.2, 00:04:59, Serial3/0
O E2     14.0.2.0 [110/20] via 1.1.1.2, 00:04:59, Serial3/0
O E2     14.0.3.0 [110/20] via 1.1.1.2, 00:04:59, Serial3/0
O IA  20.0.0.0/8 [110/65] via 1.1.1.2, 00:06:24, Serial3/0
O IA  30.0.0.0/8 [110/129] via 1.1.1.2, 00:06:24, Serial3/0

R2#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

O IA  3.0.0.0/8 [110/128] via 2.1.1.2, 00:07:04, Serial3/1
O     10.0.0.0/8 [110/65] via 1.1.1.1, 00:06:54, Serial3/0
      11.0.0.0/32 is subnetted, 4 subnets
O        11.0.0.1 [110/65] via 1.1.1.1, 00:03:54, Serial3/0
O        11.0.1.1 [110/65] via 1.1.1.1, 00:03:54, Serial3/0
O        11.0.2.1 [110/65] via 1.1.1.1, 00:03:54, Serial3/0
O        11.0.3.1 [110/65] via 1.1.1.1, 00:03:54, Serial3/0
      13.0.0.0/32 is subnetted, 4 subnets
O        13.0.0.1 [110/65] via 2.1.1.2, 00:01:04, Serial3/1
O        13.0.1.1 [110/65] via 2.1.1.2, 00:01:04, Serial3/1
O        13.0.2.1 [110/65] via 2.1.1.2, 00:01:04, Serial3/1
O        13.0.3.1 [110/65] via 2.1.1.2, 00:01:04, Serial3/1
      14.0.0.0/24 is subnetted, 4 subnets
O E2     14.0.0.0 [110/20] via 2.1.1.2, 00:05:34, Serial3/1
O E2     14.0.1.0 [110/20] via 2.1.1.2, 00:05:34, Serial3/1
O E2     14.0.2.0 [110/20] via 2.1.1.2, 00:05:34, Serial3/1
O E2     14.0.3.0 [110/20] via 2.1.1.2, 00:05:34, Serial3/1
O     30.0.0.0/8 [110/65] via 2.1.1.2, 00:07:04, Serial3/1

R2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
13.0.3.1          0   FULL/  -        00:00:39    2.1.1.2         Serial3/1
11.0.3.1          0   FULL/  -        00:00:37    1.1.1.1         Serial3/0

R1#traceroute 14.0.0.1
Type escape sequence to abort.
Tracing the route to 14.0.0.1
VRF info: (vrf in name/id, vrf out name/id)
  1 1.1.1.2 36 msec 36 msec 32 msec
  2 2.1.1.2 124 msec 128 msec 144 msec
  3 3.1.1.2 132 msec 92 msec 108 msec

we configure area 10 as stub, ensure that no external routes enter in to area 10.


R1(config)#router ospf 1

R1(config-router)#area 10 stub


R2(config)#router ospf 1

R2(config-router)#area 10 stub

R2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
13.0.3.1          0   FULL/  -        00:00:31    2.1.1.2         Serial3/1
11.0.3.1          0   FULL/  -        00:00:34    1.1.1.1         Serial3/0

R1#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 1.1.1.2 to network 0.0.0.0

O*IA  0.0.0.0/0 [110/65] via 1.1.1.2, 00:02:22, Serial3/0
O IA  2.0.0.0/8 [110/128] via 1.1.1.2, 00:02:22, Serial3/0
O IA  3.0.0.0/8 [110/192] via 1.1.1.2, 00:02:22, Serial3/0
      12.0.0.0/32 is subnetted, 4 subnets
O IA     12.0.0.1 [110/65] via 1.1.1.2, 00:02:22, Serial3/0
O IA     12.0.1.1 [110/65] via 1.1.1.2, 00:02:22, Serial3/0
O IA     12.0.2.1 [110/65] via 1.1.1.2, 00:02:22, Serial3/0
O IA     12.0.3.1 [110/65] via 1.1.1.2, 00:02:22, Serial3/0
      13.0.0.0/32 is subnetted, 4 subnets
O IA     13.0.0.1 [110/129] via 1.1.1.2, 00:02:22, Serial3/0
O IA     13.0.1.1 [110/129] via 1.1.1.2, 00:02:22, Serial3/0
O IA     13.0.2.1 [110/129] via 1.1.1.2, 00:02:22, Serial3/0
O IA     13.0.3.1 [110/129] via 1.1.1.2, 00:02:22, Serial3/0
O IA  20.0.0.0/8 [110/65] via 1.1.1.2, 00:02:22, Serial3/0
O IA  30.0.0.0/8 [110/129] via 1.1.1.2, 00:02:22, Serial3/0

R1#ping 14.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 14.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 80/90/100 ms


(comment me if you want the configuration of nssa, totally nssa. free of cost)
CLICK HERE TO GET NSSA and TOTALLY NSSA














 


 


Instagram

Facebook


Twitter



LINKEDIN








Friday, 9 November 2018

OSPF Link State Advertisement (LSA)



OSPF uses an LSDB (link state database) and fills this with LSAs (link state advertisement) LSA holds the topology information and LSA is held in the LSDB. Instead of using 1 LSA packet, OSPF has many different varieties of LSAs.

Here is the list:
  
   LSA Types
                          Description
Type 1
Router LSAs
Type 2
Network LSAs
Type 3 or 4
Summary LSAs
Type 5
Autonomous system external LSAs
Type 6
Multicast OSPF LSAs
Type 7
Defined for not-so-stubby areas
Type 8
External attribute LSAs for
 Border Gateway Protocol (BGP)
Type 9, 10, and 11
Opaque LSAs

LSA Type 1: Router LSA
Type 1 router LSA is generated by internal routers. You can identify the “O” routes in the routing table, Type 1 LSA floods within its area only; does not cross ABR. In the type 1 LSA, you will find a list with all the directly connected links of this router.


LSA Type 2: Network LSA
The network LSA or Type 2 creates for each multi-access network. LSA Type 2 is advertised by the DR of the transit network and floods within its area only, network LSA does not cross ABR. You can identify “0” routes in the routing table. In Type 2 LSA you will find all the routers that are connected to the multi-access network, the DR, and the prefix and subnet mask.


LSA Type 3: Summary LSA
 The summary LSA is created by the ABR to send updates from one area to another area. You can identify is “OIA” routes in the routing table. Summary LSA is used to flood network information subnet in the Origin area and cost but does not topology data.


LSA Type 4: ASBR summary LSA
Type 4 LSA is used to advertise ASBR to all other areas in the autonomous system. ASBR summary LSA includes the router ID of the ASBR in the link-state ID field.


LSA Type 5: External LSA
Type 5 LSA External LSA also known as autonomous system external LSA, AS external LSA created by ASBR for external routes redistributed into OSPF (LSA 5), external LSAs are advertised and owned by the originating ASBR. External LSAs flood through the entire autonomous system, and advertising router ID (ASBR) is unchanged throughout the system. Type 4 LSA is needed to find the ASBR.


LSA-6 Multicast OSPF LSA
Type 6 LSA are used in multicast routing (MOSPF routing protocol) multicast LSA (Cisco routers do not support)

LSA Type 7: NSSA external
Type 7 LSA is created by ASBR inside an NSSA, instead of a type 5 LSA. Type 7 LSA flooded only within its area of origin and converted to Type 5 LSA on an ABR toward another area.
·         N1- metric increases as it is passed through the network
·         N2- metric doesn’t increase  (default)


LSA Type 8: external attribute LSA
External attribute LSA is created by ASBR during BGP to OSPF redistribution to preserve BGP attributes of the redistribution network.

LSA Type 9, 10, 11
·         Used in OSPF and BGP inter-networking




 


 


Instagram

Facebook


Twitter



LINKEDIN








What is BGP Allowas-in Feature? How to configure BGP Allowas-in? GNS3

  BGP Allowas-in is a configuration option in Border Gateway Protocol (BGP) routing that allows a router to accept routes with its own AS (A...