Tuesday 6 November 2018

What is EIGRP Equal-Cost and Unequal-Cost load balancing? What is variance? How to configure?




EIGRP Equal-Cost and Unequal-Cost load balancing

Routes with the lowest metric get installed in the routing table by default, if two or more routes have the same metric the router will install both the routes in the routing table this is called equal cost load balancing.

EIGRP does equal cost load balancing automatically, whereas unequal cost load balancing is not automatic, for unequal cost load balancing we need to enable Variance. EIGRP can load balancing up to six paths, and the default is four paths. 




The maximum number of paths are based on Cisco IOS versions and router platform. For the older Cisco IOS versions, the maximum-paths was 6. The latest version typically supports 16 or more.
 R1 (config)#router eigrp 100
R1 (config-router)#maximum-paths ?
  <1-32> Number of paths

Unequal cost load-balancing

EIGRP also supports unequal cost load balancing, it has to be done manually using variance. Variance is a multiplier value that ranges between ­(1 – 128) and the default is 1. The routes that can go for load balancing should satisfy the condition. The cost of the successor X variance > cost of the other routes to be used for load balancing
  • ·         The variance is multiplied by the current Feasible Distance.
  • ·         Any feasible successor whose calculated metric is less than or equal to the product of the variance and feasible distance is added to the IP routing table, assuming that the maximum-paths setting allows more routes
  • ·         Routes that are neither successor nor feasible successor routes can never add to the IP routing table, regardless of the variance setting. 
Before we start  EIGRP configuration check out some important of EIGRP CCIE exam topics.

Here are the lists of all EIGRP labs and theories CCNA to CCIE

1.Enhanced Interior Gateway Routing Protocol (EIGRP)

2.Stuck In Active (EIGRP)

3.EIGRP Equal-Cost and Unequal-Cost load balancing

4.Route filtering passive interface

5.Route summarization

6.EIGRP STUB and Configuration

7.Routing Protocol Authentication (EIGRP ) and configuration





Configuration of EIGRP Equal cost load balancing-

Topology:

  •      Configure the topology as per the diagram
  •          Advertise the interfaces using EIGRP 100
  •          Ensure the load balancing via traceroute.


R1#show ip interface  brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        10.1.1.1        YES manual up                    up
Serial3/0              1.1.1.1         YES manual up                    up
Serial3/3              4.4.4.2         YES manual up                    up

R2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        20.1.1.1        YES manual up                    up
FastEthernet1/0        unassigned      YES unset  administratively down down
FastEthernet1/1        unassigned      YES unset  administratively down down
GigabitEthernet2/0     unassigned      YES unset  administratively down down
Serial3/0              1.1.1.2         YES manual up                    up
Serial3/1              2.2.2.1         YES manual up                    up

R3#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        30.1.1.1        YES manual up                    up
FastEthernet1/0        unassigned      YES unset  administratively down down
FastEthernet1/1        unassigned      YES unset  administratively down down
GigabitEthernet2/0     unassigned      YES unset  administratively down down
Serial3/0              unassigned      YES unset  administratively down down
Serial3/1              2.2.2.2         YES manual up                    up
Serial3/2              3.3.3.1         YES manual up                    up

R4#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        40.1.1.1        YES manual up                    up
Serial3/2              3.3.3.2         YES manual up                    up
Serial3/3              4.4.4.1         YES manual up                    up

R1(config)#router eigrp 100
R1(config-router)#network 1.0.0.0
R1(config-router)#network 4.0.0.0
R1(config-router)#network 10.0.0.0
R1(config-router)#no auto-summary

R2(config)#router eigrp 100
R2(config-router)#network 20.0.0.0
R2(config-router)#network 1.0.0.0
R2(config-router)#network 2.0.0.0
R2(config-router)#no auto-summary

R3(config)#router eigrp 100
R3(config-router)#network 30.0.0.0
R3(config-router)#network 2.0.0.0
R3(config-router)#network 3.0.0.0
R3(config-router)#no auto-summary


R4(config)#router eigrp 100
R4(config-router)#network 4.0.0.0
R4(config-router)#network 3.0.0.0
R4(config-router)#network 40.0.0.0
R4(config-router)#no auto-summary


R1#show ip eigrp 100 neighbors
EIGRP-IPv4 Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   4.4.4.1                 Se3/3                    12 00:15:50   37   222  0  8
0   1.1.1.2                 Se3/0                    13 00:17:52   67   402  0  20

R3#show  ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   3.3.3.2                 Se3/2                    12 00:17:17   41   246  0  9
0   2.2.2.1                 Se3/1                    11 00:17:45   48   288  0  19

R1#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

D     2.0.0.0/8 [90/2681856] via 1.1.1.2, 00:17:19, Serial3/0
D     3.0.0.0/8 [90/2681856] via 4.4.4.1, 00:17:19, Serial3/3
D     20.0.0.0/8 [90/2172416] via 1.1.1.2, 00:17:19, Serial3/0
D     30.0.0.0/8 [90/2684416] via 4.4.4.1, 00:17:19, Serial3/3
                 [90/2684416] via 1.1.1.2, 00:17:19, Serial3/0
D     40.0.0.0/8 [90/2172416] via 4.4.4.1, 00:17:19, Serial3/3




The above output you can see that the router R1 installed both routes in the routing table as it is using both the routes to reach the network 30.1.1.1.



R1#show  ip eigrp topology
EIGRP-IPv4 Topology Table for AS(100)/ID(10.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 2.0.0.0/8, 1 successors, FD is 2681856
        via 1.1.1.2 (2681856/2169856), Serial3/0
P 4.0.0.0/8, 1 successors, FD is 2169856
        via Connected, Serial3/3
P 10.0.0.0/8, 1 successors, FD is 28160
        via Connected, FastEthernet0/0
P 30.0.0.0/8, 2 successors, FD is 2684416
        via 1.1.1.2 (2684416/2172416), Serial3/0
        via 4.4.4.1 (2684416/2172416), Serial3/3
P 3.0.0.0/8, 1 successors, FD is 2681856
        via 4.4.4.1 (2681856/2169856), Serial3/3
P 40.0.0.0/8, 1 successors, FD is 2172416
        via 4.4.4.1 (2172416/28160), Serial3/3
P 1.0.0.0/8, 1 successors, FD is 2169856
        via Connected, Serial3/0
P 20.0.0.0/8, 1 successors, FD is 2172416
        via 1.1.1.2 (2172416/28160), Serial3/0

R1#traceroute 30.1.1.1
Type escape sequence to abort.
Tracing the route to 30.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 1.1.1.2 76 msec
    4.4.4.1 112 msec
    1.1.1.2 52 msec
  2 3.3.3.1 100 msec
    2.2.2.2 68 msec
    3.3.3.1 48 msec

now R1 is doing equal cost load balancing vea R2 and R4 because both the routes are having equal cost to reach network 30.1.1.1




 configuring unequal cost load balancing :

Same Topology 

 
Goal:
  • configure the bandwidth of the WAN link serial 3/0 as 1000kbps between R1- R2. this make both routes unequal and we can implement and verify unequal cost load balancing
  • configure on R1 variance to do unequal cost load balancing to 30.0.0.0 network, via R2 and R4.



R1(config)#interface serial 3/0
R1(config-if)#bandwidth 1000

R2(config)#interface serial 3/0
R2(config-if)#bandwidth 1000

R1#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

D     2.0.0.0/8 [90/3193856] via 4.4.4.1, 00:01:55, Serial3/3
D     3.0.0.0/8 [90/2681856] via 4.4.4.1, 00:01:56, Serial3/3
D     20.0.0.0/8 [90/3074560] via 1.1.1.2, 00:01:55, Serial3/0
D     30.0.0.0/8 [90/2684416] via 4.4.4.1, 00:01:56, Serial3/3
D     40.0.0.0/8 [90/2172416] via 4.4.4.1, 00:01:29, Serial 3/3


from the above output  you can see there is only one path to reach 30.0.0.0 network via 4.4.4.1 



configure variance on R1:
 the routes which is going for unequal cost load balancing should satisfy the condition 

cost of current successor x variance > cost of the other routes to be used for load balancing 

R1#show  ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "eigrp 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 Protocol for AS(100)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 10.1.1.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hop count 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    1.0.0.0
    4.0.0.0
    10.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    1.1.1.2               90      00:09:32
    4.4.4.1               90      00:09:32
  Distance: internal 90 external 170

R1(config)#router eigrp 100
R1(config-router)#variance 2

R1#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "eigrp 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 Protocol for AS(100)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 10.1.1.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hop count 100
      Maximum metric variance 2

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    1.0.0.0
    4.0.0.0
    10.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    1.1.1.2               90      00:01:36
    4.4.4.1               90      00:01:36
  Distance: internal 90 external 170

R1#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

D     2.0.0.0/8 [90/3193856] via 4.4.4.1, 00:02:21, Serial3/3
                [90/3584000] via 1.1.1.2, 00:02:21, Serial3/0
D     3.0.0.0/8 [90/2681856] via 4.4.4.1, 00:02:21, Serial3/3
D     20.0.0.0/8 [90/3196416] via 4.4.4.1, 00:02:21, Serial3/3
                 [90/3074560] via 1.1.1.2, 00:02:21, Serial3/0
D     30.0.0.0/8 [90/2684416] via 4.4.4.1, 00:02:21, Serial3/3
                 [90/3586560] via 1.1.1.2, 00:02:21, Serial3/0
D     40.0.0.0/8 [90/2172416] via 4.4.4.1, 00:02:21, Serial3/3



As can see R1 is doing unequal cost load balancing for all the possible routes which satisfy the condition.


R1#traceroute 30.1.1.1
Type escape sequence to abort.
Tracing the route to 30.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 4.4.4.1 20 msec 40 msec
    1.1.1.2 52 msec
  2 2.2.2.2 48 msec 60 msec
    3.3.3.1 72 msec












 


 


Instagram

Facebook


Twitter



LINKEDIN








No comments:

What is Virtual Router Redundancy Protocol (VRRP)? How to configure Virtual Router Redundancy Protocol (VRRP)?

 Virtual Router Redundancy Protocol (VRRP) is a gateway redundancy networking protocol used to create a virtual gateway similar to HSRP . VR...