Tuesday 29 January 2019

BGP Confederations and configuration


BGP Confederations

In this section, we’ll talk about the BGP Confederation. You might know, IBGP requires a full mesh of peering which can become administrative overhead. If you don’t know why we need a full mesh, I advise taking a look BGP peers first.

 IBGP full mash issues

  • With iBGP, every router in the BGP autonomous system must fully mesh.
  • A large number of TCP sessions
  • Unnecessary duplicate of routing traffic
  • Manual configuration






Solution

1.Route reflector
2.BGP confederations

A BGP confederation divides AS into sub-ASes to reduce the number of required IBGP peering's. in other words, BGP Confederations Feature is used to split an autonomous system into smaller autonomous systems.

Confederations are usable only for huge autonomous systems where you can afford to split them into several sub-ASes. Each sub-as in a confederation needs to have its internal iBGP peers either fully meshed or use a route reflector internally. The confederations are not much of an advantage for small ASes having a few BGP routers.

let's see the configuration for a better understanding.








Topology:




Goal:
  • configure the topology as per the diagram and assign the IP addresses.
  • configure iBGP and EBGP configuration.
  • configure BGP peerings using BGP Confederations.




R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        10.1.1.1        YES manual up                    up
Serial3/0                    1.1.1.1         YES manual up                    up
Serial3/5                    6.1.1.2         YES manual up                    up
Loopback0               11.0.0.1        YES manual up                    up



R2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        20.1.1.1        YES manual up                    up
Serial3/0                    1.1.1.2         YES manual up                    up
Serial3/1                    2.1.1.1         YES manual up                    up
Loopback0               12.0.0.1        YES manual up                    up



R3#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        30.1.1.1        YES manual up                    down
Serial3/1                    2.1.1.2         YES manual up                    up
Serial3/2                    3.1.1.1         YES manual up                    up
Loopback0               13.0.0.1        YES manual up                    up


R4#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        40.1.1.1        YES manual up                    up
Serial3/2                    3.1.1.2         YES manual up                    up
Serial3/3                    4.1.1.1         YES manual up                    up
Loopback0              14.0.0.1        YES manual up                    up



R5#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        50.1.1.1        YES manual up                    up
Serial3/3                    4.1.1.2         YES manual up                    up
Serial3/4                    5.1.1.1         YES manual up                    up
Loopback0              15.0.0.1        YES manual up                    up



R6#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        30.1.1.2        YES manual up                    up
Serial3/4                     5.1.1.2         YES manual up                    up
Serial3/5                    6.1.1.1         YES manual up                    up
Loopback0              16.0.0.1        YES manual up                    up



R1(config)#router bgp 650012
R1(config-router)#neighbor 6.1.1.1 remote-as 650006
R1(config-router)#neighbor 1.1.1.2 remote-as 650012
R1(config-router)#network 10.0.0.0
R1(config-router)#network 1.0.0.0
R1(config-router)#network 6.0.0.0
R1(config-router)#network 11.0.0.0 mask 255.255.255.0
R1(config-router)#no auto-summary
R1(config-router)#no synchronization
R1(config-router)#exit

R2(config)#router bgp 650012
R2(config-router)#neighbor 1.1.1.1 remote-as 650012
R2(config-router)#neighbor 2.1.1.2 remote-as 650345
R2(config-router)#network 1.0.0.0
R2(config-router)#network 2.0.0.0
R2(config-router)#network 20.0.0.0
R2(config-router)#network 12.0.0.0 mask 255.255.255.0
R2(config-router)#no auto-summary
R2(config-router)#no synchronization
R2(config-router)#exit



R3(config)#router bgp 650034
R3(config-router)#bgp confederation identifier 650345
R3(config-router)#neighbor 2.1.1.1 remote-as 650012
R3(config-router)#neighbor 3.1.1.2 remote-as 650034
R3(config-router)#network 30.0.0.0
R3(config-router)#network 3.0.0.0
R3(config-router)#network 2.0.0.0
R3(config-router)#network 13.0.0.0 mask 255.255.255.0
R3(config-router)#no auto-summary
R3(config-router)#no synchronization
R3(config-router)#exit



R4(config)#router bgp 650034
R4(config-router)#bgp confederation identifier 650345
R4(config-router)#bgp confederation peers 650005
R4(config-router)#neighbor 3.1.1.1 remote-as 650034
R4(config-router)#neighbor 4.1.1.2 remote-as 650005
R4(config-router)#network 40.0.0.0
R4(config-router)#network 4.0.0.0
R4(config-router)#network 3.0.0.0
R4(config-router)#network 14.0.0.0 mask 255.255.255.0
R4(config-router)#no synchronization
R4(config-router)#no auto-summary
R4(config-router)#exit


R5(config-if)#router bgp 650005
R5(config-router)#bgp confederation identifier 650345
R5(config-router)#bgp confederation peers 650034
R5(config-router)#neighbor 4.1.1.1 remote-as 650034
R5(config-router)#neighbor 5.1.1.2 remote-as 650006
R5(config-router)#network 50.0.0.0
R5(config-router)#network 5.0.0.0
R5(config-router)#network 4.0.0.0
R5(config-router)#network 15.0.0.0 mask 255.255.255.0
R5(config-router)#no auto-summary
R5(config-router)#no synchronization
R5(config-router)#exit


R6(config-if)#router bgp 650006
R6(config-router)#neighbor 5.1.1.1 remote-as 650345
R6(config-router)#neighbor 6.1.1.2 remote-as 650012
R6(config-router)#network 6.0.0.0
R6(config-router)#network 5.0.0.0
R6(config-router)#network 60.0.0.0
R6(config-router)#network 16.0.0.0 mask 255.255.255.0
R6(config-router)#no synchronization
R6(config-router)#no auto-summary
R6(config-router)#exit

R1#show ip bgp summary
BGP router identifier 11.0.0.1, local AS number 650012
BGP table version is 27, main routing table version 27
16 network entries using 2304 bytes of memory
26 path entries using 2080 bytes of memory
5/4 BGP path/bestpath attribute entries using 680 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 5136 total bytes of memory
BGP activity 21/5 prefixes, 31/5 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.2         4       650012      94      87       27    0    0 01:13:02       12
6.1.1.1         4       650006      31      31       27    0    0 00:21:31       10


R1#show ip bgp
BGP table version is 27, local router ID is 11.0.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 * i 1.0.0.0          1.1.1.2                  0    100      0 i
 *>                   0.0.0.0                  0         32768 i
 *>i 2.0.0.0          1.1.1.2                  0    100      0 i
 *   3.0.0.0          6.1.1.1                                0 650006 650345 i
 *>i                  2.1.1.2                  0    100      0 650345 i
 *   4.0.0.0          6.1.1.1                                0 650006 650345 i
 *>i                  2.1.1.2                  0    100      0 650345 i
 * i 5.0.0.0          2.1.1.2                  0    100      0 650345 i
 *>                   6.1.1.1                  0             0 650006 i
 *   6.0.0.0          6.1.1.1                  0             0 650006 i
 *>                   0.0.0.0                  0         32768 i
 *>  10.0.0.0         0.0.0.0                  0         32768 i
 *>  11.0.0.0/24      0.0.0.0                  0         32768 i
 *>i 12.0.0.0/24      1.1.1.2                  0    100      0 i
     Network          Next Hop            Metric LocPrf Weight Path
 *   13.0.0.0/24      6.1.1.1                                0 650006 650345 i
 *>i                  2.1.1.2                  0    100      0 650345 i
 *   14.0.0.0/24      6.1.1.1                                0 650006 650345 i
 *>i                  2.1.1.2                  0    100      0 650345 i
 *   15.0.0.0/24      6.1.1.1                                0 650006 650345 i
 *>i                  2.1.1.2                  0    100      0 650345 i
 *>  16.0.0.0/24      6.1.1.1                  0             0 650006 i
 *>i 20.0.0.0         1.1.1.2                  0    100      0 i
 *   40.0.0.0         6.1.1.1                                0 650006 650345 i
 *>i                  2.1.1.2                  0    100      0 650345 i
 *   50.0.0.0         6.1.1.1                                0 650006 650345 i
 *>i                  2.1.1.2                  0    100      0 650345 i

R1#show ip route bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override


Gateway of last resort is not set

B     2.0.0.0/8 [200/0] via 1.1.1.2, 00:05:53
B     3.0.0.0/8 [200/0] via 2.1.1.2, 00:05:53
B     4.0.0.0/8 [200/0] via 2.1.1.2, 00:05:53
B     5.0.0.0/8 [20/0] via 6.1.1.1, 00:05:53
      12.0.0.0/24 is subnetted, 1 subnets
B        12.0.0.0 [200/0] via 1.1.1.2, 00:05:53
      13.0.0.0/24 is subnetted, 1 subnets
B        13.0.0.0 [200/0] via 2.1.1.2, 00:05:53
      14.0.0.0/24 is subnetted, 1 subnets
B        14.0.0.0 [200/0] via 2.1.1.2, 00:05:53
      15.0.0.0/24 is subnetted, 1 subnets
B        15.0.0.0 [200/0] via 2.1.1.2, 00:05:53
      16.0.0.0/24 is subnetted, 1 subnets
B        16.0.0.0 [20/0] via 6.1.1.1, 00:05:53
B     20.0.0.0/8 [200/0] via 1.1.1.2, 00:05:53
B     40.0.0.0/8 [200/0] via 2.1.1.2, 00:05:53
B     50.0.0.0/8 [200/0] via 2.1.1.2, 00:05:53


R2#show ip bgp summary
BGP router identifier 12.0.0.1, local AS number 650012
BGP table version is 29, main routing table version 29
16 network entries using 2304 bytes of memory
20 path entries using 1600 bytes of memory
6/5 BGP path/bestpath attribute entries using 816 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 4792 total bytes of memory
BGP activity 21/5 prefixes, 26/6 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.1         4       650012      93      99       29    0    0 01:17:42        6
2.1.1.2         4       650345      66      64       29    0    0 00:52:03       10
R2#show ip bgp
BGP table version is 29, local router ID is 12.0.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  1.0.0.0          0.0.0.0                  0         32768 i
 * i                  1.1.1.1                  0    100      0 i
 *   2.0.0.0          2.1.1.2                  0             0 650345 i
 *>                   0.0.0.0                  0         32768 i
 *>  3.0.0.0          2.1.1.2                  0             0 650345 i
 *>  4.0.0.0          2.1.1.2                                0 650345 i
 *>  5.0.0.0          2.1.1.2                                0 650345 i
 * i                  6.1.1.1                  0    100      0 650006 i
 *>i 6.0.0.0          1.1.1.1                  0    100      0 i
 *>i 10.0.0.0         1.1.1.1                  0    100      0 i
 *>i 11.0.0.0/24      1.1.1.1                  0    100      0 i
 *>  12.0.0.0/24      0.0.0.0                  0         32768 i
 *>  13.0.0.0/24      2.1.1.2                  0             0 650345 i
 *>  14.0.0.0/24      2.1.1.2                                0 650345 i
     Network          Next Hop            Metric LocPrf Weight Path
 *>  15.0.0.0/24      2.1.1.2                                0 650345 i
 *   16.0.0.0/24      2.1.1.2                                0 650345 650006 i
 *>i                  6.1.1.1                  0    100      0 650006 i
 *>  20.0.0.0         0.0.0.0                  0         32768 i
 *>  40.0.0.0         2.1.1.2                                0 650345 i
 *>  50.0.0.0         2.1.1.2                                0 650345 i
R2#show ip route bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set


B     3.0.0.0/8 [20/0] via 2.1.1.2, 00:51:53
B     4.0.0.0/8 [20/0] via 2.1.1.2, 00:25:12
B     5.0.0.0/8 [20/0] via 2.1.1.2, 00:23:17
B     6.0.0.0/8 [200/0] via 1.1.1.1, 00:26:36
B     10.0.0.0/8 [200/0] via 1.1.1.1, 01:18:02
      11.0.0.0/24 is subnetted, 1 subnets
B        11.0.0.0 [200/0] via 1.1.1.1, 01:18:02
      13.0.0.0/24 is subnetted, 1 subnets
B        13.0.0.0 [20/0] via 2.1.1.2, 00:51:53
      14.0.0.0/24 is subnetted, 1 subnets
B        14.0.0.0 [20/0] via 2.1.1.2, 00:49:06
      15.0.0.0/24 is subnetted, 1 subnets
B        15.0.0.0 [20/0] via 2.1.1.2, 00:24:42
      16.0.0.0/24 is subnetted, 1 subnets
B        16.0.0.0 [200/0] via 6.1.1.1, 00:26:32
B     40.0.0.0/8 [20/0] via 2.1.1.2, 00:49:35
B     50.0.0.0/8 [20/0] via 2.1.1.2, 00:24:42


R3#show ip bgp summary
BGP router identifier 13.0.0.1, local AS number 650034
BGP table version is 36, main routing table version 36
16 network entries using 2304 bytes of memory
19 path entries using 1520 bytes of memory
7/6 BGP path/bestpath attribute entries using 952 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 4872 total bytes of memory
BGP activity 18/2 prefixes, 28/9 paths, scan interval 60 secs


Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.1.1.1         4       650012      67      68       36    0    0 00:54:26        8
3.1.1.2         4       650034      68      68       36    0    0 00:52:06        8
R3#show ip bgp
BGP table version is 36, local router ID is 13.0.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found


     Network          Next Hop            Metric LocPrf Weight Path
 *>  1.0.0.0          2.1.1.1                  0             0 650012 i
 *>  2.0.0.0          0.0.0.0                  0         32768 i
 *                    2.1.1.1                  0             0 650012 i
 * i 3.0.0.0          3.1.1.2                  0    100      0 i
 *>                   0.0.0.0                  0         32768 i
 *>i 4.0.0.0          3.1.1.2                  0    100      0 i
 *>i 5.0.0.0          4.1.1.2                  0    100      0 (650005) i
 *>  6.0.0.0          2.1.1.1                                0 650012 i
 *>  10.0.0.0         2.1.1.1                                0 650012 i
 *>  11.0.0.0/24      2.1.1.1                                0 650012 i
 *>  12.0.0.0/24      2.1.1.1                  0             0 650012 i
 *>  13.0.0.0/24      0.0.0.0                  0         32768 i
 *>i 14.0.0.0/24      3.1.1.2                  0    100      0 i
 *>i 15.0.0.0/24      4.1.1.2                  0    100      0 (650005) i
     Network          Next Hop            Metric LocPrf Weight Path
 *>i 16.0.0.0/24      5.1.1.2                  0    100      0 (650005) 650006 i
 *                    2.1.1.1                                0 650012 650006 i
 *>  20.0.0.0         2.1.1.1                  0             0 650012 i
 *>i 40.0.0.0         3.1.1.2                  0    100      0 i
 *>i 50.0.0.0         4.1.1.2                  0    100      0 (650005) i
R3#show ip route bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

B     1.0.0.0/8 [20/0] via 2.1.1.1, 00:12:49
B     4.0.0.0/8 [200/0] via 3.1.1.2, 00:12:49
B     5.0.0.0/8 [200/0] via 4.1.1.2, 00:12:49
B     6.0.0.0/8 [20/0] via 2.1.1.1, 00:12:49
B     10.0.0.0/8 [20/0] via 2.1.1.1, 00:12:49
      11.0.0.0/24 is subnetted, 1 subnets
B        11.0.0.0 [20/0] via 2.1.1.1, 00:12:49
      12.0.0.0/24 is subnetted, 1 subnets
B        12.0.0.0 [20/0] via 2.1.1.1, 00:12:49
      14.0.0.0/24 is subnetted, 1 subnets
B        14.0.0.0 [200/0] via 3.1.1.2, 00:12:49
      15.0.0.0/24 is subnetted, 1 subnets
B        15.0.0.0 [200/0] via 4.1.1.2, 00:12:49
      16.0.0.0/24 is subnetted, 1 subnets
B        16.0.0.0 [200/0] via 5.1.1.2, 00:12:49
B     20.0.0.0/8 [20/0] via 2.1.1.1, 00:12:49
B     40.0.0.0/8 [200/0] via 3.1.1.2, 00:12:49
B     50.0.0.0/8 [200/0] via 4.1.1.2, 00:12:49



R4#show ip bgp summary
BGP router identifier 14.0.0.1, local AS number 650034
BGP table version is 24, main routing table version 24
16 network entries using 2304 bytes of memory
19 path entries using 1520 bytes of memory
5/5 BGP path/bestpath attribute entries using 680 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 4576 total bytes of memory
BGP activity 18/2 prefixes, 23/4 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
3.1.1.1         4       650034      70      70       24    0    0 00:54:01        9
4.1.1.2         4       650005      38      41       24    0    0 00:29:05        6
R4#show ip bgp
BGP table version is 24, local router ID is 14.0.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found


     Network          Next Hop            Metric LocPrf Weight Path
 *>i 1.0.0.0          2.1.1.1                  0    100      0 650012 i
 *>i 2.0.0.0          3.1.1.1                  0    100      0 i
 *>  3.0.0.0          0.0.0.0                  0         32768 i
 * i                  3.1.1.1                  0    100      0 i
 *   4.0.0.0          4.1.1.2                  0    100      0 (650005) i
 *>                   0.0.0.0                  0         32768 i
 *>  5.0.0.0          4.1.1.2                  0    100      0 (650005) i
 *   6.0.0.0          5.1.1.2                  0    100      0 (650005) 650006 i
 *>i                  2.1.1.1                  0    100      0 650012 i
 *>i 10.0.0.0         2.1.1.1                  0    100      0 650012 i
 *>i 11.0.0.0/24      2.1.1.1                  0    100      0 650012 i
 *>i 12.0.0.0/24      2.1.1.1                  0    100      0 650012 i
 *>i 13.0.0.0/24      3.1.1.1                  0    100      0 i
 *>  14.0.0.0/24      0.0.0.0                  0         32768 i
     Network          Next Hop            Metric LocPrf Weight Path
 *>  15.0.0.0/24      4.1.1.2                  0    100      0 (650005) i
 *>  16.0.0.0/24      5.1.1.2                  0    100      0 (650005) 650006 i
 *>i 20.0.0.0         2.1.1.1                  0    100      0 650012 i
 *>  40.0.0.0         0.0.0.0                  0         32768 i
 *>  50.0.0.0         4.1.1.2                  0    100      0 (650005) i
R4#show ip route bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set


B     1.0.0.0/8 [200/0] via 2.1.1.1, 00:54:11
B     2.0.0.0/8 [200/0] via 3.1.1.1, 00:54:16
B     5.0.0.0/8 [200/0] via 4.1.1.2, 00:27:48
B     6.0.0.0/8 [200/0] via 2.1.1.1, 00:30:49
B     10.0.0.0/8 [200/0] via 2.1.1.1, 00:54:11
      11.0.0.0/24 is subnetted, 1 subnets
B        11.0.0.0 [200/0] via 2.1.1.1, 00:54:11
      12.0.0.0/24 is subnetted, 1 subnets
B        12.0.0.0 [200/0] via 2.1.1.1, 00:54:11
      13.0.0.0/24 is subnetted, 1 subnets
B        13.0.0.0 [200/0] via 3.1.1.1, 00:54:16
      15.0.0.0/24 is subnetted, 1 subnets
B        15.0.0.0 [200/0] via 4.1.1.2, 00:29:20
      16.0.0.0/24 is subnetted, 1 subnets
B        16.0.0.0 [200/0] via 5.1.1.2, 00:27:48
B     20.0.0.0/8 [200/0] via 2.1.1.1, 00:54:11
B     50.0.0.0/8 [200/0] via 4.1.1.2, 00:29:20


R5#show ip bgp summary
BGP router identifier 15.0.0.1, local AS number 650005
BGP table version is 19, main routing table version 19
16 network entries using 2304 bytes of memory
25 path entries using 2000 bytes of memory
5/4 BGP path/bestpath attribute entries using 680 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 5080 total bytes of memory
BGP activity 16/0 prefixes, 27/2 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
4.1.1.1         4       650034      42      39       19    0    0 00:30:22       12
5.1.1.2         4       650006      43      40       19    0    0 00:28:59        9
R5#show ip bgp
BGP table version is 19, local router ID is 15.0.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found


     Network          Next Hop            Metric LocPrf Weight Path
 *   1.0.0.0          5.1.1.2                                0 650006 650012 i
 *>                   2.1.1.1                  0    100      0 (650034) 650012 i
 *   2.0.0.0          5.1.1.2                                0 650006 650012 i
 *>                   3.1.1.1                  0    100      0 (650034) i
 *>  3.0.0.0          4.1.1.1                  0    100      0 (650034) i
 *   4.0.0.0          4.1.1.1                  0    100      0 (650034) i
 *>                   0.0.0.0                  0         32768 i
 *   5.0.0.0          5.1.1.2                  0             0 650006 i
 *>                   0.0.0.0                  0         32768 i
 *>  6.0.0.0          5.1.1.2                  0             0 650006 i
 *                    2.1.1.1                  0    100      0 (650034) 650012 i
 *   10.0.0.0         5.1.1.2                                0 650006 650012 i
 *>                   2.1.1.1                  0    100      0 (650034) 650012 i
 *   11.0.0.0/24      5.1.1.2                                0 650006 650012 i
     Network          Next Hop            Metric LocPrf Weight Path
 *>                   2.1.1.1                  0    100      0 (650034) 650012 i
 *   12.0.0.0/24      5.1.1.2                                0 650006 650012 i
 *>                   2.1.1.1                  0    100      0 (650034) 650012 i
 *>  13.0.0.0/24      3.1.1.1                  0    100      0 (650034) i
 *>  14.0.0.0/24      4.1.1.1                  0    100      0 (650034) i
 *>  15.0.0.0/24      0.0.0.0                  0         32768 i
 *>  16.0.0.0/24      5.1.1.2                  0             0 650006 i
 *   20.0.0.0         5.1.1.2                                0 650006 650012 i
 *>                   2.1.1.1                  0    100      0 (650034) 650012 i
 *>  40.0.0.0         4.1.1.1                  0    100      0 (650034) i
 *>  50.0.0.0         0.0.0.0                  0         32768 i
R5#show ip route bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set


B     1.0.0.0/8 [200/0] via 2.1.1.1, 00:30:06
B     2.0.0.0/8 [200/0] via 3.1.1.1, 00:30:34
B     3.0.0.0/8 [200/0] via 4.1.1.1, 00:30:39
B     6.0.0.0/8 [20/0] via 5.1.1.2, 00:29:16
B     10.0.0.0/8 [200/0] via 2.1.1.1, 00:30:06
      11.0.0.0/24 is subnetted, 1 subnets
B        11.0.0.0 [200/0] via 2.1.1.1, 00:30:06
      12.0.0.0/24 is subnetted, 1 subnets
B        12.0.0.0 [200/0] via 2.1.1.1, 00:30:06
      13.0.0.0/24 is subnetted, 1 subnets
B        13.0.0.0 [200/0] via 3.1.1.1, 00:30:34
      14.0.0.0/24 is subnetted, 1 subnets
B        14.0.0.0 [200/0] via 4.1.1.1, 00:30:39
      16.0.0.0/24 is subnetted, 1 subnets
B        16.0.0.0 [20/0] via 5.1.1.2, 00:29:16
B     20.0.0.0/8 [200/0] via 2.1.1.1, 00:30:06
B     40.0.0.0/8 [200/0] via 4.1.1.1, 00:30:39

R6#show ip bgp summary
BGP router identifier 16.0.0.1, local AS number 650006
BGP table version is 28, main routing table version 28
16 network entries using 2304 bytes of memory
31 path entries using 2480 bytes of memory
7/5 BGP path/bestpath attribute entries using 952 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 5832 total bytes of memory
BGP activity 18/2 prefixes, 34/3 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
5.1.1.1         4       650345      42      44       28    0    0 00:30:06       14
6.1.1.2         4       650012      44      43       28    0    0 00:32:55       14
R6#show ip bgp
BGP table version is 28, local router ID is 16.0.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found


     Network          Next Hop            Metric LocPrf Weight Path
 *   1.0.0.0          5.1.1.1                                0 650345 650012 i
 *>                   6.1.1.2                  0             0 650012 i
 *   2.0.0.0          5.1.1.1                                0 650345 i
 *>                   6.1.1.2                                0 650012 i
 *>  3.0.0.0          5.1.1.1                                0 650345 i
 *                    6.1.1.2                                0 650012 650345 i
 *>  4.0.0.0          5.1.1.1                  0             0 650345 i
 *                    6.1.1.2                                0 650012 650345 i
 *   5.0.0.0          5.1.1.1                  0             0 650345 i
 *>                   0.0.0.0                  0         32768 i
 *   6.0.0.0          6.1.1.2                  0             0 650012 i
 *>                   0.0.0.0                  0         32768 i
 *   10.0.0.0         5.1.1.1                                0 650345 650012 i
 *>                   6.1.1.2                  0             0 650012 i
     Network          Next Hop            Metric LocPrf Weight Path
 *   11.0.0.0/24      5.1.1.1                                0 650345 650012 i
 *>                   6.1.1.2                  0             0 650012 i
 *   12.0.0.0/24      5.1.1.1                                0 650345 650012 i
 *>                   6.1.1.2                                0 650012 i
 *>  13.0.0.0/24      5.1.1.1                                0 650345 i
 *                    6.1.1.2                                0 650012 650345 i
 *>  14.0.0.0/24      5.1.1.1                                0 650345 i
 *                    6.1.1.2                                0 650012 650345 i
 *>  15.0.0.0/24      5.1.1.1                  0             0 650345 i
 *                    6.1.1.2                                0 650012 650345 i
 *>  16.0.0.0/24      0.0.0.0                  0         32768 i
 *   20.0.0.0         5.1.1.1                                0 650345 650012 i
 *>                   6.1.1.2                                0 650012 i
 *>  40.0.0.0         5.1.1.1                                0 650345 i
 *                    6.1.1.2                                0 650012 650345 i
 *>  50.0.0.0         5.1.1.1                  0             0 650345 i
 *                    6.1.1.2                                0 650012 650345 i
R6#show ip route bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

B     1.0.0.0/8 [20/0] via 6.1.1.2, 00:33:10
B     2.0.0.0/8 [20/0] via 6.1.1.2, 00:33:10
B     3.0.0.0/8 [20/0] via 5.1.1.1, 00:30:21
B     4.0.0.0/8 [20/0] via 5.1.1.1, 00:30:21
B     10.0.0.0/8 [20/0] via 6.1.1.2, 00:33:10
      11.0.0.0/24 is subnetted, 1 subnets
B        11.0.0.0 [20/0] via 6.1.1.2, 00:33:10
      12.0.0.0/24 is subnetted, 1 subnets
B        12.0.0.0 [20/0] via 6.1.1.2, 00:33:10
      13.0.0.0/24 is subnetted, 1 subnets
B        13.0.0.0 [20/0] via 5.1.1.1, 00:30:21
      14.0.0.0/24 is subnetted, 1 subnets
B        14.0.0.0 [20/0] via 5.1.1.1, 00:30:21
      15.0.0.0/24 is subnetted, 1 subnets
B        15.0.0.0 [20/0] via 5.1.1.1, 00:30:21
B     20.0.0.0/8 [20/0] via 6.1.1.2, 00:33:10
B     40.0.0.0/8 [20/0] via 5.1.1.1, 00:30:21
B     50.0.0.0/8 [20/0] via 5.1.1.1, 00:30:21


(in the next session we will see BGP community local-AS with confederation. if you do not know about BGP community local_AS please click here)



Please follow us:-



Ask the question on QUORA: https://internetworks.quora.com/










 


 


Instagram

Facebook


Twitter



LINKEDIN








1 comment:

Unknown said...

The King Casino - Ventureberg
The King Casino is owned by British casino operator 출장안마 Crown Resorts gri-go.com and operated ventureberg.com/ by Crown Resorts. septcasino It is owned by British ADDRESS: 출장안마 CASTLE

What is Virtual Router Redundancy Protocol (VRRP)? How to configure Virtual Router Redundancy Protocol (VRRP)?

 Virtual Router Redundancy Protocol (VRRP) is a gateway redundancy networking protocol used to create a virtual gateway similar to HSRP . VR...