Saturday 8 December 2018

PPP Multilinks



Sometimes you notice a network design where you have more than one serial link between two routers.  A single serial link doesn’t provide enough bandwidth or maybe in case you want some extra redundancy. All the interfaces on a router need a different IP address, a design that looks like this:



Multilink PPP allows us to make a combination of multiple physical serial links into a single logical link or MLP bundle. MLP is used to aggregate multiple WAN links into one logical channel for the transportation of traffic from one router to another, MLP enable the load—balancing of traffic from different links  as we and allows some level of redundancy in case of line failure on a single link.MLP Supports a maximum of ten member links per bundle or single logical link. 



lets take a look of its configuration:


Multilink point-to-point protocol configuration :-

Topology:


Goal:
  • configure the topology as per the diagram, we are using serial range 3/0 to 3/5.
  • configure single logical link, group number 1
  • configure channel ip address 192.168.1.0/24 
  • Configure EIGRP 65100 to reach fastethernet 10.1.1.1, 20.1.1.1


R1(config)#interface multilink 1


R1(config-if)#ppp multilink group 1
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#exit

R1(config)#interface serial 3/0
R1(config-if)#no ip address
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink
R1(config-if)#ppp multilink group 1
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 3/1
R1(config-if)#no ip address
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink group 1
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#

R1(config)#interface serial 3/2
R1(config-if)#no ip address
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink group 1
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 3/3
R1(config-if)#no ip address
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink group 1
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 3/4
R1(config-if)#no ip address
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink group 1
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface serial 3/5
R1(config-if)#no ip address
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink group 1
R1(config-if)#no shutdown
R1(config-if)#exit



R2(config)#interface multilink 1
R2(config-if)#ppp multilink group 1
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#interface serial 3/5
R2(config-if)#  no ip address
R2(config-if)#  encapsulation ppp
R2(config-if)#  ppp multilink group 1
R2(config-if)#  no shutdown
R2(config-if)#  exit

R2(config)#interface serial 3/4
R2(config-if)#  no ip address
R2(config-if)#  encapsulation ppp
R2(config-if)#  ppp multilink group 1
R2(config-if)#  no shutdown
R2(config-if)#  exit

R2(config)#interface serial 3/3
R2(config-if)#  no ip address
R2(config-if)#  encapsulation ppp
R2(config-if)#  ppp multilink group 1
R2(config-if)#  no shutdown
R2(config-if)#  exit

R2(config)#interface serial 3/3
R2(config-if)#  no ip address
R2(config-if)#  encapsulation ppp
R2(config-if)#  ppp multilink group 1
R2(config-if)#  no shutdown
R2(config-if)#  exit

R2(config)#interface serial 3/2
R2(config-if)#  no ip address
R2(config-if)#  encapsulation ppp
R2(config-if)#  ppp multilink group 1
R2(config-if)#  no shutdown
R2(config-if)#  no ip address
R2(config-if)#  exit

R2(config)#interface serial 3/1
R2(config-if)#  no ip address
R2(config-if)#  encapsulation ppp
R2(config-if)#  ppp multilink group 1
R2(config-if)#  no shutdown
R2(config-if)#  exit

R2(config)#interface serial 3/0
R2(config-if)#  no ip address
R2(config-if)#  encapsulation ppp
R2(config-if)#  ppp multilink group 1
R2(config-if)#  no shutdown
R2(config-if)#  no ip address
R2(config-if)#  exit

R1#show ip interface brief
Interface              IP-Address      OK? Method Status           Protocol
FastEthernet0/0    10.1.1.1        YES manual up                    up
Serial3/0              unassigned      YES unset  up                    up
Serial3/1              unassigned      YES unset  up                    up
Serial3/2              unassigned      YES unset  up                    up
Serial3/3              unassigned      YES unset  up                    up
Serial3/4              unassigned      YES unset  up                    up
Serial3/5              unassigned      YES unset  up                    up
Multilink1         192.168.1.1     YES manual up                    up


R2#show ip interface brief
Interface              IP-Address      OK? Method Status           Protocol
FastEthernet0/0    20.1.1.1        YES manual up                    up
Serial3/0              unassigned      YES unset  up                    up
Serial3/1              unassigned      YES unset  up                    up
Serial3/2              unassigned      YES unset  up                    up
Serial3/3              unassigned      YES unset  up                    up
Serial3/4              unassigned      YES unset  up                    up
Serial3/5              unassigned      YES unset  up                    up
Multilink1         192.168.1.2     YES manual up                    up

R1(config)#router eigrp 65100
R1(config-router)#network 10.0.0.0
R1(config-router)#network 192.168.1.0
R1(config-router)#no auto-summary
R1(config-router)#exit

R2(config)#router eigrp 65100
R2(config-router)#network 20.0.0.0
R2(config-router)#network 192.168.1.0
R2(config-router)#no auto-summary
R2(config-router)#exit

R1#show run interface multilink 1
Building configuration...

Current configuration : 104 bytes
!
interface Multilink1
 ip address 192.168.1.1 255.255.255.0
 ppp multilink
 ppp multilink group 1
end

R2#show run interface multilink 1
Building configuration...

Current configuration : 104 bytes
!
interface Multilink1
 ip address 192.168.1.2 255.255.255.0
 ppp multilink
 ppp multilink group 1
end

R1#show interfaces  multilink 1
Multilink1 is up, line protocol is up
  Hardware is multilink group interface
  Internet address is 192.168.1.1/24
  MTU 1500 bytes, BW 9264 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open, multilink Open

R2#show interfaces multilink 1
Multilink1 is up, line protocol is up
  Hardware is multilink group interface
  Internet address is 192.168.1.2/24
  MTU 1500 bytes, BW 9264 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open, multilink Open

R1#show interfaces  multilink 1 | include line protocol
Multilink1 is up, line protocol is up

R2#show interfaces  multilink 1 | include line protocol
Multilink1 is up, line protocol is up

R1#show ppp multilink

Multilink1
  Bundle name: R2
  Remote Endpoint Discriminator: [1] R2
  Local Endpoint Discriminator: [1] R1
  Bundle up for 00:31:18, total bandwidth 9264, load 1/255
  Receive buffer limit 72000 bytes, frag timeout 1000 ms
    0/0 fragments/bytes in reassembly list
    0 lost fragments, 93 reordered
    0/0 discarded fragments/bytes, 0 lost received
    0xEA received sequence, 0xF0 sent sequence
  Member links: 6 active, 0 inactive (max 255, min not set)
    Se3/5, since 00:31:18
    Se3/4, since 00:30:51
    Se3/3, since 00:30:25
    Se3/2, since 00:29:29
    Se3/1, since 00:28:55
    Se3/0, since 00:28:27

R2#show ppp multilink

Multilink1
  Bundle name: R1
  Remote Endpoint Discriminator: [1] R1
  Local Endpoint Discriminator: [1] R2
  Bundle up for 00:31:54, total bandwidth 9264, load 1/255
  Receive buffer limit 72000 bytes, frag timeout 1000 ms
    0/0 fragments/bytes in reassembly list
    0 lost fragments, 97 reordered
    0/0 discarded fragments/bytes, 0 lost received
    0xFC received sequence, 0xF5 sent sequence
  Member links: 6 active, 0 inactive (max 255, min not set)
    Se3/5, since 00:31:54
    Se3/4, since 00:31:27
    Se3/3, since 00:31:00
    Se3/2, since 00:30:04
    Se3/1, since 00:29:31
    Se3/0, since 00:29:02

R1#traceroute 20.1.1.1
Type escape sequence to abort.
Tracing the route to 20.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 192.168.1.2 92 msec 40 msec 20 msec

R2#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 192.168.1.1 20 msec 16 msec 20 msec


 


 


Instagram

Facebook


Twitter



LINKEDIN








No comments:

What is Virtual Router Redundancy Protocol (VRRP)? How to configure Virtual Router Redundancy Protocol (VRRP)?

 Virtual Router Redundancy Protocol (VRRP) is a gateway redundancy networking protocol used to create a virtual gateway similar to HSRP . VR...