Tuesday 13 November 2018

Route filtering passive interface RIPv2


Route filtering passive interface

Cisco IOS provides several ways to control updates traffic. Passive interface, distribute list, prefix list route maps. In this section we take look at passive interface in RIPv2, EIGRP, and OSPF.
Passive interface command is used in al routing protocol to disable sending updates out from a specific interface. However the command behavior varies from one protocol to another.

Passive interface in RIPv2

In RIP passive interface command disable sending multicast updates via a specific interface. Allow listening to incoming updates from other RIPv2 speaking routers.

lets see the configure:

Topology:






Goal:
configure the topology as per the diagram
configure RIPv2 and advertise interfaces as per our topology
configure router 3 interface serial 3/1 as passive interface


R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        10.1.1.1        YES manual up                    up
Serial3/0                     1.1.1.1         YES manual up                    up


R2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        20.1.1.1        YES manual up                    up
Serial3/0                     1.1.1.2         YES manual up                    up
Serial3/1                     2.1.1.1         YES manual up                    up


R3#   show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        30.1.1.1        YES manual up                    up
Serial3/1                    2.1.1.2         YES manual up                    up
Loopback0              13.0.0.1        YES manual up                    up
Loopback1              13.0.1.1        YES manual up                    up
Loopback2              13.0.2.1        YES manual up                    up
Loopback3              13.0.3.1        YES manual up                    up

R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 1.0.0.0
R1(config-router)#network 10.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#end

R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 20.0.0.0
R2(config-router)#network 1.0.0.0
R2(config-router)#network 2.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#end

R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#network 13.0.0.0
R3(config-router)#network 2.0.0.0
R3(config-router)#network 30.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#end

R1#show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

R     2.0.0.0/8 [120/1] via 1.1.1.2, 00:00:02, Serial3/0
          13.0.0.0/24 is subnetted, 4 subnets
R        13.0.0.0 [120/2] via 1.1.1.2, 00:00:02, Serial3/0
R        13.0.1.0 [120/2] via 1.1.1.2, 00:00:02, Serial3/0
R        13.0.2.0 [120/2] via 1.1.1.2, 00:00:02, Serial3/0
R        13.0.3.0 [120/2] via 1.1.1.2, 00:00:02, Serial3/0
R     20.0.0.0/8 [120/1] via 1.1.1.2, 00:00:02, Serial3/0
R     30.0.0.0/8 [120/2] via 1.1.1.2, 00:00:02, Serial3/0

R2#show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

R     10.0.0.0/8 [120/1] via 1.1.1.1, 00:00:25, Serial3/0
      13.0.0.0/24 is subnetted, 4 subnets
R        13.0.0.0 [120/1] via 2.1.1.2, 00:00:17, Serial3/1
R        13.0.1.0 [120/1] via 2.1.1.2, 00:00:17, Serial3/1
R        13.0.2.0 [120/1] via 2.1.1.2, 00:00:17, Serial3/1
R        13.0.3.0 [120/1] via 2.1.1.2, 00:00:17, Serial3/1
R     30.0.0.0/8 [120/1] via 2.1.1.2, 00:00:17, Serial3/1

R3#show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

R     1.0.0.0/8 [120/1] via 2.1.1.1, 00:00:25, Serial3/1
R     10.0.0.0/8 [120/2] via 2.1.1.1, 00:00:25, Serial3/1
R     20.0.0.0/8 [120/1] via 2.1.1.1, 00:00:25, Serial3/1

R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#passive-interface serial 3/1
R3#clear ip route *

R3#show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

R     1.0.0.0/8 [120/1] via 2.1.1.1, 00:00:23, Serial3/1
R     10.0.0.0/8 [120/2] via 2.1.1.1, 00:00:23, Serial3/1
R     20.0.0.0/8 [120/1] via 2.1.1.1, 00:00:23, Serial3/1

R2#clear ip route *

R2#show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set


R     10.0.0.0/8 [120/1] via 1.1.1.1, 00:00:07, Serial3/0

(from the above output we can see aƬfter configuring serial 3/1 as passive interface  router 3 stops sending RIP updates on router 2. but router 3 still getting update from router 2). 



comment us to get ospf and eigrp passive interface configuration.







 


 


Instagram

Facebook


Twitter



LINKEDIN








1 comment:

Rahul said...

Nice Really Helpful visit my blog www.fast2way.com

What is Virtual Router Redundancy Protocol (VRRP)? How to configure Virtual Router Redundancy Protocol (VRRP)?

 Virtual Router Redundancy Protocol (VRRP) is a gateway redundancy networking protocol used to create a virtual gateway similar to HSRP . VR...