Thursday, 6 December 2018

Route Redistribution configuration



     

            we have already learned what is route redistribution and why we need, if you don't then click here . In this section we see configuration.















R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        10.1.1.1        YES manual up                    up
Serial3/0                    1.1.1.1         YES manual up                    up
Serial3/3                    4.1.1.2         YES manual up                    up
Serial3/6                  15.1.1.1        YES manual up                    up
Loopback0              11.0.0.1        YES manual up                    up
Loopback1              11.0.1.1        YES manual up                    up
Loopback2              11.0.2.1        YES manual up                    up
Loopback3              11.0.3.1        YES manual up                    up

R2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        20.1.1.1        YES manual up                    up
Serial3/0                    1.1.1.2         YES manual up                    up
Serial3/1                    2.1.1.1         YES manual up                    up
Serial3/4                  24.1.1.1        YES manual up                    up
Loopback0              12.0.0.1        YES manual up                    up
Loopback1              12.0.1.1        YES manual up                    up
Loopback2              12.0.2.1        YES manual up                    up
Loopback3              12.0.3.1        YES manual up                    up

v
R3#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        30.1.1.1        YES manual up                    up
Serial3/1                    2.1.1.2         YES manual up                    up
Serial3/2                   3.1.1.1         YES manual up                    up
Serial3/5                 35.1.1.1        YES manual up                    up
Loopback0              13.0.0.1        YES manual up                    up
Loopback1              13.0.1.1        YES manual up                    up
Loopback2              13.0.2.1        YES manual up                    up
Loopback3              13.0.3.1        YES manual up                    up



R4#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        40.1.1.1        YES manual up                    up
Serial3/2                    3.1.1.2         YES manual up                    up
Serial3/3                    4.1.1.1         YES manual up                    up
Serial3/7                  45.1.1.1        YES manual up                    up
Loopback0              14.0.0.1        YES manual up                    up
Loopback1              14.0.1.1        YES manual up                    up
Loopback2              14.0.2.1        YES manual up                    up
Loopback3              14.0.3.1        YES manual up                    up


R5#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        50.1.1.1        YES manual up                    up
Serial3/4                   24.1.1.2        YES manual up                    up
Serial3/5                   35.1.1.2        YES manual up                    up
Serial3/6                   15.1.1.1        YES manual up                    up
Serial3/7                   45.1.1.2        YES manual up                    up
Loopback0              150.0.0.1       YES manual up                    up
Loopback1              150.0.1.1       YES manual up                    up
Loopback2              150.0.2.1       YES manual up                    up
Loopback3              150.0.3.1       YES manual up                    up

R1(config)#router eigrp 210
R1(config-router)#network 1.0.0.0
R1(config-router)#network 10.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#exit

R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 15.0.0.0
R1(config-router)#network 11.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#exit

R1(config)#router eigrp 140
R1(config-router)#network 4.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#exit

R2(config)#router eigrp 210
R2(config-router)#network 1.0.0.0
R2(config-router)#network 20.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#exit

R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 12.0.0.0
R2(config-router)#network 2.0.0.0
R2(config-router)#exit

R2(config)#router ospf 11
R2(config-router)#network 25.0.0.0 0.255.255.255 area 0
R2(config-router)#exit

R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#network 2.0.0.0
R3(config-router)#network 13.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#exit

R3(config)#router eigrp 53
R3(config-router)#network 35.0.0.0
R3(config-router)#network 30.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#exit

R3(config)#router ospf 10
R3(config-router)#network 3.0.0.0 0.255.255.255 area 0
R3(config-router)#exit

R4(config)#router ospf 10
R4(config-router)#network 3.0.0.0 0.255.255.255 a
R4(config-router)#network 3.0.0.0 0.255.255.255 area 0
R4(config-router)#exit

R4(config)#router rip
R4(config-router)#version 2
R4(config-router)#network 45.0.0.0
R4(config-router)#network 14.0.0.0
R4(config-router)#no auto-summary
R4(config-router)#exit

R4(config)#router eigrp 140
R4(config-router)#network 4.0.0.0
R4(config-router)#network 40.0.0.0
R4(config-router)#no auto-summary
R4(config-router)#exit

R5(config)#router rip
R5(config-router)#ver 2
R5(config-router)#network 45.0.0.0
R5(config-router)#no auto-summary
R5(config-router)#exit

R5(config)#router ospf 11
R5(config-router)#network 24.0.0.0 0.255.255.255 a
R5(config-router)#network 24.0.0.0 0.255.255.255 area 0
R5(config-router)#network 50.0.0.0 0.255.255.255 area 0
R5(config-router)#exit

R5(config)#router eigrp 53
R5(config-router)#network 35.0.0.0
R5(config-router)#network 150.0.0.0
R5(config-router)#no auto-summary
R5(config-router)#exit

R5(config)#router rip
R5(config-router)#version 2
R5(config-router)#network 15.0.0.0
R5(config-router)#no auto-summary
R5(config-router)#exit

R1#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "eigrp 210"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 Protocol for AS(210)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 11.0.3.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    1.0.0.0
    10.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    1.1.1.2               90      00:38:42
  Distance: internal 90 external 170

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 23 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial3/6             2     2
    Loopback0             2     2
    Loopback1             2     2
    Loopback2             2     2
    Loopback3             2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    11.0.0.0
    15.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 120)

Routing Protocol is "eigrp 140"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 Protocol for AS(140)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 11.0.3.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    4.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    4.1.1.1               90      00:20:14
  Distance: internal 90 external 170



R2#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "eigrp 210"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 Protocol for AS(210)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 12.0.3.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    1.0.0.0
    20.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    1.1.1.1               90      00:39:50
  Distance: internal 90 external 170

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 7 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial3/1             2     2
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    2.0.0.0
    11.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    2.1.1.2              120      00:00:27
  Distance: (default is 120)

Routing Protocol is "ospf 11"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 12.0.3.1
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    25.0.0.0 0.255.255.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 110)


R3#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 11 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial3/1             2     2
    Loopback0             2     2
    Loopback1             2     2
    Loopback2             2     2
    Loopback3             2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    2.0.0.0
    13.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 120)

Routing Protocol is "eigrp 53"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 Protocol for AS(53)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 13.0.3.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    30.0.0.0
    35.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    35.1.1.2              90      00:29:09
  Distance: internal 90 external 170

Routing Protocol is "ospf 10"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 13.0.3.1
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    3.0.0.0 0.255.255.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 110)


R4#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "ospf 10"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 14.0.3.1
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    3.0.0.0 0.255.255.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 110)

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 28 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial3/7             2     2
    Loopback0             2     2
    Loopback1             2     2
    Loopback2             2     2
    Loopback3             2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    14.0.0.0
    45.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    45.1.1.2             120      00:00:11
  Distance: (default is 120)

Routing Protocol is "eigrp 140"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 Protocol for AS(140)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 14.0.3.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    4.0.0.0
    40.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: internal 90 external 170


R5#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "ospf 11"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 150.0.3.1
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    24.0.0.0 0.255.255.255 area 0
    50.0.0.0 0.255.255.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 110)

Routing Protocol is "eigrp 53"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 Protocol for AS(53)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 150.0.3.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    35.0.0.0
    150.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    35.1.1.1              90      00:30:12
  Distance: internal 90 external 170

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 20 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial3/6             2     2
    Serial3/7             2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    15.0.0.0
    45.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    45.1.1.1             120      00:00:01
  Distance: (default is 120)

R1(config)#router eigrp 210
R1(config-router)#redistribute rip metric 1000 20000 255 1 1500
R1(config-router)#redistribute eigrp 140 metric 1000 20000 255 1 1500
R1(config-router)#exit

R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#redistribute eigrp 210 metric 8
R1(config-router)#redistribute eigrp 140 metric 8
R1(config-router)#exit

R1(config)#router eigrp 140
R1(config-router)#redistribute eigrp 210 metric  1000 20000 255 1 1500
R1(config-router)#redistribute rip  metric  1000 20000 255 1 1500
R1(config-router)#exit

R2(config)#router eigrp 210
R2(config-router)#redistribute ospf 11 metric 1000 20000 255 1 1500
R2(config-router)#redistribute rip  metric 1000 20000 255 1 1500
R2(config-router)#exit

R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#redistribute ospf 11 metric 8
R2(config-router)#redistribute eigrp 210  metric 8
R2(config-router)#exit

R2(config)#router ospf 11
R2(config-router)#redistribute eigrp 210 subnets metric-type 1
R2(config-router)#redistribute rip  subnets metric-type 1
R2(config-router)#exit

R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#redistribute eigrp 53 metric 8
R3(config-router)#redistribute ospf 10  metric 8
R3(config-router)#exit

R3(config)#router eigrp 53
R3(config-router)#redistribute rip metric 1000 20000 255 1 1500
R3(config-router)#redistribute ospf 10  metric 1000 20000 255 1 1500
R3(config-router)#exit

R3(config)#router ospf 10
R3(config-router)#redistribute rip subnets metric-type 1
R3(config-router)#redistribute eigrp 53  subnets metric-type 1
R3(config-router)#exit

R4(config)#router ospf 10
R4(config-router)#redistribute rip subnets metric-type 1
R4(config-router)#redistribute eigrp 140  subnets metric-type 1
R4(config-router)#exit

R4(config)#router rip
R4(config-router)#version 2
R4(config-router)#redistribute eigrp 140 metric 8
R4(config-router)#redistribute ospf 10  metric 8
R4(config-router)#exit

R4(config)#router eigrp 140
R4(config-router)#redistribute rip metric 1000 20000 255 1 1500
R4(config-router)#redistribute ospf 10  metric 1000 20000 255 1 1500
R4(config-router)#exit

R5(config)#router ospf 11
R5(config-router)#redistribute eigrp 53 subnets metric-type 1
R5(config-router)#redistribute rip  subnets metric-type 1
R5(config-router)#exit

R5(config)#router rip
R5(config-router)#version 2
R5(config-router)#redistribute eigrp 53 metric 8
R5(config-router)#redistribute ospf 11 metric 8
R5(config-router)#exit

R5(config)#router eigrp 53
R5(config-router)#redistribute ospf 11 metric 1000 20000 255 1 1500
R5(config-router)#redistribute rip  metric 1000 20000 255 1 1500
R5(config-router)#exit

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/8 is directly connected, Serial3/0
L        1.1.1.1/32 is directly connected, Serial3/0
D EX  2.0.0.0/8 [170/8192000] via 4.1.1.1, 00:18:49, Serial3/3
D EX  3.0.0.0/8 [170/8192000] via 4.1.1.1, 00:18:49, Serial3/3
      4.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        4.0.0.0/8 is directly connected, Serial3/3
L        4.1.1.2/32 is directly connected, Serial3/3
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/8 is directly connected, FastEthernet0/0
L        10.1.1.1/32 is directly connected, FastEthernet0/0
      11.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
D EX     11.0.0.0/8 [170/8192000] via 4.1.1.1, 00:18:50, Serial3/3
C        11.0.0.0/24 is directly connected, Loopback0
L        11.0.0.1/32 is directly connected, Loopback0
C        11.0.1.0/24 is directly connected, Loopback1
L        11.0.1.1/32 is directly connected, Loopback1
C        11.0.2.0/24 is directly connected, Loopback2
L        11.0.2.1/32 is directly connected, Loopback2
C        11.0.3.0/24 is directly connected, Loopback3
L        11.0.3.1/32 is directly connected, Loopback3
      12.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D EX     12.0.0.0/8 [170/8192000] via 4.1.1.1, 00:09:50, Serial3/3
D EX     12.0.0.0/24 [170/8192000] via 1.1.1.2, 00:09:52, Serial3/0
D EX     12.0.1.0/24 [170/8192000] via 1.1.1.2, 00:09:52, Serial3/0
D EX     12.0.2.0/24 [170/8192000] via 1.1.1.2, 00:09:52, Serial3/0
D EX     12.0.3.0/24 [170/8192000] via 1.1.1.2, 00:09:52, Serial3/0
      13.0.0.0/24 is subnetted, 4 subnets
D EX     13.0.0.0 [170/8192000] via 4.1.1.1, 00:18:49, Serial3/3
D EX     13.0.1.0 [170/8192000] via 4.1.1.1, 00:18:49, Serial3/3
D EX     13.0.2.0 [170/8192000] via 4.1.1.1, 00:18:49, Serial3/3
D EX     13.0.3.0 [170/8192000] via 4.1.1.1, 00:18:49, Serial3/3
      14.0.0.0/24 is subnetted, 4 subnets
D EX     14.0.0.0 [170/8192000] via 4.1.1.1, 00:18:59, Serial3/3
D EX     14.0.1.0 [170/8192000] via 4.1.1.1, 00:18:59, Serial3/3
D EX     14.0.2.0 [170/8192000] via 4.1.1.1, 00:18:59, Serial3/3
D EX     14.0.3.0 [170/8192000] via 4.1.1.1, 00:18:59, Serial3/3
      15.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        15.0.0.0/8 is directly connected, Serial3/6
L        15.1.1.1/32 is directly connected, Serial3/6
D     20.0.0.0/8 [90/2172416] via 1.1.1.2, 01:29:11, Serial3/0
D EX  24.0.0.0/8 [170/8192000] via 4.1.1.1, 00:15:10, Serial3/3
D EX  30.0.0.0/8 [170/8192000] via 4.1.1.1, 00:18:49, Serial3/3
D EX  35.0.0.0/8 [170/8192000] via 4.1.1.1, 00:18:49, Serial3/3
D     40.0.0.0/8 [90/2172416] via 4.1.1.1, 01:10:38, Serial3/3
D EX  45.0.0.0/8 [170/8192000] via 4.1.1.1, 00:18:59, Serial3/3
D EX  50.0.0.0/8 [170/8192000] via 4.1.1.1, 00:15:10, Serial3/3
      150.0.0.0/24 is subnetted, 4 subnets
D EX     150.0.0.0 [170/8192000] via 4.1.1.1, 00:18:49, Serial3/3
D EX     150.0.1.0 [170/8192000] via 4.1.1.1, 00:18:49, Serial3/3
D EX     150.0.2.0 [170/8192000] via 4.1.1.1, 00:18:49, Serial3/3
D EX     150.0.3.0 [170/8192000] via 4.1.1.1, 00:18:49, Serial3/3

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/8 is directly connected, Serial3/0
L        1.1.1.2/32 is directly connected, Serial3/0
      2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        2.0.0.0/8 is directly connected, Serial3/1
L        2.1.1.1/32 is directly connected, Serial3/1
R     3.0.0.0/8 [120/8] via 2.1.1.2, 00:00:08, Serial3/1
R     4.0.0.0/8 [120/8] via 2.1.1.2, 00:00:08, Serial3/1
D     10.0.0.0/8 [90/2172416] via 1.1.1.1, 00:10:26, Serial3/0
      11.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D EX     11.0.0.0/8 [170/8192000] via 1.1.1.1, 00:10:26, Serial3/0
R        11.0.0.0/24 [120/8] via 2.1.1.2, 00:00:08, Serial3/1
R        11.0.1.0/24 [120/8] via 2.1.1.2, 00:00:08, Serial3/1
R        11.0.2.0/24 [120/8] via 2.1.1.2, 00:00:08, Serial3/1
R        11.0.3.0/24 [120/8] via 2.1.1.2, 00:00:08, Serial3/1
      12.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
D EX     12.0.0.0/8 [170/8192000] via 1.1.1.1, 00:10:26, Serial3/0
C        12.0.0.0/24 is directly connected, Loopback0
L        12.0.0.1/32 is directly connected, Loopback0
C        12.0.1.0/24 is directly connected, Loopback1
L        12.0.1.1/32 is directly connected, Loopback1
C        12.0.2.0/24 is directly connected, Loopback2
L        12.0.2.1/32 is directly connected, Loopback2
C        12.0.3.0/24 is directly connected, Loopback3
L        12.0.3.1/32 is directly connected, Loopback3
      13.0.0.0/24 is subnetted, 4 subnets
R        13.0.0.0 [120/1] via 2.1.1.2, 00:00:08, Serial3/1
R        13.0.1.0 [120/1] via 2.1.1.2, 00:00:08, Serial3/1
R        13.0.2.0 [120/1] via 2.1.1.2, 00:00:08, Serial3/1
R        13.0.3.0 [120/1] via 2.1.1.2, 00:00:08, Serial3/1
      14.0.0.0/24 is subnetted, 4 subnets
R        14.0.0.0 [120/8] via 2.1.1.2, 00:00:08, Serial3/1
R        14.0.1.0 [120/8] via 2.1.1.2, 00:00:08, Serial3/1
R        14.0.2.0 [120/8] via 2.1.1.2, 00:00:08, Serial3/1
R        14.0.3.0 [120/8] via 2.1.1.2, 00:00:08, Serial3/1
D EX  15.0.0.0/8 [170/8192000] via 1.1.1.1, 00:10:26, Serial3/0
      20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        20.0.0.0/8 is directly connected, FastEthernet0/0
L        20.1.1.1/32 is directly connected, FastEthernet0/0
      24.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        24.0.0.0/8 is directly connected, Serial3/4
L        24.1.1.1/32 is directly connected, Serial3/4
R     30.0.0.0/8 [120/8] via 2.1.1.2, 00:00:08, Serial3/1
R     35.0.0.0/8 [120/8] via 2.1.1.2, 00:00:08, Serial3/1
R     40.0.0.0/8 [120/8] via 2.1.1.2, 00:00:08, Serial3/1
R     45.0.0.0/8 [120/8] via 2.1.1.2, 00:00:08, Serial3/1
R     50.0.0.0/8 [120/8] via 2.1.1.2, 00:00:08, Serial3/1
      150.0.0.0/24 is subnetted, 4 subnets
R        150.0.0.0 [120/8] via 2.1.1.2, 00:00:08, Serial3/1
R        150.0.1.0 [120/8] via 2.1.1.2, 00:00:08, Serial3/1
R        150.0.2.0 [120/8] via 2.1.1.2, 00:00:08, Serial3/1
R        150.0.3.0 [120/8] via 2.1.1.2, 00:00:08, Serial3/1

R3#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

R     1.0.0.0/8 [120/8] via 2.1.1.1, 00:00:10, Serial3/1
      2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        2.0.0.0/8 is directly connected, Serial3/1
L        2.1.1.2/32 is directly connected, Serial3/1
      3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        3.0.0.0/8 is directly connected, Serial3/2
L        3.1.1.1/32 is directly connected, Serial3/2
O E1  4.0.0.0/8 [110/84] via 3.1.1.2, 00:21:54, Serial3/2
R     10.0.0.0/8 [120/8] via 2.1.1.1, 00:00:10, Serial3/1
      11.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
R        11.0.0.0/8 [120/8] via 2.1.1.1, 00:00:10, Serial3/1
O E1     11.0.0.0/24 [110/84] via 3.1.1.2, 00:21:54, Serial3/2
O E1     11.0.1.0/24 [110/84] via 3.1.1.2, 00:21:54, Serial3/2
O E1     11.0.2.0/24 [110/84] via 3.1.1.2, 00:21:54, Serial3/2
O E1     11.0.3.0/24 [110/84] via 3.1.1.2, 00:21:54, Serial3/2
      12.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
R        12.0.0.0/8 [120/8] via 2.1.1.1, 00:00:10, Serial3/1
O E1     12.0.0.0/24 [110/84] via 3.1.1.2, 00:11:03, Serial3/2
O E1     12.0.1.0/24 [110/84] via 3.1.1.2, 00:11:03, Serial3/2
O E1     12.0.2.0/24 [110/84] via 3.1.1.2, 00:11:03, Serial3/2
O E1     12.0.3.0/24 [110/84] via 3.1.1.2, 00:11:03, Serial3/2
      13.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
C        13.0.0.0/24 is directly connected, Loopback0
L        13.0.0.1/32 is directly connected, Loopback0
C        13.0.1.0/24 is directly connected, Loopback1
L        13.0.1.1/32 is directly connected, Loopback1
C        13.0.2.0/24 is directly connected, Loopback2
L        13.0.2.1/32 is directly connected, Loopback2
C        13.0.3.0/24 is directly connected, Loopback3
L        13.0.3.1/32 is directly connected, Loopback3
      14.0.0.0/24 is subnetted, 4 subnets
O E1     14.0.0.0 [110/84] via 3.1.1.2, 00:22:05, Serial3/2
O E1     14.0.1.0 [110/84] via 3.1.1.2, 00:22:05, Serial3/2
O E1     14.0.2.0 [110/84] via 3.1.1.2, 00:22:05, Serial3/2
O E1     14.0.3.0 [110/84] via 3.1.1.2, 00:22:05, Serial3/2
R     15.0.0.0/8 [120/8] via 2.1.1.1, 00:00:10, Serial3/1
R     20.0.0.0/8 [120/8] via 2.1.1.1, 00:00:10, Serial3/1
O E1  24.0.0.0/8 [110/84] via 3.1.1.2, 00:16:21, Serial3/2
      30.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        30.0.0.0/8 is directly connected, FastEthernet0/0
L        30.1.1.1/32 is directly connected, FastEthernet0/0
      35.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        35.0.0.0/8 is directly connected, Serial3/5
L        35.1.1.1/32 is directly connected, Serial3/5
O E1  40.0.0.0/8 [110/84] via 3.1.1.2, 00:21:54, Serial3/2
O E1  45.0.0.0/8 [110/84] via 3.1.1.2, 00:22:05, Serial3/2
O E1  50.0.0.0/8 [110/84] via 3.1.1.2, 00:16:21, Serial3/2
      150.0.0.0/24 is subnetted, 4 subnets
D        150.0.0.0 [90/2297856] via 35.1.1.2, 01:19:24, Serial3/5
D        150.0.1.0 [90/2297856] via 35.1.1.2, 01:19:24, Serial3/5
D        150.0.2.0 [90/2297856] via 35.1.1.2, 01:19:24, Serial3/5
D        150.0.3.0 [90/2297856] via 35.1.1.2, 01:19:24, Serial3/5

R4#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

O E1  1.0.0.0/8 [110/84] via 3.1.1.1, 00:25:48, Serial3/2
O E1  2.0.0.0/8 [110/84] via 3.1.1.1, 00:25:48, Serial3/2
      3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        3.0.0.0/8 is directly connected, Serial3/2
L        3.1.1.2/32 is directly connected, Serial3/2
      4.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        4.0.0.0/8 is directly connected, Serial3/3
L        4.1.1.1/32 is directly connected, Serial3/3
O E1  10.0.0.0/8 [110/84] via 3.1.1.1, 00:25:48, Serial3/2
      11.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O E1     11.0.0.0/8 [110/84] via 3.1.1.1, 00:25:48, Serial3/2
D EX     11.0.0.0/24 [170/8192000] via 4.1.1.2, 00:40:04, Serial3/3
D EX     11.0.1.0/24 [170/8192000] via 4.1.1.2, 00:40:04, Serial3/3
D EX     11.0.2.0/24 [170/8192000] via 4.1.1.2, 00:40:04, Serial3/3
D EX     11.0.3.0/24 [170/8192000] via 4.1.1.2, 00:40:04, Serial3/3
      12.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O E1     12.0.0.0/8 [110/84] via 3.1.1.1, 00:11:29, Serial3/2
D EX     12.0.0.0/24 [170/8192000] via 4.1.1.2, 00:11:30, Serial3/3
D EX     12.0.1.0/24 [170/8192000] via 4.1.1.2, 00:11:30, Serial3/3
D EX     12.0.2.0/24 [170/8192000] via 4.1.1.2, 00:11:30, Serial3/3
D EX     12.0.3.0/24 [170/8192000] via 4.1.1.2, 00:11:30, Serial3/3
      13.0.0.0/24 is subnetted, 4 subnets
O E1     13.0.0.0 [110/84] via 3.1.1.1, 00:25:48, Serial3/2
O E1     13.0.1.0 [110/84] via 3.1.1.1, 00:25:48, Serial3/2
O E1     13.0.2.0 [110/84] via 3.1.1.1, 00:25:48, Serial3/2
O E1     13.0.3.0 [110/84] via 3.1.1.1, 00:25:48, Serial3/2
      14.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
C        14.0.0.0/24 is directly connected, Loopback0
L        14.0.0.1/32 is directly connected, Loopback0
C        14.0.1.0/24 is directly connected, Loopback1
L        14.0.1.1/32 is directly connected, Loopback1
C        14.0.2.0/24 is directly connected, Loopback2
L        14.0.2.1/32 is directly connected, Loopback2
C        14.0.3.0/24 is directly connected, Loopback3
L        14.0.3.1/32 is directly connected, Loopback3
O E1  15.0.0.0/8 [110/84] via 3.1.1.1, 00:25:48, Serial3/2
O E1  20.0.0.0/8 [110/84] via 3.1.1.1, 00:25:48, Serial3/2
R     24.0.0.0/8 [120/8] via 45.1.1.2, 00:00:16, Serial3/7
O E1  30.0.0.0/8 [110/84] via 3.1.1.1, 00:25:38, Serial3/2
O E1  35.0.0.0/8 [110/84] via 3.1.1.1, 00:25:38, Serial3/2
      40.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        40.0.0.0/8 is directly connected, FastEthernet0/0
L        40.1.1.1/32 is directly connected, FastEthernet0/0
      45.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        45.0.0.0/8 is directly connected, Serial3/7
L        45.1.1.1/32 is directly connected, Serial3/7
R     50.0.0.0/8 [120/8] via 45.1.1.2, 00:00:16, Serial3/7
      150.0.0.0/24 is subnetted, 4 subnets
O E1     150.0.0.0 [110/84] via 3.1.1.1, 00:25:38, Serial3/2
O E1     150.0.1.0 [110/84] via 3.1.1.1, 00:25:38, Serial3/2
O E1     150.0.2.0 [110/84] via 3.1.1.1, 00:25:38, Serial3/2
O E1     150.0.3.0 [110/84] via 3.1.1.1, 00:25:38, Serial3/2

R5#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

R     1.0.0.0/8 [120/8] via 45.1.1.1, 00:00:11, Serial3/7
R     2.0.0.0/8 [120/8] via 45.1.1.1, 00:00:11, Serial3/7
R     3.0.0.0/8 [120/8] via 45.1.1.1, 00:00:11, Serial3/7
R     4.0.0.0/8 [120/8] via 45.1.1.1, 00:00:11, Serial3/7
R     10.0.0.0/8 [120/8] via 45.1.1.1, 00:00:11, Serial3/7
      11.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
R        11.0.0.0/8 [120/8] via 45.1.1.1, 00:00:11, Serial3/7
R        11.0.0.0/24 [120/8] via 45.1.1.1, 00:00:11, Serial3/7
R        11.0.1.0/24 [120/8] via 45.1.1.1, 00:00:11, Serial3/7
R        11.0.2.0/24 [120/8] via 45.1.1.1, 00:00:11, Serial3/7
R        11.0.3.0/24 [120/8] via 45.1.1.1, 00:00:11, Serial3/7
      12.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
R        12.0.0.0/8 [120/8] via 45.1.1.1, 00:00:11, Serial3/7
R        12.0.0.0/24 [120/8] via 45.1.1.1, 00:00:11, Serial3/7
R        12.0.1.0/24 [120/8] via 45.1.1.1, 00:00:11, Serial3/7
R        12.0.2.0/24 [120/8] via 45.1.1.1, 00:00:11, Serial3/7
R        12.0.3.0/24 [120/8] via 45.1.1.1, 00:00:11, Serial3/7
      13.0.0.0/24 is subnetted, 4 subnets
R        13.0.0.0 [120/8] via 45.1.1.1, 00:00:11, Serial3/7
R        13.0.1.0 [120/8] via 45.1.1.1, 00:00:11, Serial3/7
R        13.0.2.0 [120/8] via 45.1.1.1, 00:00:11, Serial3/7
R        13.0.3.0 [120/8] via 45.1.1.1, 00:00:11, Serial3/7
      14.0.0.0/24 is subnetted, 4 subnets
R        14.0.0.0 [120/1] via 45.1.1.1, 00:00:11, Serial3/7
R        14.0.1.0 [120/1] via 45.1.1.1, 00:00:11, Serial3/7
R        14.0.2.0 [120/1] via 45.1.1.1, 00:00:11, Serial3/7
R        14.0.3.0 [120/1] via 45.1.1.1, 00:00:11, Serial3/7
      15.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        15.0.0.0/8 is directly connected, Serial3/6
L        15.1.1.1/32 is directly connected, Serial3/6
R     20.0.0.0/8 [120/8] via 45.1.1.1, 00:00:11, Serial3/7
      24.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        24.0.0.0/8 is directly connected, Serial3/4
L        24.1.1.2/32 is directly connected, Serial3/4
D     30.0.0.0/8 [90/2172416] via 35.1.1.1, 01:20:22, Serial3/5
      35.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        35.0.0.0/8 is directly connected, Serial3/5
L        35.1.1.2/32 is directly connected, Serial3/5
R     40.0.0.0/8 [120/8] via 45.1.1.1, 00:00:11, Serial3/7
      45.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        45.0.0.0/8 is directly connected, Serial3/7
L        45.1.1.2/32 is directly connected, Serial3/7
      50.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        50.0.0.0/8 is directly connected, FastEthernet0/0
L        50.1.1.1/32 is directly connected, FastEthernet0/0
      150.0.0.0/16 is variably subnetted, 8 subnets, 2 masks
C        150.0.0.0/24 is directly connected, Loopback0
L        150.0.0.1/32 is directly connected, Loopback0
C        150.0.1.0/24 is directly connected, Loopback1
L        150.0.1.1/32 is directly connected, Loopback1
C        150.0.2.0/24 is directly connected, Loopback2
L        150.0.2.1/32 is directly connected, Loopback2
C        150.0.3.0/24 is directly connected, Loopback3
L        150.0.3.1/32 is directly connected, Loopback3


R1#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "eigrp 210"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  Redistributing: rip, eigrp 140
  EIGRP-IPv4 Protocol for AS(210)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 11.0.3.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    1.0.0.0
    10.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    1.1.1.2               90      00:12:16
  Distance: internal 90 external 170

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 21 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: eigrp 210, eigrp 140
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial3/6             2     2
    Loopback0             2     2
    Loopback1             2     2
    Loopback2             2     2
    Loopback3             2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    11.0.0.0
    Interface             Send  Recv  Triggered RIP  Key-chain
    15.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 120)

Routing Protocol is "eigrp 140"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  Redistributing: eigrp 210, rip
  EIGRP-IPv4 Protocol for AS(140)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 11.0.3.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    4.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    4.1.1.1               90      00:12:22
  Distance: internal 90 external 170

R2#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "eigrp 210"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  Redistributing: rip, ospf 11
  EIGRP-IPv4 Protocol for AS(210)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 12.0.3.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    1.0.0.0
    20.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    1.1.1.1               90      00:14:01
  Distance: internal 90 external 170

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 26 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: eigrp 210, rip, ospf 11 (internal, external 1 & 2, nssa-external 1 & 2)

  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial3/1             2     2
    Loopback0             2     2
    Loopback1             2     2
    Loopback2             2     2
    Loopback3             2     2
  Automatic network summarization is in effect
  Maximum path: 4
    Interface             Send  Recv  Triggered RIP  Key-chain
  Routing for Networks:
    2.0.0.0
    12.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    2.1.1.2              120      00:00:07
  Distance: (default is 120)

Routing Protocol is "ospf 11"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 12.0.3.1
  It is an autonomous system boundary router
 Redistributing External Routes from,
    eigrp 210, includes subnets in redistribution
    rip, includes subnets in redistribution
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    25.0.0.0 0.255.255.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 110)

R3#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 14 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip, eigrp 53, ospf 10 (internal, external 1 & 2, nssa-external 1 & 2)

  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial3/1             2     2
    Loopback0             2     2
    Loopback1             2     2
    Loopback2             2     2
    Loopback3             2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    2.0.0.0
    13.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    2.1.1.1              120      00:00:19
  Distance: (default is 120)

Routing Protocol is "eigrp 53"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  Redistributing: rip, ospf 10
  EIGRP-IPv4 Protocol for AS(53)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 13.0.3.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    30.0.0.0
    35.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    35.1.1.2              90      00:15:41
  Distance: internal 90 external 170

Routing Protocol is "ospf 10"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 13.0.3.1
  It is an autonomous system boundary router
 Redistributing External Routes from,
    rip, includes subnets in redistribution
    eigrp 53, includes subnets in redistribution
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    3.0.0.0 0.255.255.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    14.0.3.1             110      00:15:48
  Distance: (default is 110)

R4#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "ospf 10"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 14.0.3.1
  It is an autonomous system boundary router
 Redistributing External Routes from,
    rip, includes subnets in redistribution
    eigrp 140, includes subnets in redistribution
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    3.0.0.0 0.255.255.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    13.0.3.1             110      00:17:00
  Distance: (default is 110)

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 16 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: ospf 10 (internal, external 1 & 2, nssa-external 1 & 2)

  Redistributing: rip, eigrp 140
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial3/7             2     2
    Loopback0             2     2
    Loopback1             2     2
    Loopback2             2     2
    Loopback3             2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    14.0.0.0
    45.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    45.1.1.2             120      00:00:12
  Distance: (default is 120)

Routing Protocol is "eigrp 140"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  Redistributing: ospf 10, rip
  EIGRP-IPv4 Protocol for AS(140)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 14.0.3.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    4.0.0.0
    40.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    4.1.1.2               90      00:17:04
  Distance: internal 90 external 170

R5#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "ospf 11"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 150.0.3.1
  It is an autonomous system boundary router
 Redistributing External Routes from,
    eigrp 53, includes subnets in redistribution
    rip, includes subnets in redistribution
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    24.0.0.0 0.255.255.255 area 0
    50.0.0.0 0.255.255.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 110)

Routing Protocol is "eigrp 53"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  Redistributing: ospf 11, rip
  EIGRP-IPv4 Protocol for AS(53)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 150.0.3.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    35.0.0.0
    150.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    35.1.1.1              90      00:18:32
  Distance: internal 90 external 170

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 25 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: ospf 11 (internal, external 1 & 2, nssa-external 1 & 2)

  Redistributing: eigrp 53, rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial3/6             2     2
    Serial3/7             2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    15.0.0.0
    45.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    45.1.1.1             120      00:00:22
  Distance: (default is 120)


 


 


Instagram

Facebook


Twitter



LINKEDIN








Saturday, 1 December 2018

What is BGP Local Preference (Local_Pref)? How to configure?




 BGP Local preference (Local_Pref) Path attribute gives the router inside a single autonomous system a value that they can set per-route and advertise to all iBGP routers inside the autonomous system, so that all routers in the autonomous system agree about which routers is the best exit point for packet destined for that prefix.
Path with highest preference value is more desirable, by default Local_pref value is 100 and the range is 0 through 4,294,967,295. Local preference is well-known, discretionary attribute. It is advertised only to iBGP neighbors within an autonomous system.













lets see the configuration:-


Topology:





Goal:
  • configure the topology as per the diagram.
  • configure iBGP and eBGP peering using directly connected interfaces.
  • advertise all the networks as per the topology.
  • configure router 1 exit point for autonomous system of 65111.
  • make sure router 2 reaches the network via router 1.


R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        10.1.1.1        YES manual up                    up
Serial3/0              1.1.1.1         YES manual up                    up
Serial3/3              4.1.1.2         YES manual up                    up
Loopback0              11.0.0.1        YES manual up                    up
Loopback1              11.0.1.1        YES manual up                    up
Loopback2              11.0.2.1        YES manual up                    up
Loopback3              11.0.3.1        YES manual up                    up


R2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        20.1.1.1        YES manual up                    up
Serial3/0                     1.1.1.2         YES manual up                    up
Serial3/1                     2.1.1.1         YES manual up                    up
Loopback0              12.0.0.1        YES manual up                    up
Loopback1              12.0.1.1        YES manual up                    up
Loopback2              12.0.2.1        YES manual up                    up
Loopback3              12.0.3.1        YES manual up                    up

R3#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        30.1.1.1        YES manual up                    up
Serial3/1              2.1.1.2         YES manual up                    up
Serial3/2              3.1.1.1         YES manual up                    up
Loopback0              13.0.0.1        YES manual up                    up
Loopback1              13.0.1.1        YES manual up                    up
Loopback2              13.0.2.1        YES manual up                    up
Loopback3              13.0.3.1        YES manual up                    up


R4#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        40.1.1.1        YES manual up                    up
Serial3/2                    3.1.1.2         YES manual up                    up
Serial3/3                    4.1.1.1         YES manual up                    up
Loopback0              14.0.0.1        YES manual up                    up
Loopback1              14.0.1.1        YES manual up                    up
Loopback2              14.0.2.1        YES manual up                    up
Loopback3              14.0.3.1        YES manual up                    up


R1(config)#router bgp 65111
R1(config-router)#neighbor 1.1.1.2 remote-as 65111
R1(config-router)#neighbor 4.1.1.1 remote-as 65444
R1(config-router)#neighbor 1.1.1.2 next-hop-self
R1(config-router)#network 10.0.0.0
R1(config-router)#network 1.0.0.0
R1(config-router)#network 4.0.0.0
R1(config-router)#network 11.0.0.0 mask 255.255.255.0
R1(config-router)#no auto-summary
R1(config-router)#no synchronization


R2(config)#router bgp 65111
R2(config-router)#neighbor 1.1.1.1 remote-as 65111
R2(config-router)#neighbor 2.1.1.2 remote-as 65333
R2(config-router)#neighbor 1.1.1.1 next-hop-self
R2(config-router)#network 20.0.0.
R2(config-router)#network 20.0.0.0
R2(config-router)#network 2.0.0.0
R2(config-router)#network 1.0.0.0
R2(config-router)#network 12.0.0.0 mask 255.255.255.0
R2(config-router)#no auto-summary
R2(config-router)#no synchronization


R3(config)#router bgp 65333
R3(config-router)#neighbor 2.1.1.1 remote-as 65111
R3(config-router)#neighbor 3.1.1.2  remote-as 65444
R3(config-router)#network 30.0.0.0
R3(config-router)#network 3.0.0.0
R3(config-router)#network 2.0.0.0
R3(config-router)#network 13.0.0.0 mask 255.255.255.0
R3(config-router)#no synchronization
R3(config-router)#no auto-summary


R4(config)#router bgp 65444
R4(config-router)#neighbor 3.1.1.1 remote-as 65333
R4(config-router)#neighbor 4.1.1.2 remote-as 65111
R4(config-router)#network 40.0.0.0
R4(config-router)#network 4.0.0.0
R4(config-router)#network 14.0.0.0 mask 255.255.255.0
R4(config-router)#network 3.0.0.0
R4(config-router)#no synchronization
R4(config-router)#no auto-summary


R1#show ip bgp
BGP table version is 14, local router ID is 11.0.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found


     Network          Next Hop            Metric LocPrf Weight Path
 * i 1.0.0.0          1.1.1.2                  0    100      0 i
 *>                   0.0.0.0                  0         32768 i
 *>i 2.0.0.0          1.1.1.2                  0    100      0 i
 *>  3.0.0.0          4.1.1.1                  0             0 65444 i
 * i                  1.1.1.2                  0    100      0 65333 i
 *   4.0.0.0          4.1.1.1                  0             0 65444 i
 *>                   0.0.0.0                  0         32768 i
 *>  10.0.0.0         0.0.0.0                  0         32768 i
 *>  11.0.0.0/24      0.0.0.0                  0         32768 i
 *>i 12.0.0.0/24      1.1.1.2                  0    100      0 i
 *   13.0.0.0/24      4.1.1.1                                0 65444 65333 i
 *>i                  1.1.1.2                  0    100      0 65333 i
 *>  14.0.0.0/24      4.1.1.1                  0             0 65444 i
 *>i 20.0.0.0         1.1.1.2                  0    100      0 i
 *   30.0.0.0         4.1.1.1                                0 65444 65333 i
     Network          Next Hop            Metric LocPrf Weight Path
 *>i                  1.1.1.2                  0    100      0 65333 i
 *>  40.0.0.0         4.1.1.1                  0             0 65444 i


R2#show ip bgp
BGP table version is 14, local router ID is 12.0.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf     Weight Path
 *>  1.0.0.0          0.0.0.0                  0                         32768   i
 * i                  1.1.1.1                       0            100         0         i
 *   2.0.0.0          2.1.1.2                   0                           0        65333   i
 *>                   0.0.0.0                      0                        32768    i
 * i 3.0.0.0          1.1.1.1                   0             100        0        65444 i
 *>                   2.1.1.2                      0                           0        65333    i
 *>i 4.0.0.0          1.1.1.1                  0             100        0         i
 *>i 10.0.0.0         1.1.1.1                 0            100         0         i
 *>i 11.0.0.0/24      1.1.1.1                0           100         0         i
 *>  12.0.0.0/24      0.0.0.0               0                       32768     i
 *>  13.0.0.0/24      2.1.1.2                  0                       0          65333 i
 *   14.0.0.0/24      2.1.1.2                                             0         65333 65444 i
 *>i                  1.1.1.1                  0                  100      0          65444 i
 *>  20.0.0.0         0.0.0.0                  0                      32768 i
     Network          Next Hop            Metric     LocPrf       Weight    Path
 *>  30.0.0.0         2.1.1.2                  0                                0           65333 i
 *   40.0.0.0         2.1.1.2                                                     0           65333 65444 i
 *>i                  1.1.1.1                  0                   100            0           65444 i



R1#show ip route bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set


B     2.0.0.0/8 [200/0] via 1.1.1.2, 00:36:56
B     3.0.0.0/8 [20/0] via 4.1.1.1, 00:32:47
      12.0.0.0/24 is subnetted, 1 subnets
B        12.0.0.0 [200/0] via 1.1.1.2, 00:36:43
      13.0.0.0/24 is subnetted, 1 subnets
B        13.0.0.0 [200/0] via 1.1.1.2, 00:34:45
      14.0.0.0/24 is subnetted, 1 subnets
B        14.0.0.0 [20/0] via 4.1.1.1, 00:33:18
B     20.0.0.0/8 [200/0] via 1.1.1.2, 00:36:56
B     30.0.0.0/8 [200/0] via 1.1.1.2, 00:35:16
B     40.0.0.0/8 [20/0] via 4.1.1.1, 00:33:48



R1#traceroute 13.0.0.1
Type escape sequence to abort.
Tracing the route to 13.0.0.1
VRF info: (vrf in name/id, vrf out name/id)
  1 1.1.1.2 32 msec 36 msec 8 msec
  2 2.1.1.2 36 msec 64 msec 64 msec

R1#traceroute 30.1.1.1
Type escape sequence to abort.
Tracing the route to 30.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 1.1.1.2 12 msec 60 msec 24 msec
  2 2.1.1.2 44 msec 52 msec 60 msec

R2#traceroute 13.0.0.1
Type escape sequence to abort.
Tracing the route to 13.0.0.1
VRF info: (vrf in name/id, vrf out name/id)
  1 2.1.1.2 288 msec 60 msec 28 msec

R2#traceroute 30.1.1.1
Type escape sequence to abort.
Tracing the route to 30.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 2.1.1.2 76 msec 72 msec 60 msec


(To reach 30.1.1.1, 13.0.0.1 network router 1 and router 2 using 2.1.1.2 path because it has fewer numbers of an autonomous system. but as per our requirement, we need a router to use the 4.1.1.1 interface to reach all the networks, to manipulate the path we use local_pref)

R1(config)#router bgp 65111
R1(config-router)#bgp default local-preference 5000
R1(config-router)#end

R1#clear ip bgp * soft

R1#traceroute 30.1.1.1
Type escape sequence to abort.
Tracing the route to 30.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 4.1.1.1 8 msec 52 msec 28 msec
  2 3.1.1.1 [AS 65444] 80 msec 40 msec 64 msec

R1#traceroute 13.0.0.1
Type escape sequence to abort.
Tracing the route to 13.0.0.1
VRF info: (vrf in name/id, vrf out name/id)
  1 4.1.1.1 24 msec 60 msec 68 msec
  2 3.1.1.1 [AS 65444] 112 msec 72 msec 52 msec


R2#traceroute 30.1.1.1
Type escape sequence to abort.
Tracing the route to 30.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 1.1.1.1 4 msec 44 msec 28 msec
  2 4.1.1.1 36 msec 60 msec 8 msec
  3 3.1.1.1 [AS 65444] 60 msec 52 msec 44 msec


R2#traceroute 13.0.0.1
Type escape sequence to abort.
Tracing the route to 13.0.0.1
VRF info: (vrf in name/id, vrf out name/id)
  1 1.1.1.1 8 msec 28 msec 36 msec
  2 4.1.1.1 64 msec 116 msec 64 msec
  3 3.1.1.1 [AS 65444] 72 msec 72 msec 52 msec

R1#show ip bgp
BGP table version is 21, local router ID is 11.0.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 * i 1.0.0.0          1.1.1.2                  0    100      0 i
 *>                   0.0.0.0                  0         32768 i
 *>i 2.0.0.0          1.1.1.2                  0    100      0 i
 *>  3.0.0.0          4.1.1.1                  0             0 65444 i
 *   4.0.0.0          4.1.1.1                  0             0 65444 i
 *>                   0.0.0.0                  0         32768 i
 *>  10.0.0.0         0.0.0.0                  0         32768 i
 *>  11.0.0.0/24      0.0.0.0                  0         32768 i
 *>i 12.0.0.0/24      1.1.1.2                  0    100      0 i
 *>  13.0.0.0/24      4.1.1.1                                0 65444 65333 i
 *>  14.0.0.0/24      4.1.1.1                  0             0 65444 i
 *>i 20.0.0.0         1.1.1.2                  0    100      0 i
 *>  30.0.0.0         4.1.1.1                                0 65444 65333 i
 *>  40.0.0.0         4.1.1.1                  0             0 65444 i


R2#show ip bgp
BGP table version is 22, local router ID is 12.0.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found


     Network          Next Hop            Metric LocPrf Weight Path
 *>  1.0.0.0          0.0.0.0                  0         32768 i
 * i                  1.1.1.1                  0   5000      0 i
 *   2.0.0.0          2.1.1.2                  0             0 65333 i
 *>                   0.0.0.0                  0         32768 i
 *>i 3.0.0.0          1.1.1.1                  0   5000      0 65444 i
 *                    2.1.1.2                  0             0 65333 i
 *>i 4.0.0.0          1.1.1.1                  0   5000      0 i
 *>i 10.0.0.0         1.1.1.1                  0   5000      0 i
 *>i 11.0.0.0/24      1.1.1.1                  0   5000      0 i
 *>  12.0.0.0/24      0.0.0.0                  0         32768 i
 *>i 13.0.0.0/24      1.1.1.1                  0   5000      0 65444 65333 i
 *                    2.1.1.2                  0             0 65333 i
 *   14.0.0.0/24      2.1.1.2                                0 65333 65444 i
 *>i                  1.1.1.1                  0   5000      0 65444 i
     Network          Next Hop            Metric LocPrf Weight Path
 *>  20.0.0.0         0.0.0.0                  0         32768 i
 *>i 30.0.0.0         1.1.1.1                  0   5000      0 65444 65333 i
 *                    2.1.1.2                  0             0 65333 i
 *   40.0.0.0         2.1.1.2                                0 65333 65444 i
 *>i                  1.1.1.1                  0   5000      0 65444 i


R2#show ip bgp 30.1.1.1
BGP routing table entry for 30.0.0.0/8, version 17
Paths: (2 available, best #1, table default)
  Advertised to update-groups:
     3
  Refresh Epoch 2
  65444 65333
    1.1.1.1 from 1.1.1.1 (11.0.3.1)
      Origin IGP, metric 0, localpref 5000, valid, internal, best
      rx pathid: 0, tx pathid: 0x0
  Refresh Epoch 1
  65333
    2.1.1.2 from 2.1.1.2 (13.0.3.1)
      Origin IGP, metric 0, localpref 100, valid, external
      rx pathid: 0, tx pathid: 0



(you can also use route map for particular routes. comment below for route map)

 


 


Instagram

Facebook


Twitter



LINKEDIN








What is BGP Allowas-in Feature? How to configure BGP Allowas-in? GNS3

  BGP Allowas-in is a configuration option in Border Gateway Protocol (BGP) routing that allows a router to accept routes with its own AS (A...