Monday, 26 November 2018

BGP Neighbors




BGP Neighbors

BGP neighbors are routers forming TCP connections for exchanging BGP updates it’s also called BGP peers or BGP speakers.


There are two types of BGP neighbor relationship

IBGP (internal BGP)
EBGP (External BGP)

BGP first forms a neighbor relationship with BGP speakers (peer). Then its learns information from its peer, BGP place that information in its BGP table and analyze the table to choose the best working route for each subnet in the BGP table, placing those routes into the IP routing table.

There are several requirements for forming BGP neighbors:-

  • A local router’s autonomous system number must match the neighboring router’s ASN.
  • The BGP router ID of the two routers must not be the same.
  • Each router must be part of a TCP connection.
  • Authentication must be passing if it’s configured



BGP message types

  • Open- it’s used to established a neighbor relationship and exchange its parameter, its include ASN and authentication values.
  • Keepalive it’s used to maintain the neighbor relationship and it’s sent periodically
  • Update- its used to exchange path attribute.
  • Notification- it’s used error signals. It does occur in neighbor relationship reset.  




BGP neighbor states

  • Idle – it’s a down state by administratively down or waiting for the next retry attempt.

R1# show ip bgp summary



Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.2         4          501      11       9        8    0    0 00:04:28        4
4.1.1.1         4          501       0       0        1    0    0 never    Idle




  • Connect- this state means its waiting for the TCP connection to be completed.
  • Active- this state means the TCP connection has been completed but there is no BGP messages sent yet to its peer.
  • Opensent- this state means the TCP connection has been established and BGP open message is sent to its BGP speakers but the matching Open message is not received yet from the peer router.
  • Openconfirm- this state means open message has been sent and received from BGP speaker router. But it’s waiting for keepalive message.
  • Established- this state means the entire neighbor parameters match and the neighbor relationship has been established. Now BGP speakers (peers) can exchange update messages.







 Configuration:-



Topology:-


 GOAL:





  • configure the topology as per the diagram
  • configure IBGP peering AS 501 as per our topology using directly connected interfaces.
  • ensure the connectivity and make sure all bgp routers should be able exchange the routes through BGP.




R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        10.1.1.1        YES manual up                    up
Serial3/0                    1.1.1.1         YES manual up                    up
Serial3/3                    4.1.1.2         YES manual up                    up
Loopback0              11.0.0.1        YES manual up                    up
Loopback1              11.0.1.1        YES manual up                    up
Loopback2              11.0.2.1        YES manual up                    up
Loopback3              11.0.3.1        YES manual up                    up


R2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        20.1.1.1        YES manual up                    up
Serial3/0                   1.1.1.2         YES manual up                    up
Serial3/1                   2.1.1.1         YES manual up                    up
Loopback0              12.0.0.1        YES manual up                    up
Loopback1              12.0.1.1        YES manual up                    up
Loopback2              12.0.2.1        YES manual up                    up
Loopback3              12.0.3.1        YES manual up                    up


R3(config-if)#do sh ip int br
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        30.1.1.1        YES manual up                    up
Serial3/1                    2.1.1.2         YES manual up                    up
Serial3/2                    3.1.1.1         YES manual up                    up
Loopback0              13.0.0.1        YES manual up                    up
Loopback1              13.0.1.1        YES manual up                    up
Loopback2              13.0.2.1        YES manual up                    up
Loopback3              13.0.3.1        YES manual up                    up

R4#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        40.1.1.1        YES manual up                    up
Serial3/2                    3.1.1.2         YES manual up                    up
Serial3/3                    4.1.1.1         YES manual up                    up
Loopback0              14.0.0.1        YES manual up                    up
Loopback1              14.0.1.1        YES manual up                    up
Loopback2              14.0.2.1        YES manual up                    up
Loopback3              14.0.3.1        YES manual up                    up


R1(config)#router bgp 501
R1(config-router)#neighbor 1.1.1.2 remote-as 501
R1(config-router)#neighbor 4.1.1.1 remote-as 501
R1(config-router)#network 11.0.0.0 mask 255.255.255.0
R1(config-router)#network 10.0.0.0
R1(config-router)#network 1.0.0.0
R1(config-router)#network 4.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#no synchronization
R1(config-router)#end


R2(config)#router bgp 501
R2(config-router)#neighbor 1.1.1.1 remote-as 501
R2(config-router)#neighbor 2.1.1.2 remote-as 501
R2(config-router)#network 12.0.0.0 mask 255.255.255.0
R2(config-router)#network 20.0.0.0
R2(config-router)#network 2.0.0.0
R2(config-router)#network 1.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#no synchronization
R2(config-router)#end


R3(config)#router bgp 501
R3(config-router)#neighbor 2.1.1.1 remote-as 501
R3(config-router)#neighbor 3.1.1.2 remote-as 501
R3(config-router)#network 13.0.0.0 mask 255.255.255.0
R3(config-router)#network 30.0.0.0
R3(config-router)#network 3.0.0.0
R3(config-router)#network 2.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#no synchronization
R3(config-router)#end


R4(config)#router bgp 501
R4(config-router)#neighbor 4.1.1.2 remote-as 501
R4(config-router)#neighbor 3.1.1.1 remote-as 501
R4(config-router)#network 14.0.0.0 mask 255.255.255.0
R4(config-router)#network 3.0.0.0
R4(config-router)#network 4.0.0.0
R4(config-router)#no auto-summary
R4(config-router)#no synchronization
R4(config-router)#end


R1#show ip bgp summary
BGP router identifier 11.0.3.1, local AS number 501
BGP table version is 10, main routing table version 10
9 network entries using 1296 bytes of memory
11 path entries using 880 bytes of memory
2/2 BGP path/bestpath attribute entries using 272 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2448 total bytes of memory
BGP activity 9/0 prefixes, 12/1 paths, scan interval 60 secs


Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.2         4          501      25      22       10    0    0 00:15:30        4
4.1.1.1         4          501      12      12       10    0    0 00:05:01        3




R3#show ip bgp summary
BGP router identifier 13.0.3.1, local AS number 501
BGP table version is 13, main routing table version 13
9 network entries using 1296 bytes of memory
11 path entries using 880 bytes of memory
2/2 BGP path/bestpath attribute entries using 272 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2448 total bytes of memory
BGP activity 10/1 prefixes, 12/1 paths, scan interval 60 secs


Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.1.1.1         4          501      21      17       13    0    0 00:09:25        4
3.1.1.2         4          501      14      12       13    0    0 00:05:25        3

R1#show ip route bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

B     2.0.0.0/8 [200/0] via 1.1.1.2, 00:05:09
B     3.0.0.0/8 [200/0] via 4.1.1.1, 00:05:09
      12.0.0.0/24 is subnetted, 1 subnets
B        12.0.0.0 [200/0] via 1.1.1.2, 00:05:09
      14.0.0.0/24 is subnetted, 1 subnets
B        14.0.0.0 [200/0] via 4.1.1.1, 00:05:09
B     20.0.0.0/8 [200/0] via 1.1.1.2, 00:05:09
(because of the split horizon rules router 2 not get 30.0.0.0/8 and 13.0.0.0/24 networks)




R3#show ip route bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override


Gateway of last resort is not set

B     1.0.0.0/8 [200/0] via 2.1.1.1, 00:06:43
B     4.0.0.0/8 [200/0] via 3.1.1.2, 00:10:41
      12.0.0.0/24 is subnetted, 1 subnets
B        12.0.0.0 [200/0] via 2.1.1.1, 00:15:08
      14.0.0.0/24 is subnetted, 1 subnets
B        14.0.0.0 [200/0] via 3.1.1.2, 00:10:53
B     20.0.0.0/8 [200/0] via 2.1.1.1, 00:15:08

(here also router 3 is not getting 10.0.0.0/8 and 11.0.0.0/24 networks because of split horizon rules. the solution is full mesh neighbor-ship or we can use route reflector)








 


 


Instagram

Facebook


Twitter



LINKEDIN








Sunday, 25 November 2018

Introduction of BGP





Introduction of BGP

Border Gateway Protocol (BGP) advertises, learns, and chooses the best paths inside the wide internet. When two ISPs connect, they typically use BGP to exchange routing information. The ISPs of the worldwide exchange routing information with one or more than one ISPs.

Autonomous system


An autonomous system is a collection of networks under a single technical administration domain. IGPs like OSPF EIGRP operate within an Autonomous system. We use BGP between the autonomous systems to exchange loop-free routing information.

Internal and External BGP


BGP defines as two classes of neighbors.
  1. Internal BGP (iBGP) operates within the same autonomous system.
  2. External BGP (E BGP) operates in between the multiple autonomous systems  
          

BGP features 




  • BGP is an open standard protocol
  • exterior gateway protocol designed for inter-AS domain routing to scale huge neter-network like the internet 
  • It supports classless, VLSM, CIDR, auto, and manual summary 
  • updates are incremental and trigger BGP to send updates to manually defined neighbors as unicast.
  • BGP is an application layer protocol that uses TCP for reliability, TCP port 179
  • Metric is attributes
  • Administrative distance is 20 for external updates (EBGP) and 200 for internal updates (i BGP)

Types of ISP connections 

  • Single Homed
  • Dual-Homed sites
  • Multi-Homing
  • Dual Multi-Homing




Single homed 


Single homed a site with a single ISP connection is single-homed. A single homed is good for a site that does not depend heavily on Internet or WAN connectivity. you can advertise the site route or static routes and receive a default route from the internet service provider.




Dual-homed




 A Dual-homed site has two connections to the same ISP either from one router or two routers. one link might be primary and the other as backup, or the site might be load balancing over both the connections. we can use static or dynamic routing.

Multi-homed

 Multi-homing means having connecting links to one or more ISPs at the same time. it is done for redundancy and backup if one ISP fails and for better performance if one ISP provides a better path to frequently used networks. multi-homed also gives you an ISP-independent solution. BGP is typically used with multihomed connections.


Dual multi-homed

Dual multi-homed means having two connections with multiple ISPs. Dual multihomed gives you the most redundancy. BGP  is used with ISPs and can be implemented internally also.














 


 


Instagram

Facebook


Twitter



LINKEDIN








Saturday, 24 November 2018

What is Policy Based Routing (PBR)? How to configure PBR routing?


Policy-based routing is used for path manipulation. It is used for implementing a policy that causes the packet to take a different direction. Policy-based routing allows source-based routing. The routing table is the destination base.





In short: PBR is a technique used to make routing decisions based on policies implemented by the network administrator.

Here’s a list of some Advantages of policy-based routing:-
  • Different users can reach their destination from different directions
  • Load sharing
  • PBR will be implemented on the incoming direction of the source in the interface
  • If the packet matches in the route map and it is permitted it will be sent according to the policy
  • If the packet matches in the route map and the route map deny the packet will be forwarded according to the normal routing table



Lets configure policy based routing.

Topology:-

Goal:-


  • configure the topology as per our diagram
  • configure EIGRP 100 for all the routers, advertise all the interfaces as per the topology make sure the reachability between all the routers.
  • configure the bandwidth on serial 3/3 to 1000kbps and serial 3/0 remains the default bandwidth of 1544 kbps.
  • configure Policy Based Routing  on router 2 according to our given conditions 
  1. traffic sourced from 13.0.0.0/24, 13.0.1.0/24  should be forwarded on serial 3/0 interface
  2. traffic sourced from 13.0.2.0/24, 13.0.3.0/24 should be forwarded on serial 3/3 interface
  3. all the remaining traffic should use the default routing path 

Friday, 23 November 2018

What is Distribution-List ? How to configure?


Distribution lists

A distribution-list is used to control routing update either coming to your router or leaving from the router. Distribution-lists work on a variety of different IOS routing protocols like EIGRP, RIP, and OSPF. Distribution-list is one of the easiest ways to control routing updates, you can permit or deny routes using access-list or prefix-list or route map. Distribution-list can be applied to transmitted, received, or redistribute routing updates.

Each interface and routing process, Cisco IOS permits the following:

  • One incoming global distribute list
  • One outgoing global distribute list
  • One incoming interface distribute list
  • One outgoing interface distribute list
  • One outgoing redistribution distribute list


configuration:



Topology 




Goal:


  • configure topology as per our diagram and configure EIGRP 100
  • advertise all the interfaces in EIGRP 
  • configure router 3 deny 13.0.0.0/24 and 13.0.1.0/24 networks from being advertised to router 2 using distribution lists.



R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        10.1.1.1        YES manual up                    up
Serial3/0                    1.1.1.1         YES manual up                    up
Loopback0              11.0.0.1        YES manual up                    up
Loopback1              11.0.1.1        YES manual up                    up
Loopback2              11.0.2.1        YES manual up                    up
Loopback3              11.0.3.1        YES manual up                    up


R2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        20.1.1.1        YES manual up                    up
Serial3/0                     1.1.1.2         YES manual up                    up
Serial3/1                      2.2.2.1         YES manual up                    up
Loopback0              12.0.0.1        YES manual up                    up
Loopback1              12.0.1.1        YES manual up                    up
Loopback2              12.0.2.1        YES manual up                    up
Loopback3              12.0.3.1        YES manual up                    up

R3#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        30.1.1.1        YES manual up                    up
Serial3/1                    2.2.2.2         YES manual up                    up
Loopback0              13.0.0.1        YES manual up                    up
Loopback1              13.0.1.1        YES manual up                    up
Loopback2              13.0.2.1        YES manual up                    up
Loopback3              13.0.3.1        YES manual up                    up

R1(config)#router eigrp 100
R1(config-router)#network 1.0.0.0
R1(config-router)#network 10.0.0.0
R1(config-router)#network 11.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#end

R2(config)#router eigrp 100
R2(config-router)#network 1.0.0.0
R2(config-router)#network 2.0.0.0
R2(config-router)#network 20.0.0.0
R2(config-router)#network 12.0.0.0
R2(config-router)#no auto-summary

 R3(config)#router eigrp 100
R3(config-router)#network 2.0.0.0
R3(config-router)#network 30.0.0.0
R3(config-router)#network 13.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#end

R1#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

D     2.0.0.0/8 [90/2681856] via 1.1.1.2, 00:35:31, Serial3/0
      12.0.0.0/24 is subnetted, 4 subnets
D        12.0.0.0 [90/2297856] via 1.1.1.2, 00:49:36, Serial3/0
D        12.0.1.0 [90/2297856] via 1.1.1.2, 00:49:36, Serial3/0
D        12.0.2.0 [90/2297856] via 1.1.1.2, 00:49:36, Serial3/0
D        12.0.3.0 [90/2297856] via 1.1.1.2, 00:49:36, Serial3/0
      13.0.0.0/24 is subnetted, 4 subnets
D        13.0.0.0 [90/2809856] via 1.1.1.2, 00:35:31, Serial3/0
D        13.0.1.0 [90/2809856] via 1.1.1.2, 00:35:31, Serial3/0
D        13.0.2.0 [90/2809856] via 1.1.1.2, 00:35:31, Serial3/0
D        13.0.3.0 [90/2809856] via 1.1.1.2, 00:35:31, Serial3/0
D     20.0.0.0/8 [90/2172416] via 1.1.1.2, 00:49:42, Serial3/0
D     30.0.0.0/8 [90/2684416] via 1.1.1.2, 00:35:31, Serial3/0

R2#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

D     10.0.0.0/8 [90/2172416] via 1.1.1.1, 00:39:25, Serial3/0
      11.0.0.0/24 is subnetted, 4 subnets
D        11.0.0.0 [90/2297856] via 1.1.1.1, 00:39:25, Serial3/0
D        11.0.1.0 [90/2297856] via 1.1.1.1, 00:39:25, Serial3/0
D        11.0.2.0 [90/2297856] via 1.1.1.1, 00:39:25, Serial3/0
D        11.0.3.0 [90/2297856] via 1.1.1.1, 00:39:25, Serial3/0
      13.0.0.0/24 is subnetted, 4 subnets
D        13.0.0.0 [90/2297856] via 2.2.2.2, 00:36:01, Serial3/1
D        13.0.1.0 [90/2297856] via 2.2.2.2, 00:36:01, Serial3/1
D        13.0.2.0 [90/2297856] via 2.2.2.2, 00:36:01, Serial3/1
D        13.0.3.0 [90/2297856] via 2.2.2.2, 00:36:01, Serial3/1
D     30.0.0.0/8 [90/2172416] via 2.2.2.2, 00:36:01, Serial3/1

R3#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

D     1.0.0.0/8 [90/2681856] via 2.2.2.1, 00:36:22, Serial3/1
D     10.0.0.0/8 [90/2684416] via 2.2.2.1, 00:36:22, Serial3/1
      11.0.0.0/24 is subnetted, 4 subnets
D        11.0.0.0 [90/2809856] via 2.2.2.1, 00:36:22, Serial3/1
D        11.0.1.0 [90/2809856] via 2.2.2.1, 00:36:22, Serial3/1
D        11.0.2.0 [90/2809856] via 2.2.2.1, 00:36:22, Serial3/1
D        11.0.3.0 [90/2809856] via 2.2.2.1, 00:36:22, Serial3/1
      12.0.0.0/24 is subnetted, 4 subnets
D        12.0.0.0 [90/2297856] via 2.2.2.1, 00:36:22, Serial3/1
D        12.0.1.0 [90/2297856] via 2.2.2.1, 00:36:22, Serial3/1
D        12.0.2.0 [90/2297856] via 2.2.2.1, 00:36:22, Serial3/1
D        12.0.3.0 [90/2297856] via 2.2.2.1, 00:36:22, Serial3/1
D     20.0.0.0/8 [90/2172416] via 2.2.2.1, 00:36:22, Serial3/1


R3(config)#access-list 10 deny 13.0.0.0 0.0.0.255
R3(config)#access-list 10 deny 13.0.1.0 0.0.0.255
R3(config)#access-list 10 permit any

R3(config)#router eigrp 100
R3(config-router)#distribute-list 10 out serial 3/1

R2#sh ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

D     10.0.0.0/8 [90/2172416] via 1.1.1.1, 00:00:12, Serial3/0
      11.0.0.0/24 is subnetted, 4 subnets
D        11.0.0.0 [90/2297856] via 1.1.1.1, 00:00:12, Serial3/0
D        11.0.1.0 [90/2297856] via 1.1.1.1, 00:00:12, Serial3/0
D        11.0.2.0 [90/2297856] via 1.1.1.1, 00:00:12, Serial3/0
D        11.0.3.0 [90/2297856] via 1.1.1.1, 00:00:12, Serial3/0
      13.0.0.0/24 is subnetted, 2 subnets
D        13.0.2.0 [90/2297856] via 2.2.2.2, 00:00:12, Serial3/1
D        13.0.3.0 [90/2297856] via 2.2.2.2, 00:00:12, Serial3/1
D     30.0.0.0/8 [90/2172416] via 2.2.2.2, 00:00:12, Serial3/1
from the above output you can see there is no 13.0.0.1 and 13.0.1.1 route coming from router 3.

R3#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "eigrp 100"
  Outgoing update filter list for all interfaces is not set
    Serial3/1 filtered by 10 (per-user), default is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 Protocol for AS(100)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 30.1.1.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hop count 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    2.0.0.0
    13.0.0.0
    30.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    2.2.2.1               90      00:07:04
  Distance: internal 90 external 170



                                                                                                                                                                  

 


 


Instagram

Facebook


Twitter



LINKEDIN








Tuesday, 13 November 2018

Route filtering passive interface RIPv2


Route filtering passive interface

Cisco IOS provides several ways to control updates traffic. Passive interface, distribute list, prefix list route maps. In this section we take look at passive interface in RIPv2, EIGRP, and OSPF.
Passive interface command is used in al routing protocol to disable sending updates out from a specific interface. However the command behavior varies from one protocol to another.

Passive interface in RIPv2

In RIP passive interface command disable sending multicast updates via a specific interface. Allow listening to incoming updates from other RIPv2 speaking routers.

lets see the configure:

Topology:






Goal:
configure the topology as per the diagram
configure RIPv2 and advertise interfaces as per our topology
configure router 3 interface serial 3/1 as passive interface


R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        10.1.1.1        YES manual up                    up
Serial3/0                     1.1.1.1         YES manual up                    up


R2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        20.1.1.1        YES manual up                    up
Serial3/0                     1.1.1.2         YES manual up                    up
Serial3/1                     2.1.1.1         YES manual up                    up


R3#   show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        30.1.1.1        YES manual up                    up
Serial3/1                    2.1.1.2         YES manual up                    up
Loopback0              13.0.0.1        YES manual up                    up
Loopback1              13.0.1.1        YES manual up                    up
Loopback2              13.0.2.1        YES manual up                    up
Loopback3              13.0.3.1        YES manual up                    up

R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 1.0.0.0
R1(config-router)#network 10.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#end

R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 20.0.0.0
R2(config-router)#network 1.0.0.0
R2(config-router)#network 2.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#end

R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#network 13.0.0.0
R3(config-router)#network 2.0.0.0
R3(config-router)#network 30.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#end

R1#show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

R     2.0.0.0/8 [120/1] via 1.1.1.2, 00:00:02, Serial3/0
          13.0.0.0/24 is subnetted, 4 subnets
R        13.0.0.0 [120/2] via 1.1.1.2, 00:00:02, Serial3/0
R        13.0.1.0 [120/2] via 1.1.1.2, 00:00:02, Serial3/0
R        13.0.2.0 [120/2] via 1.1.1.2, 00:00:02, Serial3/0
R        13.0.3.0 [120/2] via 1.1.1.2, 00:00:02, Serial3/0
R     20.0.0.0/8 [120/1] via 1.1.1.2, 00:00:02, Serial3/0
R     30.0.0.0/8 [120/2] via 1.1.1.2, 00:00:02, Serial3/0

R2#show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

R     10.0.0.0/8 [120/1] via 1.1.1.1, 00:00:25, Serial3/0
      13.0.0.0/24 is subnetted, 4 subnets
R        13.0.0.0 [120/1] via 2.1.1.2, 00:00:17, Serial3/1
R        13.0.1.0 [120/1] via 2.1.1.2, 00:00:17, Serial3/1
R        13.0.2.0 [120/1] via 2.1.1.2, 00:00:17, Serial3/1
R        13.0.3.0 [120/1] via 2.1.1.2, 00:00:17, Serial3/1
R     30.0.0.0/8 [120/1] via 2.1.1.2, 00:00:17, Serial3/1

R3#show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

R     1.0.0.0/8 [120/1] via 2.1.1.1, 00:00:25, Serial3/1
R     10.0.0.0/8 [120/2] via 2.1.1.1, 00:00:25, Serial3/1
R     20.0.0.0/8 [120/1] via 2.1.1.1, 00:00:25, Serial3/1

R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#passive-interface serial 3/1
R3#clear ip route *

R3#show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

R     1.0.0.0/8 [120/1] via 2.1.1.1, 00:00:23, Serial3/1
R     10.0.0.0/8 [120/2] via 2.1.1.1, 00:00:23, Serial3/1
R     20.0.0.0/8 [120/1] via 2.1.1.1, 00:00:23, Serial3/1

R2#clear ip route *

R2#show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set


R     10.0.0.0/8 [120/1] via 1.1.1.1, 00:00:07, Serial3/0

(from the above output we can see aìfter configuring serial 3/1 as passive interface  router 3 stops sending RIP updates on router 2. but router 3 still getting update from router 2). 

What is BGP Allowas-in Feature? How to configure BGP Allowas-in? GNS3

  BGP Allowas-in is a configuration option in Border Gateway Protocol (BGP) routing that allows a router to accept routes with its own AS (A...