Saturday, 5 December 2020

What is PIM Spare-Dense Mode ? How to configure Multicasting PIM Spare-Dense Mode?

 

 PIM Spare-Dense Mode 

PIM (Protocol Independent Multicast) is a family of multicast routing protocols. The word independent comes from the fact that PIM does not build a topology of its own, it uses the information from IGP routing protocols to achieve this. 

There are a number of different PIM flavors:

·                      PIM Sparse-Mode 

·                      PIM Dense-Mode

·                      Bidirectional PIM 

·                      Source-Specific PIM.

 

PIM (Protocol Independent Multicast) Modes

 

PIM modes tell how the multicast tree is built from sender to receiver. PIM mode will decide how the tree is built, and who will receive traffic.

 

PIM supports three different modes:

 

 

1.             PIM Dense Mode

2.             PIM Sparse mode

3.             PIM Sparse-Dense mode

 

 

 

PIM Dense mode:- Dense mode forward multicast traffic on all interfaces until a downstream router requests us to stop forwarding.

 

Pim dense mode Uses implicit join get traffic even if not asked Also called as flood and prune.

PIM Dense Mode Suitable for small multicast implementation.  Default hello= 30 sec & dead= 90 sec Discover PIM neighbor (uses 224.0.0.13). Flood all the multicast traffic on all PIM enables interfaces Prune unwanted traffic to Maintain multicast table

 

 

PIM Sparse mode:-   (PIM-SM PIM Sparse Mode explicitly builds unidirectional shared trees rooted at an (RP) rendezvous point per group, and optionally creates shortest-path trees per source. (PIM-SM) PIM Sparse Mode generally scales fairly well for wide-area usage.


Sparse-mode protocol does not forward the group traffic to any other router unless it receives a message from that router requesting copies of a packet sent to a particular group.

 

The PIM spares mode operation begins with the packet being forwarded to a special router called the rendezvous point (RP).



PIM Sparse Mode uses explicit join means (not receive unless you ask for). PIM Sparse Mode uses both shared tree & source tree, more scalable

 


 PIM Sparse-Dense mode:- .

Let's talk about PIM Spare-Dense mode you can use spare mode or dense mode for each multicasting group. But here is the question comes why do we want to use this?

When we use PIM sparse mode, in our multicast routers we need to know where the RP (Rendezvous Point) is in the network and most important which groups they serve. But again we have a solution.

 There are two methods:

Static: configure the IP address of the RP on all multicast routers.

Dynamic: use Auto RP or BSR.

When we use PIM Sparse mode and Auto RP, the group-to-RP mapping is sent to the multicast 224.0.1.40 address wait a minute….. How do we receive traffic from 224.0.1.40 when we don’t know where the RP (Rendezvous Point) is? There are two methods to solve this:

Use the IP PIM auto RP listener command.

Use the PIM sparse-dense mode.

The IP PIM auto RP listener command floods auto RP 224.0.1.39 and 224.0.1.40 multicast groups on sparse mode interfaces, allowing all routers to receive the group-to-RP mapping information.

PIM sparse-dense mode also allows us to flood the auto RP 224.0.1.39 and 224.0.1.40 multicast groups but also, it also floods all multicast traffic that we don’t have an RP for.

 

 Let's see the configuration 

Topology:- 



`Goal :

1. configure the topology as per the diagram 

2. configure the IP addresses as per the topology 

3. configure OSPF 1 advertise the interfaces  

4. configure manually IGMP multicast  (224.5.5.5) group membership on router 5 for testing.

5. configure router 3 loopback (192.168.30.1) a static rendezvous point (RP) advertise in OSPF 1 with the mask /24. 

6. Make sure route 3 should be RP only for group 224.5.5.5

6. configure RP address on all the routers.

7. configure router 5 to join group 224.15.15.15 and ensure that router 1 should be able to ping the multicast group 224.50.50.50 without RP.


R1#show ip interface brief

Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        10.1.1.1        YES manual up                    up

Serial4/0                    1.1.1.1         YES manual up                    up

Serial4/3                    4.4.4.2         YES manual up                    up

Loopback0              192.168.10.1    YES manual up                    up

Loopback1              192.168.11.1    YES manual up                    up

Loopback2              192.168.12.1    YES manual up                    up

Loopback3              192.168.13.1    YES manual up                    up

R1(config-if)#exit


R2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        20.1.1.1        YES manual up                    up

Serial4/0              1.1.1.2         YES manual up                    up
Serial4/1              2.2.2.1         YES manual up                    up

Loopback0              192.168.20.1    YES manual up                    up
Loopback1              192.168.21.1    YES manual up                    up
Loopback2              192.168.22.1    YES manual up                    up
Loopback3              192.168.23.1    YES manual up                    up


R3#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        30.1.1.1        YES manual up                    up

Serial4/1              2.2.2.2         YES manual up                    up
Serial4/2              3.3.3.1         YES manual up                    up

Loopback0              192.168.30.1    YES manual up                    up
Loopback1              192.168.31.1    YES manual up                    up
Loopback2              192.168.32.1    YES manual up                    up
Loopback3              192.168.33.1    YES manual up                    up

R4#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        40.1.1.1        YES manual up                    up

Serial4/2              3.3.3.2         YES manual up                    up
Serial4/3              4.4.4.1         YES manual up                    up
Serial5/0              5.5.5.2         YES manual up                    up

Loopback1              192.168.41.1    YES manual up                    up
Loopback2              192.168.42.1    YES manual up                    up
Loopback3              192.168.43.1    YES manual up                    up


R5#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        50.1.1.1        YES manual up                    up
Serial5/0                    5.5.5.1         YES manual up                    up
Loopback0              15.0.0.1        YES manual up                    up
Loopback1              15.0.1.1        YES manual up                    up
Loopback2              15.0.2.1        YES manual up                    up
Loopback3              15.0.3.1        YES manual up                    up



R1(config)#router ospf 1
R1(config-router)#network 10.0.0.0 0.255.255.255  area 0
R1(config-router)#network 1.0.0.0 0.255.255.255 area 0
R1(config-router)#network 4.0.0.0 0.255.255.255  area 0
R1(config-router)#network 192.168.10.0 255.0.0.0 area 0
R1(config-router)#network 192.168.11.0 255.0.0.0 area 0
R1(config-router)#network 192.168.12.0 255.0.0.0 area 0
R1(config-router)#network 192.168.13.0 255.0.0.0 area 0
R1(config-router)#exit

*Dec  5 12:20:37.259: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.23.1 on Serial4/0 from LOADING to FULL, Loading Done


R2(config)#router ospf 1
R2(config-router)#network 1.0.0.0 0.255.255.255 area 0
R2(config-router)#network 20.0.0.0 0.255.255.255 area 0
R2(config-router)#network 2.0.0.0 0.255.255.255  area 0
R2(config-router)#network 192.168.20.0 255.0.0.0 area 0
R2(config-router)#network 192.168.21.0 255.0.0.0 area 0
R2(config-router)#network 192.168.22.0 255.0.0.0 area 0
R2(config-router)#network 192.168.23.0 255.0.0.0 area 0
R2(config-router)#exit


*Dec  5 12:19:47.011: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.13.1 on Serial4/0 from LOADING to FULL, Loading Done

*Dec  5 12:21:04.115: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.33.1 on Serial4/1 from LOADING to FULL, Loading  Done


R3(config)#router ospf 1
R3(config-router)#network 2.0.0.0 0.255.255.255 area 0
R3(config-router)#network 30.0.0.0 0.255.255.255 area 0
R3(config-router)#network 3.0.0.0 0.255.255.255  area 0
R3(config-router)#network 192.168.30.0 255.0.0.0 area 0
R3(config-router)#network 192.168.31.0 255.0.0.0 area 0
R3(config-router)#network 192.168.32.0 255.0.0.0 area 0
R3(config-router)#network 192.168.33.0 255.0.0.0 area 0
R3(config-router)#exit

*Dec  5 12:20:24.231: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.23.1 on Serial4/1 from LOADING to FULL, Loading Done

*Dec  5 12:24:51.491: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.43.1 on Serial4/2 from LOADING to FULL, Loading Done


R4(config)#router ospf 1
R4(config-router)#network 5.0.0.0 0.255.255.255 area 0
R4(config-router)#network 3.0.0.0 0.255.255.255 area 0
R4(config-router)#network 4.0.0.0 0.255.255.255  area 0
R4(config-router)#network 40.0.0.0 0.255.255.255 area 0
R4(config-router)#network 192.168.40.0 255.0.0.0 area 0
R4(config-router)#network 192.168.41.0 255.0.0.0 area 0
R4(config-router)#network 192.168.42.0 255.0.0.0 area 0
R4(config-router)#network 192.168.43.0 255.0.0.0 area 0
R4(config-router)#exit

*Dec  5 12:27:51.511: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.33.1 on Serial4/2 from LOADING to FULL, Loading  Done

*Dec  5 12:27:51.511: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.13.1 on Serial4/3 from LOADING to FULL, Loading  Done

*Dec  5 12:32:40.055: %OSPF-5-ADJCHG: Process 1, Nbr 15.0.3.1 on Serial5/0 from LOADING to FULL, Loading Done

R5(config)#router ospf 1
R5(config-router)#network 5.0.0.0 0.255.255.255 area 0
R5(config-router)#network 50.0.0.0 0.255.255.255 area 0
R5(config-router)#network 15.0.0.0  255.0.0.0 area 0
R5(config-router)#network  15.0.1.0  255.0.0.0 area 0
R5(config-router)#network 15.0.2.0  255.0.0.0 area 0
R5(config-router)#network 15.0.3.0  255.0.0.0 area 0
R5(config-router)#end

*Dec  5 12:33:10.787: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.43.1 on Serial5/0 from LOADING to FULL, Loading Done


R1#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

O     2.0.0.0/8 [110/128] via 1.1.1.2, 01:31:38, Serial4/0
O     3.0.0.0/8 [110/128] via 4.4.4.1, 01:25:54, Serial4/3
O     5.0.0.0/8 [110/128] via 4.4.4.1, 01:25:54, Serial4/3
      15.0.0.0/32 is subnetted, 4 subnets
O        15.0.0.1 [110/129] via 4.4.4.1, 01:21:05, Serial4/3
O        15.0.1.1 [110/129] via 4.4.4.1, 01:21:05, Serial4/3
O        15.0.2.1 [110/129] via 4.4.4.1, 01:21:05, Serial4/3
O        15.0.3.1 [110/129] via 4.4.4.1, 01:21:05, Serial4/3
O     20.0.0.0/8 [110/65] via 1.1.1.2, 01:31:38, Serial4/0
O     30.0.0.0/8 [110/129] via 4.4.4.1, 01:19:55, Serial4/3
                 [110/129] via 1.1.1.2, 01:19:55, Serial4/0
O     40.0.0.0/8 [110/65] via 4.4.4.1, 01:19:33, Serial4/3
O     50.0.0.0/8 [110/129] via 4.4.4.1, 01:21:05, Serial4/3
      192.168.20.0/32 is subnetted, 1 subnets
O        192.168.20.1 [110/65] via 1.1.1.2, 01:31:38, Serial4/0
      192.168.21.0/32 is subnetted, 1 subnets
O        192.168.21.1 [110/65] via 1.1.1.2, 01:31:38, Serial4/0
      192.168.22.0/32 is subnetted, 1 subnets
O        192.168.22.1 [110/65] via 1.1.1.2, 01:31:38, Serial4/0
      192.168.23.0/32 is subnetted, 1 subnets
O        192.168.23.1 [110/65] via 1.1.1.2, 01:31:38, Serial4/0
O     192.168.30.0/24 [110/129] via 4.4.4.1, 01:11:06, Serial4/3
                      [110/129] via 1.1.1.2, 01:11:06, Serial4/0
      192.168.31.0/32 is subnetted, 1 subnets
O        192.168.31.1 [110/129] via 4.4.4.1, 01:25:54, Serial4/3
                      [110/129] via 1.1.1.2, 01:30:21, Serial4/0
      192.168.32.0/32 is subnetted, 1 subnets
O        192.168.32.1 [110/129] via 4.4.4.1, 01:25:54, Serial4/3
                      [110/129] via 1.1.1.2, 01:30:21, Serial4/0
      192.168.33.0/32 is subnetted, 1 subnets
O        192.168.33.1 [110/129] via 4.4.4.1, 01:25:54, Serial4/3
                      [110/129] via 1.1.1.2, 01:30:21, Serial4/0
      192.168.41.0/32 is subnetted, 1 subnets
O        192.168.41.1 [110/65] via 4.4.4.1, 01:25:54, Serial4/3
      192.168.42.0/32 is subnetted, 1 subnets
O        192.168.42.1 [110/65] via 4.4.4.1, 01:25:54, Serial4/3
      192.168.43.0/32 is subnetted, 1 subnets
O        192.168.43.1 [110/65] via 4.4.4.1, 01:25:54, Serial4/3


R2#show ip route ospf 1
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

O     3.0.0.0/8 [110/128] via 2.2.2.2, 01:31:09, Serial4/1
O     4.0.0.0/8 [110/128] via 1.1.1.1, 01:32:27, Serial4/0
O     5.0.0.0/8 [110/192] via 2.2.2.2, 01:26:42, Serial4/1
                [110/192] via 1.1.1.1, 01:26:42, Serial4/0
O     10.0.0.0/8 [110/65] via 1.1.1.1, 01:21:27, Serial4/0
      15.0.0.0/32 is subnetted, 4 subnets
O        15.0.0.1 [110/193] via 2.2.2.2, 01:21:53, Serial4/1
                  [110/193] via 1.1.1.1, 01:21:53, Serial4/0
O        15.0.1.1 [110/193] via 2.2.2.2, 01:21:53, Serial4/1
                  [110/193] via 1.1.1.1, 01:21:53, Serial4/0
O        15.0.2.1 [110/193] via 2.2.2.2, 01:21:53, Serial4/1
                  [110/193] via 1.1.1.1, 01:21:53, Serial4/0
O        15.0.3.1 [110/193] via 2.2.2.2, 01:21:53, Serial4/1
                  [110/193] via 1.1.1.1, 01:21:53, Serial4/0
O     30.0.0.0/8 [110/65] via 2.2.2.2, 01:20:44, Serial4/1
O     40.0.0.0/8 [110/129] via 2.2.2.2, 01:20:21, Serial4/1
                 [110/129] via 1.1.1.1, 01:20:21, Serial4/0
O     50.0.0.0/8 [110/193] via 2.2.2.2, 01:21:53, Serial4/1
                 [110/193] via 1.1.1.1, 01:21:53, Serial4/0
      192.168.10.0/32 is subnetted, 1 subnets
O        192.168.10.1 [110/65] via 1.1.1.1, 01:32:27, Serial4/0
      192.168.11.0/32 is subnetted, 1 subnets
O        192.168.11.1 [110/65] via 1.1.1.1, 01:32:27, Serial4/0
      192.168.12.0/32 is subnetted, 1 subnets
O        192.168.12.1 [110/65] via 1.1.1.1, 01:32:27, Serial4/0
      192.168.13.0/32 is subnetted, 1 subnets
O        192.168.13.1 [110/65] via 1.1.1.1, 01:32:27, Serial4/0
O     192.168.30.0/24 [110/65] via 2.2.2.2, 01:11:55, Serial4/1
      192.168.31.0/32 is subnetted, 1 subnets
O        192.168.31.1 [110/65] via 2.2.2.2, 01:31:09, Serial4/1
      192.168.32.0/32 is subnetted, 1 subnets
O        192.168.32.1 [110/65] via 2.2.2.2, 01:31:09, Serial4/1
      192.168.33.0/32 is subnetted, 1 subnets
O        192.168.33.1 [110/65] via 2.2.2.2, 01:31:09, Serial4/1
      192.168.41.0/32 is subnetted, 1 subnets
O        192.168.41.1 [110/129] via 2.2.2.2, 01:26:42, Serial4/1
                      [110/129] via 1.1.1.1, 01:26:42, Serial4/0
      192.168.42.0/32 is subnetted, 1 subnets
O        192.168.42.1 [110/129] via 2.2.2.2, 01:26:42, Serial4/1
                      [110/129] via 1.1.1.1, 01:26:42, Serial4/0
      192.168.43.0/32 is subnetted, 1 subnets
O        192.168.43.1 [110/129] via 2.2.2.2, 01:26:42, Serial4/1
                      [110/129] via 1.1.1.1, 01:26:42, Serial4/0


R3(config)#interface loopback 0
R3(config-if)#ip ospf network point-to-point
R3(config-if)#exit


R3#show ip route ospf 1
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

O     1.0.0.0/8 [110/128] via 2.2.2.1, 01:31:57, Serial4/1
O     4.0.0.0/8 [110/128] via 3.3.3.2, 01:27:29, Serial4/2
O     5.0.0.0/8 [110/128] via 3.3.3.2, 01:27:29, Serial4/2
O     10.0.0.0/8 [110/129] via 3.3.3.2, 01:22:15, Serial4/2
                 [110/129] via 2.2.2.1, 01:22:15, Serial4/1
      15.0.0.0/32 is subnetted, 4 subnets
O        15.0.0.1 [110/129] via 3.3.3.2, 01:22:41, Serial4/2
O        15.0.1.1 [110/129] via 3.3.3.2, 01:22:41, Serial4/2
O        15.0.2.1 [110/129] via 3.3.3.2, 01:22:41, Serial4/2
O        15.0.3.1 [110/129] via 3.3.3.2, 01:22:41, Serial4/2
O     20.0.0.0/8 [110/65] via 2.2.2.1, 01:31:57, Serial4/1
O     40.0.0.0/8 [110/65] via 3.3.3.2, 01:21:08, Serial4/2
O     50.0.0.0/8 [110/129] via 3.3.3.2, 01:22:41, Serial4/2
      192.168.10.0/32 is subnetted, 1 subnets
O        192.168.10.1 [110/129] via 3.3.3.2, 01:27:29, Serial4/2
                      [110/129] via 2.2.2.1, 01:31:57, Serial4/1
      192.168.11.0/32 is subnetted, 1 subnets
O        192.168.11.1 [110/129] via 3.3.3.2, 01:27:29, Serial4/2
                      [110/129] via 2.2.2.1, 01:31:57, Serial4/1
      192.168.12.0/32 is subnetted, 1 subnets
O        192.168.12.1 [110/129] via 3.3.3.2, 01:27:29, Serial4/2
                      [110/129] via 2.2.2.1, 01:31:57, Serial4/1
      192.168.13.0/32 is subnetted, 1 subnets
O        192.168.13.1 [110/129] via 3.3.3.2, 01:27:29, Serial4/2
                      [110/129] via 2.2.2.1, 01:31:57, Serial4/1
      192.168.20.0/32 is subnetted, 1 subnets
O        192.168.20.1 [110/65] via 2.2.2.1, 01:31:57, Serial4/1
      192.168.21.0/32 is subnetted, 1 subnets
O        192.168.21.1 [110/65] via 2.2.2.1, 01:31:57, Serial4/1
      192.168.22.0/32 is subnetted, 1 subnets
O        192.168.22.1 [110/65] via 2.2.2.1, 01:31:57, Serial4/1
      192.168.23.0/32 is subnetted, 1 subnets
O        192.168.23.1 [110/65] via 2.2.2.1, 01:31:57, Serial4/1
      192.168.41.0/32 is subnetted, 1 subnets
O        192.168.41.1 [110/65] via 3.3.3.2, 01:27:29, Serial4/2
      192.168.42.0/32 is subnetted, 1 subnets
O        192.168.42.1 [110/65] via 3.3.3.2, 01:27:29, Serial4/2
      192.168.43.0/32 is subnetted, 1 subnets
O        192.168.43.1 [110/65] via 3.3.3.2, 01:27:29, Serial4/2



R4#show ip route ospf 1
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

O     1.0.0.0/8 [110/128] via 4.4.4.2, 01:27:58, Serial4/3
O     2.0.0.0/8 [110/128] via 3.3.3.1, 01:27:58, Serial4/2
O     10.0.0.0/8 [110/65] via 4.4.4.2, 01:22:43, Serial4/3
      15.0.0.0/32 is subnetted, 4 subnets
O        15.0.0.1 [110/65] via 5.5.5.1, 01:23:09, Serial5/0
O        15.0.1.1 [110/65] via 5.5.5.1, 01:23:09, Serial5/0
O        15.0.2.1 [110/65] via 5.5.5.1, 01:23:09, Serial5/0
O        15.0.3.1 [110/65] via 5.5.5.1, 01:23:09, Serial5/0
O     20.0.0.0/8 [110/129] via 4.4.4.2, 01:27:58, Serial4/3
                 [110/129] via 3.3.3.1, 01:27:58, Serial4/2
O     30.0.0.0/8 [110/65] via 3.3.3.1, 01:22:00, Serial4/2
O     50.0.0.0/8 [110/65] via 5.5.5.1, 01:23:09, Serial5/0
      192.168.10.0/32 is subnetted, 1 subnets
O        192.168.10.1 [110/65] via 4.4.4.2, 01:27:58, Serial4/3
      192.168.11.0/32 is subnetted, 1 subnets
O        192.168.11.1 [110/65] via 4.4.4.2, 01:27:58, Serial4/3
      192.168.12.0/32 is subnetted, 1 subnets
O        192.168.12.1 [110/65] via 4.4.4.2, 01:27:58, Serial4/3
      192.168.13.0/32 is subnetted, 1 subnets
O        192.168.13.1 [110/65] via 4.4.4.2, 01:27:58, Serial4/3
      192.168.20.0/32 is subnetted, 1 subnets
O        192.168.20.1 [110/129] via 4.4.4.2, 01:27:58, Serial4/3
                      [110/129] via 3.3.3.1, 01:27:58, Serial4/2
      192.168.21.0/32 is subnetted, 1 subnets
O        192.168.21.1 [110/129] via 4.4.4.2, 01:27:58, Serial4/3
                      [110/129] via 3.3.3.1, 01:27:58, Serial4/2
      192.168.22.0/32 is subnetted, 1 subnets
O        192.168.22.1 [110/129] via 4.4.4.2, 01:27:58, Serial4/3
                      [110/129] via 3.3.3.1, 01:27:58, Serial4/2
      192.168.23.0/32 is subnetted, 1 subnets
O        192.168.23.1 [110/129] via 4.4.4.2, 01:27:58, Serial4/3
                      [110/129] via 3.3.3.1, 01:27:58, Serial4/2
O     192.168.30.0/24 [110/65] via 3.3.3.1, 01:13:11, Serial4/2
      192.168.31.0/32 is subnetted, 1 subnets
O        192.168.31.1 [110/65] via 3.3.3.1, 01:27:58, Serial4/2
      192.168.32.0/32 is subnetted, 1 subnets
O        192.168.32.1 [110/65] via 3.3.3.1, 01:27:58, Serial4/2
      192.168.33.0/32 is subnetted, 1 subnets
O        192.168.33.1 [110/65] via 3.3.3.1, 01:27:58, Serial4/2



R5#show ip route ospf 1
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

O     1.0.0.0/8 [110/192] via 5.5.5.2, 01:23:43, Serial5/0
O     2.0.0.0/8 [110/192] via 5.5.5.2, 01:23:43, Serial5/0
O     3.0.0.0/8 [110/128] via 5.5.5.2, 01:23:43, Serial5/0
O     4.0.0.0/8 [110/128] via 5.5.5.2, 01:23:43, Serial5/0
O     10.0.0.0/8 [110/129] via 5.5.5.2, 01:23:16, Serial5/0
O     20.0.0.0/8 [110/193] via 5.5.5.2, 01:23:43, Serial5/0
O     30.0.0.0/8 [110/129] via 5.5.5.2, 01:22:33, Serial5/0
O     40.0.0.0/8 [110/65] via 5.5.5.2, 01:22:10, Serial5/0
      192.168.10.0/32 is subnetted, 1 subnets
O        192.168.10.1 [110/129] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.11.0/32 is subnetted, 1 subnets
O        192.168.11.1 [110/129] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.12.0/32 is subnetted, 1 subnets
O        192.168.12.1 [110/129] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.13.0/32 is subnetted, 1 subnets
O        192.168.13.1 [110/129] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.20.0/32 is subnetted, 1 subnets
O        192.168.20.1 [110/193] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.21.0/32 is subnetted, 1 subnets
O        192.168.21.1 [110/193] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.22.0/32 is subnetted, 1 subnets
O        192.168.22.1 [110/193] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.23.0/32 is subnetted, 1 subnets
O        192.168.23.1 [110/193] via 5.5.5.2, 01:23:43, Serial5/0
O     192.168.30.0/24 [110/129] via 5.5.5.2, 01:13:43, Serial5/0
      192.168.31.0/32 is subnetted, 1 subnets
O        192.168.31.1 [110/129] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.32.0/32 is subnetted, 1 subnets
O        192.168.32.1 [110/129] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.33.0/32 is subnetted, 1 subnets
O        192.168.33.1 [110/129] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.41.0/32 is subnetted, 1 subnets
O        192.168.41.1 [110/65] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.42.0/32 is subnetted, 1 subnets
O        192.168.42.1 [110/65] via 5.5.5.2, 01:23:43, Serial5/0
      192.168.43.0/32 is subnetted, 1 subnets
O        192.168.43.1 [110/65] via 5.5.5.2, 01:23:43, Serial5/0

R1(config)#ip multicast-routing
R1(config)#access-list 5 permit host 224.5.5.5
R1(config)#ip pim rp-address 192.168.30.1 5
R1(config)#exit


*Dec  5 12:46:07.499: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up

R1(config)#interface serial 4/3
R1(config-if)#ip pim sparse-dense-mode
R1(config-if)#exit

*Dec  5 12:48:17.707: %PIM-5-NBRCHG: neighbor 1.1.1.2 UP on interface Serial4/0

*Dec  5 12:49:29.379: %PIM-5-NBRCHG: neighbor 4.4.4.1 UP on interface Serial4/3

R2(config)#ip multicast-routing
R2(config)#access-list 5 permit host 224.5.5.5
R2(config)#ip pim rp-address 192.168.30.1 5
R2(config)#exit


R2(config)#interface serial 4/0
R2(config-if)#ip pim sparse-dense-mode
R2(config-if)#exit


R2(config)#interface serial 4/1
R2(config-if)#ip pim sparse-dense-mode
R2(config-if)#exit

*Dec  5 12:47:27.207: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up
*Dec  5 12:47:27.323: %PIM-5-NBRCHG: neighbor 1.1.1.1 UP on interface Serial4/0



R3(config)#interface loopback 0
R3(config-if)#ip ospf network point-to-point
R3(config-if)#exit

R3(config)#ip multicast-routing
R3(config)#access-list 5 permit host 224.5.5.5
R3(config)#ip pim rp-address 192.168.30.1 5
R3(config)#exit

*Dec  5 12:43:03.315: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down

*Dec  5 12:43:03.395: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel1, changed state to up

R3(config)#interface serial 4/2
R3(config-if)#ip pim sparse-dense-mode
R3(config-if)#exit

R3(config)#interface serial 4/1
R3(config-if)#ip pim sparse-dense-mode
R3(config-if)#exit

*Dec  5 12:47:14.287: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up
*Dec  5 12:47:14.763: %PIM-5-NBRCHG: neighbor 2.2.2.1 UP on interface Serial4/1

*Dec  5 12:47:58.711: %PIM-5-NBRCHG: neighbor 3.3.3.2 UP on interface Serial4/2

R4(config)#ip multicast-routing
R4(config)#access-list 5 permit host 224.5.5.5
R4(config)#ip pim rp-address 192.168.30.1 5
R4(config)#exit

R4(config)#interface serial 4/3
R4(config-if)#ip pim sparse-dense-mode
R4(config-if)#exit


*Dec  5 12:46:07.611: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down


R4(config)#interface serial 4/2
R4(config-if)#ip pim sparse-dense-mode
R4(config-if)#exit

*Dec  5 12:50:58.511: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to upal 4/3


R4(config)#interface serial 5/0
R4(config-if)#ip pim sparse-dense-mode
R4(config-if)#exit

*Dec  5 12:50:58.627: %PIM-5-NBRCHG: neighbor 3.3.3.1 UP on interface Serial4/2
*Dec  5 12:50:59.063: %PIM-5-NBRCHG: neighbor 4.4.4.2 UP on interface Serial4/3
*Dec  5 12:51:18.067: %PIM-5-NBRCHG: neighbor 5.5.5.1 UP on interface Serial5/0

R5(config)#ip multicast-routing
R5(config)#interface fastethernet 0/0
R5(config-if)#ip igmp join-group 224.5.5.5
R5(config-if)#exit

R5(config)#access-list 5 permit host 224.5.5.5
R5(config)#ip pim rp-address 192.168.30.1 5
R5(config)#exit

*Dec  5 12:46:42.247: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down

R5(config)#interface serial 5/0
R5(config-if)#ip pim sparse-dense-mode
R5(config-if)#exit

*Dec  5 12:51:48.647: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up
*Dec  5 12:51:48.755: %PIM-5-NBRCHG: neighbor 5.5.5.2 UP on interface Serial5/0

R5(config)#interface fastEthernet 0/0
R5(config-if)#ip igmp join-group 224.15.15.15
R5(config-if)#exit

R1#show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
1.1.1.1          Serial4/0                v2/SD  1      30     1      0.0.0.0
4.4.4.2          Serial4/3                v2/SD  1      30     1      0.0.0.0


R1#show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
1.1.1.2           Serial4/0                01:31:36/00:01:37 v2    1 / S P G
4.4.4.1           Serial4/3                01:30:25/00:01:24 v2    1 / S P G

R2#show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
1.1.1.2          Serial4/0                v2/SD  1      30     1      0.0.0.0
2.2.2.1          Serial4/1                v2/SD  1      30     1      0.0.0.0

R2#  show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
1.1.1.1           Serial4/0                01:32:21/00:01:20 v2    1 / S P G
2.2.2.2           Serial4/1                01:31:54/00:01:25 v2    1 / S P G



R3#show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
3.3.3.1          Serial4/2                v2/SD  1      30     1      0.0.0.0
2.2.2.2          Serial4/1                v2/SD  1      30     1      0.0.0.0

R3#  show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
3.3.3.2           Serial4/2                01:31:13/00:01:31 v2    1 / S P G
2.2.2.1           Serial4/1                01:31:57/00:01:21 v2    1 / S P G


R4#show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
3.3.3.2          Serial4/2                v2/SD  1      30     1      0.0.0.0
4.4.4.1          Serial4/3                v2/SD  1      30     1      0.0.0.0
5.5.5.2          Serial5/0                v2/SD  1      30     1      0.0.0.0

R4#  show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
3.3.3.1           Serial4/2                01:31:15/00:01:30 v2    1 / S P G
4.4.4.2           Serial4/3                01:31:14/00:01:35 v2    1 / S P G
5.5.5.1           Serial5/0                01:30:55/00:01:24 v2    1 / S P G


R5#show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
5.5.5.1          Serial5/0                v2/SD  1      30     1      0.0.0.0

R5#  show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
5.5.5.2           Serial5/0                01:30:57/00:01:24 v2    1 / S P G


R5(config)#interface fastEthernet 0/0
R5(config-if)#ip igmp join-group 224.15.15.15
R5(config-if)#exit

R1#ping 224.15.15.15 repeat 999
Type escape sequence to abort.
Sending 999, 100-byte ICMP Echos to 224.15.15.15, timeout is 2 seconds:

Reply to request 0 from 50.1.1.1, 260 ms
Reply to request 1 from 50.1.1.1, 64 ms
Reply to request 2 from 50.1.1.1, 28 ms
Reply to request 3 from 50.1.1.1, 44 ms
Reply to request 4 from 50.1.1.1, 44 ms
Reply to request 5 from 50.1.1.1, 40 ms
Reply to request 6 from 50.1.1.1, 36 ms
Reply to request 7 from 50.1.1.1, 24 ms
Reply to request 8 from 50.1.1.1, 24 ms
Reply to request 9 from 50.1.1.1, 36 ms
Reply to request 10 from 50.1.1.1, 40 ms
Reply to request 11 from 50.1.1.1, 16 ms
Reply to request 12 from 50.1.1.1, 36 ms
Reply to request 13 from 50.1.1.1, 20 ms
Reply to request 14 from 50.1.1.1, 32 ms
Reply to request 15 from 50.1.1.1, 52 ms
Reply to request 16 from 50.1.1.1, 36 ms
Reply to request 17 from 50.1.1.1, 16 ms
Reply to request 18 from 50.1.1.1, 12 ms
Reply to request 19 from 50.1.1.1, 40 ms
Reply to request 20 from 50.1.1.1, 24 ms
Reply to request 21 from 50.1.1.1, 40 ms
Reply to request 22 from 50.1.1.1, 36 ms
Reply to request 23 from 50.1.1.1, 20 ms
Reply to request 24 from 50.1.1.1, 24 ms
Reply to request 25 from 50.1.1.1, 20 ms
Reply to request 26 from 50.1.1.1, 36 ms
Reply to request 27 from 50.1.1.1, 20 ms
Reply to request 28 from 50.1.1.1, 16 ms
Reply to request 29 from 50.1.1.1, 36 ms
Reply to request 30 from 50.1.1.1, 36 ms
Reply to request 31 from 50.1.1.1, 32 ms

R1#ping 224.5.5.5
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.5.5.5, timeout is 2 seconds:

Reply to request 0 from 50.1.1.1, 172 ms
Reply to request 0 from 50.1.1.1, 232 ms

R1#ping 224.15.15.15
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.15.15.15, timeout is 2 seconds:

Reply to request 0 from 50.1.1.1, 172 ms



R2#ping 224.5.5.5
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.5.5.5, timeout is 2 seconds:

Reply to request 0 from 50.1.1.1, 116 ms
Reply to request 0 from 50.1.1.1, 180 ms

R2#ping 224.15.15.15
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.15.15.15, timeout is 2 seconds:

Reply to request 0 from 50.1.1.1, 112 ms
Reply to request 0 from 50.1.1.1, 136 ms


R3#ping 224.5.5.5
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.5.5.5, timeout is 2 seconds:

Reply to request 0 from 50.1.1.1, 172 ms
Reply to request 0 from 50.1.1.1, 184 ms
Reply to request 0 from 50.1.1.1, 172 ms

R3#ping 224.15.15.15
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.15.15.15, timeout is 2 seconds:

Reply to request 0 from 50.1.1.1, 108 ms

R4#ping 224.5.5.5
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.5.5.5, timeout is 2 seconds:

Reply to request 0 from 50.1.1.1, 56 ms
Reply to request 0 from 50.1.1.1, 232 ms
Reply to request 0 from 50.1.1.1, 212 ms

R4#ping 224.15.15.15
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.15.15.15, timeout is 2 seconds:

Reply to request 0 from 50.1.1.1, 60 ms

R1#show ip mroute 224.5.5.5
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.5.5.5), 00:25:37/stopped, RP 192.168.30.1, flags: SPF
  Incoming interface: Serial4/3, RPF nbr 4.4.4.1
  Outgoing interface list: Null

(4.4.4.1, 224.5.5.5), 00:02:14/00:00:45, flags: PFT
  Incoming interface: Serial4/3, RPF nbr 4.4.4.1, Registering
  Outgoing interface list: Null

R1#show ip mroute 224.15.15.15
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.15.15.15), 00:06:28/stopped, RP 0.0.0.0, flags: D
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial4/3, Forward/Sparse-Dense, 00:06:28/stopped
    Serial4/0, Forward/Sparse-Dense, 00:06:28/stopped

(3.3.3.2, 224.15.15.15), 00:02:22/00:00:37, flags: PT
  Incoming interface: Serial4/3, RPF nbr 4.4.4.1
  Outgoing interface list:
    Serial4/0, Prune/Sparse-Dense, 00:02:22/00:00:37, A

(4.4.4.1, 224.15.15.15), 00:02:22/00:00:37, flags: PT
  Incoming interface: Serial4/3, RPF nbr 4.4.4.1
  Outgoing interface list:
    Serial4/0, Prune/Sparse-Dense, 00:02:22/00:00:37




 

 

 

 

No comments:

What is PIM Spare-Dense Mode ? How to configure Multicasting PIM Spare-Dense Mode?

   PIM Spare-Dense Mode  PIM (Protocol Independent Multicast) is a family of multicast routing protocols. The word independent comes fr...