Pages

Saturday 29 May 2021

What is BGP RR Cluster ? How to configure Cluster RR server?

Route Reflector Cluster

A BGP enabled router or BGP speakers. By default BGP speakers routers does not advertise iBGP-learned prefixes to iBGP peers routers - this has to be done to maintain loop prevention. RFC4456 introduces the route reflection feature which help to  removes the need of full mesh configuration between iBGP speakers routers. When route reflector reflects a route, it creates and modifies an optional non-transitive attribute called CLUSTER_LIST by adding its own cluster ID to it. This attribute is used for loop prevention: when a BGP router receives update which CLUSTER_LIST contains router's own cluster ID, this update is discarded.

Route reflector

Route Reflector scalable alternative to an ibgp full mesh its allow a  BGP speaker (route reflector –RR) to advertise route received from an ibgp peer to other ibgp peers.

note:client update server. Server update to all the remaining clients.

All client should establish neighbor with only servers . client will not establish neighbor with any other client. In case if you have 2 servers ( server establish neighbor with other servers and clients).

Route reflector clusters

A group of redundant route reflector and their clients from a cluster. Route reflector rules divide a transit AS into smaller areas (called clusters). Each BGP cluster must have a unique cluster-id. Every time a prefixe is reflected, the cluster-id is added to the cluster-id BGP attribute. The prefixe that already contains the local cluster-id in the cluster-list is not reflector

Note:Each cluster contain route reflectors and  route reflector clients.

Lets see the configuration :-

Topology:



R1(config)#interface serial 4/0

R1(config-if)#ip address 1.1.1.1 255.0.0.0

R1(config-if)#no shutdown

R1(config-if)#exit

R1(config-if)#interface fastethernet 0/0

R1(config-if)#ip address 10.1.1.1 255.0.0.0

R1(config-if)#no shutdown

R1(config-if)#no keepalive

R1(config-if)#no shutdown

R1(config-if)#exit


R1(config)#interface fastEthernet 2/0

R1(config-if)#ip  address 14.1.1.1 255.0.0.0

R1(config-if)#no shutdown

R1(config-if)#exit


R1(config)#interface loopback 1

R1(config-if)#ip address 192.168.1.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#exit




R2(config)#interface serial 4/0

R2(config-if)#ip address 1.1.1.2 255.0.0.0

R2(config-if)#no shutdown

R2(config-if)#interface serial 4/1

R2(config-if)#ip address 3.3.3.1 255.0.0.0

R2(config-if)#no shutdown


R2(config-if)#interface fastethernet 0/0

R2(config-if)#ip address 20.1.1.1 255.0.0.0

R2(config-if)#no shutdown

R2(config-if)#no keepalive

R2(config-if)#exit


R2(config)#interface loopback 1

R2(config-if)#ip address 192.168.2.2 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)#exit



R3(config)#interface serial 4/1

R3(config-if)#ip address 3.3.3.2 255.0.0.0

R3(config-if)#no shutdown


R3(config-if)#interface fastethernet 0/0

R3(config-if)#ip address 30.1.1.1 255.0.0.0

R3(config-if)#no shutdown

R3(config-if)#no keepalive

R3(config-if)#exit


R3(config)#interface serial 4/3

R3(config-if)#ip address 5.5.5.1 255.0.0.0

R3(config-if)#no shutdown

R3(config-if)#exit


R3(config)#interface loopback 1

R3(config-if)#ip address 192.168.3.1 255.255.255.0

R3(config-if)#no shutdown

R3(config-if)#exit



R4(config)# interface serial 4/3
R4(config-if)#ip address 4.4.4.2 255.0.0.0
R4(config-if)#no shutdown
R4(config-if)#exit

R4(config)#interface fastEthernet 0/0
R4(config-if)#ip address 40.1.1.1 255.0.0.0
R4(config-if)#no shutdown
R4(config-if)#exit

R4(config)#interface loopback 1
R4(config-if)#ip address 192.168.4.1 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit

R5(config)#interface fastEthernet 0/0
R5(config-if)#ip address 50.1.1.1 255.0.0.0
R5(config-if)#no shutdown
R5(config-if)#no keepalive
R5(config-if)#exit

R5(config)#interface serial 4/3
R5(config-if)#ip address 5.5.5.2 255.0.0.0
R5(config-if)#no shutdown
R5(config-if)#exit

R5(config)#interface fastEthernet 2/0
R5(config-if)#ip address 35.1.1.2 255.0.0.0
R5(config-if)#no shutdown
R5(config-if)#exit

R5(config)#interface loopback 1
R5(config-if)#ip address 192.168.5.1 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#exit



R1(config)#router eigrp 65100
R1(config-router)#network 1.0.0.0
R1(config-router)#network 10.0.0.0
R1(config-router)#network 14.0.0.0
R1(config-router)#network 192.168.1.0
R1(config-router)#no auto-summary
R1(config-router)#exit


R2(config)#router eigrp 65100
R2(config-router)#network 20.0.0.0
R2(config-router)#network 1.0.0.0
R2(config-router)#network 1.0.0.0

*May 28 13:40:01.543: %DUAL-5-NBRCHANGE: EIGRP-IPv4 65100: Neighbor 1.1.1.1 (Serial4/0) is up: new adjacency

R2(config-router)#network 3.0.0.0
R2(config-router)#network 192.168.2.0
R2(config-router)#no auto-summary
R2(config-router)#exit

*May 28 13:41:21.191: %DUAL-5-NBRCHANGE: EIGRP-IPv4 65100: Neighbor 3.3.3.2 (Serial4/1) is up: new adjacency

R3(config)#router eigrp 65100
R3(config-router)#network 3.0.0.0

*May 28 13:40:41.283: %DUAL-5-NBRCHANGE: EIGRP-IPv4 65100: Neighbor 3.3.3.1 (Serial4/1) is up: new adjacency

R3(config-router)#network 35.0.0.0
R3(config-router)#network 192.168.3.0
R3(config-router)#network 30.0.0.0
R3(config-router)#network 2.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#exit

R4(config)#router eigrp 65100
R4(config-router)#network 14.0.0.0

*May 28 14:01:12.327: %DUAL-5-NBRCHANGE: EIGRP-IPv4 65100: Neighbor 14.1.1.1 (FastEthernet2/0) is up: new adjacency
R4(config-router)#network 192.168.4.0
R4(config-router)#network 40.0.0.0
R4(config-router)#no auto-summary
R4(config-router)#exit
R4(config)#end

R5(config)#router eigrp 65100
R5(config-router)#network 192.168.5.0
R5(config-router)#network 35.0.0.0

*May 28 13:52:02.671: %DUAL-5-NBRCHANGE: EIGRP-IPv4 65100: Neighbor 35.1.1.1 (FastEthernet2/0) is up: new adjacency

R5(config-router)#network 50.0.0.0
R5(config-router)#no auto-summary
R5(config-router)#exit
R5(config)#end

R1#show ip eigrp interfaces
EIGRP-IPv4 Interfaces for AS(65100)
                              Xmit Queue   PeerQ        Mean   Pacing Time   Multicast    Pending
Interface              Peers  Un/Reliable  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se4/0                    1        0/0       0/0          34       0/16         168           0
Fa0/0                    0        0/0       0/0           0       0/0            0           0
Fa2/0                    1        0/0       0/0          30       0/0          136           0
Lo1                      0        0/0       0/0           0       0/0            0           0
Se4/2                    1        0/0       0/0          36       0/16         176           0
R1#show ip ei
R1#show ip eigrp nei
R1#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(65100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
2   14.1.1.2                Fa2/0                    10 00:04:14   30   180  0  5
1   33.1.1.2                Se4/2                    12 00:21:19   36   216  0  24
0   1.1.1.2                 Se4/0                    12 00:26:25   34   204  0  25

R1#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

D     3.0.0.0/8 [90/2681856] via 33.1.1.2, 00:21:25, Serial4/2
                [90/2681856] via 1.1.1.2, 00:21:25, Serial4/0
D     20.0.0.0/8 [90/2172416] via 1.1.1.2, 00:21:25, Serial4/0
D     30.0.0.0/8 [90/2172416] via 33.1.1.2, 00:21:25, Serial4/2
D     35.0.0.0/8 [90/2172416] via 33.1.1.2, 00:21:25, Serial4/2
D     40.0.0.0/8 [90/30720] via 14.1.1.2, 00:04:02, FastEthernet2/0
D     50.0.0.0/8 [90/2174976] via 33.1.1.2, 00:15:15, Serial4/2
D     192.168.2.0/24 [90/2297856] via 1.1.1.2, 00:21:25, Serial4/0
D     192.168.3.0/24 [90/2297856] via 33.1.1.2, 00:21:25, Serial4/2
D     192.168.4.0/24 [90/156160] via 14.1.1.2, 00:04:09, FastEthernet2/0
D     192.168.5.0/24 [90/2300416] via 33.1.1.2, 00:15:28, Serial4/2




R2#show ip eigrp interface
EIGRP-IPv4 Interfaces for AS(65100)
                              Xmit Queue   PeerQ        Mean   Pacing Time   Multicast    Pending
Interface              Peers  Un/Reliable  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Fa0/0                    0        0/0       0/0           0       0/0            0           0
Se4/0                    1        0/0       0/0          31       0/16         148           0
Se4/1                    1        0/0       0/0          32       0/16         148           0
Lo1                      0        0/0       0/0           0       0/0            0           0



R2#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

D     10.0.0.0/8 [90/2172416] via 1.1.1.1, 00:21:58, Serial4/0
D     14.0.0.0/8 [90/2172416] via 1.1.1.1, 00:21:58, Serial4/0
D     30.0.0.0/8 [90/2172416] via 3.3.3.2, 00:21:58, Serial4/1
D     33.0.0.0/8 [90/2681856] via 3.3.3.2, 00:21:58, Serial4/1
                 [90/2681856] via 1.1.1.1, 00:21:58, Serial4/0
D     35.0.0.0/8 [90/2172416] via 3.3.3.2, 00:21:58, Serial4/1
D     40.0.0.0/8 [90/2174976] via 1.1.1.1, 00:04:35, Serial4/0
D     50.0.0.0/8 [90/2174976] via 3.3.3.2, 00:15:48, Serial4/1
D     192.168.1.0/24 [90/2297856] via 1.1.1.1, 00:21:58, Serial4/0
D     192.168.3.0/24 [90/2297856] via 3.3.3.2, 00:21:58, Serial4/1
D     192.168.4.0/24 [90/2300416] via 1.1.1.1, 00:04:43, Serial4/0
D     192.168.5.0/24 [90/2300416] via 3.3.3.2, 00:16:01, Serial4/1


R3#show ip eigrp neighbor
EIGRP-IPv4 Neighbors for AS(65100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
2   35.1.1.2                Fa2/0                    11 00:16:26   12   100  0  6
1   33.1.1.1                Se4/2                    14 00:22:21   39   234  0  24
0   3.3.3.1                 Se4/1                    10 00:26:07   46   276  0  24

R3#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

D     1.0.0.0/8 [90/2681856] via 33.1.1.1, 00:22:35, Serial4/2
                [90/2681856] via 3.3.3.1, 00:22:35, Serial4/1
D     10.0.0.0/8 [90/2172416] via 33.1.1.1, 00:22:35, Serial4/2
D     14.0.0.0/8 [90/2172416] via 33.1.1.1, 00:22:35, Serial4/2
D     20.0.0.0/8 [90/2172416] via 3.3.3.1, 00:22:35, Serial4/1
D     40.0.0.0/8 [90/2174976] via 33.1.1.1, 00:05:12, Serial4/2
D     50.0.0.0/8 [90/30720] via 35.1.1.2, 00:16:25, FastEthernet2/0
D     192.168.1.0/24 [90/2297856] via 33.1.1.1, 00:22:35, Serial4/2
D     192.168.2.0/24 [90/2297856] via 3.3.3.1, 00:22:35, Serial4/1
D     192.168.4.0/24 [90/2300416] via 33.1.1.1, 00:05:20, Serial4/2
D     192.168.5.0/24 [90/156160] via 35.1.1.2, 00:16:38, FastEthernet2/0

R4#show ip eigrp interface
EIGRP-IPv4 Interfaces for AS(65100)
                              Xmit Queue   PeerQ        Mean   Pacing Time   Multicast    Pending
Interface              Peers  Un/Reliable  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Fa2/0                    1        0/0       0/0        1047       0/0         5192           0
Lo1                      0        0/0       0/0           0       0/0            0           0
Fa0/0                    0        0/0       0/0           0       0/0            0           0

R4#show ip eigrp neighbor
EIGRP-IPv4 Neighbors for AS(65100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   14.1.1.1                Fa2/0                    14 00:05:52 1047  5000  0  25

R4#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

D     1.0.0.0/8 [90/2172416] via 14.1.1.1, 00:06:00, FastEthernet2/0
D     3.0.0.0/8 [90/2684416] via 14.1.1.1, 00:06:00, FastEthernet2/0
D     10.0.0.0/8 [90/30720] via 14.1.1.1, 00:06:00, FastEthernet2/0
D     20.0.0.0/8 [90/2174976] via 14.1.1.1, 00:06:00, FastEthernet2/0
D     30.0.0.0/8 [90/2174976] via 14.1.1.1, 00:06:00, FastEthernet2/0
D     33.0.0.0/8 [90/2172416] via 14.1.1.1, 00:06:00, FastEthernet2/0
D     35.0.0.0/8 [90/2174976] via 14.1.1.1, 00:06:00, FastEthernet2/0
D     50.0.0.0/8 [90/2177536] via 14.1.1.1, 00:06:00, FastEthernet2/0
D     192.168.1.0/24 [90/156160] via 14.1.1.1, 00:06:00, FastEthernet2/0
D     192.168.2.0/24 [90/2300416] via 14.1.1.1, 00:06:00, FastEthernet2/0
D     192.168.3.0/24 [90/2300416] via 14.1.1.1, 00:06:00, FastEthernet2/0
D     192.168.5.0/24 [90/2302976] via 14.1.1.1, 00:06:00, FastEthernet2/0

R5#show ip eigrp interfaces
EIGRP-IPv4 Interfaces for AS(65100)
                              Xmit Queue   PeerQ        Mean   Pacing Time   Multicast    Pending
Interface              Peers  Un/Reliable  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Lo1                      0        0/0       0/0           0       0/0            0           0
Fa2/0                    1        0/0       0/0          26       0/0          120           0
Fa0/0                    0        0/0       0/0           0       0/0            0           0

R5#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(65100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   35.1.1.1                Fa2/0                    14 00:17:32   26   156  0  23

R5#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

D     1.0.0.0/8 [90/2684416] via 35.1.1.1, 00:17:35, FastEthernet2/0
D     3.0.0.0/8 [90/2172416] via 35.1.1.1, 00:17:35, FastEthernet2/0
D     10.0.0.0/8 [90/2174976] via 35.1.1.1, 00:17:35, FastEthernet2/0
D     14.0.0.0/8 [90/2174976] via 35.1.1.1, 00:17:35, FastEthernet2/0
D     20.0.0.0/8 [90/2174976] via 35.1.1.1, 00:17:35, FastEthernet2/0
D     30.0.0.0/8 [90/30720] via 35.1.1.1, 00:17:35, FastEthernet2/0
D     33.0.0.0/8 [90/2172416] via 35.1.1.1, 00:17:35, FastEthernet2/0
D     40.0.0.0/8 [90/2177536] via 35.1.1.1, 00:06:08, FastEthernet2/0
D     192.168.1.0/24 [90/2300416] via 35.1.1.1, 00:17:35, FastEthernet2/0
D     192.168.2.0/24 [90/2300416] via 35.1.1.1, 00:17:35, FastEthernet2/0
D     192.168.3.0/24 [90/156160] via 35.1.1.1, 00:17:35, FastEthernet2/0
D     192.168.4.0/24 [90/2302976] via 35.1.1.1, 00:06:16, FastEthernet2/0

R1(config)#router bgp 6500
R1(config-router)#bgp router-id 192.168.1.1
R1(config-router)#neighbor 192.168.4.1 remote-as 6500
R1(config-router)#network 10.0.0.0
R1(config-router)#neighbor 192.168.4.1 update-source loopback 1
R1(config-router)#neighbor 192.168.4.1 route-reflector-client
R1(config-router)#exit

R2(config)#router bgp 6500
R2(config-router)#bgp router-id 192.168.2.1
R2(config-router)#neighbor 192.168.3.1 remote-as 6500
R2(config-router)#neighbor 192.168.3.1 update-source loopback 1
R2(config-router)#network 20.0.0.0
R2(config-router)#exit

*May 28 15:14:06.523: %BGP-5-ADJCHANGE: neighbor 192.168.3.1 Up

R3(config)#router bgp 6500
R3(config-router)#bgp router-id 192.168.3.1
R3(config-router)#neighbor 192.168.2.2 remote-as 6500
R3(config-router)#neighbor 192.168.2.2 update-source loopback 1
R3(config-router)#neighbor 192.168.2.2 route-reflector-client
R3(config-router)#neighbor 192.168.50.1 remote-as 6500
R3(config-router)#neighbor 192.168.5.1 remote-as 6500
R3(config-router)#neighbor 192.168.5.1 update-source loopback 1
R3(config-router)#neighbor 192.168.5.1 route-reflector-client
R3(config-router)#network 30.0.0.0 mask 255.0.0.0
R3(config-router)#exit


R4(config)#router bgp 6500
R4(config-router)#neighbor 192.168.1.1 remote-as 6500

*May 28 15:01:56.411: %BGP-5-ADJCHANGE: neighbor 192.168.1.1 Up

R4(config-router)#neighbor 192.168.1.1 update-source loopback 1
R4(config-router)#network 40.0.0.0
R4(config-router)#bgp router-id 192.168.4.1
R4(config-router)#exit


R5(config)#router bgp 6500
R5(config-router)#bgp router-id 192.168.5.1
R5(config-router)#neighbor 192.168.3.1 remote-as 6500

*May 28 15:05:30.131: %BGP-5-ADJCHANGE: neighbor 192.168.3.1 Up

R5(config-router)#neighbor 192.168.3.1 update-source loopback 1
R5(config-router)#network 50.0.0.0
R5(config-router)#exit


R1(config)#router bgp 6500
R1(config-router)#neighbor 192.168.3.1 remote-as 6500
R1(config-router)#neighbor 192.168.3.1 update-source loopback 1
R1(config-router)#neighbor 192.168.3.1 route-reflector-client

*May 28 15:17:56.747: %BGP-5-ADJCHANGE: neighbor 192.168.3.1 Up

R1(config-router)#exit

R3(config)#router bgp 6500
R3(config-router)#neighbor 192.168.1.1 remote-as 6500
R3(config-router)#neighbor 192.168.1.1 update-source loopback
R3(config-router)#neighbor 192.168.1.1 update-source loopback 1
R3(config-router)#neighbor 192.168.1.1 route-reflector-client

*May 28 15:16:01.771: %BGP-5-ADJCHANGE: neighbor 192.168.1.1 Up

R3(config-router)#exit

R1(config)#router bgp 6500
R1(config-router)#bgp cluster-id 10.10.10.10

*May 28 15:18:18.883: %BGP-5-NBR_RESET: Neighbor 192.168.3.1 reset (Cluster ID changed)
*May 28 15:18:18.887: %BGP-5-NBR_RESET: Neighbor 192.168.4.1 reset (Cluster ID changed)
*May 28 15:18:18.895: %BGP-5-ADJCHANGE: neighbor 192.168.3.1 Down Cluster ID changed
*May 28 15:18:18.899: %BGP_SESSION-5-ADJCHANGE: neighbor 192.168.3.1 IPv4 Unicast topology base removed from session  Cluster ID changed
*May 28 15:18:18.915: %BGP-5-ADJCHANGE: neighbor 192.168.4.1 Down Cluster ID changed
*May 28 15:18:18.919: %BGP_SESSION-5-ADJCHANGE: neighbor 192.168.4.1 IPv4 Unicast topology base removed from session  Cluster ID changed

*May 28 15:18:25.443: %BGP-5-ADJCHANGE: neighbor 192.168.3.1 Up
*May 28 15:18:26.343: %BGP-5-ADJCHANGE: neighbor 192.168.4.1 Up

R1(config-router)#exit

R3(config)#router bgp 6500
R3(config-router)#bgp cluster-id 30.30.30.30

*May 28 15:16:27.919: %BGP-5-NBR_RESET: Neighbor 192.168.1.1 reset (Cluster ID changed)
*May 28 15:16:27.923: %BGP-5-NBR_RESET: Neighbor 192.168.2.2 reset (Cluster ID changed)
*May 28 15:16:27.923: %BGP-5-NBR_RESET: Neighbor 192.168.5.1 reset (Cluster ID changed)
*May 28 15:16:27.935: %BGP-5-ADJCHANGE: neighbor 192.168.1.1 Down Cluster ID changed
*May 28 15:16:27.935: %BGP_SESSION-5-ADJCHANGE: neighbor 192.168.1.1 IPv4 Unicast topology base removed from session  Cluster ID changed
*May 28 15:16:27.943: %BGP-5-ADJCHANGE: neighbor 192.168.2.2 Down Cluster ID changed

*May 28 15:16:27.943: %BGP_SESSION-5-ADJCHANGE: neighbor 192.168.2.2 IPv4 Unicast topology base removed from session  Cluster ID changed
*May 28 15:16:27.951: %BGP-5-ADJCHANGE: neighbor 192.168.5.1 Down Cluster ID changed
*May 28 15:16:27.951: %BGP_SESSION-5-ADJCHANGE: neighbor 192.168.5.1 IPv4 Unicast topology base removed from session  Cluster ID changed

*May 28 15:16:35.027: %BGP-5-ADJCHANGE: neighbor 192.168.2.2 Up

*May 28 15:16:36.611: %BGP-5-ADJCHANGE: neighbor 192.168.1.1 Up

*May 28 15:16:39.919: %BGP-5-ADJCHANGE: neighbor 192.168.5.1 Up

R1#show ip bgp
BGP table version is 24, local router ID is 192.168.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  10.0.0.0         0.0.0.0                  0         32768 i
 r>i 20.0.0.0         192.168.2.2              0    100      0 i
 r>i 30.0.0.0         192.168.3.1              0    100      0 i
 r>i 40.0.0.0         192.168.4.1              0    100      0 i
 r>i 50.0.0.0         192.168.5.1              0    100      0 I

R1#show ip bgp summary
BGP router identifier 192.168.1.1, local AS number 6500


Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.168.3.1     4         6500      52      47       24    0    0 00:37:04        3
192.168.4.1     4         6500      45      51       24    0    0 00:37:03        1

R1#show ip bgp 50.1.1.1
BGP routing table entry for 50.0.0.0/8, version 21
Paths: (1 available, best #1, table default, RIB-failure(17))
  Advertised to update-groups:
     2
  Refresh Epoch 2
  Local, (Received from a RR-client)
    192.168.5.1 (metric 2812416) from 192.168.3.1 (192.168.3.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      Originator: 192.168.5.1, Cluster list: 30.30.30.30
      rx pathid: 0, tx pathid: 0x0



R2#show ip bgp
BGP table version is 18, local router ID is 192.168.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 r>i 10.0.0.0         192.168.1.1              0    100      0 i
 *>  20.0.0.0         0.0.0.0                  0         32768 i
 r>i 30.0.0.0         192.168.3.1              0    100      0 i
 r>i 40.0.0.0         192.168.4.1              0    100      0 i
 r>i 50.0.0.0         192.168.5.1              0    100      0 I

R2#show ip bgp summary
BGP router identifier 192.168.2.1, local AS number 6500


Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.168.3.1     4         6500      52      47       18    0    0 00:37:56        4

R2#show ip bgp 50.1.1.1
BGP routing table entry for 50.0.0.0/8, version 14
Paths: (1 available, best #1, table default, RIB-failure(17))
  Not advertised to any peer
  Refresh Epoch 1
  Local
    192.168.5.1 (metric 2300416) from 192.168.3.1 (192.168.3.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      Originator: 192.168.5.1, Cluster list: 30.30.30.30
      rx pathid: 0, tx pathid: 0x0


R3#show ip bgp
BGP table version is 22, local router ID is 192.168.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 r>i 10.0.0.0         192.168.1.1              0    100      0 i
 r>i 20.0.0.0         192.168.2.2              0    100      0 i
 *>  30.0.0.0         0.0.0.0                  0         32768 i
 r>i 40.0.0.0         192.168.4.1              0    100      0 i
 r>i 50.0.0.0         192.168.5.1              0    100      0 I

R3#show ip bgp summary
BGP router identifier 192.168.3.1, local AS number 6500
Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.168.1.1     4         6500      47      52       22    0    0 00:37:36        2
192.168.2.2     4         6500      47      53       22    0    0 00:38:07        1
192.168.5.1     4         6500      46      59       22    0    0 00:38:02        1

R3#show ip bgp 40.1.1.1
BGP routing table entry for 40.0.0.0/8, version 22
Paths: (1 available, best #1, table default, RIB-failure(17))
  Advertised to update-groups:
     3          4
  Refresh Epoch 1
  Local, (Received from a RR-client)
    192.168.4.1 (metric 2812416) from 192.168.1.1 (192.168.1.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      Originator: 192.168.4.1, Cluster list: 10.10.10.10
      rx pathid: 0, tx pathid: 0x0


R5#show ip bgp
BGP table version is 22, local router ID is 192.168.5.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 r>i 10.0.0.0         192.168.1.1              0    100      0 i
 r>i 20.0.0.0         192.168.2.2              0    100      0 i
 r>i 30.0.0.0         192.168.3.1              0    100      0 i
 r>i 40.0.0.0         192.168.4.1              0    100      0 i
 *>  50.0.0.0         0.0.0.0                  0         32768 I

R5#show ip bgp summary
BGP router identifier 192.168.5.1, local AS number 6500

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.168.3.1     4         6500      60      46       22    0    0 00:38:24        4

R5#show ip bgp 10.1.1.1
BGP routing table entry for 10.0.0.0/8, version 21
Paths: (1 available, best #1, table default, RIB-failure(17))
  Not advertised to any peer
  Refresh Epoch 3
  Local
    192.168.1.1 (metric 2812416) from 192.168.3.1 (192.168.3.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      Originator: 192.168.1.1, Cluster list: 30.30.30.30
      rx pathid: 0, tx pathid: 0x0

R4#traceroute 50.1.1.1
Type escape sequence to abort.
Tracing the route to 50.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 14.1.1.1 20 msec 96 msec 48 msec
  2 1.1.1.2 8 msec 20 msec 24 msec
  3 3.3.3.2 28 msec 36 msec 40 msec
  4 35.1.1.2 56 msec 56 msec 40 msec

R5#traceroute 40.1.1.1
Type escape sequence to abort.
Tracing the route to 40.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 35.1.1.1 60 msec 96 msec 24 msec
  2 3.3.3.1 12 msec 28 msec 32 msec
  3 1.1.1.1 64 msec 48 msec 48 msec
  4 14.1.1.2 248 msec 56 msec 44 msec












 


 


Instagram

Facebook


Twitter



LINKEDIN








No comments:

Post a Comment