Monday 17 December 2018

All the methods of Inter-Vlan Routing configuration



When you want to establish communication between different VLANs you will need a device that can do routing. You could use an external router with separate physical gateways or sub-interface (router on stick) method but it’s also possible to use a multilayer switch. 
The router must have a physical or logical connection to each VLAN so that it can forward packets between VLANs.





Let’s see the first method router with separate physical gateways:-

Topology:
Goal:

  • configure the topology as per our diagram  and  the assign the IP addresses.
  • create VLAN 101 sales and VLAN 102 marketing and assign the interfaces to their VLAN as per the diagram



Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.10.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 192.168.20.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Router#show ip interface brief
Interface               IP-Address       OK? Method    Status    Protocol

FastEthernet0/0    192.168.10.1    YES manual     up        up
FastEthernet         192.168.20.1    YES manual     up        up

Switch(config)#vlan 101
Switch(config-vlan)#name sales
Switch(config-vlan)#exit

Switch(config)#vlan 102
Switch(config-vlan)#name marketing
Switch(config-vlan)#exit

Switch(config)#interface range fastEthernet 0/1-2
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 101
Switch(config-if-range)#exit

Switch(config)#interface range fastEthernet 0/3-4
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 102

Switch(config-if-range)#exit



Switch(config)#interface fastEthernet 0/5
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 101
Switch(config-if)#exit

Switch(config)#interface fastEthernet 0/6
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 102

Switch(config-if)#exit

FROM HOST 1

lets see from HOST 4
FROM HOST 4




A router on stick can be used to route between VLANs using either ISL or IEEE 801.1Q as the trunking protocol. its requires sub-interface for each respective VLAN.

NOTE: whatever is your VLAN number its should be exact on sub-interface.

Let see the configuration using sub-interface (router on stick)

Topology:-


Goal:


  • configure the topology as per the diagram and assign the IP addresses 
  • configure VLAN 101 and VLAN 102
  • assign the port to their respective VLANs
  • configure sub-interfaces on router fast Ethernet 0/0 assign IP address as per the topology
  • ensure the connectivity between VLAN 101 and VLAN 102, make sure HOST 1 (VLAN 101) IS able to ping HOST 4 (VLAN 102).

Switch(config)#vlan 101
Switch(config-vlan)#name sales
Switch(config-vlan)#exit

Switch(config)#vlan 102
Switch(config-vlan)#name marketing
Switch(config-vlan)#exit

Switch(config)#interface range fastEthernet 0/1-2
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 101
Switch(config-if-range)#exit

Switch(config)#interface range fastEthernet 0/3-4
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 102

Switch(config-if-range)#exit



Switch(config)#interface fastEthernet 0/5
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport trunk allowed vlan 101,102

Switch(config-if)#exit

Router(config)#interface fastEthernet 0/0
Router(config-if)#no shutdown
Router(config-if)#exit

Router(config)#interface fastEthernet 0/0.101
Router(config-subif)#encapsulation dot1Q 101
Router(config-subif)#ip address 192.168.10.1 255.255.255.0
Router(config-subif)#exit

Router(config)#interface fastEthernet 0/0.102
Router(config-subif)#encapsulation dot1Q 102
Router(config-subif)#ip address 192.168.20.1 255.255.255.0

Router(config-subif)#exit

%LINK-5-CHANGED: Interface FastEthernet0/0.102, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.102, changed state to up

Router#show ip interface brief
Interface                         IP-Address          OK?      Method   Status          Protocol
FastEthernet0/0             unassigned          YES      manual      up                    up
FastEthernet0/0.101      192.168.10.1       YES      manual      up                    up

FastEthernet0/0.102      192.168.20.1       YES      manual      up                    up


from host 1


from host 4



Sunday 16 December 2018

Dynamic Trunking Protocol (DTP) and configuration

Cisco has implemented a proprietary, point-to-point protocol called Dynamic Trunking protocol (DTP) that negotiates a common trunking mode between two switches. DTP is used on Cisco IOS switches to negotiate if the interface should become an access port or trunk port.


By default Dynamic Trunking Protocol DTP is enabled and the interfaces of our switches will be in (dynamic auto) or (dynamic desirable) mode. Its means that whenever we receive a DTP packet that requests to form a trunk, your interface will be in trunk mode.



You should disable DTP negotiation if a switch has a trunk link connected a non-trunking router or firewall interface because those devices cannot participate in DTP negotiation.

(if you are not familiar with trunk link click Trunk Link and configuration ).

 Dynamic Trunking Protocol modes:-

1. Desirable
  • This mode is desire to become trunk. in other words this mode always want to be trunk. desirable mode sends and response (reply) to DTP messages. this mode can beecome a trunk is the other side of switch is set to trunk, dynamic desirable or dynamic auto mode.
2. Auto:


  • This mode only response  (reply) to DTP messages but it do not sent. auto mode is default mode  on most of the modern switches. auto mode it only become a trunk if the other switch link is set to trunk or dynamic desirable mode.
3. Trunk:
  • this mode configure manually by the command switchport mode trunk. this port also negotiates trunking with the port on the other side switch link.
4. Access:
  • This port is also configure manually by the command switchport mode access. access port is a end user port in a single VLAN.
5. NO-Negotiate:
  • this mode means DTP is disable, there is no DTP messages. the port is a trunk but does not do DTP negotiation with any side of the link.

                                         


 dynamic auto  
 dynamic desirable  
 Trunk
 Access
 dynamic auto
  access
  Trunk
  Trunk
 Access
 dynamic desirable
  Trunk
  Trunk
  Trunk
 Access
 Trunk
  Trunk
  Trunk
 Trunk
 limited connectivity (not recommended) 
 Access
 access
 access
 limited connectivity (not recommended)
 Access




NOTE: Configure trunk links statically whenever possible. The default DTP mode is dependent on the Cisco IOS Software version and on the platform.



let see the configuration:-

Topology:-

Goal:

  • configure the topology as per the diagram, configure VLAN 10 on both the switch and shift the port to  respective VLAN 10.
  • configure fastethernet 0/2 of switch 1 to actively negotiate the DTP messages and switch 2 fastethernet 0/2 port should reply to the DTP messages. make sure host 1 can communicate with his vlan 10 partner host 2 on other switch .




Switch(config)#hostname switch-1
switch-1(config)#vlan 10
switch-1(config-vlan)#name sales
switch-1(config-vlan)#exit

Switch(config)#hostname switch-2
switch-2(config)#vlan 10
switch-2(config-vlan)#name sales
switch-2(config-vlan)#exit

switch-1(config-if)#interface fastEthernet 0/1
switch-1(config-if)#switchport mode access
switch-1(config-if)#switchport access vlan 10
switch-1(config-if)#exit

switch-2(config)#interface fastEthernet 0/1
switch-2(config-if)#switchport mode access
switch-2(config-if)#switchport access vlan 10
switch-2(config-if)#exit



SWITCH -1




SWITCH - 2
switch-1#show interfaces fastEthernet 0/2 switchport
Name: Fa0/2
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: On

Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false

Appliance trust: none

switch-1(config)#interface fastEthernet 0/2

switch-1(config-if)#switchport mode ?
access Set trunking mode to ACCESS unconditionally
dynamic Set trunking mode to dynamically negotiate access or trunk mode
trunk Set trunking mode to TRUNK unconditionally

switch-1(config-if)#switchport mode dynamic ?
auto Set trunking mode dynamic negotiation parameter to AUTO
desirable Set trunking mode dynamic negotiation parameter to DESIRABLE

switch-1(config-if)#switchport mode dynamic desirable


%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down


%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up

switch-1#show interfaces fastEthernet 0/2 switchport
Name: Fa0/2
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false

Appliance trust: none


(from the above output you can see fastethernet 0/2 is become trunk via DTP negotiation process.)

switch-1#show interfaces trunk
Port          Mode          Encapsulation     Status     Native vlan
Fa0/       desirable          n-802.1q         trunking        1

Port Vlans allowed on trunk
Fa0/2 1-1005

Port Vlans allowed and active in management domain
Fa0/2 1,10

Port Vlans in spanning tree forwarding state and not pruned

Fa0/2 1,10

switch-2#show interfaces trunk
Port          Mode            Encapsulation     Status           Native vlan
Fa0/2       auto                 n-802.1q         trunking             1

Port Vlans allowed on trunk
Fa0/2 1-1005

Port Vlans allowed and active in management domain
Fa0/2 1,10

Port Vlans in spanning tree forwarding state and not pruned


Fa0/2 1,10

switch-1#show dtp
Global DTP information
Sending DTP Hello packets every 30 seconds
Dynamic Trunk timeout is 300 seconds

1 interfaces using DTP

switch-2#show dtp
Global DTP information
Sending DTP Hello packets every 30 seconds
Dynamic Trunk timeout is 300 seconds

1 interfaces using DTP

(let see the connectivity between host 1 and host 2 both are in same VLAN 10  but on different switches.)



from HOST 1


from HOST 2


 


 


Instagram

Facebook


Twitter



LINKEDIN








Saturday 15 December 2018

What is VLAN Trunking? How to configure?


A Trunk link is a point-to-point link between two network devices. Trunk link carry more than one VLAN. With VLAN trunking, we can extend our configured VLAN across the entire network. Remember, sending information from an access link on one VLAN to another VLAN is not possible without the additional device a router or a external layer 2 bridge connected between the VLAN.



A Trunk link can transport multiple VLANs traffic through a single switch port. A trunk link is not assigned to a specific VLAN.

Types of links/ports.

Access links
  • Connecting to end devices (hosts or router)
  • Part of one VLAN
ACCESS LINK



Trunk links
  • Do not belong to any VLAN
  • Its Carry multiple VLANs traffic
  • It’s a physical Link between two switches
TRUNK LINK


Frame tagging

In order to make sure that same VLAN users on different switch communicate with each other there is a method of tagging happens on trunk links. Tag is added before a frame is send and removed once it is received on trunk link. Frame tagging happen only on the trunk links.
VLAN Frame Identification


A Trunk link can transport multiple VLANs traffic; a switch must identify frames with their respective VLANs as they are sent and received over a trunk link.

VLAN identification can be performed using  two methods, each using  a different frame identification mechanism:
  • Inter-switch link (ISL) protocol
  • IEEE 802.1Q (Dot1Q) protocol

Inter-switch link (ISL) is a Cisco-proprietary method for preserving the source VLAN identification of frame passing over trunk link. ISL work with Ethernet, Token ring, FDDI. ISL adds a 26-bytes header and a byte trailer to the frame you can say its adds 30 bytes of tag. The ISL method of VLAN identification or trunking encapsulation no longer is supported across all Cisco catalyst switch platform.

The IEEE 802.1Q protocol is also used to carry VLAN traffic, dot1q is a open standard trunking protocol, its work only on Ethernet, dot1q introduce us the concept of Native VLAN on a trunk. The frame belong to native VLAN is not encapsulation and with any tag. Dot1q is only adding 4 bytes tag will be added to original frame just after the source address field.


Lets see the configuration:

Topology:-





GOAL:
  • configure VLAN 110, and VLAN 120 on both the switches 
  • shift the ports in to their respective VLAN as per our topology
  • configure  link between switch 1  and switch 2 as trunk link
  • make sure the users of same VLAN on the different switch must communicate with each other.




Switch>enable
Switch#configure terminal
Switch(config)#hostname sw1

sw1(config)#vlan 110
sw1(config-vlan)#exit


sw1(config)#vlan 120
sw1(config-vlan)#exit

sw1(config)#interface range FastEthernet 0/1-2
sw1(config-if-range)#switchport mode access
sw1(config-if-range)#switchport access vlan 110
sw1(config-if-range)#exit

sw1(config)#interface range fastEthernet 0/3-4
sw1(config-if-range)#switchport mode access
sw1(config-if-range)#switchport access vlan 120


sw1(config-if-range)#end

sw1#show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
Gig0/1, Gig0/2
110 VLAN0110 active Fa0/1, Fa0/2
120 VLAN0120 active Fa0/3, Fa0/4
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
110 enet 100110 1500 - - - - - 0 0
120 enet 100120 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------


Switch>enable
Switch#configure terminal
Switch(config)#hostname sw2

sw2(config)#vlan 110
Sw2(config-vlan)#exit

Sw2(config)#vlan 120
Sw2(config-vlan)#exit


Sw2(config)#interface range fastEthernet 0/1-2
Sw2(config-if-range)#switchport mode access
Sw2(config-if-range)#switchport access vlan 110
Sw2(config-if-range)#exit

Sw2(config)#interface range fastEthernet 0/3-4
Sw2(config-if-range)#switchport mode access
Sw2(config-if-range)#switchport access vlan 120
Sw2(config-if-range)#end


Sw2#show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
Gig0/1, Gig0/2
110 VLAN0110 active Fa0/1, Fa0/2
120 VLAN0120 active Fa0/3, Fa0/4
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
110 enet 100110 1500 - - - - - 0 0
120 enet 100120 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

Remote SPAN VLANs
------------------------------------------------------------------------------

Primary Secondary Type Ports

------- --------- ----------------- ------------------------------------------




HOST 1


host 2 can communicate  to host 3 both are in same VLAN 110.


host 3 can communicate with host 1 both are in same  VLAN 110, but host 3 can not communicate with host  5 its also in the same  VLAN 110, because there is no trunking is configure yet . 



sw1(config)#interface fastEthernet 0/10
sw1(config-if)#switchport mode trunk
sw1(config-if)#switchport trunk encapsulation dot1q
sw1(config-if)#switchport trunk allowed vlan 110-120
sw1(config-if)#end

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/10, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/10, changed state to up

sw2(config)#interface fastEthernet 0/10
sw2(config-if)#switchport mode trunk
sw1(config-if)#switchport trunk encapsulation dot1q
sw2(config-if)#switchport trunk allowed vlan 110 120
sw1(config-if)#end

(The ISL method of VLAN identification or trunking encapsulation no longer is supported across all Cisco catalyst switch platform.)
some cisco switch do not have option of ISL. so there is no need to specify encapsulation dot.1q ,


sw1#show interfaces trunk
Port Mode Encapsulation Status Native vlan
Fa0/10 on 802.1q trunking 1

Port Vlans allowed on trunk
Fa0/10 110-120

Port Vlans allowed and active in management domain
Fa0/10 110,120


Port Vlans in spanning tree forwarding state and not pruned
Fa0/10 110,120


sw2#show interfaces trunk
Port Mode Encapsulation Status Native vlan
Fa0/10 on 802.1q trunking 1

Port Vlans allowed on trunk
Fa0/10 110-120

Port Vlans allowed and active in management domain
Fa0/10 110,120

Port Vlans in spanning tree forwarding state and not pruned

Fa0/10 110,120






 after configuring trunk between both the switch now host 3 can communicate with host 5.

                         

 


 


Instagram

Facebook


Twitter



LINKEDIN








Saturday 8 December 2018

PPP Multilinks



Sometimes you notice a network design where you have more than one serial link between two routers.  A single serial link doesn’t provide enough bandwidth or maybe in case you want some extra redundancy. All the interfaces on a router need a different IP address, a design that looks like this:



Multilink PPP allows us to make a combination of multiple physical serial links into a single logical link or MLP bundle. MLP is used to aggregate multiple WAN links into one logical channel for the transportation of traffic from one router to another, MLP enable the load—balancing of traffic from different links  as we and allows some level of redundancy in case of line failure on a single link.MLP Supports a maximum of ten member links per bundle or single logical link. 



lets take a look of its configuration:

Friday 7 December 2018

What is BGP Route Reflectors (RR)? How to configure?




Route reflectors (RR) are one of the methods to get rid of the full-mesh of IBGP peers in your network. The route reflector allows all IBGP speakers within your autonomous system to learn about the available routes without creating loops.

There are three types of peering in route reflector:


  1. EBGP neighbor
  2. IBGP client neighbor
  3. IBGP non-client neighbor

When we configure a route reflector (RR), we have to tell the router the other IBGP router is a client or non-client. A  IBGP client is an IBGP router that the route reflector will “reflect” routes to, the non-client is just a regular IBGP neighbor.


When a route reflector forwards a route updates, there are a few rules that must follow:

  • A route learned from an EBGP neighbor can be forwarded to another EBGP neighbor, a client and non-client.
  • A route learned from a client can be forwarded to another EBGP neighbor, client and non-client.
  • A route learned from a non-client can be forwarded to another EBGP neighbor and client, but not to a non-client.




In other words: Route Reflector-RR to advertise route received from an iBGP peers to other iBGP peers. All the valid client update server Route Reflector-RR and server update to all the valid clients.
Each client only establish neighbor relationship with servers, client are not allow to establish neighbor with other clients. Route Reflector (servers) establish neighbor relationship with other servers (if you have more the one servers) and clients.


I hope now you have an idea what is route reflector, so let see the configuration:







Route-Reflector Configuration:-

Topology:

Goal:
  • configure the topology as per our diagram.
  • configure EIGRP 65100 to provide connectivity between peers 
  • advertise all the directly connected interfaces
  • configure BGP AS 65100 as per our diagram using loopbacks.
  • configure router 5 as Route-Reflector server and rest of the routers will play client role.




R1#show ip interface brief

Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        10.1.1.1        YES manual up                    up
Serial3/0                    1.1.1.1         YES manual up                    up
Serial3/3                    4.1.1.2         YES manual up                    up
Serial3/6                 15.1.1.1        YES manual up                    up
Loopback0              11.0.0.1        YES manual up                    up
Loopback1              11.0.1.1        YES manual up                    up
Loopback2              11.0.2.1        YES manual up                    up
Loopback3              11.0.3.1        YES manual up                    up
R2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        20.1.1.1        YES manual up                    up
Serial3/0                     1.1.1.2         YES manual up                    up
Serial3/1                     2.1.1.1         YES manual up                    up
Serial3/4                  25.1.1.1        YES manual up                    up
Loopback0              12.0.0.1        YES manual up                    up
Loopback1              12.0.1.1        YES manual up                    up
Loopback2              12.0.2.1        YES manual up                    up
Loopback3              12.0.3.1        YES manual up                    up



R3#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        30.1.1.1        YES manual up                    up
Serial3/1                    2.1.1.2         YES manual up                    up
Serial3/2                    3.1.1.1         YES manual up                    up
Serial3/5                  35.1.1.1        YES manual up                    up
Loopback0              13.0.0.1        YES manual up                    up
Loopback1              13.0.1.1        YES manual up                    up
Loopback2              13.0.2.1        YES manual up                    up
Loopback3              13.0.3.1        YES manual up                    up



R4#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        40.1.1.1        YES manual up                    up
Serial3/2                    3.1.1.2         YES manual up                    up
Serial3/3                    4.1.1.1         YES manual up                    up
Serial3/7                  45.1.1.1        YES manual up                    up
Loopback0              14.0.0.1        YES manual up                    up
Loopback1              14.0.1.1        YES manual up                    up
Loopback2              14.0.2.1        YES manual up                    up
Loopback3              14.0.3.1        YES manual up                    up



R5#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        50.1.1.1        YES manual up                    up
Serial3/4                   25.1.1.2        YES manual up                    up
Serial3/5                   35.1.1.2        YES manual up                    up
Serial3/6                   15.1.1.2        YES manual up                    up
Serial3/7                   45.1.1.2        YES manual up                    up
Loopback0              150.0.0.1       YES manual up                    up
Loopback1              150.0.1.1       YES manual up                    up
Loopback2              150.0.2.1       YES manual up                    up
Loopback3              150.0.3.1       YES manual up                    up


R1(config)#router eigrp 65100
R1(config-router)#network 1.0.0.0
R1(config-router)#network 4.0.0.0
R1(config-router)#network 15.0.0.0
R1(config-router)#network 11.0.0.0
R1(config-router)#network 10.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#exit


R2(config)#router eigrp 65100
R2(config-router)#network 1.0.0.0
R2(config-router)#network 2.0.0.0
R2(config-router)#network 20.0.0.0
R2(config-router)#network 12.0.0.0
R2(config-router)#network 25.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#exit


R3(config)#router eigrp 65100
R3(config-router)#network 2.0.0.0
R3(config-router)#network 3.0.0.0
R3(config-router)#network 13.0.0.0
R3(config-router)#network 30.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#exit


R4(config)#router eigrp 65100
R4(config-router)#network 3.0.0.0
R4(config-router)#network 4.0.0.0
R4(config-router)#network 14.0.0.0
R4(config-router)#network 40.0.0.0
R4(config-router)#network 45.0.0.0
R4(config-router)#no auto-summary
R4(config-router)#exit


R5(config)#router eigrp 65100
R5(config-router)#network 150.0.0.0
R5(config-router)#network 50.0.0.0
R5(config-router)#network 15.0.0.0
R5(config-router)#network 25.0.0.0
R5(config-router)#network 35.0.0.0
R5(config-router)#network 45.0.0.0
R5(config-router)#no auto-summary
R5(config-router)#exit


R1(config)#router bgp 65100

R1(config-router)#neighbor 12.0.0.1 remote-as 65100
R1(config-router)#neighbor 12.0.0.1 update-source loopback 0

R1(config-router)#neighbor 14.0.0.1 remote-as 65100
R1(config-router)#neighbor 14.0.0.1 update-source loopback 0


R1(config-router)#neighbor 150.0.0.1 remote-as 65100
R1(config-router)#neighbor 150.0.0.1 update-source loopback 0


R1(config-router)#network 10.0.0.0
R1(config-router)#no synchronization
R1(config-router)#no auto-summary
R1(config-router)#exit

R2(config)#router bgp 65100
R2(config-router)#neighbor 11.0.0.1 remote-as 65100
R2(config-router)#neighbor 11.0.0.1 update-source loopback 0

R2(config-router)#neighbor 13.0.0.1 remote-as 65100
R2(config-router)#neighbor 13.0.0.1 update-source loopback 0

R2(config-router)#  neighbor 150.0.0.1 remote-as 65100
R2(config-router)#  neighbor 150.0.0.1 update-source loopback 0

R2(config-router)#network 20.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#no synchronization
R2(config-router)#exit





R3(config)#router bgp 65100
R3(config-router)#neighbor 12.0.0.1 remote-as 65100
R3(config-router)#neighbor 12.0.0.1 update-source loopback 0


R3(config-router)#neighbor 14.0.0.1 remote-as 65100
R3(config-router)#neighbor 14.0.0.1 update-source loopback 0

R3(config-router)#neighbor 150.0.0.1 remote-as 65100
R3(config-router)#neighbor 150.0.0.1 update-source loopback 0

R3(config-router)#network 30.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#no synchronization
R3(config-router)#exit


R4(config)#router  bgp 65100
R4(config-router)#neighbor 13.0.0.1 remote-as 65100
R4(config-router)#neighbor 13.0.0.1 update-source loopback 0

R4(config-router)#neighbor 11.0.0.1 remote-as 65100
R4(config-router)#neighbor 11.0.0.1 update-source loopback 0


R4(config-router)#  neighbor 150.0.0.1 remote-as 65100
R4(config-router)#  neighbor 150.0.0.1 update-source loopback 0



R4(config-router)#network 40.0.0.0
R4(config-router)#no auto-summary
R4(config-router)#no synchronization
R4(config-router)#exit


R5(config)#router bgp 65100
R5(config-router)#neighbor 11.0.0.1 remote-as 65100
R5(config-router)#neighbor 11.0.0.1 update-source loopback 0

R5(config-router)#neighbor 12.0.0.1 remote-as 65100
R5(config-router)#neighbor 12.0.0.1 update-source loopback 0


R5(config-router)#neighbor 13.0.0.1 remote-as 65100
R5(config-router)#neighbor 13.0.0.1 update-source loopback 0

R5(config-router)#neighbor 14.0.0.1 remote-as 65100
R5(config-router)#neighbor 14.0.0.1 update-source loopback 0

R5(config)#router bgp 65100
R5(config-router)#neighbor 11.0.0.1 route-reflector-client

*Dec  7 14:07:56.415: %BGP-5-ADJCHANGE: neighbor 11.0.0.1 Down RR client config change
*Dec  7 14:07:56.419: %BGP_SESSION-5-ADJCHANGE: neighbor 11.0.0.1 IPv4 Unicast topology base removed from session  RR client config change
*Dec  7 14:07:57.291: %BGP-5-ADJCHANGE: neighbor 11.0.0.1 Up


R5(config-router)#neighbor 12.0.0.1 route-reflector-client

*Dec  7 14:08:04.183: %BGP-5-ADJCHANGE: neighbor 12.0.0.1 Down RR client config change
*Dec  7 14:08:04.187: %BGP_SESSION-5-ADJCHANGE: neighbor 12.0.0.1 IPv4 Unicast topology base removed from session  RR client config change
*Dec  7 14:08:04.407: %BGP-5-ADJCHANGE: neighbor 12.0.0.1 Up

R5(config-router)#neighbor 13.0.0.1 route-reflector-client


*Dec  7 14:08:15.187: %BGP-5-ADJCHANGE: neighbor 13.0.0.1 Down RR client config change
*Dec  7 14:08:15.187: %BGP_SESSION-5-ADJCHANGE: neighbor 13.0.0.1 IPv4 Unicast topology base removed from session  RR client config change
*Dec  7 14:08:15.683: %BGP-5-ADJCHANGE: neighbor 13.0.0.1 Up

R5(config-router)#neighbor 14.0.0.1 route-reflector-client

*Dec  7 14:08:33.659: %BGP-5-ADJCHANGE: neighbor 14.0.0.1 Down RR client config change
*Dec  7 14:08:33.663: %BGP_SESSION-5-ADJCHANGE: neighbor 14.0.0.1 IPv4 Unicast topology base removed from session  RR client config change
*Dec  7 14:08:33.983: %BGP-5-ADJCHANGE: neighbor 14.0.0.1 Up

R5(config-router)#end


R5#show ip bgp 10.1.1.1
BGP routing table entry for 10.0.0.0/8, version 7
Paths: (1 available, best #1, table default, RIB-failure(17))
  Advertised to update-groups:
     2
  Refresh Epoch 2
  Local, (Received from a RR-client)
    11.0.0.1 (metric 2297856) from 11.0.0.1 (11.0.3.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      rx pathid: 0, tx pathid: 0x0
R5#show ip bgp 20.1.1.1
BGP routing table entry for 20.0.0.0/8, version 9
Paths: (1 available, best #1, table default, RIB-failure(17))
  Advertised to update-groups:
     2
  Refresh Epoch 2
  Local, (Received from a RR-client)
    12.0.0.1 (metric 2297856) from 12.0.0.1 (12.0.3.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      rx pathid: 0, tx pathid: 0x0
R5#show ip bgp 30.1.1.1
BGP routing table entry for 30.0.0.0/8, version 11
Paths: (1 available, best #1, table default, RIB-failure(17))
  Advertised to update-groups:
     2
  Refresh Epoch 2
  Local, (Received from a RR-client)
    13.0.0.1 (metric 2809856) from 13.0.0.1 (13.0.3.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      rx pathid: 0, tx pathid: 0x0


R5#show ip bgp 40.1.1.1
BGP routing table entry for 40.0.0.0/8, version 13
Paths: (1 available, best #1, table default, RIB-failure(17))
  Advertised to update-groups:
     2
  Refresh Epoch 2
  Local, (Received from a RR-client)
    14.0.0.1 (metric 2297856) from 14.0.0.1 (14.0.3.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      rx pathid: 0, tx pathid: 0x0


R1#show ip bgp 20.1.1.1
BGP routing table entry for 20.0.0.0/8, version 3
Paths: (2 available, best #2, table default, RIB-failure(17))
  Not advertised to any peer
  Refresh Epoch 1
  Local
    12.0.0.1 (metric 2297856) from 150.0.0.1 (150.0.3.1)
      Origin IGP, metric 0, localpref 100, valid, internal
      Originator: 12.0.3.1, Cluster list: 150.0.3.1
      rx pathid: 0, tx pathid: 0
  Refresh Epoch 1
  Local
    12.0.0.1 (metric 2297856) from 12.0.0.1 (12.0.3.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      rx pathid: 0, tx pathid: 0x0



 


 


Instagram

Facebook


Twitter



LINKEDIN








What is Virtual Router Redundancy Protocol (VRRP)? How to configure Virtual Router Redundancy Protocol (VRRP)?

 Virtual Router Redundancy Protocol (VRRP) is a gateway redundancy networking protocol used to create a virtual gateway similar to HSRP . VR...